LVDSBiosNativeMode must be turned off on Radeon 7500 Mobile (regression)

Bug #132716 reported by David Tomaschik on 2007-08-15
86
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
Nominated for Trunk by berg
xserver-xorg-video-ati (Ubuntu)
High
Unassigned
Nominated for Gutsy by berg

Bug Description

I'm running Gutsy Tribe 4 with all the latest updates available through apt.

What happens: When X starts, all I get is a black screen. I've had to switch to the VESA driver to get X up and running.

Expected behavior: X starts normally.

This has only occurred since the xserver-xorg-video-ati update on the 14th, so it's a fairly new regression.

I will attach broken xorg.conf, lspci -vv, and lspci -vvn.

Note from bug triager:
Before commenting on this bug report, please read https://wiki.ubuntu.com/Bugs/AtiDriver

David Tomaschik (matir) wrote :

Broken xorg.conf.

David Tomaschik (matir) wrote :
David Tomaschik (matir) wrote :
Nico Bogaert (nico-bogaert) wrote :

Same happened to me (also on Mobility Radeon 7500) on my Dell Inspiron 5100 (i was just about to file a bug report). This is what I updated last night (in case someone can figure out it has something to do with another package upgrade than xserver-xorg-video-ati but it's the only one I can come out with too. I'll attach my xorg.0.log too (where I can't find any errors explaining the problem).

Nico Bogaert (nico-bogaert) wrote :
Nico Bogaert (nico-bogaert) wrote :
alistairi (alistairi) wrote :

I have the same problem with ATI Radeon 9800 Pro (ie desktop not laptop)

Since upgrade of ATI drivers yesterday (15 August), get a black screen when X Starts.

ctrl-alt-backspace is broken, can't get back to command line.

alistairi (alistairi) wrote :

Ran today's update ( 16 Aug ) which updated fglrx driver and xorg and the problem is still there.

My xorg.conf is dated July4, so I'm not sure providing this is going to help as the the system was working fine until the latest updates.

If any more information is needed, please ask

TuxFan (make) wrote :

I guess my bug is related to this one. I have a dualhead setup using Radeon 7500 and my right screen (connected to VGA) went blank after my todays update in Gutsy, but the left screen (connected to DVI) still works. Well it actually works when using my single screen setup, since on dualhead the left screen is totally messed up. (Windows are drawn only partly and so on.)

My last upgrade did this:
upgrade xserver-xorg-video-ati 1:6.6.3-2ubuntu6 1:6.6.193-1ubuntu1

Daniel Berghenti (pecos7) wrote :

I also had this bug with Radeon 9700 mobile. I resolved the problem removing my xorg.conf.

David Tomaschik (matir) wrote :

Did you just delete the xorg.conf, or did you need to reconfigure it as well?

I get screen distortions on a radeon 9250 since the latest updates,

gmaniac (gman1ac) wrote :

Same problem (Ati 9600). I had to disable agpfastwrite for X to work.

alistairi (alistairi) wrote :

disabling agpfastwrite worked for me too (radeon 9800 pro)

TuxFan (make) wrote :

Disabling AGPFastWrite didn't fix my dualhead setup. (Tried to disable it on both devices and also only for the VGA device.) One note: when I use my original single screen setup, the desktop gets correctly cloned to both screens.

TuxFan (make) wrote :

Here is my log on dualhead setup from start to KDM's login screen. This time the login screen was a mess too. The user list wasn't loaded and it missed other components too... Like said before, the right screen connected to VGA (called "Extra Screen" in log) is blank. The screen "is there" though, I can move the mouse cursor there, but that doesn't help much... :(

Could someone at least mark this bug as confirmed?

Timo Aaltonen (tjaalton) wrote :

A lot of you seem to be playing with various radeon-options.. please don't do that. If it works for you without the xorg.conf, maybe it's the options that broke it.

To the ones with the same bug as the original reporter; try playing around with the MonitorLayout -option, or disable DRI.

TuxFan (make) wrote :

This is my xorg.conf for the dualhead setup. DRI is always disabled by X itself since it's not working with xinerama. I tried to play around with the MonitorLayout option, but it didn't make any difference...

Confirmed with Mobility Radeon M24. Works with Vesa-driver.

Changed in xserver-xorg-video-ati:
status: New → Confirmed

I have clean install of Kubuntu Gutsy Tribe 5 and first boot after install ends with black screen and a system freeze. Removing xorg.conf causes my screen to be white and a system freeze.

My display adapter is Mobility Radeon M6 LY not Mobility Radeon M24 as i wrote above.

Latest updates to Xorg seemed to resolve issue for me.

It seems to be still broken. My display adapter doesn't work if power supply is connected. I used my laptop with battery and thought this issue was resolved. If I connect power supply my screen fills with carbage. Gutsy tribe 5 livecd works fine though with power supply connected.

Can somebody else test this with battery only.

TuxFan (make) wrote :

I can confirm that my desktop's dualhead setup is still broken with the latest updates (Tribe 5).

TuxFan (make) wrote :

Is anyone else still having problems with this bug? Since this starts to be quite irritating. Imagine being able to use only the left half of your desktop...

Nico Bogaert (nico-bogaert) wrote :

I am still having this problem (sorry, was out of the country for a couple of days, I actually hoped it would be fixed by now but doesn't seem so). I did a full upgrade without any effect.

- I tried to work on battery only but I don't see any difference
- I tried to play around with the MonitorLayout option, but this doesn't solve anything either. I don't have an external screen to attach to my laptop, so I still don't have anything but a black screen.
- I uncommented all additional options that I've added, without any result
- I backed up my xorg.conf and then did a reconfigure, but also without any result.

Thus far, I don't see any solution coming up to see my X on a single screen setup on my laptop.

David Tomaschik (matir) wrote :

Still broken for me with latest updates. Running on battery or on AC power makes absolutely no difference -- perhaps the person experiencing that has an unrelated ACPI bug?

Downgrading to 6.6.3-2ubuntu6 fixes the problem in its entirety, so there's definitely an issue with the upgrade.

alistairi (alistairi) wrote :

Hallo,

My system is updated to todays state (ie 1/Sept). I still have this problem. By the way this means I have to do a hard restart, I cant get out of it with ctrl-alt-backspace.

I followed the advice from Timo Aaltonen above:

1. Re-enable AGPFASTREWRITE and restart X.
Result: black screen
Reboot machine into recoverz mode

2. Disable loading of DRI module and start X
Result: black screen
Reboot machine into recoverz mode

3. Rename xorg.conf as xorg.bak and start X
Result: X starts successfullz but Gnome gives an error message on trzing to set some properties.

Of course now mz German kezboard is a US kezboard and mz lefthanded mouse is a righthanded mouse ...

4. I don|t know what to do about MonitorLayout, maybe you can give some more instructions here

Timo Aaltonen (tjaalton) wrote :

Please try this driver:

http://people.ubuntu.com/~bryce/Testing/ati/

we will (hopefully) upload it to gutsy, since it seems to fix more than it breaks, so far :)

David Tomaschik (matir) wrote :

Thanks for the update, but unfortunately, same behavior observed here. I've attached a new Xorg.log to see if anything might be more helpful. I can only hope. :)

TuxFan (make) wrote :

Same here, it didn't fix my problem. The xserver-xorg-video-ati_6.7.192-1ubuntu1_i386.deb downloaded from http://people.ubuntu.com/~bryce/Testing/ati/ worked actually even worse with my dualhead setup: even the left screen connected to DVI was blank. It seems that X crashed completely with this setup. On single monitor setup this driver worked like the "real" Gutsy's driver.

How about going back to the old driver If this can't be fixed before Gutsy is released... ?

berg (berg-foss) wrote :

see this my bug report at #LP 137396 that seems duplicate of this bug
https://bugs.launchpad.net/compizsettings/+bug/137396

there is some logs that i I hope can help.

If duplicate , can I assign that bug as duplicate to this

David Tomaschik (matir) wrote :

I agree that 137396 may be a duplicate, and I don't think it's a compiz bug, so probably more appropriate here. I'll leave it to your discretion.

Tormod Volden (tormodvolden) wrote :

Tuxfan, I think your dual-head crash is the same as in https://bugs.freedesktop.org/show_bug.cgi?id=12295

Timo Aaltonen (tjaalton) wrote :

please try the latest driver (only x86 binary available):

http://users.tkk.fi/~tjaalton/dpkg/ati

also, run "dpkg-reconfigure -phigh xserver-xorg" to get a clean xorg.conf. It doesn't generate a Modules-section anymore, and that could help here.

Nico Bogaert (nico-bogaert) wrote :

I tried all previous suggested options, still without any change: the screen remains black (even after getting the clean xorg.conf).

berg (berg-foss) wrote :
Download full text (50.8 KiB)

I tried use driver from

 http://people.ubuntu.com/~bryce/Testing/ati/
with version xserver-xorg-video-ati_6.7.192-1ubuntu1_i386.deb 28-Aug-2007 18:46 389K

and have the result of screen blank with errors like the picture attached.
and stop there. with alt-f2 I have access from terminal

the logs

Xorg.0.log
xorg.conf

XORG.0.log

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu2)
Current Operating System: Linux instavel-laptop 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686
Build Date: 26 August 2007
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 6 12:22:13 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "ATI Technologies Inc RC410 [Radeon Xpress 200M]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "stylus"
(**) |-->Input Device "cursor"
(**) |-->Input Device "eraser"
(**) |-->Input Device "Synaptics Touchpad"
(**) Option "NoTrapSignals" "true"
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
 Entry deleted from font path.
(WW) Including the default font path /usr/share/fonts/X11/misc,/usr/share/fonts/X11/cyrillic,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType.
(**) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/cyrillic,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81e8500
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.3
 X.Org Video Driver: 1.2
 X.Org XInput driver : 0.7
 X.Org Server Extension : 0.3
 X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
 compiled for 1.3.0, module version = 1.0.0
 ABI class: X.Org Video Driver, version 1.2
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1002,5a31 card 1025,0109 rev 01 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1002,5a3f...

TuxFan (make) wrote :

Tormod: could be. Do you think it's related to this bug?

Timo: no luck. Dual head still crashes with xserver-xorg-video-ati_6.7.192-1ubuntu2_i386.deb from http://users.tkk.fi/~tjaalton/dpkg/ati

I made a new dual head config after the suggested "dpkg-reconfigure -phigh xserver-xorg", it's attached in this comment. I'll post the log in a minute.

berg (berg-foss) wrote :

I tried use too the driver from

 http://users.tkk.fi/~tjaalton/dpkg/ati/
with version xserver-xorg-video-ati_6.7.192-1ubuntu2_i386.deb 06-Sep-2007 14:47 389K

and have the result of screen not blank but with wallpaper :) but with errors yet :( like the picture attached.
and stop there. with alt-f2 I have access from terminal too

I see that is better atached long logs in the other posts ;)

I will attached the xorg logs

berg (berg-foss) wrote :
Changed in xorg-server:
status: Unknown → Confirmed
Timo Aaltonen (tjaalton) on 2007-09-22
Changed in xserver-xorg-video-ati:
importance: Undecided → High
Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Committed
Changed in xorg-server:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) on 2007-10-06
Changed in xserver-xorg-video-ati:
status: Fix Committed → Fix Released
David Tomaschik (matir) on 2007-10-09
Changed in xserver-xorg-video-ati:
status: Fix Released → Confirmed
Changed in xorg-server:
status: Fix Released → Confirmed
119 comments hidden view all 199 comments
David Tomaschik (matir) wrote :

This bug is about the Open Source X.org ATI Driver supporting older Radeons, FIreGLs, etc. fglrx is a proprietary, closed-source driver for newer Radeons.

Sascha Morr (saschamorr) wrote :

I had have the same problem. I use the instruction at the release notes:

-->
Blank screen with some ATI hardware

People with ATI display adapters may get a blank screen when loading X due to the driver being unable to initialize certain hardware. Upstream is working on it, and hopefully we'll be able to release an update for 7.10 soon after the release. In the meantime, add 'Option "LVDSBiosNativeMode" "false"' to the driver section of xorg.conf. Bug #132716
<--

After i change the xorg.conf i could start with a resolution of 800x600 pixels. Then i use the grafical tool to chance the resolution to 1280x1024 pixels, the normal resolution of my display.

cheers
Sascha

Sascha Morr (saschamorr) wrote :

The Problem is that my solution is use the vesa driver. The new ATI driver at http://ppa.launchpad.net/tormodvolden/ubuntu/pool/main/x/xserver-xorg-video-ati/ don't works. Only get the *black screen of dead*.

Hoping for a solution.

Cheers
Sascha

hendrixski (hendrixski) wrote :

I gots gutsy running on an ATI Radeon Mobility 7500 and no black screen... though, it does go black for a second or two during bootup.

However, everything I move something on the display my CPU usage skyrockets! The xorg.conf says the driver is "ati" not fglrx.

Tormod Volden (tormodvolden) wrote :

Sascha, I think you should open a new bug report. You have another card and probably another issue than David.

André Gondim (andregondim) wrote :

Same happened to me (also on Radeon 9200) on my Desktop. I only install with safety mode, but don't have all power, like i can't use compiz.

Hugs.

Ricky Campbell (cyberdork33) wrote :

10202007 i386 driver seems to be working for me without the "LVDSBiosNativeMode" Option

viktor (lfraisse) wrote :

10202007 amd64 driver works for me (ATI Radeon Xpress 200G; mobo integrated) after I blind logged in, Ctrl+F7, xrandr... and rebooted.
I also activated the ATI proprietary driver before installing Tormod's version which is recognized as the most recent.
No "LVDSBiosNativeMode" Option added to xorg.config either.

viktor (lfraisse) wrote :

Although the 10202007 driver works to bypass the blank screen bug I'm struggling to get Ubuntu take into account my LCD resolution (1400*1050). Currently working with default 1280*1024...
Should I file for a new bug or wait for the official driver update?

mabovo (mabovo) wrote :

As reported on this launchpad I can't figure out if bug is related only for mobility Radeon 7500 using opensource driver or not and if the main problem refers to "blank" or "black" screen. So I decided to open another bug report on https://bugs.edge.launchpad.net/ubuntu/+bug/154586.
If somebody conclude its a duplicate bug report, please feel free to change it.

Tormod Volden (tormodvolden) wrote :

victor, yes please open a new bug for the resolution issue.

Tormod Volden (tormodvolden) wrote :

David, could you please check if this bug is fixed in xserver-xorg-video-ati_6.7.195+git20071020tv ?

mabovo (mabovo) wrote :

Yes, I can confirm, driver 6.7.195+git20071020tv solved the problem with dark screen on start up for Radeon 9600 RV350.

2fun4me (2fun4me) wrote :

I have the same problem but I'm a complete newbie on all this.... How do I do to install the xserver-xorg-video-ati_6.7.195+git20071020tv in my Gutsy Gibbons?

Tormod Volden (tormodvolden) wrote :

> I have the same problem but I'm a complete newbie on all this...

Please read the previous comments to find the links, or wait for an official update.

Biber (c-woltmann) wrote :

Looking forward to an official update. How long will it propably take?

Hi Guys!

I'm still with Feisty Fawn. I have downloaded and ripped to CD Gutsy but I've heard about the bugs related to ATI's so I guess I will wait until the bugs get fixed.
Feisty works ok with Beryl and Compiz. Only when I have a video "running" and if I rotate the Cube the screen turns black:( I could never solve that. Maybe it's because of being an ATI. My Laptop runs ok, but has an Nvidia Geforce Go 7300.

Desktop: Intel i386, PIV, 3.4GHz, 1 GB RAM DDR 400, ATI 9200 Radeon.

Hope this can get solved!

Biber, we'll probably wait until 6.8 is released upstream. Maybe some weeks from now.

nunoribeiro, you can always check with the live CD if things work fine on your hardware.

And thanks to everybody testing the work-in-progress. Upstream is very grateful for your feedback, which helps to make an excellent final release.

nunoribeiro (harakiri1976) wrote :

Tormod, Live CD runs very well! I've tested! I changed the appearance for the very nitty effects and everything went ok. I was surprised because the cube didn't rotate but someone told me that I should download compiz-tools-config. That's why. I'm just afraid things get wrong:(
It's better a fresh install rather than an upgrade right?
Thanks!

Tormod Volden (tormodvolden) wrote :

Note that you can even install packages like compiz-tools-config inside the live session, if you have network and enough RAM. Yes, a clean install is always a bit safer than upgrading, but it adds the hassle of reinstalling what extra packages you use and any configuration you have done.

nunoribeiro (harakiri1976) wrote :

Yes I know:( And I have a lot of Packages so organized:) I use Gnome all the time, but I used Kopete as my preferred instant messenger, and a lot of other:) I will make backup up of everything and test either ways. I mean, first upgrade and see what's going on. If everything is ok I'll keep it!

Thank you very much for your support!

Keep up the Good Work!:)

Best Regards,

Nuno Ribeiro

wb8erj (wb8erj) wrote :

Hello,

Here is a possible workaround, and clue. I too had no video when I installed 7.10. However I did have version 7.04 installed and did a full install of 7.10. Out of curiosity, I re-installed 7.04, then I did an UPGRADE from 7.04 to 7.10 Per the instructions for upgrading. I now have video!!

It would be interesting if others can do this too.

Tormod Volden (tormodvolden) wrote :

wb8erj, the most likely explanation would be that the xorg.conf generated in the 7.04 install works better than the one generated in the 7.10 install. Can you please compare them, or attach them here? On the other hand you maybe had a totally different issue than what this bug report is about.

Having something like that on a laptop with ATI 345M graphics with 128 megs of shared ram, 690 megs of ram, and an Intel Celeron M 1.80 GHz processor. When I start up the laptop, everything starts out fine, and then when the Ubuntu splash screen (that's what I call the screen with the Ubuntu logo and that progress bar) is supposed to come up, i just get this screen that changes colors from black to white and other light colors randomly. It starts up about a fifth of the time, and if i hold down the power button to turn it off, it just gets stuck on the BIOS screen. Then I have to restart the computer about ten times to get back to the damaged splashed screen. An Ubuntu memory scan says there are no errors in ram. What do I need to do to what? I'm not a linux noob.

Aaron Larson (aaronpublic) wrote :

I have an Asus a8v, athlon with an "ATI Technologies Inc M10 NQ [Radeon Mobility 9600]" and I'm experiencing the "black screen" on startup of the X server. I've done the "dpkg-reconfigure -phigh xserver.xorg", tried the xserver-xorg-video-ati_6.7.195+git20071020tv_i386.deb, and 'Option "LVDSBiosNativeMode" "false"', and I'm still getting the black screen. Here is a more detailed description:

Start with running system using vesa driver.

dpkg-query -W 'xserver*ati*'
xserver-xorg-driver-ati
xserver-xorg-video-ati 1:6.7.195+git20071020tv
xserver-xorg-video-ati-dbg
xserver-xorg-video-atimisc
dpkg-reconfigure -phigh xserver-xorg
Ctrl-Alt-Backspace

Result:
  Monitor goes into power save.
  Xorg starts consuming CPU, is not able to be killed (even with -9).

Reboot.
  Results unchanged.

ed xorg.conf s/"ati"/"vesa"
reboot.

  Works fine.

ed xorg.conf s/"vesa"/"ati"

apt-get install xserver-xorg-video-ati
dpkg-query -W 'xserver*ati*'
xserver-xorg-driver-ati
xserver-xorg-video-ati 1:6.7.195-1ubuntu2
xserver-xorg-video-ati-dbg
xserver-xorg-video-atimisc

Ctrl-Alt-Backspace
Result:
  black screen, xorg max cpu, unkillable.

Add Option "LVDSBiosNativeMode" "false"
reboot
Result:
  black screen, xorg max cpu, unkillable.

hanna (theknife) wrote :

hi folks - have just d/led 7.10 and found that i cannot get video when trying to run from the CD. i have a Radeon X1300 graphics card and assume the issue is a variation on the above. how can this issue be worked around when running from the CD? (clearly, please - noob on board)

thanks!
hanna

Tormod Volden (tormodvolden) wrote :

This bug report is not the place to report other bugs even if they involve black screens. Basically only David's comments are wanted here, and once his bug is resolved, your other comments will be forgotten. Please read https://wiki.ubuntu.com/Bugs/AtiDriver

Nico Bogaert (nico-bogaert) wrote :

Tormod,

sorry for not being able to test the last version earlier. If i remember correct, I have the same configuration as David (inspiron 5100 and ATI Radeon 7500 Mobility), and i can confirm too that the latest version (xserver-xorg-video-ati_6.7.195+git20071020tv) is working without the LVDS-option.

Thanks a lot!

Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Committed
Max Jonas Werner (makkes) wrote :

I've just upgraded from Feisty to Gutsy fearing the evil black screen but it just works. This is my adapter:

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] [1002:4c57] (prog-if 00 [VGA])

I didn't even have to insert the "LVDSBiosNativeMode" option. Everything fine.

Max

Soner Tari (comixwall) wrote :

My adapter is:
ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

My problem description is the following:
After Grub finishes I see "Starting..." string on the black screen, and the font of the string changes. But right after that the screen becomes completely black and I get a large underscore cursor blinking on the top left corner of the screen.

This black screen with cursor stays there for about 3 minutes (Feisty boots much faster on the same machine, I don't understand), and right after that (i.e. after X loads) I can see the famous Ubuntu login screen with brown background. Thereafter, I don't have any problems. This has been the case since fresh install.

Since my problem occurs before X loads and after that everything is fine, I wasn't too hopeful that new Xserver driver would solve my problem. But I've installed the latest driver from Tormod's page:
xserver-xorg-video-ati - 1:6.7.195+git20071026-0ubuntu0tv

Since it did not solve my problem, I've also added the following lines to xorg.conf later on:
Option "LVDSBiosNativeMode" "false"
Option "DRI" "off"

Nothing changed.

Since I don't have any problem after X loads, my situation is not so bad. But any suggestions are welcome.

Tormod Volden (tormodvolden) wrote :

Soner, that has obviously nothing to do with this bug report.

Anthony Brock (anthony-brock) wrote :
Download full text (3.7 KiB)

I'm experiencing problems with dual-head setup and xrandr 1.2 on a recent upgrade to Ubuntu 7.10 on my Dell Latitude D810 laptop with docking station. Previously this worked with the ati driver and it still functions when I change over to the "fglrx" driver (which rules out bad hardware).

I have a striped down configuration xorg.conf file (see below) with two identical Dell FP1905 monitors connected through a docking station, one via VGA-0 and the other via DVI-0. On startup the DVI-0 monitor functions as expected while the VGA-0 monitor displays "1: Analog Input Cannot Display This Video Mode". The "working" monitor shifts from DVI-0 to VGA-0 when I issue the following command:

xrandr --output DVI-0 --crtc 0 --output VGA-0 --crtc 1

At this point, my desktop is properly displayed on VGA-0 while DVI-0 displays "2: Digital Input Cannot Display This Video Mode". Is it possible that this bug is related to "crtc 0" on the ATI x600 (M24)?

The log of this session is attached. Here is my xorg.conf file:

*** BEGIN xorg.conf ***
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
 Driver "ati"
 BusID "PCI:1:0:0"
 Option "LVDSBiosNativeMode" "false"
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies Inc M24 1P ...

Read more...

Ricky Campbell (cyberdork33) wrote :

Anthony, I don't think that you have the same problem for this bug. read the Gutsy Release notes about multi-screen setups: https://wiki.ubuntu.com/GutsyGibbon/ReleaseNotes

mek (marekda) wrote :

I had same kind of problem when tried 7.10 at Live-CD. X starts with black screen. Bug 153188, https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/153188

Anthony Brock (anthony-brock) wrote :

Cyberdork33,

I have read these release notes. That is why I posted my information to this bug report (it references people having problems with blank screens to this bug report). I created this configuration (and discovered how to move the problem from window to window) by following the steps at the sites referenced and by following Debian's guide to using xrandr:

http://wiki.debian.org/XStrikeForce/HowToRandR12

If the issues with "crtc 0" are not related to this bug, then what is the next step in trouble-shooting the issue?

Anthony

description: updated
abishek22 (abishek) wrote :

this is my first ubuntu installation

first I use a dell inspiron 5100 the blue Laptop

after booting from live cd the display was dead I e black screen

I choose the second option to install using safe drivers either on the live cd or the alternate insaller cd

how ever it worked installation was done using vesa driver

when I tried to change vesa to Ati driver using dkpg configuration

after saving xconfg....
it rebooted to black screen

after changing xorg.conf to what's given below the display appeared

i'm sure there is a problem here

xorg.conf

Section "Device"
  Identifier "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
  Driver "ati"
  BusID "PCI:1:0:0"
  Option "LVDSBiosNativeMode" "false"
 EndSection

This has been fixed for a while.

Changed in xorg-server:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-ati:
status: Fix Committed → Fix Released
dotancohen (dotancohen) wrote :

Now that the bug is fixed, a note should be added to the 7.10 release notes stating such.

Tormod Volden (tormodvolden) wrote :

Well, there's no official fix released for 7.10 users yet. There might be a backport later though. Anyway, the release notes link to this bug report.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 199 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.