Ubuntu

Running Unity disables Xorg's 3-finger click support (middle click)

Reported by Alex Launi on 2011-04-07
292
This bug affects 61 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned

Bug Description

Xorg fails to recognize a 3-finger click as a middle-button-click when Unity is running and instead thinks it's a left-click. This bug only happens in Unity 3D. It does not happen with Unity 2D or Gnome Shell.

Please note this bug is about physically "clicking" a clickpad with 3 fingers. 3 finger tapping is different and has been intentionally overridden in Unity 3D by new gestures.

Related branches

lp:~vanvugt/ubuntu/precise/xserver-xorg-input-synaptics/fix-754000
Chase Douglas (community): Disapprove on 2012-01-27
Bryce Harrington: Needs Fixing (sponsorship) on 2012-01-26
Ubuntu branches: Pending requested 2011-10-21
Alex Launi (alexlauni) on 2011-04-07
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
description: updated
Daniel van Vugt (vanvugt) wrote :

Is there a good reason why we should accept this bug as Low? There is probably a good UX case for making middle-button-clicks work as expected for owners of click-pads. At least in the case of multitouch clickpads (like Apple's), the three-finger middle click is very distinct from the "love handles" because clicking with three fingers can only be a middle click. I don't believe there is any other common interpretation for three-fingers+click.

And thanks for the workaround; this bug was starting to annoy me.

rubengs (rgarcia-cucea) wrote :

I think is great to have a complete multitouch experience in Natty, but I have a sensible problem, at least for me, I desperately need to use the three finger tap to simulate the mouse middle click button, and need to drag with three fingers as well, I use it to drag text to search zones in firefox and other programs. The three finger middle click is very useful to close open tabs and to open links in new tabs in firefox, to open directories in tabs in nautilus, to close windows in the scale plugin in compiz, etc.

How can I assign another gesture other than three finger tap/drag to mouse moving resizing and take back this to the previous behavior?

summary: - 3 finger press interferes with middle click on macbook pro trackpad
+ 3 finger touch interferes with 3 finger click (middle click)
Jason Smith (jassmith) on 2011-04-26
Changed in unity:
status: Triaged → Invalid
Changed in utouch:
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-26
Changed in unity:
status: Invalid → Triaged

Just want to confirm, and point out that with the Apple Magic Trackpad, there is NO workaround, and therefore no middle-click.

This bug should perhaps be retitled - "No middle-click for multitouch devices". This is important, the cut-buffer is useless without it. A way to disable the three-finger "move window" would suffice.

Daniel van Vugt (vanvugt) wrote :

Interesting to see the button events using the command "xinput test bcm5974"... With Unity loaded the middle click (three fingers) is reported incorrectly as button #1 being pressed and released. Without Unity, xinput correctly reports the middle click as button #2.

Also note that without Unity in Ubuntu Classic (not effects), I can reintroduce the bug by running "geistest" at the same time as the above xinput test (in different windows). So it would seem that libutouch-geis might be close the cause.

Daniel van Vugt (vanvugt) wrote :

Fixed (in xserver-xorg-input-synaptics)! The patch to go in debian/patches is attached...

  * Number of active touches can be less than number of active fingers/contacts
    so ask grail for the real number of fingers when clicking. This fixes
    3-finger clicks (middle click) when there are geis/grail clients active
    such as Unity. (LP: #754000)

affects: unity (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

The fix is now available for testing in ppa:vanvugt/unity
(https://launchpad.net/~vanvugt/+archive/unity)

tags: added: patch
Alex Murray (alexmurray) wrote :

I can confirm the fix resolves this bug for me - thanks Daniel, nice work. This was really bugging me since I use 3-finger click to paste all the time so its great you fixed it.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → Confirmed
Daniel van Vugt (vanvugt) wrote :

Thanks Alex. Nice to know other people are benefiting from the fix.

P.S. In future, please don't change the status of a bug that's already Triaged. Triaged usually comes after Confirmed. See: https://wiki.ubuntu.com/Bugs/Status

Alex Murray (alexmurray) wrote :

Ahh thanks for the heads up on bug statuses - sorry bout that.

Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Triaged → Invalid
tags: removed: patch
rubengs (rgarcia-cucea) wrote :

I'm using oneiric and the problem is still there, efectively making unity unusable for me because the lack of middle click (used regularly to paste, close tabs, etc.), I love the beautiful handles but middle click is too much more useful. Is there a way to test the fix in ppa:vanvugt/unity in oneiric?

Daniel van Vugt (vanvugt) wrote :

Sorry, I haven't made an oneiric build available in the PPA. We're still trying to work through compatibility problems with some touchpads that the fix has:
    https://code.launchpad.net/~vanvugt/ubuntu/oneiric/xserver-xorg-input-synaptics/fix-754000/+merge/64125
Once that's done and the final fix is agreed upon, I'm happy to make it available for oneiric.

bwat47 (bwat47) wrote :

So will this fix make it into oneric? As it stands unity is pretty unusable for anyone that uses a touchpad and expects middle click to work...

Middle click is essential for me as mentioned above for closing tabs ect...

Ian Turner (vectro) wrote :

Note that there is a workaround for Oneric: Use KDE. (That's what I've done)

shane (shane-animail) wrote :

Well yes, also using windows, gnome shell or unity 2d also workaround the problem.
Having said that, they have their own issues but this 3 finger tap problem is one of the major factors in my decision to use KDE for the foreseeable future and since this has been marked as won't fix (for at least the next few releases I imagine), I guess it's up to people to weigh up how important middle clicks are and decide whether they want unity 3d or middle-clicks, you can't have both.

Daniel van Vugt (vanvugt) wrote :

The merge proposal is still waiting on feedback from Chase Douglas. He said my fix breaks his Dell Inspiron model 1011/1012? So I asked him for more info back in July.

I've just subscribed Chase because he may have lost track of this ticket.

Ian Turner (vectro) wrote :

Shane: I wasn't being sarcastic, this issue has also prompted me to switch to KDE.

I don't think using Gnome shell or Unity 2D work around this issue, since they both still use Gnome Settings Daemon.

I'm using Gnome (Ubuntu Classic session) and three-finger click
works fine here. I use it in Firefox all the time.

Regards,
Colin

@ Ian,
I didn't think you were being sarcastic as this is a very frustrating issue for people who are used to the "normal" 3 finger middle-click behaviour.

But yes, neither gnome shell or unity 2d suffer from this problem (at least they didn't last time I checked a couple of weeks ago), it is only the compiz enabled unity 3d.

Daniel van Vugt (vanvugt) wrote :

This bug is only a problem when there is multitouch geis/grail code active, which is unity. When there is no such multitouch code active then the "normal" 3 finger click support in Xorg works. So the bug does not happen in regular Gnome (Ubuntu Classic) and KDE. If Unity-2D is safe too then that's good news.

Note the simple workaround that Alex mentioned in the Bug Description, so you can kind-of use middle click in Unity still.

Also note, you can a full fix for natty from ppa:vanvugt/unity
    https://launchpad.net/~vanvugt/+archive/unity
That is the fix currently being discussed and refined for release.

shane (shane-animail) wrote :

Well the workaround mentioned doesn't work for me I'm afraid.

As for a full fix for natty, I don't get this fix in natty. I can use 3 finger middle-click there too.

shane (shane-animail) wrote :

I meant I don't get this problem in natty ^

Chase Douglas (chasedouglas) wrote :

In Unity a design decision has been made that three and four finger gestures are reserved for the shell. For example, any time you put three touches down on a multitouch trackpad you can start draging the window around (assuming it's not full screen). The only way to implement this behavior is to mask out the three-touch-tap behavior that X synaptics supports.

I'm sorry to say that they only reason three touch tapping works in unity 2D is because it doesn't yet implement the window moving gesture.

There's no reason this can't be made configurable. I can envision an option turns off specific gestures in Unity. If you disable the window move gesture you'll get three touch tap to paste functionality back. If someone in the community wants to offer a patch to do this we would be happy to review it.

Changed in mactel-support:
status: New → Invalid
Changed in unity:
status: Invalid → Opinion
Changed in utouch:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Invalid → Opinion
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Invalid
Ian Turner (vectro) wrote :

Chase,

Just a suggestion: If this is the future, it might be best to set the two finger tap to middle click by default, at least on systems with physical buttons. The rationale on this is that right-clicks are easy to do through other mechanisms (right button or menu key), while middle-clicks are more difficult to synthesize on most PC hardware.

Cheers,

--Ian

Chase Douglas (chasedouglas) wrote :

Hi Ian,

I understand the sentiment, but such a change would cause untold number of complaints from users who are used to two-tap being right click :). It would be a huge behavior change, so I don't think we would do it.

BTW, I think you may be able to change the mapping of number of touches to actions by fiddling with the xinput props for the trackpad device.

Daniel van Vugt (vanvugt) wrote :

Sigh.

Clicking is not a gesture. That is my opinion. And three-finger clicks can be made to co-exist with all the current gestures in Unity as my fix (above) shows.

The fix I proposed in June is nearly perfect. Certainly it seems perfect on Mac hardware and just needs some minor tweaking to avoid breaking some Dells etc.

It would be very unfortunate for Ubuntu and Unity if we abandoned this. We probably don't want to give people more reasons to not use Unity.

Daniel van Vugt (vanvugt) wrote :

Also, something I noticed earlier this year in Unity that is probably still true:

Unity treats "touch" as a gesture. "touch" probably should never be a gesture. Responding to "tap" and "drag" is enough to control the appearance of the grab handles.

If you remove Unity's sensitivity to all initial "touch" events then some of the perceived ambiguity in this argument should be resolved.

summary: - 3 finger touch interferes with 3 finger click (middle click)
+ Running Unity disables Xorg's 3-finger click support (middle click)
Ian Turner (vectro) wrote :

Chase: You wrote that changing the behavior of a two-finger click "would be a huge behavior change", wouldn't the same reasoning apply to changing the behavior of a three-finger click?

Daniel van Vugt (vanvugt) wrote :

It seems a couple of duplicates of this bug, and Chase himself, are talking about 3-finger taps. Please note this bug is about 3-finger *clicks* on clickpads. Not 3-finger taps.

description: updated
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Invalid → In Progress
Chase Douglas (chasedouglas) wrote :

Daniel,

Sorry for mixing up the clicking vs tapping aspect of this bug. You are right that they are different. I'm not sure yet what the best answer is for how to handle three touch clicking when three touch anything is grabbed by Unity.

On your merge request, I simply haven't had time to do any of the things you requested, and I'm not sure I will anytime soon :(. The best thing I can offer is to have you try to replay the example recording I attached in the merge request that shows how there are issues when using my trackpad. I know you've had issues trying to replay it, but maybe you'll be able to figure it out.

Chase Douglas (chasedouglas) wrote :

Ian,

You're right that taking three tap for paste away is a use case change, but it's not as big of a change as moving one response from one action to a different action.

Another thing to note is that Ubuntu tries to cater to people who come from all environments. The X copy/paste functionality is sort of an oddity in desktop systems. It ends up confusing people who aren't used to it. An argument could be made that although it can be used effectively, making it less easy to use would not be very harmful to the majority of users. All these aspects have been weighed against the ability to add meaningful gesture use cases, and the design team at Canonical believes this is the best approach at this time.

Daniel van Vugt (vanvugt) wrote :

No problem at all. It seems none of us realized we were talking about different things till now.

I would still like to see the fix for this bug though to the end. If you don't have time to look at it in detail just yet then that's understandable.

description: updated
Roland Dreier (roland.dreier) wrote :

Agreed. I have an Apple magic trackpad that I occasionally play with, and this issue / design choice makes it pretty unusable with current Unity. The multitouch gestures for moving windows are great and all, but what's the substitute for "highlight text with click and drag, and then middle click to paste" -- catering to all backgrounds is great, but what about old school X users? Also as others mention, middle click to close tabs in Firefox is pretty useful too.

Serhiy Zahoriya (xintx-ua) wrote :

What is the difference between click and tap?
Can I disable Unity getting in the way? I've tried to disable "Unity MT Grab Handles" plugin in ccsm, but it didn't work, obviously.
I have an old Eee PC 901 and I doubt that the touchpad has real multitouch capability. So for me it's a major regression because I still can't use three fingers to move/resize windows and will lose the ability to omit copying and pasting any needed text.

Daniel van Vugt (vanvugt) wrote :

In this case, a *click* means you have a clickpad which itself is one big button that can be depressed and makes a clicking sound. Like on an Apple Macbook, Magic Trackpad, or some HP laptops. Particularly, the button of a clickpad can be pressed and released without the fingers lifting off the clickpad/touchpad. So clicking a clickpad is different to tapping on a touchpad.

I have two suggestions that might work on an EeePC:

1. [Alex's workaround] Touch each finger down at a slightly different time. This seems to bypass the gesture recognition and lets you do a good-old middle button tap.

2. Use the buttons on your touchpad - Pressing both at the same time should generate a middle click. Run "man synaptics" for more info on that.

Daniel van Vugt (vanvugt) wrote :

I've made the current fix available for natty and oneiric in ppa:vanvugt/unity:

    https://launchpad.net/~vanvugt/+archive/unity

The natty version has been well tested on a Macbook Air. The oneiric version isn't yet tested.

Please try it and let me know how it goes for you, along with the details of what machine/touchpad you are using and your /var/log/Xorg.0.log file. Hopefully we can iron out the kinks soon (which have only been reported for a Dell so far)...

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Opinion → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Opinion → In Progress
Changed in mactel-support:
status: Invalid → Confirmed
Changed in utouch:
status: Invalid → Confirmed
shane (shane-animail) wrote :

Does this fix only affect the Mac problem with CLICKABLE touchpads or should this work with 3 finger TAPS also?

Daniel van Vugt (vanvugt) wrote :

Once perfected, the fix should only affect clickpads. It should not affect tap-to-click on touchpads.

But the fix is not perfect. So I'm interested in getting feedback to hear what kind of devices it fixes (or breaks), and which ones it has no effect on.

bwat47 (bwat47) wrote :

I would really like a fix for TOUCHPADS. ubuntu is unusable for me because of this. I've even tried switching from unity to gnome-shell but 3 finger tap does not work at all in ubuntu... It works fine in every other distro I've used.

bwat47 (bwat47) wrote :

Can confirm that fix does absolutely nothing for the touchpad on my asus u52f. two finger right click works fine, 3 finger does absolutely nothing whether I am in unity or gnome-shell. This is totally unacceptable behavior.

Serhiy Zahoriya (xintx-ua) wrote :

IIRC, three fingers click used to work for me in the Openbox but I didn't try it for a week.

Daniel van Vugt (vanvugt) wrote :

I agree touchpad owners should have the option of disabling Unity's 3-finger-touch gesture handling and getting 3-finger middle button emulation back. Such a general fix for touchpads would be in unity itself. I am only working on fixing clickpad support right now in xserver-xorg-input-synaptics.

The fix proposed in comment #35 is only intended to fix clickpads right now. However if you have a touchpad, then it is very helpful to know that the fix doesn't break anything. :)

Changed in unity:
assignee: Daniel van Vugt (vanvugt) → nobody
status: In Progress → Confirmed
Daniel van Vugt (vanvugt) wrote :

Someone else can work on the unity fix. That's very separate to what I'm doing in xserver-xorg-input-synaptics.

Changed in unity (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
status: In Progress → Confirmed
NachoR (nachordez-gmail) wrote :

All that's a bit confusing for me. I have a synaptics touchpad, and I was using really MUCH the three-fingers tap for opening links in a new tab, closing tab, pasting selections, etc. I think that was such a natural way of doing, that to say: change that for two fingers, is not a solution I can accept. There is a BIG advantage on having the mid-click assigned for three fingers: I use two for scrolling, and having two as a mid-clicks can trigger this action by mistake if I touch accidentally shot the touchpad, and then is much nicer to have the two-fingers-click assigned to right button, so, it just triggers the menu, ans just touching outside it get its out. Really fast and comfortable.

The problem (don't know if that's what Unity is doing to avoid the three-finger-click) is that synclient -m 100 reports just one finger in touchpad when there are three. And for me is the same in unity or XFCE4. I cannot use he mid-click with three fingers, and, really, it's a hell...... That should never be changed in that way, with no option to re-adjust. It's not a new action. It's a BUG.

bwat47 (bwat47) wrote :

I agree NachoR. I'm not sure if the touchpad issue is the same as this clickpad issue.

Because I've tried using gnome-shell and kubuntu. 3 finger tap doesn't work with either of them! In kubuntu I could get middle click working because by default kubuntu has middle click assigned to 2 fingers, but if I change it to 3 fingers it doesn't work. Any action assigned to 3 fingers in ubuntu 11.10 and its derivities does nothing at all. This is a big problem.

I also tried using xinput via the command line to swap the 2 finger and 3 finger actions. As with kubuntu middle click worked when assigned to 2 fingers, but right click (now assigned to 3) no longer worked. I have an asus u52f with a ETPS/2 Elantech Touchpad (uses synaptics driver).

Should there be a seperate bug filed for this? I've noticed basically every bug relating to 3 finger tap not working is marked as a duplicate for this bug.

bwat47 (bwat47) wrote :

Forgoet to mention a few things in my haste:

Of course even if this possible separate bug were fixed, an option to have unity recognize 3 finger tap as middle click would still be needed, and that relates to this bug. I also should mention I do not get the "love handles" in unity when I 3 finger tap, further showing 3 finger tap is not being detected correctly.

Serhiy Zahoriya (xintx-ua) wrote :

I just upgraded 11.04 with Gnome3 from PPA to the official 11.10 on my friend`s Asus T101MT and the three-finger click _works_ in Gnome 3.2.

Daniel van Vugt (vanvugt) wrote :

The issue with touchpads and clickpads actually overlaps a little bit in code. The fix I have so far (which still needs work), does affect touchpads and clickpads. But it will probably affect them differently...

The distinction between touchpads and clickpads is necessary because the Unity designers have reserved 3-finger tap as a special gesture. I agree this is very annoying, but reserving the 3 finger tap gesture does not affect clickpad users because they can still do a 3-finger click without triggering a tap gesture.

That all said, I know touchpad users still want a fix too, so I'll be looking at a general touchpad solution afterwards.

P.S. Please make sure you can get 3-finger clicking/tapping working in Gnome Classic or Gnome Shell. If it doesn't even work for you there, then you're not experiencing this bug.

bwat47 (bwat47) wrote :

Excellent, touchpad users would really appreciate that.

For the people having 3 finger tap not being recognized, when you 3 finger tap is it recognizing it as a single click? If so I think you should be looking at this bug:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/873482

Daniel van Vugt (vanvugt) wrote :

Similarly to bug 873482, if you're using the Apple Magic Trackpad and can't get any multi-finger clicks to work then you have bug 862094.

description: updated
G V V Sharma (gadepall) wrote :

1. The two finger problem happens only with the PPA
2. I do not have the option of tap to click in system settngs > mouse and touchpad. In touchpad, the only available options are two fingure scrolling and pointer speed
3. dpkg -l | grep synaptics gives
ii xserver-xorg-input-synaptics 1.4.1-1ubuntu2vv1 Synaptics TouchPad driver for X.Org server

Is the two finger right click problem new? I mean does it only happen with the PPA?

Do you have tap to click turned on in System Settings > Mouse and Touchpad?

Please also confirm the package version you have using:
dpkg -l | grep synaptics

And please post all replies as comments in bug 754000:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/754000

On 05/11/11 13:16, G V V Sharma wrote:
> Hi,
>
> Thanks to your ppa, I was able to get three finger touch recognized as
> a middle click on my mactel. However, I am not able to use two-finger
> scrolling well because two finger right click keeps interfering. could
> you suggest a way out?
>
> Vishwanath Rao.

Daniel van Vugt (vanvugt) wrote :

I just realized my PPA had the old version of the fix in it. I've now uploaded the new version:
1.4.1-1ubuntu2vv2

Please wait for it to build and be published, then let me know if it solves the 2-finger problem. If it doesn't then I have another fix in mind that I can apply...

Daniel van Vugt (vanvugt) wrote :

@gadepall, please try updating to the latest version 1.4.1-1ubuntu2vv2 from my PPA and let us know if that solves the 2-finger problem.

G V V Sharma (gadepall) wrote :

when I type
sudo apt-get update
I get the following
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net oneiric Release: The following signatures were invalid: BADSIG 07F44D6CE0BB1767 Launchpad PPA for Daniel van Vugt

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://extras.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key <email address hidden>

W: GPG error: http://in.archive.ubuntu.com oneiric Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <email address hidden>
W: Failed to fetch http://ppa.launchpad.net/vanvugt/unity/ubuntu/dists/oneiric/Release

W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/oneiric/Release

W: Some index files failed to download. They have been ignored, or old ones used instead

Daniel van Vugt (vanvugt) wrote :

@gadepall, it seems like you might have been temporarily unable to reach the required servers, or forgotten to configure the repository properly. Please try:

sudo add-apt-repository ppa:vanvugt/unity
sudo apt-get update
sudo apt-get upgrade

If that fails please contact the Ubuntu forums for further help, because I don't believe there is a problem with the PPA.

description: updated

The package from the ppa does not solve the problem on Oneiric.

I have installed the package from http://packages.debian.org/squeeze-backports/i386/xserver-xorg-input-synaptics/download which does not contain the Unity MT Grab handles patch. This makes 3 finger tapping to middle click work again.

So please, remove these patches or modify them to three finger hold instead of three finger tap for Love Handle activation.

Daniel van Vugt (vanvugt) wrote :

Marcus,
1. What kind of touchpad/hardware are you using?
2. Is it a click-pad or a touch-pad?
3. Could you please attach a copy of your /var/log/Xorg.0.log ?

N: Name="ETPS/2 Elantech Touchpad"

It can be clicked but I am using three finger tap.

xorg log file as requested

Daniel van Vugt (vanvugt) wrote :

I can confirm 3-finger tap-to-click does not work, even with the MT Grab Handles plugin disabled in ccsm. But this is not a bug in the PPA and I did only intend to fix actual clicking with clickpads for now.

From memory, the reason for this is that unity unconditionally captures all 3-finger touch events. And the only way I know of preventing this is to hack the unity code (last time I checked about 9 months ago). This is why my fix works with clickpads and not touchpads (or tap to click). Because a 3-finger click on a clickpad is a physical button event that happens after a 3-finger touch, so it's easy to handle the button event even while unity is already handling the touch event that happened before it.

I think a fix in unity itself is required to support touchpads or tap-to-click. It probably makes no sense that unity should still be capturing all 3-finger touches even when the MT Grab Handles plugin is disabled.

bwat47 (bwat47) wrote :

Are there any plans on some sort of fix for this? I'm really hoping there's something workable by 12.04. I'd imagine ubuntu currently has significantly more touchpad users than touchscreen users and they should not have significant missing functionality missing, especially for an LTS release.

Would some sort of option in CCSM be a possibility? Or automatic detection of a touchpad that could enable this? Seems a bit odd that as mentioned above disabling the offending plugin still doesn't seem help things. Disabling the plugin isn't something I can test though, as a separate bug in the synaptics driver (mentioned above I believe) is also causing trouble with 3 finger taps without unity.

Chase Douglas (chasedouglas) wrote :

We are working on options for 12.04. I don't know exactly how things will fall out, but my hope is that it can be configurable.

Bence Lukács (lukacs-bence1) wrote :

For me on Precise 3 finger tap doesn't work either.
It also doesn't work with unity2d.
If I tap three finger on the touchpad nothing happen.
I have a synaptics touchpad.
xserver-xorg-input-synaptics: 1.5.99~git20120223-0ubuntu1

Chase Douglas (chasedouglas) wrote :

On Precise, the uTouch gesture stack sits on the client side of X. For it to work properly, touch events need to be emitted. Unfortunately, if the X synaptics input module is listening for three touch gestures (three touch tap for middle click, for example), this will prevent the X server from sending touch events, which blocks uTouch gestures.

We decided to disable three touch gestures in X synaptics by default. It is still possible to enable them by using xorg.conf or the synclient/xinput utilities. For example:

$ synclient TapButton3=2

will enable three-tap to middle click emulation.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Won't Fix
no longer affects: utouch
no longer affects: unity (Ubuntu)
no longer affects: unity
Changed in mactel-support:
status: Confirmed → Invalid
Bence Lukács (lukacs-bence1) wrote :

Oh, thanks for the workaround.
So that means, that this bug won't be fixed in Precise?

Chase Douglas (chasedouglas) wrote :

Hi Bence,

It's not really a bug because it is working as designed. However, you are free to override the default behavior if you want.

Daniel van Vugt (vanvugt) wrote :

It sounds more like the status should be Fix Released in precise. With a note that it's disabled by default.

Assuming that "synclient TapButton3=2" does indeed solve this bug in precise.

Daniel van Vugt (vanvugt) wrote :

Confirmed with a touchpad that this now works in Ubuntu 12.04. Just set:
    synclient TapButton3=2
which means when tapping with 3 fingers, send a click for mouse button 2 (middle).

Daniel van Vugt (vanvugt) wrote :

And confirmed with a clickpad (Apple Magic Trackpad) that clickpads also work in 12.04. Just set:
    synclient ClickFinger3=2
which means when clicking with 3 fingers, send a click for button 2 (middle).

Please change the status to Fix Released if possible (I can't).

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
bwat47 (bwat47) wrote :

Synclient workaround doesn't seem to be working for me anymore after today's synaptics updates...

Marius Jigmond (mjigmond) wrote :

I can confirm the workaround no longer works. Annoyingly inconsistent behavior :).

Kamyar (kammoh) wrote :

I as well may confirm that three button tap does not work with xserver-xorg-input-synaptics 1.5.99.902-0ubuntu1 (precise) update. "xinput test" doesn't show a thing. This new bug is absolutely unrelated to unity though. So I'd better fill in a new report; or maybe someone could point me to a relevant bug report?

bwat47 (bwat47) wrote :

If you have an elantech touchpad it seems there is a regression with the newest synaptics driver:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/873482

"It is almost certainly 200_fix_four_tap.patch, it reintroduces the finger counting which is not valid for our touchpads."

"And merged upstream now, so I guess it finally is an upstream bug. http://patchwork.freedesktop.org/patch/9628/ http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/commit/?id=da461b91659d0c64aa6827e065aee2682116a57e (a week after I get the upstream bug closed...)"

Here's the upstream report that was initially closed because it was an ubuntu issue, but now does seem to be upstream:
https://bugs.freedesktop.org/process_bug.cgi

Its causing 3 finger tap to be recognized as 1 finger AGAIN. I was so glad this was finally fixed only to see it regress late in the dev cycle, just awesome :/

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Won't Fix → Confirmed
assignee: nobody → Chase Douglas (chasedouglas)
Kamyar (kammoh) wrote :

I'm not really sure about the brand and make of my touchpad. It's on a VAIO laptop and xinput lists it as " SynPS/2 Synaptics TouchPad". I believe my case to be different from #873482 as 2-finger taps works fine and xinput does NOT report anything from a 3-finger tap. I'm now back to 1.5.99.901-0ubuntu2 (precise) as it works flawlessly for me.

Chase Douglas (chasedouglas) wrote :

Rather than reuse this bug for a new issue, I've decided to create a new bug and revert this to "Won't Fix". Please see bug 971783 for more details.

Thanks!

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Won't Fix
assignee: Chase Douglas (chasedouglas) → nobody
Salvador Diaz (salvadordiaz) wrote :

For anyone looking for a simple solution on Precise:
* Make sure ccsm is installed (sudo apt-get install compizconfig-settings-manager)
* Open ccsm
* Search for Unity
* Disable 'Unity MT grab handles'

Vincent Tschanz (fogia) wrote :

Salvador Diaz > disabling "Unity MT grab handles" does not solve the problem for me.
I have a Macbook pro 1.2, and middle click with 3 fingers worked on 11.10.

Miek Gieben (miek) wrote :

On raring this still is an issue

NoBugs! (luke32j) wrote :

Any fix for 13.10 for the three finger middleclick?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments