Keyboard does not work when touchpad disable button pressed

Bug #571638 reported by ken.rowe
192
This bug affects 41 people
Affects Status Importance Assigned to Milestone
XOrg-Driver-Synaptics
Unknown
Medium
xserver-xorg-input-synaptics (Ubuntu)
Incomplete
Low
Unassigned

Bug Description

When the touchpad disable button is pushed on an HP DV6000, the touchpad is disabled, but the keyboard stops responding. Running Lucid Beta 2 with all updates. The button worked fine until two days ago. The only way to restore the keyboard is restart with Ctrl-Alt-Del.

Expected action: Disable touchpad.

Result: Touchpad is disabled, but keyboard stops responding.

Ubuntu 10.04 LTS

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: udev 151-12
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
CustomUdevRuleFiles: 10-vboxdrv.rules
Date: Thu Apr 29 18:49:40 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
MachineType: Hewlett-Packard HP Pavilion dv6000 (GA374UA#ABA)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=4ea1d3f9-59e7-45d3-969d-57cdb7a41d5c ro quiet quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: udev
dmi.bios.date: 06/01/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.26
dmi.board.name: 30BB
dmi.board.vendor: Quanta
dmi.board.version: 66.3E
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.26:bd06/01/2007:svnHewlett-Packard:pnHPPaviliondv6000(GA374UA#ABA):pvrRev1:rvnQuanta:rn30BB:rvr66.3E:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6000 (GA374UA#ABA)
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Revision history for this message
ken.rowe (kenrowe410) wrote :
Revision history for this message
Timothy J. Lanza (tjlanza) wrote :

I'm not sure how to generate all the logs ken.rowe supplied, but my machine is also an HP DV6000. I did not have any problem disabling the touchpad via the hardware button under 9.10.

Revision history for this message
extremus (serg-mikhailoff) wrote :

I confirm the bug on my HP dv6220eu.
Pull down menus (gnome-menu) and most of the keyboard are dead after pressing the hardware touchpad disable button.
The only workaround to re-enable keyboard and menus is to kill gnome-settings-daemon, then start it again.
The nautilus should be also restarted to look fine after using this trick.

Revision history for this message
Evan Gilbert (gilbert-evang) wrote :

The behavior extremus describes happens to me as well. I'm using an HP dv7 laptop.

Revision history for this message
Thach Nguyen (deus-ex-nova) wrote :

I have an HP dv6500/dv6500t and I am having the same problem. I was running the Ubuntu 10.04 RC up until its LTS release, and the problem is still not fixed.

Revision history for this message
bhood (byron-phareware) wrote :

I also have an HP dv6000 series notebook and am experiencing this issue. I am running the production release of 10.04LTS, upgraded from 9.10. Any ideas on what is causing this issue?

Revision history for this message
Sean (seanrijs) wrote :

I have the exact same issue with my HP dv7-3080ed laptop.

Revision history for this message
Juan Borla (jaborla) wrote :

I have the exact same issue with my HP dv5t series. It did not happen with karmic, nor does it happen with my Windows Vista partition.

Revision history for this message
extremus (serg-mikhailoff) wrote :

1. It seems that I've found a workaround that is slightly less ugly than 'killall gnome-settings-daemon' from my first comment. When I press the disable button while mouse pointer is over an open menu (gnome main menu e.g.), a next click to re-enable the touchpad is not freezing the keyboard.

2. I am not sure, but the xserver-xorg-input-synaptics (1.2.2-1ubuntu4) package may be responsible for the bug. I suppose so, because after removing this package the bug disappeared. (My touchpad was working. But cursor's dynamics made it unusable; so I've re-installed the package).

P.S. I use HP dv6000 series laptop with Ubuntu Lucid (amd64) upgraded from Karmic.

Revision history for this message
Thomas Edwards (tom-rb-edwards) wrote :

I have the same problem on an HP Pavilion dv9560 laptop. However, when I press the touchpad on/off button, not only does the keyboard become unresponsive but I can no longer access the applications menu (whether I left-click on it with my mouse or press alt+f3). Also, when using my mouse after the problem occurs, right-click doesn't do anything, and the only things I can left-click on are on the taskbar.

I use an HP dv9560 with Ubuntu lucid upgraded from Karmic.

Revision history for this message
Lazyfirecloud (lazyfirecloud) wrote :

same problem with a tx1400us tablet pc. ctrl+alt+backspace is my quick fix (if you enabled it in your keyboard shortcuts)... I'm running Lucid upgraded from Karmic, with all updates (but seriously thinking of putting Jaunty back). Let me know if you need any log files.

Revision history for this message
Max (maxencelegrand) wrote :

Same problem on HP DV6510ef.

With Ubuntu 9.10, I hadn't this bug !

Revision history for this message
Max (maxencelegrand) wrote :
Revision history for this message
Thomas Edwards (tom-rb-edwards) wrote :

Its only a temp fix though. As soon as you press the touchpad button again, you get the same problems as before

Revision history for this message
Max (maxencelegrand) wrote :

Yes sorry. When I reboot, the problem comes back. I must press CTRL+ALT+F1 to restart gdm and then the touchpad disabled button works well.

Revision history for this message
NasRat (nasrat87) wrote :

i have the same problem , i had it when i upgraded from 9.10 to 10.04 beta , then after i did a clean install i had the same problem , if I press the disable button not only the keyboard freeze , but most of gnome also , like the keyboard respond only to "Ctrl + Alt + del" , i cant do anything in the upper panel, the compiz does not work (Cube for example) , only the shortcuts works and it keeps going like this until i terminate the gnome-session from the processes in the system monitor, after shutting it down and relogin I can disable it and reenable it without any problem , untill i shutdown or restart my system the hall thing comes back again .

-$ uname -a
Linux ******-laptop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

Revision history for this message
Timothy Hanneman (duke-tim) wrote :

Same issue as tomas #10, same fix as max #15 this is now LTS and the original bug reported seems to be related but not the same.

Revision history for this message
Frisbee (anurakph) wrote :

I have also the same problem with my DV6057ea and clean installed 10.04LTS and latest package update doesn't help me at all.

Revision history for this message
SDonatas (sdonatas) wrote :

With new kernel my touchpad doesn't work at all, whether turned on or off on boot. And yes, I have the same odd issue with keyboard when I press touchpad off button when OS is loaded.

I'm using ubuntu 10.04 x64 (fully updated) on HP DV6529em laptop.

Revision history for this message
Mark Simmons (mark-mysimmons) wrote :

I have the same problem on my dv6-1388. I use my DV6 at work and home. At work i don't use WiFi and the touchpad seems to work better then when I get home and start using WiFi. ubuntu 10.04 32bit

I can enable / disable without loosing my keyboard buy following the #13 reference link link in this thread and then look @ #34
sudo modprobe -r mouse
sudo modprobe -r psmouse

Revision history for this message
hamacker (sirhamacker) wrote :

I confirm this but on notebook dv9000.

When touchpad is on/off after gdm session, keyboard stop responding, but not freeze because CTRL+ALT+F1, CTRL+ALT+F2,CTRL+ALT+F3,...,CTRL+ALT+F12 and CTRL+ALT+DEL work as well.

If I go to the terminal with CTRL+ALT+F1 and come back to gnome session with CTRL+ALT+F7 then keyboard does work again.

This is a BIG BIG BUG.

Revision history for this message
Jonathan Siebott (jonsiebott) wrote :

I can confirm this bug on HP Pavilion dv6700.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Jonathan Siebott (jonsiebott) wrote :

I think we all agree the bug is real and resides in package xserver-xorg-input-synaptics (1.2.2-1ubuntu4).

affects: ubuntu → xserver-xorg-input-synaptics (Ubuntu)
Revision history for this message
SDonatas (sdonatas) wrote :

I have the same problem. Just want to add, that it is possible to make touchpad usable permanently at startup with this command:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

However, keyboard problems still appear when I use touchpad on/off button (hp DV6500). Once I press this button, mouse moves, but doesn't click (inc. right/left click) on gnome related GUI desktop elements (gnome-panel, desktop). But strangely it does click on Avant window manager dock icons. Keyboard typing doesn't work, but again strangely some keyboard short-cuts seem to work e.g. ctrl+alt+backspace (xserver restart). I personally believe it is something deep and I would avoid using random workarounds which doesn't fix the root of the problem. Also there may be no problems with synaptic, because live CD works fine for me. I turn on and off my touch-pad without loosing keyboard functionality or having other crashes. This may be related to updates originated after official release of Ubuntu 10.04, including new kernel updates.

Revision history for this message
wribeiro (wribeiro) wrote :

I can confirm the same behavior with my HP Pavilion dv6000, Ubuntu 10.04.
Once touchpad's lock button is pressed, menu completely freezes and system must be restarted using ctrl-alt-del.
This problem didn't happen in earlier versions of Ubuntu.

Revision history for this message
Mattia Impellizzeri (matt-91web) wrote :

Hi, I have this problem too.
but I noticed something strange. When this happens, if I go to one of the console with CTRL + ALT + F1 and then return to graphics mode, and the keyboard starts to work and second that it recharges the graphic mode the mouse works, and are forced to use an external mouse .
Then if I go out and go from GNOME to KDE (although I have not seen graphics that I have installed all of KDE), the touchpad works, and also the login screen it works.

Sorry if I haven't written in correct English.
Always available for questions.

Revision history for this message
Mattia Impellizzeri (matt-91web) wrote :

hi, the bug in my opinion is very serious, whereas all of the HP laptop series dv6xxx dv7xxx and can not use the touchpad.
My question is, there is an "alternative" how we can solve the problem, even momentarily?
how I can help you help us?
I emphasize that it is a LTS Lucyd
thanks

Revision history for this message
SDonatas (sdonatas) wrote :

Please read all of the replies and you will find the temporary solution.

This one seems to work for me, but you shouldn't touch your on/off button otherwise this will mess it up your mouse/keyboard functionality.

Run the terminal and paste this:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

Then reboot your laptop. After start-up your touch-pad should work as it should.

To undo it when permanent solution will come up just paste:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled false

Revision history for this message
Evan Gilbert (gilbert-evang) wrote :

Post #103 in this bug report seemed to fix this issue for me on my HP dv7 laptop (https://bugs.launchpad.net/bugs/549727). I've rebooted several times, and I am now able to enable and disable my touchpad without the gnome menus or keyboard breaking.

Revision history for this message
extremus (serg-mikhailoff) wrote :

Thank you #29! I confirm the solution on my dv6220.

Revision history for this message
Alan Reed (al-reed13) wrote :

Solution works on my dv5-1235dx

Revision history for this message
Tenho Tuhkala (muppis) wrote :

I tested solution mentioned in post #29 in two DV6000 -series laptops, first has upgraded Ubuntu Lucid Lynx and second fresh installed Linux Mint 9. It works in both.

Revision history for this message
nencio (f-nencio) wrote :

Solution proposed on Post #103 in https://bugs.launchpad.net/bugs/549727 works for my HP dv6626us as well.

Revision history for this message
Jonathan Siebott (jonsiebott) wrote :

Works with HP Pavilion dv6700. Reposting relevant excerpt of #103 of Bug Report #549727 for everyone's convenience...

You need to prevent gnome-settings-daemon from disabling your touchpad in the first place, because the Synaptics touchpad driver does this already. To do so, run the following command in a terminal:

Code:

gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad ""

This dissociates the key to lock your touchpad from gnome-settings-daemon. If for any reason, the latter command breaks the lock touchpad support for you, than you probably have a different issue. To re-associate the key with gnome-settings-daemon, run this command:

gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad XF86TouchpadToggle

Revision history for this message
shadow (s-shadowless) wrote :

Helllo

i confirm this BUG for my hp dv6700 laptop in ubuntu lucyd .
i work with an usb mouse and the touchpad together. when i disable the touch pad, even mouse and keybord
stop working and i have to reboot the system . The mouse and even the touchpad can't sselect widgets on the panels ,thus
i have to reboot with the CTRL+ALT+CANC menu

Hope you can solve soon this bug

Regards to all

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Invalid
status: Invalid → Confirmed
Revision history for this message
Mark (pilota51) wrote :

I also have this problem on HP Pavilion DV9912NR with Ubuntu 10.04 64bit.
After it happened and could hardly do anything, I disconnected the AC and closed the lid to suspend/sleep, then when I woke it up the keyboard and mouse clicks were working properly, although the touchpad was still disabled regardless of the toggle button status. As little as I've tried, I haven't been able to reproduce the bug on-demand. As mentioned in a few other posts, I gave the #103 of #549727 workaround a spin, but it'll be awhile before I'm sure if it works since I haven't managed to reproduce.

Revision history for this message
Daniel Garcia Stelzner (dani-garcia87) wrote :

Works for me too! :-)

I have Pavilion dv5 1140, Ubuntu Lucyd 32bits

thanks a lot!

Revision history for this message
Marzata (marzata) wrote :

I confirm the bug on my HP Pavilion dv6000.
Ubuntu 10.04 LTS (lucid).
Kernel Linux 2.6.32-24-generic-pae.
GNOME 2.30.2

When I press the touch pad disable button the keyboard and the external usb mouse stop working and the laptop need to be hard rebooted. It is outrageous to have such big in a LTS, the bug did not exist on Ubuntu 9.10 and before.

Revision history for this message
sssent (sssent) wrote :

This bug still exists in Ubuntu 10.10 on an HP 2530p, however removing the touchpad key binding for gnome-settings-daemon (as described above) works like a charm. This should be the default option.

tags: added: regression
Revision history for this message
Christian Göbel (christiangoebel) wrote :

Same issue on a Samsung X20.

I tagged this bug as regression, since before Lucid everything worked fine.

The following bug seems to be related (as mentioned above):
https://bugs.launchpad.net/bugs/549727
The comments there suggest that the issue is due to the interaction between gnome-settings-daemon and the synaptics driver.

So it is not clear if the bug is appropriately assigned to the synaptics driver.

Anything we could do to get more attention? Should we deliver more information? Open a bug-report upstream? Which project?

Revision history for this message
Christian Göbel (christiangoebel) wrote :

I am just a user, trying to find out if the problem is due to a change in the Synaptics-driver or to a change in the gnome-setting (or gnome-settings daemon).

In earlier versions of Ubuntu (8.04) the following entry (apparently responsible for the problem) does not exist in gconf:
/apps/gnome_settings_daemon/keybindings/touchpad

Could somebody please check if the keybinding is set in Ubuntu 9.04 (the last version of Ubuntu where the problem did not appear). I already tried to check this is a live-cd - however Ubuntu 9.04 did not boot on my laptop.
If you have a live-CD or install of Ubuntu 9.04 available please:
a) boot
b) open gconf-editor (e.g. Atl-F2, type gconf-editor)
c) check the value of /apps/gnome_settings_daemon/keybindings/touchpad
d) report back the answers to the following questions:
- Does the entry /apps/gnome_settings_daemon/keybindings/touchpad exist?
- What is the value of the setting?

Thanks a lot in advance.

Revision history for this message
Ashley (lifenstein) wrote :

Had this problem on my HP DV6733TX laptop from at least Ubuntu 10.04, still have in 10.10. Keyboard doesn't respond after trackpad is disabled using trackpad toggle button is pressed, and USB mouse is also affected. Mouse clicks don't register all the time, especially in menus.

Revision history for this message
Christian Göbel (christiangoebel) wrote :

I finally got my hands on a computer that could boot with Ubuntu 9.04 (the last version of Ubuntu where this problem did not appear).
In Ubuntu 9.04 (gnome 2.26.1) the following entry does NOT exist in gnome settings:
/apps/gnome_settings_daemon/keybindings/touchpad

Since setting this entry to empty solves the problems the issue seems to be related to the introduction of the key in recent versions of Ubuntu.
The following comment on a related bug provides a possible explanation:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/549727/comments/103

In short, the author suspects that gnome_settings_deamon and the synaptics driver both try to activate and deactivate the touchpad and one of them fails, which is suffienct to lead to the reported issue.

If you delete the corresponding key in gnome settings then everything works fine again, since the synaptics driver takes care of this (as has been the case prior to Ubuntu 9.10).

Now, is this a gnome_settings bug?
Who should take care of switching touchpad on/off? Gnome? The synaptics driver?

I am willing to open a bug upstream if a knowledgeable developer could provide some indication who should fix the bug.

Revision history for this message
Christian Göbel (christiangoebel) wrote :

One of the developers of gnome-settings-demon has commented on the upstream-report:
https://bugzilla.gnome.org/show_bug.cgi?id=638458

To summarize:
udev seems to be responsible for this issue.
The issue has been fixed in current versions of udev.

Revision history for this message
Christian Göbel (christiangoebel) wrote :

Hmm - I tried to add udev (ubuntu) to the bug-tracker, without success. :-(
It would be great if one of the developers could:
- verify if the bug is actually due to and issue with udev
- assign this bug to udev
- if possible: patch/update udev to solve the problem for Ubuntu 10.04 and 10.10 users.
Thanks in advance

Changed in xorg-driver-synaptics:
importance: Unknown → Medium
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

ken.rowe, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-input-synaptics REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.