Ubuntu

Touchpad stops working after login

Reported by Diego Viganò on 2010-03-27
472
This bug affects 103 people
Affects Status Importance Assigned to Milestone
Freespire
New
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
samuel
Declined for Dapper by Timo Aaltonen
Declined for Hardy by Timo Aaltonen
Declined for Intrepid by Timo Aaltonen
Declined for Jaunty by Timo Aaltonen
Nominated for Karmic by Ace
Nominated for Lucid by Ace
Nominated for Maverick by daniel

Bug Description

Binary package hint: udev (but not quite sure)

On my Lenovo T60 the Touchpad works great until I login using GDM.

After 2-3 seconds I've pressed "Login" it suddenly stops working and I must use an external USB mouse.

I'm using Lucid Lynx Beta1.

description: updated
Lawry (lade334) wrote :

Can confirm this bug on Acer Aspire 5536G

Javier Cabezas (javier-cabezas) wrote :

Confirmed on a Lenovo T400

Changed in hal (Ubuntu):
status: New → Confirmed
Naxiey (naxiey) wrote :

Can confirm it on an HP dv7-2122eo

summary: - [10.04] Touchpad stop working after login
+ [10.04] Touchpad stops working after login

I can confirm that since upgrading to beta 2 my touchpad on an HP dv2054ea stopped working. If I uninstall the xserver-xorg-input-synaptics driver it then works, although in a slightly erratic fashion.

fdegir (fdegir) wrote :

Same problem occurs on Lucid Lynx Beta2. (Using Acer Aspire 5920G.)

Jarige (jarikvh) wrote :

Yup, this is exactly my problem either. Acer Aspire one ZG5...
I hope this will be fixed soon, or at least a workaround from anyone... I use the touchpad more often then the mouse (I actually got used to that thing! :O ). I'm glad I've found people with the same problems, that means it should be fixed one of these days :)

Jarige (jarikvh) wrote :

Isn't this a bug in xserver-xorg-input-synaptics since it is gone when removing this package?

Jarige (jarikvh) wrote :

I did some testing; and previous versions of xserver-xorg-input-synaptics don't work. I thought it would work as a workaround, but it didn't. The 1.2.2-1ubuntu1 version had the same problem (apparently, the current version and 1.2.2-1ubuntu1 were released 41 seconds after oneother) and 1.2.0-3ubuntu2 acted as if the drivers weren't installed. The touchpad was very weird acting, and I could not scroll etc.
I tried 1.1.2-1ubuntu7 (the current version in Karmic) but that one didn't install because of some package conflict.

I hope that anyone finds this information useful in some strange way :) I just wanted a workaround and thought a previous version might fix it.
So I'm still having this problem... :(

Chris Highfield (cmhighfield) wrote :

I have managed to resolve the problem on my HP DV2054ea laptop by installing the following two packages:

gpointing-device-settings
touchfreeze

I hope this helps others.

Regards,

Chris.

Jarige (jarikvh) wrote :

Christ, thanks for your efforts.
Sadly your solution doesn't work with me. I tried rebooting, I added touchfreeze to the startup applications, turned the touchpad on and off on both touchfreeze and Fn + F7. All to no avail.
I hope there's an other way to do this :S This obviously must be fixed before release. It looks until now as if every touchpad has this...

Jarige (jarikvh) wrote :

Is there any way of notifying this bug report to the xserver-xorg-input-synaptics developers? If they don't know this bug, they won't be fixing this bug. I don't know how that works though. I think it has something to do with the 'also affects project' button, but I couldn't find that package name anywhere.

Diego Viganò (diego-vgn) wrote :

I changed the "Affects" column at the top of the page, changing it from "hal" to "xserver-xorg-inputs-synaptics". Maybe this can be helpful to the developers of such package.

affects: hal (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Bryce Harrington (bryce) on 2010-04-13
tags: added: lucid
Jarige (jarikvh) wrote :

Thank you Diego. For some reason, I wasn't able to do that.
Now lets hope someone will fix this soon...

Ace (linuxrawkstar) wrote :

I confirm that this bug affects me. Using acer aspire 5740-5255

Jarige (jarikvh) wrote :

For some reason, this bug stopped affecting me. Maybe the gnome version that recently came through the update manager fixes this? I'm able to use the touchpad again, so I recommend you guys to just go to the update manager and install the updates. I don't know which one fixed this bug for me, but I'm curious to see whether you guy have it fixed too.

Jarige (jarikvh) wrote :

No reply so far. Did anyone notice this bug has been fixed or is it just me?

acme (cyb-acme) wrote :

I confirm that this bug affects me. Using Acer Aspire 5106AWMLi

Bryce Harrington (bryce) wrote :

I don't really think there's enough information provided to consider this bug report a true "defect report" but am assigning it to tseliot to take a look at and decide if the issue looks worth evaluation.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

Can you reproduce the problem and attach your /var/log/Xorg.0.log, please?

What kind of information do you need? There is nothing strange in /var/log/Xorg.0.log nor in dmesg output.

Happens to me every time I boot the machine

Naxiey (naxiey) wrote :

My touchpad has start working again after a lot of packages updated earlier today :)

Jarige (jarikvh) wrote :

Ah, I knew I shouldn't have been the only one for whom this bug has been gone suddenly. I think this bug is solved already, somehow. If the original bug reporter would return here and share his thoughts on this that would be ideally.
Is there anyone still having this bug, whilst not having any problem before?

Lawry (lade334) wrote :

I can confirm it has been fixed in an update also. Acer Aspire 5536G

Jarige (jarikvh) wrote :

Since multiple people confirmed a fix, I found this appropriate.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Fix Released

Not working here. Lenovo T400

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Fix Released → Confirmed
GabePez (gabe-findgabe) wrote :

This is not working for me. I had the problem start about 3 days ago (4/14?) after applying updates. The pointer started shaking and being unresponsive. I rebooted and the touchpad worked until I logged in. After some troubleshooting I created another user account and the touch pad works in that account.

I think this is probably due to corruption or mis-configuration of a user level configuration, but I have not been able to find information about user specific config files that reference touchpad settings. Toggleing TouchpadOff with synclient does not seem to have any effect, but I don't know if I need to restart a service or whatnot to get the new setting to take effect. After logging back in it reverts back to 0.

Exiting and entering Xwindows and applying other packages per #10 did not help.

I am working with an HP Touchsmart tx2, running 10.04 beta2, amd64, applying the latest patches daily. If I can provide any more information let me know.

Alternatively if anyone can point me to config files to look at it would help greatly. I really feel like a user level configuration simply toggled the touchpad off.

GabePez (gabe-findgabe) wrote :

After getting frustrated and deleting all gnome configurations with:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

obviously this is a bit of a pain, but better than the touchpad not working. I will post another comment if the problem happens again.

Lawry (lade334) wrote :

This bug is back for me too now, acer aspire 5535G.
It happens on the reboot after I disable the touchpad (this model has a hardware button for this).
Back to frustration!!

FlashFire (teflashfire) wrote :

I can confirm that this bug also affects the Acer Aspire 5739g.

Naxiey (naxiey) wrote :

And now it has stopped work again...

Jarige (jarikvh) wrote :

This bug appears to come and go randomly. A few days back it suddenly stopped working when logging in, the day after (or a reboot, can't remember) it worked again.
BTW, I heard that Synaptic was bussy on (proprietary) drivers for the touchpads to enable multi-touch on Linux :D Pity they are proprietary though... But hopefully, those drivers will show the open source drivers developers how to solve that :) Has nothing to do with the bug though. Just something that popped up in my mind.

Pål F. Kristiansen (paalfe) wrote :

using 10.04 RC with all updates and I have this problem

Jarige (jarikvh) wrote :

I received a possible workaround on my Ubuntuforums topic. I didn't try this, and I don't know the details of what these commands do. This is what I was told to do:

[quote]
You can write:
Code:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

To make permanet include the last line in /etc/modprobe.d/options
[/quote]

Got it from here:
http://ubuntuforums.org/showthread.php?p=9173688#post9173688

Pål F. Kristiansen (paalfe) wrote :

I did what Jarige wrote and it worked after running:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

To make permanet include the last line in /etc/modprobe.d/options did not work.

PC is a HP Pavilion dv9550 eo

Lawry (lade334) wrote :

Likewise, this fix works for me but cannot add it through modprob.d.
I do not have a /etc/modprob.d/options.conf so have created one but with success. Has someone managed to do this?

Jarige (jarikvh) wrote :

The file in the workaround does not exist. In Lucid, apparently, that file has been judged obsolete and been removed. There's probably a file which does the same, or some other workaround that will do this every boot.

I attached an .sh file for the convenience, and I changed 'sudo' to 'gksudo' so you'll get a graphical interface question for the root password instead of a commandline version. You can download it in your /home directory, and make it run every boot by going to System -> Preferences -> Startup Applications and click on 'Add'. Type anything in the name section, and type this command in the command section: sh ~/workaround.sh

I don't know whether this works though. I don't have this bug anymore for some strange reason (without workaround). So I can't test it... And again, the workaround is not mine.

Dale Russell (drussell-gmail) wrote :

I have a T500 and it was working on 10.04 for a month until I did an update this morning. The workaround works but the bug still exists.

JonathanD (stolenpie) wrote :

Yup, after updating to 10.04 my touchpad also stopped working. Even on the login page I cannot use my touchpad.

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

also works for me but only as a temp solution, it's not yet a fix...

Ben Munro (benjamin-munro) wrote :

The above fix works for me, but leaves me with a non-accelerating pointer and unable to scroll with the touchpad.

I found another fix that works better.:

rm -rf /home/ben/.gconf/desktop/gnome/peripherals/touchpad

You need to kill the session (killall gnome-session) and log in again after you do this. The bug keeps re-occurring and needs to be fixed every time.

This is on a Hewlett Packard dv6 2113tx.

74 comments hidden view all 154 comments
nencio (f-nencio) wrote :

The solution suggested on comment #103 worked on my HP Pavillion dv6626us.

Arvind V (arvind-venkatadri) wrote :

Hi there all,

I am a Linux newbie. I recalled that I had had similar problem with Karmic about 4 months ago and I had fixed it then. After some recalling, I got it and here it is:

I went to the System -> Administration - > Windows menu and went to the Windows Preferences tab.

There for the "Movement Key" there is a radio button selection of "Super Key" or ALT" key. BOTH radio buttons had somehow become enabled, I do not know how this happened, but I suspect it is because I installed SUGAR. However, when I selected just one option there, the Touch Pad began to work immediately.

I hope this is of help to someone.

Warm Regards
Arvind

nico (nicolas-pourcelot) wrote :

#103 works for me, too. Acer Aspire Timeline 4810T

daniel (nelsondaniel94) wrote :

the touch pad was not working for me after making the switch from windows 7 to ubuntu you could not use the touch pad as soon as it connected to the wifi if the wifi is turned off it works perfectly how ever after reinstalling Ubuntu to see if that was the problem i loaded the live cd with ubuntu 10.4lts on it and i connected to the internet via wifi and the touch pad was working i have found if you install ubuntu 10.4lts when you have connected to your wifi network and if you don't encrypt you home directory the touch pad works fine i am using a acer aspire 5535 and ubuntu 10.4lts 64bit and all i can say is it is amazing fast and easy to use much better than windows

Kevin Brodigan (kev-brodigan) wrote :

Had same problem on acer aspire laptop.

touchpad worked, then stopped working for my user only. When logging in with my son's user, the touchpad worked fine. So went with the deleting the .gnome2, gconf etc etc solution as it seemed to be user specific and not system specific (the modprobe solution).

Touchpad now works fine, but all other settings gone too. Bit of a pain, but not too hard to put right.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Alberto Milone (albertomilone) → Frank Nielsen (frank-boegh)
Brando753 (brando753) wrote :

Can confirm bug on Hp dv5 series laptop, Was acting weird so i reset it then the mouse stopped working on my main account. Works fine in my other accounts and fine in the login screen.

GlenMH (glenmh) wrote :

#103 works on an Acer Aspire One D250. Thanks Quirks!

Nick Twigg (nick-nick-web) wrote :

I would like to add that I DONT have a trackpad or touchpad installed, and use an MS Wireless Multimedia Keyboard V1.0A (WUR0335).. This issue presented itself and the keyboard would just stop working. The menus in 10.04 would highlight (i.e Applications, Places and System) but no dropdown would occur. I disabled any desktop effects to no avail.

At first, I kept hitting the power button on the machine to switch off and on, as the menus would not respond, however, as un-scientific as it is, if i pressed my hands on as many keys as possible, I was given an Ubuntu Notification then my keyboard stopped working.

The notification looked like a trackpad, so I looked in the notification folder, found the icon, and found what normally uses it for notifications (BTW - There was no record of the notification in the log!)

From there, it led to this bug, and to this fix :

gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad ""

~Which runs at every login. I know, elegant, eh?

This is a fresh 10.04 install.. One thing I did notice tho, is bug 192508. That bug could be related to Remote Desktop.. Is there a possibility this could also be? Does anyone have RD Enabled?

Thanks,

N

I'm running a Acer Aspire One 110 with Lucid (10.04), with all updates current.

I've had a non-functional touchpad since I installed Ubuntu on the AAO (v.8.xx), and nothing I've done has resuscitated it - until I read comment #93, which has worked like a charm.

Many thanks.
SoM

michael (michael-nonan) wrote :

Tried everything here, nothing works for me so far.
My laptop is: Blue, Model #626
Problem: Touchpad doesn't work at all. cursor not moving, no respond from left and right clicks. it is also not recognized on the xinput --list command.

i've got to thinking, mine has a manual on/off switch for my touchpad. could it be because linux does not recognize this switch that's why it is not working at all?

Alexia Death (alexiade) wrote :

I have a generic compal laptop without such physical button. However, I got this bug. The solution offered in comment #50 fixed it for me. Just prior to this bug manifesting my laptop went into sleep mode it failed to wake up from leaving my touchpad in this disabled state and as described in separate bug Network Manager turned off pretty much making my laptop unusable.

Alexia Death (alexiade) wrote :

Correction, it was the post nr #40 that helped.

Confirmed on a Acer Aspire One 752

Will Miller (willmiller97) wrote :

Giorgi Maghlakelidze, Thank you so much!!! Post #93 fixed the problem for me (on Lucid Lynx 10.04, HP Pavilion Laptop). That bug affected me for ages.

Anyone else who has this problem, paste this into your terminal:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

Thanks again.

oktapod (oktapod81) wrote :

Thank you guys! Post #93 fixed the problem. (on Lucid Lynx 10.04 Pavilion dv6780el).

Giorgi Maghlakelidze (dracid) wrote :

@Will Miller & oktapod:
No problem! ;)
Glad U guys resolved the issue!

For those on whose machines the bug "returns" occasionally(it did on mine!) :
I have added a keyboard shortcut via System->Preferences->Keyboard Shortcuts that had this command:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

It just saves time U know... ;)

Oh, BTW, I am on Maverick Meerkat x32 Beta. NO TRACE OF THE PROBLEM...

jonbonjovi (jonbonjovi-84) wrote :

@Gorgi:

I'm on Maverick 64bit and the problem is still there!!

Luckily, with #103 the problem can still be solved.

Nick Flyer (nickflyerspam) wrote :

I have been on 10.10 for a few days and it just started doing this on my HP Pavilion DV6103NR. It started after I used the mousepad lockout button on the mousepad.

jonbonjovi (jonbonjovi-84) wrote :

I'm on Maverick 64-bit and since today the problem can't be solved anymore through #103!!

Heeelp!

Bug confirmed on Aspire 7535G, However #103 seems to solve it for me.

Carl Michiels (carl-michiels) wrote :

I had the same problem on an Acer Aspire 8735G, however the workaround #103 from quirks solved it. Thank you quirks!

Alex Wauck (awauck) wrote :

I have observed this problem with a HP dv2500t running Natty (latest updates). Manually changing /desktop/gnome/peripherals/touchpad/touchpad_enabled to true fixed it. Seriously, what's going on here?

Mark Forgette (mw4jet) wrote :

Post # 9 worked for me, I lost touchpad and keypad after updates, Broadcom started working but I could'nt do anything with it!!
I used USB mouse and keyboard to open terminal to run:

sudo apt-get install gpointing-device-settings touchfreeze

After reboot the Linksys wireless card, touchpad, AND keyboard were all working perfectly!

Thanks!

Mark Forgette (mw4jet) wrote :

Add to my post #137---

Ubuntu 10.04 Lucid Lynx
Dell Inspiron 2650----too old for Windoz, so awfully slow--- working good with Ubuntu!!

US (upendra007) wrote :

Sony Vaio VPCEB34EN
touchpad not working

samuel (sps91mail) on 2011-04-28
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Frank Nielsen (frank-boegh) → samuel (sps91mail)
status: Confirmed → New
Liam Ward (liam-dv4) wrote :

I just upgraded my Lenovo Thinkpad T410 to 11.04 Natty and hit this issue. The solution that worked for me seems a bit simpler than some of the ones offered earlier so hopefully this will help someone.

Hit Alt-F2
Type gconf-editor and hit return
Browse to desktop/gnome/peripherals key
Look for your touchpad - mine looked like "SybPS@47@2..."
Uncheck the "disable while other device exists" option

Bingo!

Presumably the problem was that Thinkpads have two built-in pointing devices. While the solution turned out to be simple, it took me a good hour to figure it out and the earlier comments in this thread helped me to start looking in the right place. Thanks.

Bob Barrett (tenbob1) wrote :

IMPORTANT - this contains steps to reproduce the problem.

Comment #103 above has the solution - but it's slightly more subtle than this.

I can easily reproduce the problem on my Acer netbook which has a dedicated keypress (Fn F7) to toggle the touchpad on or off. I'm running Ubuntu 10.04.2 LTS Netbook.

It seems like the touchpad is enabled in two different places. The one we know about is at /desktop/gnome/peripherals/touchpad/touchpad_enabled. The other is elsewhere, presumably in the Synaptics device driver. Both persist over a reboot.

Normally when you hit Fn F7 the touchpad toggles reliably between the enabled and disabled states.

But it's like two electrical switches in series. Provided they both remain in step it works. But if there's ever a glitch that causes one switch to be off while the other is on, there's no easy way to correct it. Hitting Fn F7 will just reverse the existing state. But with one switch on and the other off the touchpad never gets enabled.

Steps to reproduce.

(1) Use gconftool-2 to monitor the state of the relevant gconf key using the command below.
gconftool-2 -g /desktop/gnome/peripherals/touchpad/touchpad_enabled

Press Fn F7 repeatedly and each time check the results with gconftool-2. As expected, you can see the key toggle from true to false and back again. At the same check that the touchpad is being enabled and disabled correctly. This is the normal behaviour.

(2) Finish up with the key value set to false. Now use gconftool-2 to change the key to true using the command below.
gconftool-2 --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true
Note that this sets the two flags out of step with each other.

After this you can keep on hitting FnF7 and see the gconf key change from true to false. But whatever you do you can't get the touchpad to work. Whenever gconf thinks the keypad is enabled the other flag thinks it is disabled and vice versa.

To solve this, the software needs to link the two flags together so they can never have different values.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
higuita (higuita) wrote :

This also affects 11.04 and 11.10, so maybe its better to remove the 10.04 from the subject, as this is still a current and annoying bug

higuita (higuita) wrote :

on 11.10 the "disable touchpad while typing" seems to activate again this problem... some times disabling and re-enabling the touchpad several times make the touchpad return back to life... but doesnt work always.
also, on 11.10, disabled the touchpad and re-enable one will not work, i need to do it twice to really re-enable the touchpad.
it looks like there is yet another apps trying to play with the touchpad and confusing even more this

summary: - [10.04] Touchpad stops working after login
+ Touchpad stops working after login

On a Toshiba Protege M700, I did not have the issue with 11.04 amd64. After the upgrade to 11.10, my touchpad stops working shortly after login. Performed fresh install of 11.10 amd64 and issue persisted.

Unchecking "disable touchpad while typing", as suggested in this bug, keeps my touchpad functional.

cpbtklogic (cpb) wrote :

Just installed 11.10. My Synaptics PS/2 mouse was working before (11.04) but post upgrade it stopped working right after login.

I did two things to (seemingly) fix it.

(1) sudo apt-get install --reinstall xserver-xorg-input-synaptics
(2) gconftool-2 --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true

After one reboot it seems to be working post login.

cpbtklogic (cpb) wrote :

But....

It is clear the button to 'disable' my touchpad and 'disable while typing' puts some set of variables in a state where my touchpad does not work.

going to try:

removing 'psmouse.ko' > add it back
xinput list
gconftool-2 --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true

If that doesn't work, I might try reinstall w/ apt-get.

Patrick Horgan (phorgan1) wrote :

It seems like these two commands together get them back in sync:

synclient TouchpadOff=0
gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

Either one of them will make my touch pad start working, but both together seems to fix the problem.

My laptop (Compaq CQ41) running Ubuntu 12.04 was also same problem.

same problem here hp dv6 runing 12.04

SonhadorPR (sonhadorpr) wrote :

Same problem.
Sony Vaio VPCEB490X

ethanay (ethan-y-us) wrote :

this problem exists on Linux Mint 12 and 13, but for some reason is not affecting me on Ubuntu 12.04...

unchecking "disable touchpad while typing" fixes the issue. in order to avoid accidental clicks, you must also unceck "enable mouse clicks with touchpad" and use the purpose-built buttons only :) (are they really that inconvenient?)

downward (invisioslice) wrote :

this bug also affect Ubuntu 12.04

downward (invisioslice) wrote :

UBUNTU 12.04 This is a partial solution: https://answers.launchpad.net/touchpad-indicator/+question/195181 but the touchpad scroll is dead.

LLR (rufneck) wrote :

touchpad will be deactivated by keyboard shortcut but never switched on again. Can be fixed by dconf

install > sudo apt-get install dconf-tools
run dconf
see > org.gnome.settings-daemon.peripherals.touchpad
Enable touchpad

Displaying first 40 and last 40 comments. View all 154 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.