Touchpad stops working after login

Bug #549727 reported by Diego Viganò on 2010-03-27
484
This bug affects 106 people
Affects Status Importance Assigned to Milestone
Freespire
New
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
samuel
Declined for Dapper by Timo Aaltonen
Declined for Hardy by Timo Aaltonen
Declined for Intrepid by Timo Aaltonen
Declined for Jaunty by Timo Aaltonen
Nominated for Karmic by Ace
Nominated for Lucid by Ace
Nominated for Maverick by daniel

Bug Description

Binary package hint: udev (but not quite sure)

On my Lenovo T60 the Touchpad works great until I login using GDM.

After 2-3 seconds I've pressed "Login" it suddenly stops working and I must use an external USB mouse.

I'm using Lucid Lynx Beta1.

description: updated
Lawry (lade334) wrote :

Can confirm this bug on Acer Aspire 5536G

Javier Cabezas (javier-cabezas) wrote :

Confirmed on a Lenovo T400

Changed in hal (Ubuntu):
status: New → Confirmed
Naxiey (naxiey) wrote :

Can confirm it on an HP dv7-2122eo

summary: - [10.04] Touchpad stop working after login
+ [10.04] Touchpad stops working after login

I can confirm that since upgrading to beta 2 my touchpad on an HP dv2054ea stopped working. If I uninstall the xserver-xorg-input-synaptics driver it then works, although in a slightly erratic fashion.

Fatih Degirmenci (fdegir) wrote :

Same problem occurs on Lucid Lynx Beta2. (Using Acer Aspire 5920G.)

Jarige (jarikvh) wrote :

Yup, this is exactly my problem either. Acer Aspire one ZG5...
I hope this will be fixed soon, or at least a workaround from anyone... I use the touchpad more often then the mouse (I actually got used to that thing! :O ). I'm glad I've found people with the same problems, that means it should be fixed one of these days :)

Jarige (jarikvh) wrote :

Isn't this a bug in xserver-xorg-input-synaptics since it is gone when removing this package?

Jarige (jarikvh) wrote :

I did some testing; and previous versions of xserver-xorg-input-synaptics don't work. I thought it would work as a workaround, but it didn't. The 1.2.2-1ubuntu1 version had the same problem (apparently, the current version and 1.2.2-1ubuntu1 were released 41 seconds after oneother) and 1.2.0-3ubuntu2 acted as if the drivers weren't installed. The touchpad was very weird acting, and I could not scroll etc.
I tried 1.1.2-1ubuntu7 (the current version in Karmic) but that one didn't install because of some package conflict.

I hope that anyone finds this information useful in some strange way :) I just wanted a workaround and thought a previous version might fix it.
So I'm still having this problem... :(

Chris Highfield (cmhighfield) wrote :

I have managed to resolve the problem on my HP DV2054ea laptop by installing the following two packages:

gpointing-device-settings
touchfreeze

I hope this helps others.

Regards,

Chris.

Jarige (jarikvh) wrote :

Christ, thanks for your efforts.
Sadly your solution doesn't work with me. I tried rebooting, I added touchfreeze to the startup applications, turned the touchpad on and off on both touchfreeze and Fn + F7. All to no avail.
I hope there's an other way to do this :S This obviously must be fixed before release. It looks until now as if every touchpad has this...

Jarige (jarikvh) wrote :

Is there any way of notifying this bug report to the xserver-xorg-input-synaptics developers? If they don't know this bug, they won't be fixing this bug. I don't know how that works though. I think it has something to do with the 'also affects project' button, but I couldn't find that package name anywhere.

Diego Viganò (diego-vgn) wrote :

I changed the "Affects" column at the top of the page, changing it from "hal" to "xserver-xorg-inputs-synaptics". Maybe this can be helpful to the developers of such package.

affects: hal (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Bryce Harrington (bryce) on 2010-04-13
tags: added: lucid
Jarige (jarikvh) wrote :

Thank you Diego. For some reason, I wasn't able to do that.
Now lets hope someone will fix this soon...

Ace (linuxrawkstar) wrote :

I confirm that this bug affects me. Using acer aspire 5740-5255

Jarige (jarikvh) wrote :

For some reason, this bug stopped affecting me. Maybe the gnome version that recently came through the update manager fixes this? I'm able to use the touchpad again, so I recommend you guys to just go to the update manager and install the updates. I don't know which one fixed this bug for me, but I'm curious to see whether you guy have it fixed too.

Jarige (jarikvh) wrote :

No reply so far. Did anyone notice this bug has been fixed or is it just me?

acme (cyb-acme) wrote :

I confirm that this bug affects me. Using Acer Aspire 5106AWMLi

Bryce Harrington (bryce) wrote :

I don't really think there's enough information provided to consider this bug report a true "defect report" but am assigning it to tseliot to take a look at and decide if the issue looks worth evaluation.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

Can you reproduce the problem and attach your /var/log/Xorg.0.log, please?

What kind of information do you need? There is nothing strange in /var/log/Xorg.0.log nor in dmesg output.

Happens to me every time I boot the machine

Naxiey (naxiey) wrote :

My touchpad has start working again after a lot of packages updated earlier today :)

Jarige (jarikvh) wrote :

Ah, I knew I shouldn't have been the only one for whom this bug has been gone suddenly. I think this bug is solved already, somehow. If the original bug reporter would return here and share his thoughts on this that would be ideally.
Is there anyone still having this bug, whilst not having any problem before?

Lawry (lade334) wrote :

I can confirm it has been fixed in an update also. Acer Aspire 5536G

Jarige (jarikvh) wrote :

Since multiple people confirmed a fix, I found this appropriate.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Fix Released

Not working here. Lenovo T400

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Fix Released → Confirmed
GabePez (gabe-findgabe) wrote :

This is not working for me. I had the problem start about 3 days ago (4/14?) after applying updates. The pointer started shaking and being unresponsive. I rebooted and the touchpad worked until I logged in. After some troubleshooting I created another user account and the touch pad works in that account.

I think this is probably due to corruption or mis-configuration of a user level configuration, but I have not been able to find information about user specific config files that reference touchpad settings. Toggleing TouchpadOff with synclient does not seem to have any effect, but I don't know if I need to restart a service or whatnot to get the new setting to take effect. After logging back in it reverts back to 0.

Exiting and entering Xwindows and applying other packages per #10 did not help.

I am working with an HP Touchsmart tx2, running 10.04 beta2, amd64, applying the latest patches daily. If I can provide any more information let me know.

Alternatively if anyone can point me to config files to look at it would help greatly. I really feel like a user level configuration simply toggled the touchpad off.

GabePez (gabe-findgabe) wrote :

After getting frustrated and deleting all gnome configurations with:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

obviously this is a bit of a pain, but better than the touchpad not working. I will post another comment if the problem happens again.

Lawry (lade334) wrote :

This bug is back for me too now, acer aspire 5535G.
It happens on the reboot after I disable the touchpad (this model has a hardware button for this).
Back to frustration!!

FlashFire (teflashfire) wrote :

I can confirm that this bug also affects the Acer Aspire 5739g.

Naxiey (naxiey) wrote :

And now it has stopped work again...

Jarige (jarikvh) wrote :

This bug appears to come and go randomly. A few days back it suddenly stopped working when logging in, the day after (or a reboot, can't remember) it worked again.
BTW, I heard that Synaptic was bussy on (proprietary) drivers for the touchpads to enable multi-touch on Linux :D Pity they are proprietary though... But hopefully, those drivers will show the open source drivers developers how to solve that :) Has nothing to do with the bug though. Just something that popped up in my mind.

Pål F. Kristiansen (paalfe) wrote :

using 10.04 RC with all updates and I have this problem

Jarige (jarikvh) wrote :

I received a possible workaround on my Ubuntuforums topic. I didn't try this, and I don't know the details of what these commands do. This is what I was told to do:

[quote]
You can write:
Code:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

To make permanet include the last line in /etc/modprobe.d/options
[/quote]

Got it from here:
http://ubuntuforums.org/showthread.php?p=9173688#post9173688

Pål F. Kristiansen (paalfe) wrote :

I did what Jarige wrote and it worked after running:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

To make permanet include the last line in /etc/modprobe.d/options did not work.

PC is a HP Pavilion dv9550 eo

Lawry (lade334) wrote :

Likewise, this fix works for me but cannot add it through modprob.d.
I do not have a /etc/modprob.d/options.conf so have created one but with success. Has someone managed to do this?

Jarige (jarikvh) wrote :

The file in the workaround does not exist. In Lucid, apparently, that file has been judged obsolete and been removed. There's probably a file which does the same, or some other workaround that will do this every boot.

I attached an .sh file for the convenience, and I changed 'sudo' to 'gksudo' so you'll get a graphical interface question for the root password instead of a commandline version. You can download it in your /home directory, and make it run every boot by going to System -> Preferences -> Startup Applications and click on 'Add'. Type anything in the name section, and type this command in the command section: sh ~/workaround.sh

I don't know whether this works though. I don't have this bug anymore for some strange reason (without workaround). So I can't test it... And again, the workaround is not mine.

Dale Russell (drussell-gmail) wrote :

I have a T500 and it was working on 10.04 for a month until I did an update this morning. The workaround works but the bug still exists.

JonathanD (stolenpie) wrote :

Yup, after updating to 10.04 my touchpad also stopped working. Even on the login page I cannot use my touchpad.

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

also works for me but only as a temp solution, it's not yet a fix...

Ben Munro (benjamin-munro) wrote :

The above fix works for me, but leaves me with a non-accelerating pointer and unable to scroll with the touchpad.

I found another fix that works better.:

rm -rf /home/ben/.gconf/desktop/gnome/peripherals/touchpad

You need to kill the session (killall gnome-session) and log in again after you do this. The bug keeps re-occurring and needs to be fixed every time.

This is on a Hewlett Packard dv6 2113tx.

Chris Olin (chris.olin) wrote :

Upgrading from Karmic to Lucid, it seems the xserver-xorg-input-synaptics package was removed and never reinstalled. When I went to try Chris Highfield's idea (#9), I noticed the package was a dependency and was downloaded because it wasn't installed.

Since the other two packages he suggested downloaded and installed, I'll never know if it was the two programs he suggested or the missing xserver-synaptics package causing the problem. Nonetheless, it's fixed now.

Ivan S. (freeazy) wrote :

I also had the same problem on my acer 4736z, it started happening when I finished updating Lucid RC.
thanks for the advice of # 40-Ben Munro,
i try: sudo gedit / home / ivan / .gconf / desktop / gnome / peripherals / touchpad /% gconf.xml

then edit the lines:
<entry name="touchpad_enabled" mtime="1272748884" type="bool" value="false"/>
to
<entry name="touchpad_enabled" mtime="1272748884" type="bool" value="true"/>

then killall gnome-session.
and now my touchpad working again! I hope this helps.

Slawek (elviz) wrote :

I can confirm than Chris' idea #9 did the trick for me. I'm using Acer Aspire 8930g. All I had to do after installing this 2 packages was pressing fn + f7 and everything working just fine.
Cheers Chris

Jarige (jarikvh) wrote :

Chris' idea originally didn't do the trick for me though. I still do not know what did. xserver-xorg-input-synaptics was installed when the bug appeared. I tried reinstaling it at the time, and even purging it and install it again. Nothing made any difference, but after a few updates it got fixed and I only had the problem once after those updates. At that time, I rebooted and everything worked again.

Pål F. Kristiansen (paalfe) wrote :

This does the same as ivan90112 wrote, just faster and easier

gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean true
killall gnome-session

Morten Minke (morten-amagi) wrote :

This happens to me too on a HP Pavilion dv9000 (dv9845ed) but I have some additional info:

When I boot up with the touchpad disabled, I can use my external USB mouse to login.
The external mouse works fine and I can do everything, however....
When I now activate the touchpad, my mouse stops working too!!! and the touchpad is not working correctly either. I can disable the touchpad again, but the mouse still does not work properly. I can use the right mouse button (see context sensitive menus, etc.) but the left mouse button does nothing.
The only thing I can do is use ctrl-alt-delete, click with my external mouse on suspend, then the button gets highlighted (so it does see a mouse event) but it does not trigger the action!!! I have to press the 'enter' key to really put it in suspend.
After waking up from suspend, everything works normal again.

I have tried the 'sudo rmmod.......' commands, and they seem to fix this problem, but I have only tried this a few times now. It's also not a real solution because now I have to run a script everytime I login to prevent my mouse/touchpad from becoming unresponsive.

If anyone has an idea / suggestion how I can give more info which can help, pls let me know.

Morten Minke (morten-amagi) wrote :

Oh, I forgot to mention, I am on 10.04, with the latest updates, as of 2010-05-03.

Linux bm-laptop1 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

Mark Kelly (m-kelly) wrote :

I had this problem, and it turned out that the gconf key mentioned by ivan90112 and paalfe was set to false, and changing it fixed the problem.

Is there any reason to disable the touchpad (apparently) by default?

Matt Skelton (mattskelton) wrote :

My touch pad doesn't work past the login in screen. Using Ubuntu 10.04 on an Acer Aspire 4810TZ. USB mouse works fine. Touchpad works in Windows and worked with 9.10.

To fix this (without startup-scripts) create a file "/etc/modprobe.d/touchpad.conf" and put "options psmouse proto=imps" in it.

Maybe some packager/developer can fix this for us?

FlashFire (teflashfire) wrote :

Haksell's fix (#50) works, but only in the strictest sense of the word. It's touchpad functionality at it's most basic, is unaccelerated, and side scrolling is disabled. Further, touchpad configuration becomes disabled in the GUI configuration tool.

Have we removed the "Fix released" status? Because this bug is continuing to wreak havoc for multiple varieties of touchpad on multiple varieties of laptop.

Yes I do agree, this is not a module related issue... That works, but it's just an huge workaround.

The only way I can make my touchpad and my touchpad-button to work is to invert the "/desktop/gnome/peripherals/touchpad/touchpad_enabled" gconf option; after that the touchpad works following the hardware button status.

I guess that this all due to the fact that the above setting is inverted at the beginning of a session (so, using the hardware button you enable the touchpad, but you disable gnome to grab its values and vice-versa).

Linuxslate (johnapf) wrote :

Same Computer as Morten Minke (It's a Co-workers HP dv9000) and same symptoms, including the inability to left click.

Fresh install of release version of 10.04LTS (never had any Ubuntu/Linux before, whole hd for Ubuntu), problem not present or not noticed until after doing the updates.

Switching to a psuedo term and back sometimes seems to fix it.

Also, due to some other problems, the keychain password and login password were out of sync. This seemed to be when the problem started, and seems to have been fixed when either I fixed this, or when I did:

gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean true

Not sure if the keychain stuff is relevant, but Gnome is so integrated with everything these days. Perhaps it thinks my input device preferences should be secret.

Interestingly, I have rebooted, and completely shutdown several times, and it now seems fine without doing the gconftool line again.

aswanson (bigfoot-08) wrote :

I just noticed this problem tonight. I'm not sure how long its been going on for, I normally use a USB mouse. Using a HP dv5z-1000 with the 64 bit version of Lucid and all the latest updates. I just tried switching terminals and switching back like Linuxslate suggested, and its working at least for now. Seems like this should be a fairly high priority if its affecting as many different people and systems as it seems to be, especially since on a laptop, you often don't have a way to use a conventional usb mouse.

bford16 (bford16) wrote :

Confirmed still a problem on Lucid. I suspect the culprit was an updated "laptop-detect" package, but I have no evidence to back that up.

Doing this did solve the problem:

gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean true

I used gconf-editor to make the change graphically.

Experiencing the same issue on an Acer Aspire 6930G, the touchpad works fine at the GDM login screen and then stops working after login. Enabling/disabling the touchpad does not solve the problem.

It took a while for me to notice this bug as I also tend to default to a USB optical mouse.

Sean Crites (bdk907) wrote :

HP dv6000 - Having same issue. Temp fix/work around #42 worked for me; would still like to see a perm fix put into place.

Guido I (guidoweb) wrote :

Same problem here, HP Pavillion tx1000, upgraded to Lucid from Karmic.

When I turn on the machine it starts fine, but if I disable the touchpad with the hardware button, and then re-enable it again, it won't come back.

I managed to make it work again with workaround #42 , great, thanks!

Why was that gconf value disabled in the first place??

jonbonjovi (jonbonjovi-84) wrote :

[QUOTE]
When I turn on the machine it starts fine, but if I disable the touchpad with the hardware button, and then re-enable it again, it won't come back.
[/QUOTE]

Exactly the same for me.

Morten (morten-hh) wrote :

don't know if this helps anybody but i have the problem only when i am log-in to my main usr account. ive created another to test it and the touchpad worked flawless. (also if i only chance the user without a reboot) so the problem must be somewhere in the user settings...

Elmer Fudd (efuudd) wrote :

Have always had the problem (with Karmic and Lucid) where if I turned of the pad with the laptop hardware switch, it would turn off but I could not turn it back on with the switch. The switch woudl set/release the touchpad toggle (could watch it in gconf-editor). In the last week the touchpad has stopped working alltogether- pad and buttons.

Acer 7736Z
Lucid 2.6.32-22
no restricted drivers

Morten (morten-hh) wrote :

i think the problem with the touchpad on/off button is a different bug.
those of you who have problems with the on/off button check this link out

https://help.ubuntu.com/community/AspireTimeline/Fixes

scroll down to: "Touchpad On/Off button"
this fix works

bianchi (uspbianchi) wrote :

This bug affects me too and I have an HP DV5 1260br.

I upgraded from Ubuntu 9.10 to Ubuntu 10.04.

The touchpad worked fine for a while, but then odd things started happening. Occasionally I would get this problem where the right-click would stop working, then only the left click would work but I could only click on certain things (I couldn't open the applications menu with left-click). At the same time this happens, my keyboard becomes unresponsive, and the problem would only go away if I turned off the power.

But then these problems started occurring soon after I logged in. Now my touchpad only works for a couple of seconds after I've logged in.

I'm not sure if all these bugs are related, but I thought I'd mention them just in case.

I'm using an HP Pavilion dv9650 laptop.

Ok, I figured out that those problems only occurred after I pressed the touchpad on/off button.
If I press this button, the keyboard becomes unresponsive and for some reason I can't do anything except left-click on tasks in the taskbar using the mouse (the applications menu doesn't open even whether I click on it or press alt+f3).

The thing in #42 works, but if I press the touchpad on/off button then everything stops working, so I can't turn off the touchpad when I don't want to use it.

Evan Gilbert (gilbert-evang) wrote :

The on/off button problem happens to me too (HP dv7 laptop): https://bugs.launchpad.net/ubuntu/+bug/571638

Ben Munro (benjamin-munro) wrote :

I just worked out the same thing as #65.

After using the trackpad on/off button, I can't use the keyboard anymore. Also, I can't click on the gnome Applications/Places/System menu. The trackpad still works though.

When I log out and back in, the keyboard is working again, but the touchpad does not work.

Sompong Turayoth (tusompong) wrote :

Touchpad stops working after login.
I confirm that this bug . I'm using Acer TravelMate TM8471.

Alexey Ivasyuk (oebs-pm) wrote :

This bug affects me too on Samsung N200. Tired of it already.
Sometimes it works after login but then stops, sometimes it doesn't work after boot.
Sometimes during while booting the system says that something wrond with UDEV.

Tried all the fixed proposed here. Sometimes they help, but sometimes doesn't

Alexey Ivasyuk (oebs-pm) wrote :

I started Ubuntu in the safe mode, updated GRUB, recreated Xorg.cfg (set to default) and the problem with touchpad has disappeared for 30 minutes aproximately, but then the trouble has occured again.

What I've found out is that the touchpad problem occurs only when WiFi network is active.
When by PC is not connected to WiFi there are no touchpad issues.

Alexey Ivasyuk (oebs-pm) wrote :

When there is no WiFi connection, the touchpad works better, but still freezes time to time.
Without touchpad the following workaround gets it back to life:

gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean false
gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean true

After that I also have to do some dancing with the desktop/windows switching to resume it.
But usually the touchpad freezes when I press a button on it.

When WiFi is connected, everything looks like a catastrophe.
It even disapears from "xinput list".

And in both cases it receives no events when I start "xev".

Can someone help with this issue please? I do not use mouse when I'm travelling and it makes me suffering.

Alexey Ivasyuk (oebs-pm) wrote :

Finally, it looks like the problem has gone. At the least, durng the past hour the touchpad works fine.
What I have done is:
1) removed all unnecessary xorg-input drivers and kept the only following:
     xf86-input-mouse, xserver-xorg-input-evdev, xserver-xorg-input-vmmous, xserver-xorg-input-synaptic
2) maybe it was non mandatory, but removed all unnecessary xorg-video drivers and kept the only needed by my vcard and abstract:
     xf86-video-v4l, xf86-video-vesa, xf86-video-fbdev, xf86-video-vmware, xf86-video-intel
3) removed all nvidia and radeon tools - maybe not mandatory
4) booted in recovery mode and regenerated Xorg.conf.

Now I work with the touchpad more then an hour without any troubles.
Tried to reboot, etc.

So far so good. Hope it helps others.

Alexey Ivasyuk (oebs-pm) wrote :

Tried almost everything! So far my touchpad works without any problems!
After having so big problems with it, I'm trying to avoid saying that this is the best solution, but:
I think the problem isn't in xserver-xorg-input-synaptic, but is in some other package which is not compatible with it.

Just try this solution and let me know if it works for you.
I've upgraded my Samsung N210 from Ubuntu 9.10 and after the update a week ago had a lot of problems with touchpad.
And now it looks good, so far.

Elvin Santos (bedistado) wrote :

LinuxMint 9 user here, I found in one of the threads under Ubuntu forum about this code you have to type in the terminal:

gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean true

after tying this in the terminal, my touchpad is alive! not sure if it will comeback after I restart though...

Note: It started when I connected my usb wireless mouse...

Just started having this problem with my Acer Aspire 5535, and am really confused. I tried changing the boolean value in the gconf file, and it's still not working. Not sure how to install touchfreeze and gpointing-device-settings. Any other ideas?

Alexey Ivasyuk (oebs-pm) wrote :

I'm sad to say that the problem is back on my Samsung NP-N210.
I've googled through many articles, tried many changes, but problem still occurs.
To be more exact, it gets OK sometimes, and sometimes following actions help:

gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean false
gconftool -s /desktop/gnome/peripherals/touchpad/touchpad_enabled -t boolean true

sudo modprobe -r mouse
sudo modprobe -r psmouse

if I run "syndaemon", I receive the message "Unable to find a synaptics device."
Tried to change xorg.conf file with many ways, but successful.

What I also tried is to set "TouchPad" as "AlwaysCore" in xorg.conf, it helped for some time but then the problem was back.
Done the fresh install of Ubuntu 10.04 from USB, formatted drive, but useless.
Donno what to do. Confused, frustrated,,,

The module is loaded according to Xorg.0.log:
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
 compiled for 1.7.6, module version = 1.2.2
 Module class: X.Org XInput Driver
 ABI class: X.Org XInput driver, version 7.0

And then it's reloaded:
(II) LoadModule: "synaptics"
(II) Reloading /usr/lib/xorg/modules/input/synaptics_drv.so

But then it's unloaded:
(II) Synaptics touchpad driver version 1.2.2
TouchPad no synaptics event device found
(**) Option "Device" "/dev/psaux"
(**) Option "SHMConfig" "on"
(**) Option "LeftEdge" "1700"
(**) Option "RightEdge" "5300"
(**) Option "TopEdge" "1700"
(**) Option "BottomEdge" "4200"
(**) Option "FingerLow" "25"
(**) Option "FingerHigh" "30"
(**) Option "MaxTapTime" "0"
(**) Option "MaxTapMove" "220"
(**) Option "VertScrollDelta" "100"
(**) Option "MinSpeed" "0.06"
(**) Option "MaxSpeed" "0.12"
(**) Option "AccelFactor" "0.0010"
Query no Synaptics: 6003C8
(--) TouchPad: no supported touchpad found
(EE) TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "TouchPad"
(II) UnloadModule: "synaptics"

But sometimes, when the messages are the same in the log file, the touchpad is functioning.
Really unpredictable behavior.
Finally I bought wireless mouse and it has solved my issue without the touchpad.

Bug [1] might be related to this. Anyone using a KMS driver and still has this problem?

I'm also building a touchpad driver without the patch 01-synaptics-dont-grab-if-not-on-current-VT.patch that *might* have something to do with this as I'm not sure what it does as [2] seems to do the same thing (?). The driver will hopefully land in my PPA [3] when ready, please try it and report any issues (as I'm not affected by the problem).

[1] https://bugs.freedesktop.org/show_bug.cgi?id=25870
[2] http://cgit.freedesktop.org/xorg/xserver/commit/?id=562ca3f2f9005e7c5ed0a24b0759051ded2173e9
[3] https://launchpad.net/~0-launchpad-mejlamej-nu/+archive/ppa

Nick (nikh123123) wrote :

I can confirm too that #9 worked for me too!
Machine - ACER 5920

NB: interesting to note that the touchpad worked without any trouble for another user I had created. Didn't work only for the default user (one that was created during the installation)

Ace (linuxrawkstar) wrote :

Run this command in a terminal and then reboot; problem solved:

perl -pi -e 's/(?<=touchpad(.{48}))false/true/' ~/.gconf/desktop/gnome/peripherals/touchpad/%gconf.xml

There ya go.

Alexey Ivasyuk (oebs-pm) wrote :

Hi Ace,
This didn't help. Last time, in 90% of boots, XOrg doesn't see the touchpad at all.
Even touchpad driver doesn't load (no touchpad in "xinput list"), see the log bellow.

But sometimes (10% of boots) everything is OK, touchpad works the first time, but then stops.

(II) Synaptics touchpad driver version 1.2.2
TouchPad no synaptics event device found
(**) Option "Device" "/dev/psaux"
(**) Option "SHMConfig" "on"
(**) Option "LeftEdge" "1700"
(**) Option "RightEdge" "5300"
(**) Option "TopEdge" "1700"
(**) Option "BottomEdge" "4200"
(**) Option "FingerLow" "25"
(**) Option "FingerHigh" "30"
(**) Option "MaxTapTime" "0"
(**) Option "MaxTapMove" "220"
(**) Option "VertScrollDelta" "100"
(**) Option "MinSpeed" "0.06"
(**) Option "MaxSpeed" "0.12"
(**) Option "AccelFactor" "0.0010"
Query no Synaptics: 6003C8
(--) TouchPad: no supported touchpad found
(EE) TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "TouchPad"
(II) UnloadModule: "synaptics"

Alexey Ivasyuk (oebs-pm) wrote :

Marcus,

I've also tried this driver from your post #77
[3] https://launchpad.net/~0-launchpad-mejlamej-nu/+archive/ppa

It doesn't help

Juggler (phil-lancelotte) wrote :

This bug also affects me, (But not my wife....yet)I am running a new install on a root partition and calling /home on another. I originally started running Lucid as soon as it became available and updated through the update manager. my touchpad worked flawlessly until last week. I had a problem with boot up causing the root partition to fail, I reformatted that partition today and installed Lucid. I had a number of issues, but the only one I have left is the touchpad issue

My wife's netbook is running an update version (Karmic -> Lucid) and currently has no issues.

If anyone needs to compare files let me know, the netbooks are identical (Acer Aspire ZG5)

I finally got time to debug on the computer in trouble and these are my findings;
It seems some application sets the gconf value to false and g-s-d picks this up and disables the touchpad as it should. Doing a switch to a console (ctrl + alt + f1) and back (ctrl + alt + f7) seems to trigger this - but just once after boot.

I think that the "offending" application is media keys manager in g-s-d in the do_touchpad_action (gsd-media-keys-manager.c ~650) but my debug time is up for now.

hopugop (guilhy-nogueira) wrote :

#50 REALLY works for good! Someone should get it on as a patch ASAP!

jonbonjovi (jonbonjovi-84) wrote :

#83 works, confirmed. At the moment, it's the best we can get ;)

Alexey Ivasyuk (oebs-pm) wrote :

Now my touchpad stopped work at all.
It is not detected by Synaptics (Xorg.0.log):

(II) Synaptics touchpad driver version 1.2.2
TouchPad no synaptics event device found

It' is not in "xinput list":
alexey@alexey-netbook:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech USB Receiver id=10 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Power Button id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Logitech USB Receiver id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

"sudo modprobe psmouse" doesn't loads the module
Can someone help, please?

Nathan Blair (nathan-blair) wrote :

I have an Acer Aspire 1420p and experienced the same issues. Following the advice in bug #501843, I added "i8042.reset i8042.nomux" to my kernel command line and now the touchpad is working perfectly.

I first tried it by modifying the command line. Select the desired kernel and then press 'e' at the grub menu and add "i8042.reset i8042.nomux" (without quotes) just before the "quiet noplash" parameters. Once I determined that this worked, I made it permanent by modifying the GRUB_CMDLINE_LINUX_DEFAULT value in /etc/default/grub to be:
GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset i8042.nomux quiet splash"

I'm running kernel 2.6.32-22-generic x86_64 on Ubuntu 10.04LTS x64. dmesg shows the following about my hardware:

Synaptics Touchpad, model: 1, fw: 7.2, id: 0x1c0b1, caps: 0xd04731/0xa40000
input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input9

Hope this helps someone out there.

FlashFire (teflashfire) wrote :

I can confirm fix #87 provides a permanent solution. Excellent work.

Alexey Ivasyuk (oebs-pm) wrote :

Perhaps #87 provides a permanent solution, but not for me.
I added the parameters:
$ dmesg | grep i8042
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=6011851c-f1ed-4a48-a724-d02cd7732d6b ro i8042.reset i8042.nomux quiet splash
[ 0.663510] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 0.663534] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 0.697496] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5

But the touchpad is still dead.
What I've found out with tpconfig:

$ tpconfig -i
Could not open PS/2 Port [/dev/psaux].

$ sudo tpconfig -i
Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).
Sensor type: unknown (0).
Geometry: rectangular/landscape/up.
Packets: absolute, 80 packets per second.
Corner taps disabled; no tap gestures.
Edge motion: none.
Z threshold: 6 of 7.
2 button mode; corner tap is right button click.

Is it okay that it doesn't find the touchpad without sudo?

Andrea Bernardini (andrebask) wrote :

I confirm #89 response, #87 solution doesn't help.

Alexey Ivasyuk (oebs-pm) wrote :
Giorgi Maghlakelidze (dracid) wrote :

I confirm same problem - touchpad not working after login... Before it worked just fine! After Login - stops working at all.
Started about 3 days ago after an update (i THINK)

HP Pavilion dv5 1000, Ubuntu Lucid x86, latest updates 2010-06-08.

The modprobe thing helped but provided really raw functions - move cursor & click... and I had to do it on every reboot.

the thing that helped me, was running in terminal this:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

from here: http://swiss.ubuntuforums.org/showthread.php?p=9329991

It's given me my touchpad back! Even after a reboot - working just fine! [Thank U guys!]

Please try this and respond... I guess this should solve the problem with touchpad not working after logon...

Yes, post #93 helped. For some reason, touchpad_enable must have been set to false after a recent update. After re-setting it (with gconf-editor) my touchpad (on a HP Pavilion dv5) works again.

S. Sikkema (sikke345) wrote :

I too experience this problem since a few days, probably after an update. At home I always use a mouse, so I did not notice until recently. I have an Acer Aspire One ZG5 with Ubuntu 10.04 2.6.32-22 generic. My touchpad is completely dead for all users. Unlike others it does neither temporarily work at the login screen, nor randomly, nor for a limited period. I tried Fn-F7, gconf-editor (Touchpad is enabled), mouse settings menu, checked outputs from dmesg | grep Touch, xinput list-props "SynPS/2 Synaptics TouchPad" and cat /proc/bus/input/devices. Nothing special found.

Then I booted from a USB start-up stick with Ubuntu 9.10, with the expectance that touchpad would work again which would allow me to find the differences in settings. Guess what: it did not. I did the same listings and settings check, compared with the previous investigations. Again found nothing weird. Unless the problem was also present in the ubuntu-9.10-desktop-i386.iso (I maybe did not notice then since immediately after installation there were many updates), it leads to my suspicion that it the problem is resident in the netbook. Does this help anyone to find the root cause? Can anyone confirm the same behaviour on his laptop? I realise it could even be a hardware problem. Nevertheless, I'm still looking forward to a solution.

SDonatas (sdonatas) wrote :

I have the same problem, my DV6000 HP laptop touch pad is dead. Nothing rely makes it alive in 10.04 x64. I'm sure it is not hardware problem, this is something in software. And it is taking quite long time to sort this out. But it works fine in live CD. Ubuntu could be great, but these little things are very painful, and makes my laptop useless while I'm on the go. And its taking such a long time to get a solution.

Giorgi Maghlakelidze (dracid) wrote :

@SDonatas, post #96

Are You SURE that U have the same 'symptoms'? Could You describe them?

I'm starting to have a feeling that some ppl here are talking about a different bug with a different nature of it.

Have You tried solutions @ post #93? post #87?

#93 worked wonderfully! Never had a problem since! I have a HP Pavilion as well...

SDonatas (sdonatas) wrote :

Giorgi Maghlakelidze [DrAcid]:

Solution 93 allowed me to use my touchpad again, but it didn't really fixed the whole problem, because when I use on/off button for the touch pad, my touchpad mouse crashes, external usb mouse stops clicking, and keyboard starts to malfunction. This is triggered when I press on/off button for HP laptop touch-pad. If to be honest, I'm sure that this solution:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

is not the cause of the problem. There is something deeper, maybe related to the new kernel, because on ubuntu 10.04 final release first install everything worked fine as far as i remember. After few kernel and other updates this bug kicked in.

S. Sikkema (sikke345) wrote :

Dear all,

One-and-a-half weeks after my initial reaction (#95) on this bug I can report it solved in my particular case. A couple of weeks ago I tried to flash the BIOS on my Acer Aspire One 150. I followed the official Acer instructions by placing the new BIOS files on a USB stick and then hold three particular keys during power-up. After three attempts the version number still showed the old version. It must have been around that time that the touchpad stopped working too. Today I succesfully updated the BIOS by means of bootable USB stick (unetbootin, FreeDOS). And to my big surprise: the touchpad worked!

wribeiro (wribeiro) wrote :

I can confirm it on a HP dv6000 (dv6646us)

jonbonjovi (jonbonjovi-84) wrote :

@wribero: how did you solve it? I have a HP dv5 and I don't have any BIOS update.

wribeiro (wribeiro) wrote :

@jonbonjovi: I have an external mouse, I don't use the touchpad and I am very upset because this is a big inconvenience to me.

quirks (quirks) wrote :

Poster #83 got it right. The issue is caused by gnome-settings-daemon. There is, however, no need to adjust/recompile any code.

Hi, I was having the same issue. I believe that the Synaptics touchpad driver and Gnome both disable the touchpad individually. For some reason, Gnome (in particular gnome-settings-daemon) fails to re-enable it; which is why you end up with a dead touchpad, once you disable it.

Here is what fixed it for me (HP Pavilion DV6730ec):

First of all, open a terminal. Press Alt+F1 to open the applications menu and choose the Terminal application from the accessories or use an external mouse to so.

To bring your touchpad back to life, enter the following command:

Code:

gconftool --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true

The key "/desktop/gnome/peripherals/touchpad/touchpad_enabled" is where gnome-settings-daemon remembers that you disabled your touchpad. This is the reason, why it is disabled even after a reboot.

The issue will re-appear, next time you disable your touchpad. You need to prevent gnome-settings-daemon from disabling your touchpad in the first place, because the Synaptics touchpad driver does this already. To do so, run the following command in a terminal:

Code:

gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad ""

This dissociates the key to lock your touchpad from gnome-settings-daemon. If for any reason, the latter command breaks the lock touchpad support for you, than you probably have a different issue. To re-associate the key with gnome-settings-daemon, run this command:

gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad XF86TouchpadToggle

Hope this helps. I recommend rebooting after this procedure and check if this really fixed it for good. I noticed that the error only occurs only once after a reboot.

Andrea Bernardini (andrebask) wrote :

#103 solution works well for me. I tried all the other workarounds but only #103 solved the problem. Thanks quirks!

#103 works for me. Thanks quirks!
 Now I can turn on and off the touchpad in my HP dv6745

Evan Gilbert (gilbert-evang) wrote :

#103 worked for me on an HP dv7 laptop

extremus (serg-mikhailoff) wrote :

Thank you, #103, It's great! The solution works on my HP dv6220.

jonbonjovi (jonbonjovi-84) wrote :

#103 works for me, too. HP dv5 - 1112el.

SDonatas (sdonatas) wrote :

I confirm that solution #103 works for me too on HP DV6. Big thanks to 'quirks' and all of you. Now only left to get SD card 5in1 and s video to work and goodbye windows forever.

bianchi (uspbianchi) wrote :

I can confirm the solution #103 too. I have a HP dv5-1260 br. Thanks a lot!!!!! Now we can just wait for the official solution, but without too many rush :)

I can confirm solution #103 on a Samsung R70 Diness.

Alexey700 (strela337) wrote :

I do not now if I have the same problem, but I found very simple solution for mine:

When I switch touchpad off with "Disable" button (physical button near touchpad) and reboot, my touchpad starts working again.

The problem reappear, if I reboot with the touchpad switched off again.

So it looks like either Gnome or Synaptics Driver dose not save ON/OFF state when you reboot, and another thing (Gnome or Synaptics Driver) does. And after reboot their ON/OFF states are inconsistent.

I use Acer Aspire 5740 and Ubuntu 10.4.

Manoel Campos (manoelcampos) wrote :

The comment #103 works for me. I have a HP Pavillion dv6345.

Skilly (michael-scheepers) wrote :

I've been frustrated by my trackpad\mouse freezing since installing 10.04 until I suddenly realized today that this occurred whenever my fan kicked in - without fail.

modprobe -r psmouse
modprobe psmouse proto=imps

nencio (f-nencio) wrote :

The solution suggested on comment #103 worked on my HP Pavillion dv6626us.

Arvind V (arvind-venkatadri) wrote :

Hi there all,

I am a Linux newbie. I recalled that I had had similar problem with Karmic about 4 months ago and I had fixed it then. After some recalling, I got it and here it is:

I went to the System -> Administration - > Windows menu and went to the Windows Preferences tab.

There for the "Movement Key" there is a radio button selection of "Super Key" or ALT" key. BOTH radio buttons had somehow become enabled, I do not know how this happened, but I suspect it is because I installed SUGAR. However, when I selected just one option there, the Touch Pad began to work immediately.

I hope this is of help to someone.

Warm Regards
Arvind

nico (nicolas-pourcelot) wrote :

#103 works for me, too. Acer Aspire Timeline 4810T

daniel (nelsondaniel94) wrote :

the touch pad was not working for me after making the switch from windows 7 to ubuntu you could not use the touch pad as soon as it connected to the wifi if the wifi is turned off it works perfectly how ever after reinstalling Ubuntu to see if that was the problem i loaded the live cd with ubuntu 10.4lts on it and i connected to the internet via wifi and the touch pad was working i have found if you install ubuntu 10.4lts when you have connected to your wifi network and if you don't encrypt you home directory the touch pad works fine i am using a acer aspire 5535 and ubuntu 10.4lts 64bit and all i can say is it is amazing fast and easy to use much better than windows

Kevin Brodigan (kev-brodigan) wrote :

Had same problem on acer aspire laptop.

touchpad worked, then stopped working for my user only. When logging in with my son's user, the touchpad worked fine. So went with the deleting the .gnome2, gconf etc etc solution as it seemed to be user specific and not system specific (the modprobe solution).

Touchpad now works fine, but all other settings gone too. Bit of a pain, but not too hard to put right.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Alberto Milone (albertomilone) → Frank Nielsen (frank-boegh)
Brando753 (brando753) wrote :

Can confirm bug on Hp dv5 series laptop, Was acting weird so i reset it then the mouse stopped working on my main account. Works fine in my other accounts and fine in the login screen.

GlenMH (glenmh) wrote :

#103 works on an Acer Aspire One D250. Thanks Quirks!

Nick Twigg (nick-nick-web) wrote :

I would like to add that I DONT have a trackpad or touchpad installed, and use an MS Wireless Multimedia Keyboard V1.0A (WUR0335).. This issue presented itself and the keyboard would just stop working. The menus in 10.04 would highlight (i.e Applications, Places and System) but no dropdown would occur. I disabled any desktop effects to no avail.

At first, I kept hitting the power button on the machine to switch off and on, as the menus would not respond, however, as un-scientific as it is, if i pressed my hands on as many keys as possible, I was given an Ubuntu Notification then my keyboard stopped working.

The notification looked like a trackpad, so I looked in the notification folder, found the icon, and found what normally uses it for notifications (BTW - There was no record of the notification in the log!)

From there, it led to this bug, and to this fix :

gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad ""

~Which runs at every login. I know, elegant, eh?

This is a fresh 10.04 install.. One thing I did notice tho, is bug 192508. That bug could be related to Remote Desktop.. Is there a possibility this could also be? Does anyone have RD Enabled?

Thanks,

N

I'm running a Acer Aspire One 110 with Lucid (10.04), with all updates current.

I've had a non-functional touchpad since I installed Ubuntu on the AAO (v.8.xx), and nothing I've done has resuscitated it - until I read comment #93, which has worked like a charm.

Many thanks.
SoM

michael (michael-nonan) wrote :

Tried everything here, nothing works for me so far.
My laptop is: Blue, Model #626
Problem: Touchpad doesn't work at all. cursor not moving, no respond from left and right clicks. it is also not recognized on the xinput --list command.

i've got to thinking, mine has a manual on/off switch for my touchpad. could it be because linux does not recognize this switch that's why it is not working at all?

Alexia Death (alexiade) wrote :

I have a generic compal laptop without such physical button. However, I got this bug. The solution offered in comment #50 fixed it for me. Just prior to this bug manifesting my laptop went into sleep mode it failed to wake up from leaving my touchpad in this disabled state and as described in separate bug Network Manager turned off pretty much making my laptop unusable.

Alexia Death (alexiade) wrote :

Correction, it was the post nr #40 that helped.

Confirmed on a Acer Aspire One 752

Will Miller (willmiller97) wrote :

Giorgi Maghlakelidze, Thank you so much!!! Post #93 fixed the problem for me (on Lucid Lynx 10.04, HP Pavilion Laptop). That bug affected me for ages.

Anyone else who has this problem, paste this into your terminal:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

Thanks again.

oktapod (oktapod81) wrote :

Thank you guys! Post #93 fixed the problem. (on Lucid Lynx 10.04 Pavilion dv6780el).

Giorgi Maghlakelidze (dracid) wrote :

@Will Miller & oktapod:
No problem! ;)
Glad U guys resolved the issue!

For those on whose machines the bug "returns" occasionally(it did on mine!) :
I have added a keyboard shortcut via System->Preferences->Keyboard Shortcuts that had this command:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

It just saves time U know... ;)

Oh, BTW, I am on Maverick Meerkat x32 Beta. NO TRACE OF THE PROBLEM...

jonbonjovi (jonbonjovi-84) wrote :

@Gorgi:

I'm on Maverick 64bit and the problem is still there!!

Luckily, with #103 the problem can still be solved.

Nick Flyer (nickflyerspam) wrote :

I have been on 10.10 for a few days and it just started doing this on my HP Pavilion DV6103NR. It started after I used the mousepad lockout button on the mousepad.

jonbonjovi (jonbonjovi-84) wrote :

I'm on Maverick 64-bit and since today the problem can't be solved anymore through #103!!

Heeelp!

Bug confirmed on Aspire 7535G, However #103 seems to solve it for me.

Carl Michiels (carl-michiels) wrote :

I had the same problem on an Acer Aspire 8735G, however the workaround #103 from quirks solved it. Thank you quirks!

Alex Wauck (awauck) wrote :

I have observed this problem with a HP dv2500t running Natty (latest updates). Manually changing /desktop/gnome/peripherals/touchpad/touchpad_enabled to true fixed it. Seriously, what's going on here?

Mark Forgette (mw4jet) wrote :

Post # 9 worked for me, I lost touchpad and keypad after updates, Broadcom started working but I could'nt do anything with it!!
I used USB mouse and keyboard to open terminal to run:

sudo apt-get install gpointing-device-settings touchfreeze

After reboot the Linksys wireless card, touchpad, AND keyboard were all working perfectly!

Thanks!

Mark Forgette (mw4jet) wrote :

Add to my post #137---

Ubuntu 10.04 Lucid Lynx
Dell Inspiron 2650----too old for Windoz, so awfully slow--- working good with Ubuntu!!

US (upendra007) wrote :

Sony Vaio VPCEB34EN
touchpad not working

samuel (sps91mail) on 2011-04-28
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Frank Nielsen (frank-boegh) → samuel (sps91mail)
status: Confirmed → New
Liam Ward (liam-dv4) wrote :

I just upgraded my Lenovo Thinkpad T410 to 11.04 Natty and hit this issue. The solution that worked for me seems a bit simpler than some of the ones offered earlier so hopefully this will help someone.

Hit Alt-F2
Type gconf-editor and hit return
Browse to desktop/gnome/peripherals key
Look for your touchpad - mine looked like "SybPS@47@2..."
Uncheck the "disable while other device exists" option

Bingo!

Presumably the problem was that Thinkpads have two built-in pointing devices. While the solution turned out to be simple, it took me a good hour to figure it out and the earlier comments in this thread helped me to start looking in the right place. Thanks.

Bob B (tenbob1) wrote :

IMPORTANT - this contains steps to reproduce the problem.

Comment #103 above has the solution - but it's slightly more subtle than this.

I can easily reproduce the problem on my Acer netbook which has a dedicated keypress (Fn F7) to toggle the touchpad on or off. I'm running Ubuntu 10.04.2 LTS Netbook.

It seems like the touchpad is enabled in two different places. The one we know about is at /desktop/gnome/peripherals/touchpad/touchpad_enabled. The other is elsewhere, presumably in the Synaptics device driver. Both persist over a reboot.

Normally when you hit Fn F7 the touchpad toggles reliably between the enabled and disabled states.

But it's like two electrical switches in series. Provided they both remain in step it works. But if there's ever a glitch that causes one switch to be off while the other is on, there's no easy way to correct it. Hitting Fn F7 will just reverse the existing state. But with one switch on and the other off the touchpad never gets enabled.

Steps to reproduce.

(1) Use gconftool-2 to monitor the state of the relevant gconf key using the command below.
gconftool-2 -g /desktop/gnome/peripherals/touchpad/touchpad_enabled

Press Fn F7 repeatedly and each time check the results with gconftool-2. As expected, you can see the key toggle from true to false and back again. At the same check that the touchpad is being enabled and disabled correctly. This is the normal behaviour.

(2) Finish up with the key value set to false. Now use gconftool-2 to change the key to true using the command below.
gconftool-2 --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true
Note that this sets the two flags out of step with each other.

After this you can keep on hitting FnF7 and see the gconf key change from true to false. But whatever you do you can't get the touchpad to work. Whenever gconf thinks the keypad is enabled the other flag thinks it is disabled and vice versa.

To solve this, the software needs to link the two flags together so they can never have different values.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
higuita (higuita) wrote :

This also affects 11.04 and 11.10, so maybe its better to remove the 10.04 from the subject, as this is still a current and annoying bug

higuita (higuita) wrote :

on 11.10 the "disable touchpad while typing" seems to activate again this problem... some times disabling and re-enabling the touchpad several times make the touchpad return back to life... but doesnt work always.
also, on 11.10, disabled the touchpad and re-enable one will not work, i need to do it twice to really re-enable the touchpad.
it looks like there is yet another apps trying to play with the touchpad and confusing even more this

summary: - [10.04] Touchpad stops working after login
+ Touchpad stops working after login

On a Toshiba Protege M700, I did not have the issue with 11.04 amd64. After the upgrade to 11.10, my touchpad stops working shortly after login. Performed fresh install of 11.10 amd64 and issue persisted.

Unchecking "disable touchpad while typing", as suggested in this bug, keeps my touchpad functional.

cpbtklogic (cpb) wrote :

Just installed 11.10. My Synaptics PS/2 mouse was working before (11.04) but post upgrade it stopped working right after login.

I did two things to (seemingly) fix it.

(1) sudo apt-get install --reinstall xserver-xorg-input-synaptics
(2) gconftool-2 --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true

After one reboot it seems to be working post login.

cpbtklogic (cpb) wrote :

But....

It is clear the button to 'disable' my touchpad and 'disable while typing' puts some set of variables in a state where my touchpad does not work.

going to try:

removing 'psmouse.ko' > add it back
xinput list
gconftool-2 --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true

If that doesn't work, I might try reinstall w/ apt-get.

Patrick Horgan (phorgan1) wrote :

It seems like these two commands together get them back in sync:

synclient TouchpadOff=0
gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

Either one of them will make my touch pad start working, but both together seems to fix the problem.

My laptop (Compaq CQ41) running Ubuntu 12.04 was also same problem.

same problem here hp dv6 runing 12.04

SonhadorPR (sonhadorpr) wrote :

Same problem.
Sony Vaio VPCEB490X

ethanay (ethan-y-us) wrote :

this problem exists on Linux Mint 12 and 13, but for some reason is not affecting me on Ubuntu 12.04...

unchecking "disable touchpad while typing" fixes the issue. in order to avoid accidental clicks, you must also unceck "enable mouse clicks with touchpad" and use the purpose-built buttons only :) (are they really that inconvenient?)

downward (invisioslice) wrote :

this bug also affect Ubuntu 12.04

downward (invisioslice) wrote :

UBUNTU 12.04 This is a partial solution: https://answers.launchpad.net/touchpad-indicator/+question/195181 but the touchpad scroll is dead.

LLR (rufneck) wrote :

touchpad will be deactivated by keyboard shortcut but never switched on again. Can be fixed by dconf

install > sudo apt-get install dconf-tools
run dconf
see > org.gnome.settings-daemon.peripherals.touchpad
Enable touchpad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.