Source rename clobbered local changes (so tapping not working in Karmic)

Bug #378391 reported by Carey Underwood on 2009-05-19
304
This bug affects 42 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
High
William Grant

Bug Description

According to /usr/share/doc/xserver-xorg-input-synaptics, tap-to-click is now disabled for many chipsetsby upstream.

The relevant changes to re-enable it should be included in our default hal config:

        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.TapButton2" type="string">2</merge>
        <merge key="input.x11_options.TapButton3" type="string">3</merge>

Carey Underwood (cwillu) on 2009-05-19
description: updated
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
William Grant (wgrant) wrote :

Tap-to-click has been disabled upstream by default since some time during Jaunty, but we've carried patches inside the driver itself to change the defaults. The changes were clobbered a few days ago when Debian renamed the source package from xfree86-driver-synaptics to xserver-xorg-input-synaptics, and we autosynced it. The new source package replaced the patched binaries from the old one, and all of our local changes went away.

We need to merge the changes from the old package to this new version - I've got it mostly done in my PPA, and am updating it now.

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → William Grant (wgrant)
importance: Undecided → High
status: Confirmed → Triaged
summary: - Tapping now disabled by default
+ Source rename clobbered local changes
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → In Progress

William you don't carry karmic yet in your PPA could you pretty please make adjustments for that.

William Grant (wgrant) wrote :

The Jaunty packages will work fine (I've been using them on Karmic), but I'll copy them into Karmic from now on.

nyarnon (cabal) wrote :

Thanks, Karmic wasn't available yet so I went for Jaunty and my touchpad likes tapping again. Tank you ever so much.

William Grant (wgrant) on 2009-05-23
summary: - Source rename clobbered local changes
+ Source rename clobbered local changes (tapping not working in Karmic)
summary: - Source rename clobbered local changes (tapping not working in Karmic)
+ Source rename clobbered local changes (so tapping not working in Karmic)
Alberto Milone (albertomilone) wrote :

I have ported some of my patches from Jaunty to Karmic. Can anyone test them in karmic, please?

See the attached debdiff.

Manoj Iyer (manjo) wrote :

Alberto, do you have a PPA I can use to test ?

William Grant (wgrant) wrote :

Alberto, I've already done the merge in my PPA (which lots of people use), and nobody has complained.

this debdiff not work correctly.after installed,the gdm can't start,and the
ctrl+alt+fn can't work correctly ,too.

2009/6/5 Alberto Milone <email address hidden>

> I have ported some of my patches from Jaunty to Karmic. Can anyone test
> them in karmic, please?
>
> See the attached debdiff.
>
> ** Attachment added:
> "xserver-xorg-input-synaptics_1.1.1~git20090510-1ubuntu1.debdiff"
>
> http://launchpadlibrarian.net/27527242/xserver-xorg-input-synaptics_1.1.1%7Egit20090510-1ubuntu1.debdiff
>
> --
> Source rename clobbered local changes (so tapping not working in Karmic)
> https://bugs.launchpad.net/bugs/378391
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “xserver-xorg-input-synaptics” source package in Ubuntu: In
> Progress
>
> Bug description:
> According to /usr/share/doc/xserver-xorg-input-synaptics, tap-to-click is
> now disabled for many chipsetsby upstream.
>
> The relevant changes to re-enable it should be included in our default hal
> config:
>
> <merge key="input.x11_options.TapButton1" type="string">1</merge>
> <merge key="input.x11_options.TapButton2" type="string">2</merge>
> <merge key="input.x11_options.TapButton3" type="string">3</merge>
>
>

Tom Wright (twright-tdw) wrote :

It it worth talking about taking this change upstream? The default behaviour simply cannot be considered sensible as tap to click is an expected and useful feature which many touchpads are designed in the expectation of. Mine at least is almost impossible to use without it.

Architecture: i386
DistroRelease: Ubuntu 9.10
MachineType: Acer, inc. Aspire 4530
NonfreeKernelModules: nvidia
Package: xserver-xorg-input-synaptics 1.1.1~git20090510-1
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.30-9-generic root=UUID=581f131b-5c8b-4036-991f-396605f85828 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4~5ubuntu21
 libgl1-mesa-glx 7.4.1-1ubuntu2
 libdrm2 2.4.11-0ubuntu1
 xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu2
 xserver-xorg-video-ati 1:6.12.2-2ubuntu1
Uname: Linux 2.6.30-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/18/2008
dmi.bios.vendor: Acer
dmi.bios.version: v1.3334
dmi.board.name: Grasmoor
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3334:bd09/18/2008:svnAcer,inc.:pnAspire4530:pvrNotApplicable:rvnAcer,Inc.:rnGrasmoor:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 4530
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.30-9-generic

Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :

Tap to click was already not working for me (I used a preferences.fdi file to reenable it).

But now I have a new issue -- right clicking is not working anymore (with the touchpad button).

apt-cache policy xserver-xorg-input-synaptics
xserver-xorg-input-synaptics:
  Installed: 1.1.1~git20090510-1

Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :
Ken Lewis (kenlewis) wrote :

Asif,

With respect to your great contribution to this bug report, you're actually experiencing a different issue now -- which may or may not be related. To help the bug squashing team, can you put the new issue into a new bug?

Asif Youssuff (yoasif) wrote :

Ken, sure thing.

Jorge G (geojorg) wrote :

I have two questions: Tapping would be disable by default in Karmic ?
If it is, there would be information on how to make it work again or at least a help page or something?

Max Bowsher (maxb) wrote :

Tapping is *currently* disabled by default in Karmic, it will be enabled again once wgrant uploads the fixes he has already prepared. In the meantime, you might use the package in my PPA, which is just the one from wgrant's PPA merged with the recent sync from Debian.

Robert Hooker (sarvatt) wrote :

debdiff against the current 1.1.2-1 that was auto synced from debian incase it helps any since this is still a problem.

Robert Hooker (sarvatt) wrote :

Forgot to mention, changelog for the previous debdiff is:

xserver-xorg-input-synaptics (1.1.2-1ubuntu1) karmic; urgency=low

  * Merge from Debian unstable, Remaining changes:
    - Restore the Ubuntu patch series. (LP: #378391)
     - 103_enable_cornertapping.patch: Enable right/middle clicks by
       tapping in the bottom- and top-right corners.
     - 104_always_enable_tapping.patch: Enable tapping regardless of the
       presence of physical buttons.
     - 105_correct_multifinger_click.patch: Swap the right/middle clicks
       generated by multi-finger tapping.
     - 106_always_enable_vert_edge_scroll.patch: Enable vertical edge
       tapping by default even if we enable two-finger scrolling as well.
     - 110_remove_bound_auto_adjust.patch: Don't auto-adjust to bounds of
       the hardware scroll area.

 -- Robert Hooker (Sarvatt) <email address hidden> Sun, 28 Jun 2009 18:13:52 -0400

Bryce Harrington (bryce) wrote :

Thanks, debdiff looks good. Sponsoring upload now...

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.1.2-1ubuntu1

---------------
xserver-xorg-input-synaptics (1.1.2-1ubuntu1) karmic; urgency=low

  * Merge from Debian unstable, Remaining changes:
    - Restore the Ubuntu patch series. (LP: #378391)
     - 103_enable_cornertapping.patch: Enable right/middle clicks by
       tapping in the bottom- and top-right corners.
     - 104_always_enable_tapping.patch: Enable tapping regardless of the
       presence of physical buttons.
     - 105_correct_multifinger_click.patch: Swap the right/middle clicks
       generated by multi-finger tapping.
     - 106_always_enable_vert_edge_scroll.patch: Enable vertical edge
       tapping by default even if we enable two-finger scrolling as well.
     - 110_remove_bound_auto_adjust.patch: Don't auto-adjust to bounds of
       the hardware scroll area.

 -- Robert Hooker (Sarvatt) <email address hidden> Sun, 28 Jun 2009 18:13:52 -0400

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Fix Committed → Fix Released
Nizar Kerkeni (nizarus) wrote :

I confirm that is working again on karmic 64 bits version

Tapping stopped working for me today in 9.10. It was working fine until the last updates today on Acer Aspire One 110

Vincenzo Ciancia (vincenzo-ml) wrote :

Same for me, could some developer double check if the bug may have returned by mistake? E.g. a patch omitted in an upgrade?

Tom Wright (twright-tdw) wrote :

Same for me, will test some more and give info (again!)

Tom Wright (twright-tdw) wrote :

Looking in synaptic there has been no upgrade to xserver-xorg-input-synaptics and changing the options in gpointing-device-settings they don't work because there is probably a problem caused by the udev/devicekit/whatever switch. This works in Fedora which switched first so they may be doing something we are not. This is however probably a separate bug (the settings never worked in this version).

Philip Muškovac (yofel) wrote :

@ Martin, Vincenzo and Tom:
I beleive what you have is bug 404219 since I've got that as well.

pep (atreyv) wrote :

@ Martin
It happened to me as well on the first update after installing alpha-3 on july 24th.

For whom might be interested, to regain tapping again:

on a terminal run gconf-editor

Go to /Desktop/gnome/peripherals/touchpad and activate the options you want.

Martin Emrich (emme) wrote :

Thanks pep, that's what I needed, my two-finger-scrolling works again! Actually, these options can also be set via the mouse properties.

Philip Muškovac (yofel) wrote :

Yes, they can now be set in the mouse properties as it was intended by gnome since the new version of gnome-control-center was uploaded to karmic repos on 2009-07-27. :)

Paul Larson (pwlars) wrote :

Did this regress again? It seemed to be working for me in alpha3, but is now broken again in the daily image. The current version I'm on is: 1.1.2-1ubuntu2

Alberto Milone (albertomilone) wrote :

@Paul
Does it work if you follow the suggestion in comment #47 ?

bodhi.zazen (bodhi.zazen) wrote :

I had the same problem after upgrading to 9.10 alpha.

The fix was to :/usr/share/hal/fdi/policy/20thirdparty/11-x11-synaptics.fdi

sudo cp /usr/share/hal/fdi/policy/20thirdparty/11-x11-synaptics.fdi /etc/hal/fdi/policy/

Reboot

Go under System -> Preferences -> Mouse

Go under the "Touchpad" tab
Select (check off) the "Enable mouse clicks with touchpad" box

(While you are there, you may wish to disable it while typing =) )

I can confirm bodhi.zazen's solution.

Alberto Milone (albertomilone) wrote :

@bodhi, Christian
The 11-x11-synaptics.fdi has very little to do with the settings from the "Touchpad" tab. Furthermore I think the fdi file is fine where it is.

Can you remove the fdi file from /etc/hal/fdi/policy/, reboot and attach your /var/log/Xorg.0.log , please?

After removing /etc/hal/fdi/policy/11-x11-synaptics.fdi and rebooting
the touchpad tab is still available in mouse settings - also tapping still works.

I just doublechecked with a daily-live CD and that tab normally isn't there.

Alberto Milone (albertomilone) wrote :

@Christian
Can you check that xserver-xorg-input-synaptics is installed when using the livecd, please?

You can check it with the following command:
apt-cache policy xserver-xorg-input-synaptics

@Alberto
yes, xserver-xorg-input-synaptics is installed by default on Karmic (1.1.2-1ubuntu3)

Alberto Milone (albertomilone) wrote :

@Christian
Weird... that tab should be visible when a touchpad is detected.

Can you file a new bug report about the problem and attach the /var/log/Xorg.0.log from the livecd, please?

My bad - the touchpad tab is visible (tried on multiple laptops).
So it's now just a matter of activating tapping again - which you still need to know - especially when you had it enabled before upgrading.

Jerone Young (jerone) wrote :

This problem has now reapeared and the tapping is relabed in the gnome-mouse-prefrences as "Enable mouse clicks with touchpad"

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Fix Released → Confirmed
William Grant (wgrant) wrote :

File a new bug. That is not the same issue.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Fix Released
Franck Milleville (fmillevi) wrote :

gnome-mouse-prefrences as "Enable mouse clicks with touchpad" work perfectly on my Notebook

i have just upgraded from 9.04 to karmic.
i can confirm that going to System -> Preferences -> Mouse -> Touchpad and checking "Enable mouse clicks with touchpad" fixes the problem.

Bence Balint (kraxor) wrote :

Why isn't the feature enabled by default? It's usually the preferred behaviour, isn't it?

Also, as users are not notified that the default behaviour has changed after upgrading to Karmic, therefore most people will think it's a bug and start filing bugreports, try to search for driver updates, etc.

John Gilmore (gnu-gilmore) wrote :

According to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/441013/comments/5:

   The behavior in realease Karmic has changed. You will be able to try it on a live cd and install tommorow. "Enable mouse clicks with touchpad" is now enabled by default. It has had this behavior since RC build.

Bruno Girin (brunogirin) wrote :

I can confirm that it works perfectly well in release Karmic: tap to click is enabled by default and works as expected (typed from a newly Karmic Eee PC).

tags: added: iso-testing
To post a comment you must log in.