Ubuntu

Incorrect screen resolution on Samtron 75E in Dapper LiveCD unless HorizSync and VertRefresh specified

Reported by Ricardo Pérez López on 2006-02-17
48
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
High
Unassigned

Bug Description

The screen resolution in X is not correct. It appears in 640x480, 24 bit color. In "System -> Preferences -> Screen resolution" I can't change the resolution to another one (only appears "640x480", 60 Hz).

I have a MSI K7N2G-ILSR motherboard (3 years, more or less), with nVidia nForce2 chipset. I use the internal graphics card. Breezy works perfectly for me (installed and LiveCD).

0000:03:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX - nForce GPU] (rev a3)
0000:03:00.0 0300: 10de:01f0 (rev a3)

[Workaround]
Add the following HorizSync and VertRefresh settings:
Section "Monitor"
 Identifier "Monitor genérico"
 Option "DPMS"
 HorizSync 30-70
 VertRefresh 50-160
EndSection

The output of the "lspci" command during LiveCD execution.

The output of the "lspci -n" command during LiveCD execution.

The /var/log/Xorg.0.log file

The /etc/X11/xorg.conf file

If I do "sudo dpkg-reconfigure xserver-xorg", and follow the steps, I finally have a configuration that works perfectly, with 1024x768, 800x600 and 640x480 resolutions available. I attach the xorg.conf file generated by the "dpkg-reconfigure" execution.

This is the "good" file generated by "sudo dpkg-reconfigure xserver-xorg", which works perfectly for me.

Can you try booting the live cd, but removing "splash" from the boot loader command line? (Press F5 (more options) when you see the initial splash screen and use the keyboard to remove it).

I'm wondering if running xresprobe while usplash is running is a bad idea; it might seem so.

Ricardo Pérez López (ricardo) wrote :

I tried removing "splash" from the boot loader command line, without luck. It doesn't solves the problem.

The problem is that the file /etc/X11/xorg.conf is generated without the "HorizSync" and "VertRefresh" lines in the "Monitor" section, as you can see in the attachment above. If I put the following lines:

HorizSync 30-70
VertRefresh 50-160

into the "Monitor" section of the xorg.conf file, then the problem dissapears and all works ok.

It seems that there's a problem in the monitor autodetection.

For your reference, I have a Samtron 75E (a 17" CRT monitor), which works perfectly in Warty, Hoary and Breezy install & liveCD.

Alexandre Otto Strube (surak) wrote :

Via chips suffers from that too.

Tested on Flight 4. The problem is still here.

I've got same problem on
Display adapter: Intel 82945g Express Chipset Family

Tested on Live CD build 20060310. The problem is still here.

Putting the following lines:

HorizSync 30-70
VertRefresh 50-160

in the "Monitor" section of the /etc/X11/xorg.conf file, the problem solves. It seems that the problem is in the monitor properties autodetection.

Similar here:

Nvidia Geforce4 - Digimate 17" Monitor

I should get a resolution of 1280x1024 like in Breezy but am only offered 1024x768. Works fine if I manually edit the xorg file.

HSync & VRefresh are also off the mark.

Henrik Nilsen Omma (henrik) wrote :

I'm setting tge status to confirmed since several people agree.

Has anyone with this hardware also performed a standard install? If so, is it detected on install or do you have to run 'dpkg-reconfigure' after install?

Thanks.

Changed in xorg:
status: Unconfirmed → Confirmed

I haven't done any Dapper standard install, only upgrades from Dapper.

I have an Ubuntu Dapper installed at work. It shows at 1024x768 in a TFT screen, but changes to 640x480 if I put it in a CRT 15" screen.

I'm not a developer, but I think the problem is that the monitor autodetection doesn't works very well, and leads to a lack of HorizSync and VertRefresh options in /etc/X11/xorg.conf.

This is a regression problem: the screen resolution was always perfect in Warty, Hoary and Breezy.

Henrik Nilsen Omma (henrik) wrote :

Hello,

Could eeither of you please try running the following two commands on the live CD (or standard version if you have it installed):
wget http://www.ubuntulinux.nl/files/pastebin
python pastebin --debug-x

That will first download a debugging script from ubuntulinux.nl. Running it will in turn gather all the log files and output we should need and paste it to a URL at http://paste.ubuntu-nl.org

If you then just paste that URL into a new comment here we should have what we need. Thanks! You can see a sample of what is collected here: http://paste.ubuntu-nl.org/11955

Changed in xorg:
status: Confirmed → Needs Info

> Could eeither of you please try running the following two commands on the live CD

Done. I've executed in my installed system.

Data posted to http://paste.ubuntu-nl.org/11982

I've executed in my installed system. I'm going to download a livecd iso and I'll try with it.

> Could either of you please try running the following two commands on the live CD

I did try to execute the file but it failed so I took a quick look at the script and collected the data that I thought the script was trying to and it is at the URL below:

http://paste.ubuntu-nl.org/11990

As you can see the resolutions collected by "ddcprobe" are different from the ones that get in to the xorg.conf file.

Incidentally this is from the live CD - flight 4.

I've downloaded (20060410) Dapper LiveCD. The problem still remains, exactly as the first day. The desktop appears at 640x480@60Hz, and I can't change the resolution or the refresh rate.

I've executed the script in that LiveCD, and the results were posted to

http://paste.ubuntu-nl.org/12002

Hope this helps to fix this _very_ annoying regression.

Sorry!!!!!!!!!

The above link is incorrect! The results is in

http://paste.ubuntu-nl.org/12001

Please, don't use the above link (the 12002). The correct is 12001.

Using the same LiveCD (20060410), I tried "sudo dpkg-reconfigure xserver-xorg", answering the configuration questions, and then Ctrl-Alt-Backspace... and all works perfectly. After that, I can use many different resolutions in the LiveCD: 1024x768, 1280x1024, 800x600, 640x480, 1280x960, 1280x800, 1152x864, 1280x768, 1152x768 and 832x624, at several refresh rates.

I run the "pastefile" tool again after "sudo dpkg-reconfigure xserver-xorg", and the results is in

http://paste.ubuntu-nl.org/12023

I would like to repeat that this results is when all works perfectly (after "dpkg-reconfigure").

Hope this helps.

Tormod Volden (tormodvolden) wrote :

I have similar problems in a standard (from scratch) install (savage card, via chipset) see bug #39311.

andrewpmk (andrewpmk) wrote :

I have this problem in Beta 1; the default resolution is 1024x768. My video adapter is a "Silicon Integrated Systems (SiS) 630/730 PCI/AGP VGA Display Adapter"; my monitor, a 17" KDS XFlat, supports resolutions up to 1280x1024. Running dpkg-reconfigure corrects xorg.conf.

Mike Perrin (mperrin) wrote :

Another twist to this problem on a Dapper Beta hard drive install from live CD, with all updates as of 2006-04-23. I have a Samsung 204T 1600x1200 LCD display behind an 8-port IOGear KVM switch. If I boot Dapper with the switch pointed at the Ubuntu machine, I get the desired 1600x1200 resolution. If I boot Dapper with the KVM switch pointed to another machine, I get 640x480 on the login screen and as the only choice in System->Preferences->Screen Resolution. The modification time on my /etc/X11/xorg.conf file is about 10 minutes prior to the mod time on /etc/passwd, indicating that the Xorg configuration file is as created on installation. This problem does not occur with other distributions on switched machines, including FC5, Suse 10.0, Xandros 3 and Mandrake 10.0. Come to think of it, this problem did not occur with Breezy Badger that I can remember. Following are the relevant sections of my xorg.conf file.

Section "Device"
        Identifier "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64
Pro]"
        Driver "nv"
        BusID "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier "SyncMaster"
        Option "DPMS"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64
Pro]"
        Monitor "SyncMaster"
        DefaultDepth 24
        SubSection "Display"
                Depth 1
                Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth 4
                Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth 8
                Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth 15
                Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth 16
                Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth 24
                Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
EndSection

meeehhh too many bugs in one bug.... ok i will try to sort them out but in future pretty please use the Add Attachment funcionality here in launchpad to collect infos. We cannot rely on external resources like pastebin.

Fabio

Mike Perrin (mperrin) wrote :

Fabio,
Sorry about that. Next time I will use the attachment feature. If there is anything you would like me to test out to help you narrow down the problem, please let me know.

Mike

Mikko Saarinen (mikk0) wrote :

I have a sis chipset and I have this problem too.

I booted with Beta2 Live CD and selected at boot options 1280x800 mode (my laptops native resolution). The splash screen obeyed, but when X started it was running at 1024x768 and I could only select lower modes, not any higher ones.

I used the installer at the live CD and the installed system suffers from the same symptom.

However I got the correct resolution when I first installed Flight6 from the Install CD. So I guess that means the text based installation has better chances to detect the correct video modes.

Matthew Lange (matthewlange) wrote :

Similar to Bug #5801?
Set to confirmed, package: xserver-xorg

Changed in xorg:
status: Needs Info → Confirmed

I'm the author of the original post.

I'm using now the Kubuntu Live CD (build from today, 20060530.1), and the problem is still here, 3 months after!

The desktop appears at 640x480@60Hz, and I can't change it (that is the only resolution the system recognizes).

I must do "sudo dpkg-reconfigure xserver-xorg", follow the instructions, and then restart kdm.

Obviously, a joe user almost sure doesn't knows how to workaround the problem with dpkg-reconfigure.

I repeat: this is a rather important regression problem: the problem doesn't appears in Breezy LiveCD. And remember that LiveCD is used for try AND INSTALL Dapper.

Dominique Meeùs (dominiquem) wrote :

I confirm the original bug.
The Ubuntu 6.06 live CD (final release, downloaded about june 10, 2006) doesn't detect my graphics hardware correctly and chooses basic vga definition. (MSI K7NG2G motherboard with integrated Nvidia nForce2 video. AG Neovo E-17 17" LCD monitor 1280x1024, 135 MHz max, horizontal: 30-80kHz, vertical: 49-75Hz.)
As a result, "OK" or other buttons of many dialogs and, still worse, the installer program, are out of reach. As such, installing is impossible. I had to do dpkg-reconfigure xserver-xorg before I could go on with installing. (I suppose most newbies wouldn't do so and be definitely unable to use the live CD or to install Dapper.)
This is mostly a detection problem. With dpkg-reconfigure, I get my 1280x1024 resolution OK.

Have tested Edgy and this has carried on through to the Beta - The monitors frequencies are not set up properly and the proper resolutions aren't detected (not that those frequencies would work until the frequencies were set up).

Still occurs in Edgy production version.

Hi David,

Try the following actions which were suggested for Dapper by Ricardo
Perez. It might work for Edgy too.
I am quoting him:
Re: Incorrect screen resolution in Dapper LiveCD

'If I do "sudo dpkg-reconfigure xserver-xorg", and follow the steps, I
finally have a configuration that works perfectly, with 1024x768, 800x600
and 640x480 resolutions available. I attach the xorg.conf file generated by
the "dpkg-reconfigure" execution.'

On 11/9/06, David Taylor < <email address hidden>> wrote:
>
> Still occurs in Edgy production version.
>
> --
> Incorrect screen resolution in Dapper LiveCD
> https://launchpad.net/bugs/31830
>

Many thanks Don, I have edited my Xorg.conf file to correct already (I am from Debian way back when editing Xorg was a necessity).

It appears this fault may eventually be cured simply by the fact that set up will be done by X in future if Sebastian Kuegler's blog post is anything to go by:

"X will be able to do much more runtime configuration, to the point where the developers think that the infamous xorg.conf can be abandoned completely. That'd mean that we're basically doing all kind of displayconfiguration at runtime"

Maybe Feisty will Squash this bug once and for all.

> Maybe Feisty will Squash this bug once and for all.
Maybe :)

In my understanding (for when dpkg-reconfigure xserver-xorg" works later)
the bug is in casper.

casper-bottom/20xconfig calls dpkg-reconfigure in a chroot but it only mounts /proc and /sys.

dpkg-reconfigure xserver-xorg can call ddcprobe which needs a working /dev/fb0...

adding:
mount -n -o bind /dev /root/dev
works for me.

I wished you were right Didier however this bug has been neglected again. I have just tried Feisty (herd five) and the same resolutions are presented to me but this time I have a GeForce 6200. I'll keep you all posted for Feisty +1.

The problem is still here with Feisty Herd 4, and it's a _very_ annoying bug.

I also confirm this bug on Herd 5

Display adapter: Intel 82945g Express Chipset Family

This bug is one year old. Has been confirmed for several users, and its importance is 'medium'. Even there's a possible workaround to solve the problem (given by didier). However, it hasn't been assigned to a developer yet. I wonder why.

Timo Aaltonen (tjaalton) wrote :

this is not neglected :)

can you try Herd 5 without usplash, ie. remove 'splash' from the kernel boot parameters?

didier: casper might bind-mount /dev, and that could in fact be the remedy for this and the numerous similar bugs that have been reported recently. ("livecd detects badly, dpkg-reconfigure on an installed system makes it ok")

> can you try Herd 5 without usplash, ie. remove 'splash' from the kernel
> boot parameters?
I don't use usplash.

I've tried it on the ubuntu/kubuntu feisty 5 CD's alas no joy.

I should have pointed out - my last post was referring to booting without the splash on the live CD.

Green (green-r8) wrote :

I too confirmed this bug here
with Intel 845GE chipset
in AOpen MX4GER motherboard,
using LCD display I-O DATA A152GS.

For a reference, see my note at
http://f40.aaa.livedoor.jp/~green/?DebianLinux-FAQ%2FDebianLive

Best regards.

Tollef Fog Heen (tfheen) wrote :

I have just committed a fix which I believe solves this problem now; please test tomorrow's daily CDs to verify.

Changed in casper:
status: Confirmed → Fix Committed
Tollef Fog Heen (tfheen) on 2007-03-30
Changed in casper:
status: Fix Committed → Fix Released

I tested the "feisty-desktop-i386.iso 31-Mar-2007 06:09 695M Desktop CD for PC (Intel x86) computers (standard download)" and the result was no improvement. Thanks for trying though.

As far I can tell changes are not yet in the liveCD.

Just tell us when you want us to test Tollef.

I can confirm using my setup that this still is not working in Feisty (Kubuntu).

I have moved the status back to confirmed as the fix released has not worked, does anyone else wish to confirm this with their system set-up.

Changed in casper:
status: Fix Released → Confirmed
Mike Perrin (mperrin) wrote :

I retested both 7.04 and 6.10 (with all updates) on the same configuration as my 2006-04-25 posting: a Samsung 204T 1600x1200 LCD behind an 8 port IOGear KVM switch. If I boot with the switch pointed at another machine, both 7.04 and 6.10 come up with 800x600 resolution. If I boot with the KVM switch pointed to the booting computer, they come up at 1600x1200. This may indicate that the resolution problem experienced by others, presumably without interposing hardware between the computer and display, has something to do with the ability to interrogate the connected monitor.

I don't want to speak too soon without others experiences but after a year and eight months I think this one has been corrected!!! I'm just in the live CD Kubuntu Gutsy Beta and looking at this web form through 1280x1024 goodness (and it's crystal clear). It may well be due to the Xorg improvements as per one of my previous posts:

"
It appears this fault may eventually be cured simply by the fact that set up will be done by X in future if Sebastian Kuegler's blog post is anything to go by:
"X will be able to do much more runtime configuration, to the point where the developers think that the infamous xorg.conf can be abandoned completely. That'd mean that we're basically doing all kind of displayconfiguration at runtime"
"

In that case hoorah Xorg.

How is others experiences?

adair (al-lairds) wrote :

I'm afraid this problem has reappeared (at least for me) in the Hardy beta. I used to have it regularly in earlier versions of ubuntu, but not in Gutsy, nor, I think, in Feisty.

It's a Dell Latitude C600 with an ATI Mobility 128 graphics chipset. The boot process, with or without splash, is fine, but X is offering a top resolution of 800x600. Also, and more seriously, the screen is broken into three unequal vertical sections, effectively three partial projections of the desktop---exactly the same old problem that I thought I'd seen the last of some time ago!

Has anyone else got this problem (I've got one or two others including an hard drive install that fails around the 60% mark, but that's not relevant to this). Happy days!!!

adair (al-lairds) wrote :

I should add that this problem only applies to running the live CD. The actual installation sets xorg.conf correctly.

This still works well for me on Hardy Beta (infact oddly slightly crisper but that might just be my perception or my vision). AFAIK this is actually the first time that X is working out the set up and not relying on the xorg file so your fault 'adair' may be more to do with X than 'casper' (what ever that is).

"the screen is broken into three unequal vertical sections, effectively three partial projections of the desktop"

That is unrelated to Ricardo's original problem so I suggest looking through the rest of the faults for something similar and if not logging your own as with the silence on this suggests this fault should have been closed. I would have done this myself but fear getting a telling off as I have in the past (That may have been Debian's or KDE's fault logging tools).

bunak (bunak-prelouc) wrote :

When I run live CD (Ubuntu, Xubuntu) on my computer with graphic card Gainward Bliss 7300LE PCX (monitor Samtron 76BDF), system correctly detect graphic card as Nvidia card, but set resolution of screen on 1600x1200@85Hz. But this resolutin on this frequency dont work on this monitor. This mean that monitor switch off. When I install system I can choose resolution during installation, but login screen is allways in resolution 1600x1200@85Hz. For this reasons I cannot test live distribution of Ubuntu (Xubuntu) because I am not able to set lower resolution.

Bryce Harrington (bryce) on 2009-01-06
description: updated
description: updated
Bryce Harrington (bryce) wrote :

This is long since fixed in X. Resolution handling has been completely revamped since this bug was first reported.

The original issue was just that for some monitors it used to be that you had to manually specify H/V rates in order for the X to work because the install-time config generator wasn't able to detect that properly. But today those scripts are eliminated, and now X does all the resolution detection internally, which works like 99% of the time. (There are cases where it still fails, see https://bugs.edge.launchpad.net/ubuntu/+source/xorg-server/+bug/194760 as the main example, but these are rare corner cases now.)

Ricardo's last comment was in early 2007 which iirc was before much of this new stuff hit. I'm going to go ahead and make a guess that with the new resolution autodetection code, his problem went away, and will close the bug.

Other commenters on this bug have indicated their issues were solved by this change. Anyone else still having resolution detection problems - please report as a new bug, don't re-open this one.

Changed in xorg:
importance: Medium → High
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers