[hybrid] Xorg crashed with SIGABRT in DamageRegister()

Bug #1194114 reported by Samuele on 2013-06-24
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)

Bug Description

Xorg crashed

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-core 2:1.13.3-0ubuntu13
Uname: Linux 3.9.7-030907-generic x86_64

ApportVersion: 2.10.2-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Mon Jun 24 14:38:38 2013
DistUpgraded: 2013-06-15 12:02:31,293 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes, including running git bisection searches
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1457]
 NVIDIA Corporation GF119M [GeForce 610M] [10de:1058] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1457]
InstallationDate: Installed on 2013-06-14 (9 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
ProcCmdline: /usr/bin/X :0 -core -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.9.7-030907-generic root=UUID=a6036e43-2276-4f02-a312-1f90222e0f8a ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
 DamageRegister ()
 ?? ()
 BlockHandler ()
 WaitForSomething ()
 ?? ()
Title: Xorg crashed with SIGABRT in DamageRegister()
UpgradeStatus: Upgraded to saucy on 2013-06-15 (9 days ago)

dmi.bios.date: 03/12/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K55VD.203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K55VD
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK55VD.203:bd03/12/2012:svnASUSTeKCOMPUTERINC.:pnK55VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnK55VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: K55VD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.45-2ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.3-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.3-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu13
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8-0ubuntu1
xserver.bootTime: Mon Jun 24 14:39:23 2013
xserver.configfile: default
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu13
xserver.video_driver: intel

 DamageRegister (pDrawable=0x0, pDamage=0x7f098d25a9b0) at ../../../miext/damage/damage.c:1774
 xf86RotatePrepare (pScreen=0x7f098d00ae00) at ../../../../hw/xfree86/modes/xf86Rotate.c:171
 xf86RotateRedisplay (pScreen=0x7f098d00ae00) at ../../../../hw/xfree86/modes/xf86Rotate.c:192
 xf86RotateBlockHandler (pScreen=0x7f098d00ae00, pTimeout=0x7fffb2d05148, pReadmask=0x7f098c971ee0 <LastSelectMask>) at ../../../../hw/xfree86/modes/xf86Rotate.c:238
 BlockHandler (pTimeout=pTimeout@entry=0x7fffb2d05148, pReadmask=pReadmask@entry=0x7f098c971ee0 <LastSelectMask>) at ../../dix/dixutils.c:390

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private Security → Public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2013-09-26
summary: - Xorg crashed with SIGABRT in DamageRegister()
+ [hybrid] Xorg crashed with SIGABRT in DamageRegister()

Samuele, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:

Changed in xorg-server (Ubuntu):
importance: Medium → Low
status: Confirmed → Incomplete
tags: added: trusty
Karma Dorje (taaroa) on 2014-01-21
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
tags: added: bios-outdated-411
removed: trusty
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: added: trusty
Bruce Pieterse (octoquad) wrote :

Looks like the GeForce 6xxM graphic cards might be the cause of this?

Chris Wilson (ickle) wrote :

The interation between -intel and -nouveau is definitely a suspect here.

Despite no response from OR (Samuele), for now marking to Confirmed due to apport auto-marking duplicates, and Medium as it's reproducible in Trusty by a few others.

Changed in xorg-server (Ubuntu):
importance: Low → Medium
status: Incomplete → Confirmed
tags: added: vivid
To post a comment you must log in.