Device 0 (vif) could not be connected. Hotplug scripts not working.

Bug #199533 reported by Todd Deshane
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xen-3.2 (Ubuntu)
Fix Released
Undecided
Unassigned
Nominated for Hardy by Marco Scholl

Bug Description

HVM guest boots fine without networking

add vif=[''] or vif=['bridge=eth0']

then get the error
Error: Device 0 (vif) could not be connected. Hotplug scripts not working.

xend.log attached

Related branches

Revision history for this message
Todd Deshane (deshantm) wrote :
Revision history for this message
Todd Deshane (deshantm) wrote :

strace of xm create attached

Also, i noticed that /bin/sh symlinks to /bin/dash again. I pointed it back at /bin/bash, but same problem.

The xend-config.sxp is the same no changes.

I can attach it though

Revision history for this message
Todd Deshane (deshantm) wrote :

xend config attached

Revision history for this message
Todd Deshane (deshantm) wrote :

$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1a:92:97:26:50
          inet addr:128.153.146.84 Bcast:128.153.146.255 Mask:255.255.255.0
          inet6 addr: fe80::21a:92ff:fe97:2650/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:17 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2097 (2.0 KB) TX bytes:4285 (4.1 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:10632 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10632 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16735008 (15.9 MB) TX bytes:16735008 (15.9 MB)

peth0 Link encap:Ethernet HWaddr 00:1a:92:97:26:50
          inet6 addr: fe80::21a:92ff:fe97:2650/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
          RX packets:12097 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6943 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9216290 (8.7 MB) TX bytes:1626696 (1.5 MB)
          Interrupt:23 Base address:0x8000

$ brctl show
bridge name bridge id STP enabled interfaces
eth0 8000.001a92972650 no peth0

Also, brctl show doesn't change during the xm create attempt. So, it doesn't look like the vif is being added to the bridge at all.

Revision history for this message
Todd Deshane (deshantm) wrote :
Revision history for this message
Todd Deshane (deshantm) wrote :

bug #192294 seems to be a big reason for this bug

I still need to confirm the workaround

https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/192294

Revision history for this message
Marco Scholl (traxanos) wrote :

Hi,

i have the exalty problems on this maschine

DISTRIB_ID=Ubuntu
DISTRIB_ARCH=x64
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

xen will only work perfect without network :(
i have build a xen from stable und unstable source, too.
it don't help.

i have install a gutsy version from iproute. without success.

Revision history for this message
Todd Deshane (deshantm) wrote :

Marco: What network card(s)?

Anything else you can tell about your hardware setup that might be a factor?

For me:

$lspci | grep net
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit Ethernet PCI Express (rev 02)
04:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
stepping : 6
cpu MHz : 1600.000
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips : 4791.36
clflush size : 64

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
stepping : 6
cpu MHz : 2400.000
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips : 4788.00
clflush size : 64

It's a DEll OPTIPLEX 745, with an added network card (the realtek card is added)

Also, how did you build from source?

It might be the Xen Linux kernel config file that is the problem...

I will try to investigate that more.

Changed in xen-3.2:
status: New → Confirmed
Revision history for this message
Todd Deshane (deshantm) wrote :

quick update Marco (or others building from source). The source from xen.org works properly without modification and after getting the gutsy iproute tools.

Revision history for this message
Marco Scholl (traxanos) wrote :

i have reinstall the complete server without success, again.
I think ne network-bridge work fine and the vif-brigde won't work correctly.

https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/192294 is not the problem if think because
>ip link set eth0 up < won't throw an error.

i have only test the amd64-version of ubuntu

Revision history for this message
terra01 (ac-coenen-online) wrote :

Hello all,
i have the same problem on my machine (32bit). I changed the Hardware from my Computer so i can't use the kernel 2.5.18 from xensource. Any solutions found?

DISTRIB_ID=Ubuntu
DISTRIB_ARCH=x86 (32bit)
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Computer:
- Asus P5K Pro
- Q6600
- 8192 MB RAM

xen:
- ubuntu-xen-desktop
- script "multi-bridges" same as in xen 3.1 before (xenbrX changed to ethX)
- standart xend-config.sxp (only script changed, but before testet with )

uname -r:
2.6.24-12-xen

iproute from hardy:
should work, i get no error message

lspci |grep net:
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

brctl show:
bridge name bridge id STP enabled interfaces
eth0 8000.000e2eb7c63e no peth0
eth1 8000.001e8c0d3aea no peth1

xm create testmachine.cfg:
Using config file "testmachine.cfg".
Error: Device 0 (vif) could not be connected. Hotplug scripts not working.

thanks, Andy

Revision history for this message
Todd Deshane (deshantm) wrote :

Some debugging ideas

add the line:
set -x
to the network scripts that you are using (i.e. network-brige, vif-bridge)
This will produce output in /var/log/syslog

configure udev log DEBUG in /etc/udev.conf

keep an eye on xenstore with xenstore-ls and xenstore-read to see if the vif devices are being created.

Make sure that the vif and veth devices exists

Keep an eye on all the logs in /var/log/xen/

try to use strace on different commands, scripts, entry points to see where things hang etc.

Revision history for this message
Marco Scholl (traxanos) wrote :

if i have time on weekend i would debug the scripts.

Revision history for this message
Todd Deshane (deshantm) wrote :

A few more bugs with some ideas in them.

https://bugs.launchpad.net/ubuntu/+source/xen-3.0/+bug/55219
https://bugs.launchpad.net/ubuntu/+source/xen-3.0/+bug/55220
https://bugs.launchpad.net/ubuntu/+source/xen-3.0/+bug/55216

One idea that I hadn't thought of yet was to strace the udevd process in the foregroud (i think you pass -f maybe also -d check manpage)

There are other tricks used in the bugs above, but I don't know a lot about them. I will have to investigate more.

Revision history for this message
Todd Deshane (deshantm) wrote :

I also wanted to note that this affects both HVM and PV guest (in case it wasn't stated clearly above)

Revision history for this message
terra01 (ac-coenen-online) wrote :
Download full text (8.4 KiB)

when i boot the machine without starting xen the network cards don't up. Ifconfig shows only the "lo"-interface.

- /etc/init.d/networking stop/start/restart don't helps.
- ifup eth0 / eth1 helps... then the interfaces come up.
- /etc/init.d/xend start peth0 / peth1 are shown
- there is NO vif listed in ifconfig

i set the "set -x" commands in the script "network-bridge" and "vif-bridge" in the top:

----snip--- network-bridge---
# Print addresses, interfaces, routes
#
#========================================
# Log all into syslog
set -x

dir=$(dirname "$0")
. "$dir/xen-script-common.sh"
. "$dir/xen-network-common.sh"
----snip--- network-bridge---

----snip--- vif-bridge---
# down:
# Removes the vif interface from the bridge and removes the iptables
# rules for its ip addresses (if any).
#============================================================================
# Log all into syslog
set -x

dir=$(dirname "$0")
. "$dir/vif-common.sh"
----snip--- vif-bridge---

After reboot and starting / restarting xend i get the following messages:

---snip---
root@atlantis:~# /etc/init.d/xend restart
++ dirname /etc/xen/scripts/network-bridge
+ dir=/etc/xen/scripts
+ . /etc/xen/scripts/xen-script-common.sh
++ set -e
+ . /etc/xen/scripts/xen-network-common.sh
++ '[' -e /etc/SuSE-release ']'
++ which ifup
+ findCommand start vifnum=0 vifname=vm0 bridge=eth0 netdev=eth0
+ for arg in '"$@"'
+ expr index start =
+ command=start
+ return
+ evalVariables start vifnum=0 vifname=vm0 bridge=eth0 netdev=eth0
+ for arg in '"$@"'
+ expr index start = '>' 1
+ for arg in '"$@"'
+ expr index vifnum=0 = '>' 1
+ eval vifnum=0
++ vifnum=0
+ for arg in '"$@"'
+ expr index vifname=vm0 = '>' 1
+ eval vifname=vm0
++ vifname=vm0
+ for arg in '"$@"'
+ expr index bridge=eth0 = '>' 1
+ eval bridge=eth0
++ bridge=eth0
+ for arg in '"$@"'
+ expr index netdev=eth0 = '>' 1
+ eval netdev=eth0
++ netdev=eth0
+ netdev=eth0
+ is_network_root
++ awk '{ if ($1 !~ /^[ \t]*#/ && $2 == "/") { print $3; }}' /etc/mtab
+ local rootfs=ext3
++ awk '{ if ($1 !~ /^[ \t]*#/ && $2 == "/") { print $4; }}' /etc/mtab
+ local rootopts=rw,errors=remount-ro
+ [[ ext3 =~ \^nfs ]]
+ [[ rw,errors=remount-ro =~ _netdev ]]
+ return 1
+ netdev=eth0
+ bridge=eth0
+ antispoof=no
+ pdev=peth0
+ tdev=tmpbridge
+ case "$command" in
+ op_start
+ '[' eth0 = null ']'
+ link_exists peth0
+ ip link show peth0
+ return 0
+ return
++ dirname /etc/xen/scripts/network-bridge
+ dir=/etc/xen/scripts
+ . /etc/xen/scripts/xen-script-common.sh
++ set -e
+ . /etc/xen/scripts/xen-network-common.sh
++ '[' -e /etc/SuSE-release ']'
++ which ifup
+ findCommand start vifnum=1 vifname=vm1 bridge=eth1 netdev=eth1
+ for arg in '"$@"'
+ expr index start =
+ command=start
+ return
+ evalVariables start vifnum=1 vifname=vm1 bridge=eth1 netdev=eth1
+ for arg in '"$@"'
+ expr index start = '>' 1
+ for arg in '"$@"'
+ expr index vifnum=1 = '>' 1
+ eval vifnum=1
++ vifnum=1
+ for arg in '"$@"'
+ expr index vifname=vm1 = '>' 1
+ eval vifname=vm1
++ vifname=vm1
+ for arg in '"$@"'
+ expr index bridge=eth1 = '>' 1
+ eval bridge=eth1
++ bridge=eth1
+ for arg in '"$@"'
+ expr index netdev=eth1 = '>' 1
+ eval netdev=eth1
++ netdev=eth1
+ netdev=eth1
+ is...

Read more...

Revision history for this message
terra01 (ac-coenen-online) wrote :
Download full text (5.8 KiB)

I paste only a part from syslog... here attached the rest...

Here are the warnings about the vif-devices (xend.log):

2008-03-11 17:38:05 6541] INFO (SrvDaemon:331) Xend Daemon started
[2008-03-11 17:38:05 6541] INFO (SrvDaemon:335) Xend changeset: unavailable.
[2008-03-11 17:38:05 6541] INFO (SrvDaemon:342) Xend version: Unknown.
[2008-03-11 17:38:05 6541] DEBUG (XendDomainInfo:132) XendDomainInfo.recreate({'max_vcpu_id': 3, 'cpu_time': 315127662538L, 'ssidref': 120, 'hvm': 0, 'shutdown_reason': 0, 'dying': 0, 'online_vcpus': 4, 'domid': 0, 'paused': 0, 'crashed': 0, 'running': 1, 'maxmem_kb': 4294967292L, 'shutdown': 0, 'mem_kb': 8180736L, 'handle': [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0], 'blocked': 0, 'name': 'Domain-0'})
[2008-03-11 17:38:05 6541] INFO (XendDomainInfo:149) Recreating domain 0, UUID 00000000-0000-0000-0000-000000000000. at /local/domain/0
[2008-03-11 17:38:05 6541] DEBUG (XendDomainInfo:2211) Storing VM details: {'on_xend_stop': 'ignore', 'shadow_memory': '0', 'uuid': '00000000-0000-0000-0000-000000000000', 'on_reboot': 'restart', 'image': '(linux (kernel ))', 'on_poweroff': 'destroy', 'on_xend_start': 'ignore', 'on_crash': 'restart', 'xend/restart_count': '0', 'vcpus': '4', 'vcpu_avail': '15', 'name': 'Domain-0'}
[2008-03-11 17:38:05 6541] DEBUG (XendDomainInfo:1027) Storing domain details: {'cpu/3/availability': 'online', 'name': 'Domain-0', 'console/limit': '1048576', 'memory/target': '8180736', 'cpu/2/availability': 'online', 'vm': '/vm/00000000-0000-0000-0000-000000000000', 'domid': '0', 'security_label': '', 'cpu/0/availability': 'online', 'cpu/1/availability': 'online', 'control/platform-feature-multiprocessor-suspend': '1', 'console/type': 'xenconsoled'}
[2008-03-11 17:38:05 6541] DEBUG (XendDomain:443) Adding Domain: 0
[2008-03-11 17:38:05 6541] DEBUG (XendDomain:379) number of vcpus to use is 0
[2008-03-11 17:38:05 6541] DEBUG (XendDomainInfo:1111) XendDomainInfo.handleShutdownWatch
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VBD.set_device not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VBD.set_type not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: session.get_all_records not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: event.get_record not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: event.get_all not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VM.get_auto_power_on not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VM.set_auto_power_on not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VIF.get_network not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VIF.set_device not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VIF.set_MAC not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: VIF.set_MTU not found
[2008-03-11 17:38:05 6541] WARNING (XendAPI:678) API call: debug.get_all not found
[2008-03-11 17:38:05 6541] INFO (XMLRPCServer:149) Opening Unix domain socket XML-RPC server on /var/run/xend/xen-api.sock; authentication has been disabled for this server.
[2008-03-11 17:38:05 6541] INFO (XMLRPCServer:...

Read more...

Revision history for this message
Todd Deshane (deshantm) wrote :

another debugging thing to try...

I think that maybe the vif interfaces are missing or having trouble coming up

Try putting the following in your /etc/network/interfaces

auto br0
iface br0 inet static
  address 192.168.133.7
  netmask 255.255.255.0
  broadcast 192.168.133.0
  bridge_ports eth0
  bridge_fd 9
  bridge_hello 2
  bridge_maxage 12
  bridge_stp off

Then run:
/etc/init.d/networking restart

Then in the guest try changing the vif line to add

vif=['bridge=br0']

Then try to start the guest.

Revision history for this message
Todd Deshane (deshantm) wrote :

Ignore that last comment (unless you are doing special private networks)

I think the solution is to load the netbk module

Try:

modprobe netbk

Revision history for this message
Todd Deshane (deshantm) wrote :

For PV guests it seems that you may also need to put the proper modules into the initrd

change /etc/initramfs-tools/modules to include the modules the guest will need and rebuild the initrd with the command:

mkinitramfs -o /boot/<xen initrd> <xen kernel version>

my guest is that it need sd_mod and blktap, maybe other modules in /lib/modules/<xen kernel verion>/kernel/drivers/xen/

I'll try to test later....

Revision history for this message
Marco Scholl (traxanos) wrote :

what is netbk?
i cant found the module in the xen-kernel-package. i can't test at the momenten but i will do it in the night.

do u mean really Dom0 with the modprobe?

Revision history for this message
Todd Deshane (deshantm) wrote :

yeah on the dom0 do:

modprobe netbk

The modules are probably come with package linux-image-2.6.24-11-xen

Revision history for this message
Marco Scholl (traxanos) wrote :

YES!!! It is work!

Now the Ubuntudeveloper should find a solution to integrated into a package!

Revision history for this message
Todd Deshane (deshantm) wrote :

a couple easy ideas for the fix.

add netbk to /etc/modules

maybe a better solution would actually be to add detection for the module and if the module doesn't exist, then run the modprobe line
This code could be put in /etc/init.d/xend (which last I knew was missing in hardy)

Revision history for this message
Marco Scholl (traxanos) wrote :

Yes i have the same idea as workaround, too.
now i wait wor correct xen-utils with correct initscripts :D

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.2 - 3.2.0-0ubuntu9

---------------
xen-3.2 (3.2.0-0ubuntu9) hardy; urgency=low

  * Fixed typo in debian/rules. Init scripts are back. (LP: #191875)
  * Disabled suse patches. (LP: #199533)
  * Dont conflict with libxen3.0 (LP: #199467)

 -- Chuck Short <email address hidden> Thu, 13 Mar 2008 07:24:42 -0400

Changed in xen-3.2:
status: Confirmed → Fix Released
Revision history for this message
terra01 (ac-coenen-online) wrote :

I work yesterday on my Computer and test your Solution.

In the 32-Bit Version the Module "loop" is not loaded in standard configuration. I load the modules (netbk, loop), the error message was gone an i get the message ... VM startet.

I look with xm list... and find the VM, but she don't works.

I checked the vm-log files (qemu-dm-xx.log) in /var/log/xen and get the message:

---snip---
/etc/xen/qemu-ifup: could not launch network script
Could not initialize device 'tap'
---snip---

 In the Version 3.1 "qemu-ifup" is an part from xend-utils but in the 3.2 i couldn't find. I use the file from the xen 3.1-Package and now it' running fine.

As workaround for the 32 Bit Version should be tested, if "netbk" are loaded and the script "qemu-ifup" should be included in "xen-utils-3.2".

Thanks @ Todd & Marco

Revision history for this message
Maurício Magalhães (mauriciommagalhaes) wrote :
Download full text (3.9 KiB)

Hi All

I am not getting the start domU gives the following error in the terminal how fix this ?
Tanks a lot

Using config file "./ecolx01_VM.cfg."
Error: Device 769 (vbd) could not be connected. Losetup / dev/loop11 / xen/domains/ecolx01_VM/swap.img failed
/etc/modules
loop max_loop=64

My /etc/xen-tools/xen-tools.conf
 dir=/xen
 install-method = debootstrap
 size = 5Gb # Disk image size.
 memory = 256Mb # Memory size
 swap = 512Mb # Swap size
 fs = ext3 # use the EXT3 filesystem for the disk image.
 dist = dapper # Default distribution to install.
 image = sparse # Specify sparse vs. full disk images.
 gateway = 10.32.76.10
 netmask = 255.255.255.128
 broadcast = 10.32.76.128
 passwd = 1
 kernel = /boot/vmlinuz-`uname -r`
 initrd = /boot/initrd.img-`uname -r`
 mirror = http://gb.archive.ubuntu.com/ubuntu/
 ext3_options = noatime,nodiratime,errors=remount-ro
 ext2_options = noatime,nodiratime,errors=remount-ro
 xfs_options = defaults
 reiser_options = defaults
 use-ide = 1
#

My /etc/xen/ecolx01_VM.cfg
# Created by xen-tools
 kernel = '/boot/vmlinuz-2.6.24-12-xen'
 ramdisk = '/boot/initrd.img-2.6.24-12-xen'
 memory = '256'
 root = '/dev/hda2 ro'
 disk = [
                  'file:/xen/domains/ecolx01_VM/swap.img,hda1,w',
                  'file:/xen/domains/ecolx01_VM/disk.img,hda2,w',
                    ]
 name = 'ecolx01_VM'
 vif = [ 'ip=10.32.76.100,mac=00:16:3E:59:12:88' ]
 on_poweroff = 'destroy'
 on_reboot = 'restart'
 on_crash = 'restart'
#

LOGS

/var/log/xen/xend.log
[2008-03-14 11:39:13 7800] DEBUG (XendDomainInfo:1111) XendDomainInfo.handleShutdownWatch
[2008-03-14 11:39:13 7800] DEBUG (DevController:150) Waiting for devices vif.
[2008-03-14 11:39:13 7800] DEBUG (DevController:155) Waiting for 0.
[2008-03-14 11:39:13 7800] DEBUG (DevController:594) hotplugStatusCallback /local/domain/0/backend/vif/6/0/hotplug-status.
[2008-03-14 11:39:13 7800] DEBUG (DevController:594) hotplugStatusCallback /local/domain/0/backend/vif/6/0/hotplug-status.
[2008-03-14 11:39:13 7800] DEBUG (DevController:608) hotplugStatusCallback 1.
[2008-03-14 11:39:13 7800] DEBUG (DevController:150) Waiting for devices vbd.
[2008-03-14 11:39:13 7800] DEBUG (DevController:155) Waiting for 769.
[2008-03-14 11:39:13 7800] DEBUG (DevController:594) hotplugStatusCallback /local/domain/0/backend/vbd/6/769/hotplug-status.
[2008-03-14 11:39:13 7800] DEBUG (DevController:594) hotplugStatusCallback /local/domain/0/backend/vbd/6/769/hotplug-status.
[2008-03-14 11:39:13 7800] DEBUG (DevController:608) hotplugStatusCallback 2.
[2008-03-14 11:39:14 7800] DEBUG (XendDomainInfo:1913) XendDomainInfo.destroy: domid=6
[2008-03-14 11:39:14 7800] DEBUG (XendDomainInfo:1930) XendDomainInfo.destroyDomain(6)
[2008-03-14 11:39:14 7800] DEBUG (XendDomainInfo:1548) Destroying device model
[2008-03-14 11:39:14 7800] DEBUG (XendDomainInfo:1555) Releasing devices
[2008-03-14 11:39:14 7800] DEBUG (XendDomainInfo:1561) Removing vif/0
[2008-03-14 11:39:14 7800] DEBUG (XendDomainInfo:590) XendDomainInfo.destroyDevice: deviceClass = vif, device = vif/0
[2008-03-14 11:39:14 7800] DEBUG (XendDomai...

Read more...

Revision history for this message
Todd Deshane (deshantm) wrote :

try changing file: to tap:aio: (in your guest config file)

file: has been deprecated. I think this is a bug with tools.

Also, the other problem is the loop module not being loaded. Not sure if I would consider this a bug or not considering file: has been deprecated.

Could you report the bugs/fixed to appropriate packages once you resolve the issue? Thanks!

Revision history for this message
Maurício Magalhães (mauriciommagalhaes) wrote :

Ai todd,

Tanks work fine!!

But,
I do not start with the image, its stops here and not continue

############################################
[...]
[ 0.379126] cpuidle: using governor ladder
[ 0.379216] NET: Registered protocol family 1
[ 0.379246] Using IPI No-Shortcut mode
[ 0.379277] registered taskstats version 1
[ 0.379288] XENBUS: Device with no driver: device/vbd/2049
[ 0.379291] XENBUS: Device with no driver: device/vbd/2050
[ 0.379295] XENBUS: Device with no driver: device/vif/0
[ 0.379298] XENBUS: Device with no driver: device/console/0
[ 0.379317] Magic number: 1:252:3141
[ 0.379565] Freeing unused kernel memory: 208k freed
Loading, please wait...
Begin: Loading essential drivers... ...
[ 0.779240] fuse init (API version 7.9)
[ 0.826698] thermal: Unknown symbol acpi_processor_set_thermal_limit
Done.
Begin: Running /scripts/init-premount ...
Done.
Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Done.
Begin: Waiting for root file system... ...

################################################
Log xend.log

[2008-03-14 12:56:46 26637] DEBUG (DevController:150) Waiting for devices ioports.
[2008-03-14 12:56:46 26637] DEBUG (DevController:150) Waiting for devices tap.
[2008-03-14 12:56:46 26637] DEBUG (DevController:155) Waiting for 2049.
[2008-03-14 12:56:46 26637] DEBUG (DevController:594) hotplugStatusCallback /local/domain/0/backend/tap/10/2049/hotplug-status.
[2008-03-14 12:56:46 26637] DEBUG (DevController:608) hotplugStatusCallback 1.
[2008-03-14 12:56:46 26637] DEBUG (DevController:155) Waiting for 2050.
[2008-03-14 12:56:46 26637] DEBUG (DevController:594) hotplugStatusCallback /local/domain/0/backend/tap/10/2050/hotplug-status.
[2008-03-14 12:56:46 26637] DEBUG (DevController:608) hotplugStatusCallback 1.
[2008-03-14 12:56:46 26637] DEBUG (DevController:150) Waiting for devices vtpm.
[2008-03-14 12:56:46 26637] INFO (XendDomain:1165) Domain ubuntu (10) unpaused.

Revision history for this message
Maurício Magalhães (mauriciommagalhaes) wrote :

Sorry, continue
######################################
Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Done.
Begin: Waiting for root file system... ...
Done.
 Check root= bootarg cat /proc/cmdline
 or missing modules, devices: cat /proc/modules ls /dev
ALERT! /dev/sda1 does not exist. Dropping to a shell!

BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)
#####################################
WHAt is this

Revision history for this message
Marco Scholl (traxanos) wrote :

Its an configuration error. It not a bug.

Revision history for this message
Todd Deshane (deshantm) wrote :

Maurício: I think the last case you are running into is a different bug. I have the same problem.

I think it may be related to the following bug #1446331, but I am not sure yet - I haven't had a chance to test all the workarounds.

https://bugs.launchpad.net/ubuntu/+source/xen-3.1/+bug/144631

Marco: could you post your working configuration file? and lsmod etc.?

Revision history for this message
Maurício Magalhães (mauriciommagalhaes) wrote :

Todd

add to /etc/initramfs-tools/modules:
xenblk
blktap
blkbck

and launch update-initramfs -u

Work.

Revision history for this message
Todd Deshane (deshantm) wrote :

 Maurício: Thanks for the suggestion, but it still doesn't work for me :(

I added a comment to bug # 144631.

Further ideas/fixes should go there as this bug has been accurately marked fix released.

The root file system hang bug is the one that still (at least sometimes) exists.

https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/144631

Revision history for this message
Clemens Hupka (clemens) wrote :

I have some similar problems... Followed almost all of the instructions on this thread, on a hardy Alpha6 i386 (and amd64)

I have the vif figuring on the right bridge, interface figuring up in the domU, firewall rule (phys-in-thing) up, so all i've found seem to be allright, but not a single packet gets its way to the domU. Arp-packets emitted from the Hardy-domU gets onto the bridge, but the basic arp-reply (is-at) never gets to the domU.

Logs and traces are quite normal, no error, no anomalities...

Both dom0 & domU are running on hardy Alpha6.
Bridges are xen-3.2 (eth0 bridge with peth0 if)

Already did a deep research on the net, but no got no clue.

Anyone an idea? Could this be a kernel-issue???

Revision history for this message
Maurício Magalhães (mauriciommagalhaes) wrote :

Todd, No problema
My Problems

  => I can not access the network by domU! Already tried everything and nothing
  => Some distributions downloaded by xen-tools domU eg: gutsy, faisty freeze in /etc/ rc.local
  => The dapper in domU starts with this error below, but it works:
          [...]
          18 12:57:55 ecolx02 kernel: Can not find map file.
          Mar 18 12:57:55 ecolx02 kernel: No module loaded symbols - kernel modules not enabled.
          Mar 18 12:57:55 ecolx02 kernel:; this will be ignored in a future version kernel
          [...]
================================================== ==================
* The one that really started it was totally the centos0s5
    But in all cases above, I can not make the DOMU access the network.

    Any suggestions?

    Tanks

Revision history for this message
Todd Deshane (deshantm) wrote :

Clemens, Maurício: I don't have suggestions for you at this point as I may be running into a different problem.

You both might consider giving adequate information to the xen-users list and see if you get any suggestions.

http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users

I will try to report back if I find out anything that can help you.

Revision history for this message
xontero (xontero) wrote :

hello, sorry I'm a debian user but I have totally the same as https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/199533/comments/4

I'm using etch and xen-3.2-1 (backports). i tried to use modprobe netbk, but i have linux-image-2.6.18-6-xen-amd64 and it didnt work(FATAL: Module netbk not found.). I don't know what to do. I hope you could help me.

thanks.

Revision history for this message
Todd Deshane (deshantm) wrote :

xontero: this isn't the right place for such discussion.

I would suggest:
http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users

As a quick idea check in your /boot/config-<xen kernel> to see if that is built in for the debian kernel, it may not be built as a module in debian.

Revision history for this message
Andrew Shugg (ashugg) wrote :

Now it seems with the latest Xen kernel package (linux-image-2.6.24-16-xen) the xen modules are missing altogether. So with release 2.6.24-16.30 it is not possible to load the modules to work around this problem...?

sysadmin@dom0:/var/lib/dpkg/info$ grep /lib/modules linux-image-2.6.24-15-xen.list | cut -d/ -f5- > /tmp/linux-image-2.6.24-15-xen.list
sysadmin@dom0:/var/lib/dpkg/info$ grep /lib/modules linux-image-2.6.24-16-xen.list | cut -d/ -f5- > /tmp/linux-image-2.6.24-16-xen.list
sysadmin@dom0:/var/lib/dpkg/info$ cd /tmp
sysadmin@dom0:/tmp$ diff -u linux-image-2.6.24-1*
--- linux-image-2.6.24-15-xen.list 2008-04-12 21:45:47.170719689 +0800
+++ linux-image-2.6.24-16-xen.list 2008-04-12 21:45:55.179151282 +0800
@@ -1620,29 +1620,6 @@
 kernel/drivers/watchdog/w83977f_wdt.ko
 kernel/drivers/watchdog/wafer5823wdt.ko
 kernel/drivers/watchdog/wdt_pci.ko
-kernel/drivers/xen
-kernel/drivers/xen/blkback
-kernel/drivers/xen/blkback/blkbk.ko
-kernel/drivers/xen/blkfront
-kernel/drivers/xen/blkfront/xenblk.ko
-kernel/drivers/xen/blktap
-kernel/drivers/xen/blktap/blktap.ko
-kernel/drivers/xen/fbfront
-kernel/drivers/xen/fbfront/xenfb.ko
-kernel/drivers/xen/fbfront/xenkbd.ko
-kernel/drivers/xen/gntdev
-kernel/drivers/xen/gntdev/gntdev.ko
-kernel/drivers/xen/netback
-kernel/drivers/xen/netback/netbk.ko
-kernel/drivers/xen/netback/netloop.ko
-kernel/drivers/xen/netfront
-kernel/drivers/xen/netfront/xennet.ko
-kernel/drivers/xen/pciback
-kernel/drivers/xen/pciback/pciback.ko
-kernel/drivers/xen/tpmback
-kernel/drivers/xen/tpmback/tpmbk.ko
-kernel/drivers/xen/xenbus
-kernel/drivers/xen/xenbus/xenbus_be.ko
 kernel/fs
 kernel/fs/9p
 kernel/fs/9p/9p.ko
sysadmin@dom0:/tmp$ cd -

Revision history for this message
John Ferlito (johnf-inodes) wrote :

I've recently solved this problem. I upgraded from gutsy to hardy and everything seemed to work fine. Up until I removed the xen-utils-3.1 package. For some reason after the upgrade I had xen-utils-3.1 and xen-utils-3.2 installed.

The postrm script on the uninstall removes the following symlink

lrwxrwxrwx 1 root root 20 2008-04-28 11:58 /etc/udev/rules.d/z60_xen-backend.rules -> ../xen-backend.rules

Adding this link back seems to fix things.

Revision history for this message
gizmo (patrick-hieber) wrote :

On my clean Hardy the module netbk doesn't exist.
I'm running a SATA Softraid ...
my config is here:
http://de.pastebin.ca/1018166

xm create /etc/xen/exchange.conf
Using config file "/etc/xen/exchange.conf".
Error: Device 768 (vbd) could not be connected. losetup /dev/loop2 /srv/domus/exchange/windisk.img failed

after changing the file: to tap:aio:
i get
xm create /etc/xen/exchange.conf
Using config file "/etc/xen/exchange.conf".
Started domain xp

BUT a xm list lists only the dom0

Revision history for this message
Todd Deshane (deshantm) wrote :

gizmo: change your file: to tap:aio (for your disk entries and it will boot.

Also, you will probably run into the network bug see:
https://bugs.launchpad.net/ubuntu/+source/xen-3.2/+bug/204010
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/218126

The workarounds are described in detail:
http://howtoforge.com/ubuntu-8.04-server-install-xen-from-ubuntu-repositories
http://deshantm.livejournal.com/29959.html

Revision history for this message
dgammell (dbgsystems) wrote :

Hi guys

I know this won't work for everyone but I was getting the error this report was originally logged for and resolved it with the dash fix.
ie

remove the symlink /bin/sh -> dash
and create the symlink /bin/sh -> /bin/bash

I know this was mentioned above but I breezed over it so I think others might too.

Thanks

Darragh

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers