apport-gpu-error-intel.py keep crashing for 4-5 times on every reboot

Bug #997470 reported by lufuhao on 2012-05-10
436
This bug affects 100 people
Affects Status Importance Assigned to Milestone
xdiagnose (Ubuntu)
High
Unassigned
Precise
High
Bryce Harrington
Quantal
Undecided
Unassigned
Raring
High
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[Impact]
Apport is disabled in the release itself, so this hook should not be getting triggered at all. However, for some users it does. This wouldn't be a big deal, except it also gets triggered in cases where no GPU lockup was experienced (aka False GPU lockups - bug #983640), which gives poor user experience.

[Development Fix]
Since we want any and all GPU lockup reports in the development release, we leave things as they are, and focus on getting a targeted fix to just #983640.

[Stable Fix]
Since we don't intend for the GPU lockup hook to be run at all, whether or not Apport is enabled, in the stable release we forcefully disable the udev hook entirely.

If someone does specifically want this enabled, they'd need to also manually enable apport and so forth, in addition to re-enabling this udev rule. But I think it'd probably be easier for these people to just manually collect the gpu dump and dmesg directly, so don't expect anyone to need the script.

A duplicate udev rule calling the gpu lockup apport hook has been installed by xserver-xorg-video-intel. Since the hook has been moved to xdiagnose, this extra rule is redundant and should be dropped from the package. Indeed, I believe this second hook is the cause of the false gpu lockup reports (the hook in xdiagnose was already fixed to not file these.)

[Test Case]
The issues have been strange corner case problems that seem to be highly hardware-specific, and not synthetically reproducible.

1. To verify the apport hook has been properly changed, do:

 grep apport-gpu-error /lib/udev/rules.d/*

Expected Behavior: A single, commented-out line is printed
Broken Behavior: Multiple lines printed, or the line is not commented out.

2. On affected hardware, boot into a regular user session normally

Expected Behavior: No apport popups about GPU lockups
Broken Behavior: Apport pops up dialog about a GPU lockup bug, when nothing of the sort had actually happened.

[Regression Potential]
None really, as this is just disabling functionality we don't need enabled in the release.

The class of regressions to watch for with this would be udev-related problems, or odd apport behaviors. But I don't think anything untoward is remotely likely to happen.

[Original Report]
I installed ubuntu 12.04 recently on a DELL inspiron 1440 notebook. I think the chipset is GM45 something. I am quite fresh on linux operation system. I do not know how could I solve this problem. It seems not only me have this problem.

I install ubuntu 12.04 64bit and windows 7 64bit on my notebook. Every time I enter the ubuntu, I will notify me this problem for 4-5 times. It say "sorry, Ubuntu 12.04 has experienced an internal error". the detail are as follows:

ExecutablePath
/usr/share/apport/apport-gpu-error-intel.py
Package
xserver-xorg-xideo-intel2:2.17.0-1ubuntu4
ProblemType
Crash
Title
[gm45] GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00100000

ApportVerion
2.0.1-0ubuntu7
Architecture
amd64
.........

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xdiagnose 2.5
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CurrentDmesg: [ 139.311070] init: plymouth-stop pre-start process (3041) terminated with status 1
Date: Thu May 10 14:30:41 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:02cf]
   Subsystem: Dell Device [1028:02cf]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Inspiron 1440
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=dd6a65d6-fbb6-46ab-9fd5-1a1c48907d47 ro quiet splash vt.handoff=7
SourcePackage: xdiagnose
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/29/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0K138P
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd07/29/2009:svnDellInc.:pnInspiron1440:pvr:rvnDellInc.:rn0K138P:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1440
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

lufuhao (lufuhao-q) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdiagnose (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2012-05-24
Changed in xdiagnose (Ubuntu):
importance: Undecided → High
description: updated
summary: - apport-gpu-error-intel.py keep craching for 4-5 times on every reboot
+ apport-gpu-error-intel.py keep crashing for 4-5 times on every reboot
Bryce Harrington (bryce) wrote :

Guessing it's still seeing those false gpu lockups. Probably we should just disable the hook entirely for the release; I don't think it allows filing these bugs anyway.

George Stathopoulos (stathopog) wrote :

The bug started affected my Dell XPS 13 a 3-4 days ago (probably a package update?).
I have installed Ubuntu 12.04, 64bits.

I am relatively new to the community so I'd appreciate some more detailed explanation
on how it can be fixed. Since I am running solely on Ubuntu at the time, this is crucial. Thanks.

Frank Bruch (f-bruch) wrote :

Same for me. Ubuntu 12.04, 32bits. Lenovo Thinkpad T420s

  http://thinkwiki.de/T420s

  Intel HD 3000 Grafik
  Nvidia NVS 4200M, 1GB VRAM, Optimus

After todays update (first since ca. 2 weeks) I went in an endless loop with these dialogs, not only 4-5 of it.

One hint: The "Hardware" Widget shows "no proprietary drivers". I am not sure if I had an nvidea driver here, once.

lspci shows onboard only:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

System check shows, dito.:

OpenGL vendor string: Tungsten Graphics, Inc OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2 OpenGL version string: 3.0 Mesa 8.0.2 Not software rendered: yes Not blacklisted: yes GLX fbconfig: yes GLX texture from pixmap: yes GL npot or rect textures: yes Compiz supported: yes

More info?

muawijhe (muawijhe) wrote :

This bug also affects Macbook Pro 13'' with Intel Graphics Card HD3000.

Bloch (aidenoreilly) wrote :

Also affects my Optiplex-755

ExecutablePath
/usr/share/apport/apport-gpu-error-intel.py
Package
xserver-xorg-video-intel 2:2.17.0-1ubuntu4
Problem type
Crash
Title
[q35]GPU lockup render.IPEHR:0x02000011

Bryce Harrington (bryce) on 2012-06-15
description: updated
Changed in xdiagnose (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Bryce Harrington (bryce)
Changed in xdiagnose (Ubuntu):
status: Confirmed → Won't Fix
biju (biju-cbs) wrote :

This bug affects my Dell Inspiron with Intel Pentium processor.

https://bugs.launchpad.net/ubuntu/+source/xdiagnose/+bug/995525

Hello lufuhao, or anyone else affected,

Accepted xdiagnose into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xdiagnose (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Jon Eliot (jon-stromme) wrote :

Upgraded to version 2.5.1 of xdiagnose from precise-proposed (was installed as version 2.5)

Can't see that you have prescribed just what to do with it, but installing and ticking off the debug options did not change the behaviour.

NB - the error at my laptop is quite similar to this, but intermittent on boot, it only occurs about half of the time, and not necessarily right away. It is very frequent on resume from suspend, and almost certain to occur on resume from suspend with 2 X sessions active. There also seems to be a genuine gpu or other X related bug sometimes, which messes up the screen and eventually brings down compiz, and it is hard to tell which is which.

The Xorg logs from before the upgrade of xdiagnose and the debug options have "hung GPU" entries, the present Xorg log does not. But the pop-up panel symptom was definitely there anyway.

root@byttevora:~# ls -l /var/log/X*
-rw-r--r-- 1 root root 35511 Jun 19 09:21 /var/log/Xorg.0.log
-rw-r--r-- 1 root root 35333 Jun 19 09:19 /var/log/Xorg.0.log.old
-rw-r--r-- 1 root root 35819 Jun 19 07:01 /var/log/Xorg.1.log
-rw-r--r-- 1 root root 36557 Jun 18 07:36 /var/log/Xorg.1.log.old
-rw-r--r-- 1 root root 40082 Jun 18 19:11 /var/log/Xorg.2.log
-rw-r--r-- 1 root root 52957 Jun 13 14:54 /var/log/Xorg.2.log.old
root@byttevora:~# grep '(EE)' /var/log/X*
/var/log/Xorg.0.log: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.0.log.old: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.1.log: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.1.log:[ 17290.426] (EE) intel(0): Detected a hung GPU, disabling acceleration.
/var/log/Xorg.1.log:[ 17290.426] (EE) intel(0): When reporting this, please include i915_error_state from debugfs and the full dmesg.
/var/log/Xorg.1.log.old: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.2.log: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
/var/log/Xorg.2.log:[ 34773.156] (EE) intel(0): Detected a hung GPU, disabling acceleration.
/var/log/Xorg.2.log:[ 34773.213] (EE) intel(0): When reporting this, please include i915_error_state from debugfs and the full dmesg.
/var/log/Xorg.2.log.old: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
root@byttevora:~#

Will now try the workarounds "disable bootloader graphics" and "disable VESA framebuffer driver".

The PAT memory workaround seems to be targeted on proprietary drivers, while this system has an Intel driver which AFAIK is not proprietary. Will try it later anyway, if the others do not remove the symptoms.

Jon Eliot (jon-stromme) wrote :

version 2.5.1 of xdiagnose from precise-proposed, all debug options ticked off, workarounds "disable bootloader graphics" and "disable VESA framebuffer driver" ticked off, rebooted.
Flawless suspend/resume with 2 X sessions active. The graphics (Intel 915 chip in Lenovo X201s laptop) also seem more controlled and responsive, but that might just be me being euphoric. This workaround seems to work! Thanks a million.
Will report if - heaven forbid - the symptoms reappear.

Bryce Harrington (bryce) wrote :

Jon, thanks for confirming the fix.

Upgrading the package and rebooting once or twice should be all you need to do; there's nothing needing changed in the GUI, it's just disabling a udev rule, which will take effect on a subsequent boot.

Bryce Harrington (bryce) on 2012-06-19
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 2.5.1

---------------
xdiagnose (2.5.1) precise-proposed; urgency=low

  * xdiagnose.udev: Disable GPU apport hook from being triggered by udev.
    This should only be enabled during the development period. Apport is
    disabled after release, but it appears the hook still gets triggered
    under certain circumstances.
    (LP: #1009971, #997470)
  * apport/source_xorg.py: Link to all technical support options, not just
    to Ask Ubuntu. Reword recommendation to explain why technical support
    should be used first. Add a 'referred-by-support' tag so we can give
    those bugs priority attention. Provide an option to just file the bug.
    (LP: #991602)
 -- Bryce Harrington <email address hidden> Fri, 15 Jun 2012 11:39:10 -0700

Changed in xdiagnose (Ubuntu Precise):
status: Fix Committed → Fix Released
biju (biju-cbs) wrote :

Since i am not so tech savy.. Could you please suggest me the steps to fix this bug.

Hi,

I've Ubuntu 12.04 with the last update on my MacBook White 4.1 and I've got this issue when I boot.
I checkded and it's well the xdiagnose 2.5.1 is installed on my laptop.

Should I do anything to correct this issue?

Thanks

Fuhao Lu (lufuhao) wrote :

update the Xdiagnose has no effect. The system still keep crashing.

Help!

Yannick (ybarbel) wrote :

Same here. Have Xdiagnose 2.5.2 installed on my system, but bug is still there.

Maurits Lamers (mauritslamers) wrote :

Xdiagnose 2.5.2 installed, but the bug is still here. (Macbook 2,1 13")

Jeff (texaggies89) wrote :

xdiagnose 2.5.2 installed in 12.04; hook still triggered, problem not resolved. reinstalled 12.04 as a possible solution, no joy. is there a way to disable Apport? If so, is it ok to disable Apport as a solution? In short, this fix doesn't seem to "fix" anything related to this issue on my computer, and I don't want to submit a new bug report since this identical problem has been already identified. No sure how to proceed since the "fix" did not work.

Jeff (texaggies89) wrote :

disabled all checkboxes in xdiagnose as recommended above (note: only box checked by default was auto-reporting). rebooted. no joy. opened xdiagnose GUI and auto-reporting was "re"-enabled; this option must be a persistent option in xdiagnose as I could not "apply" or save and survive a reboot. effected computer = Dell Dimension E510.

Of note, I have this same .iso installed on a 1) Dell E6400 laptop as a bootable partition, 2) virtually installed with Fusion in a Macbook Pro, 3) virtually installed with Virtual Box in Windows v7 Bootcamp on a Macbook Pro - and this bug is not presentwithin any of these installs... possibly a hardware specific bug for the Dimension E510?

Lastly, if I attempt to report the bug via the pop-up error window, the error becomes a loop, lasting at least 4 - 5 times as already mentioned. But if I "cancel", the error may only appear one more time, select cancel again and the error window does not reappear... other than being annoying, I see no performance issues.

oldmankit (oldmankit) wrote :

I've just read through all the comments and can't see that there's a fix. If it's there but I missed it, please point it out.

I've been using Precise since it was released and have been hoping that this bug would be fixed through an update. No luck. I now am actively looking, but it seems like there is not fix. This obviously affects a lot of people. What can we do to speed a fix?

Bryce Harrington (bryce) wrote :

apport-gpu-error-intel.py is just a script that gets run when udev detects a GPU fault. I am not able to reproduce any of the problems people are reporting, but probably that's because I do not get GPU faults on my hardware.

The fix I uploaded is to stop installing the udev rule that triggers running /usr/share/apport/apport-gpu-error-intel.py

See `man udevadm` for tips on examining your udev rules. I can't find on my systems anywhere that this script is being hooked in. But perhaps in certain corner cases it's still present. You can use udevadm to identify where it's hooked in. If it shows up there, let me know what you find, and that may give me more clues on how to fix this better.

If you don't care to have a proper fix, and just want to eliminate the behavior on your system locally, just delete /usr/share/apport/apport-gpu-error-intel.py and it should stop bothering you (at least until your system updates and re-installs that file).

Thank you,
I will certainly do this if and when the problem reappears. Now on
12.10, and things are slightly different.

No problem with boot, but serious trouble that is superficially similar
to the boot problems on resume from suspend with 2 X sessions active.
The same popups, but now they mean business :-).

On 2012-10-26 05:48, Bryce Harrington wrote:
> apport-gpu-error-intel.py is just a script that gets run when udev
> detects a GPU fault. I am not able to reproduce any of the problems
> people are reporting, but probably that's because I do not get GPU
> faults on my hardware.
>
> The fix I uploaded is to stop installing the udev rule that triggers
> running /usr/share/apport/apport-gpu-error-intel.py
>
> See `man udevadm` for tips on examining your udev rules. I can't find
> on my systems anywhere that this script is being hooked in. But perhaps
> in certain corner cases it's still present. You can use udevadm to
> identify where it's hooked in. If it shows up there, let me know what
> you find, and that may give me more clues on how to fix this better.
>
> If you don't care to have a proper fix, and just want to eliminate the
> behavior on your system locally, just delete /usr/share/apport/apport-
> gpu-error-intel.py and it should stop bothering you (at least until your
> system updates and re-installs that file).
>

Tom (tom-lorinthe) wrote :

Getting this on 12.04 after I added an extra xrandr resolution for external monitor in lightdm.

For now I tried to switch off sudo xdiagnose and then disable automatic crash reporting... see if it will stop nagging with this bug...

Pierre Rudloff (rudloff) wrote :

This keeps happening on Quantal...

Otto Kekäläinen (otto) wrote :

I have an Dell Latitude E5420 which was sold pre-installed with Ubuntu, and this bug affects it too.

So far it seems that the effective remedy is removing Apport:
 $ sudo apt-get remove apport apport-gtk apport-symptoms python-apport

This solution is fine for me, since Apport anyways only wastes my time. It wants to report the same issues over and over, and I never get any feedback on the bug number or what happened to the issue, and I can't find the reports anywhere, so I assume the reporting system is broken and my reports don't actually get send anywhere or at least never get processed.

It would be nice to see a Canonical blog post telling how much help Apport-initiated reports have had in finding and solving bugs, if any at all.

Bryce Harrington (bryce) wrote :

Just discovered that there is a second udev rule being installed by xserver-xorg-video-intel. That one is not commented out, and must be why some people are still seeing the bug report popups even with xdiagnose 3.4.4 installed.

In fact, that rule is the older version that acts on ERROR rather than RESET. We switched to RESET as it would not trigger on false gpu lockups, so this probably also explains why false gpu lockups have still been getting reports!

The udev rule in xserver-xorg-video-intel should be dropped. This change should also be SRU'd to precise and quantal.

Bryce Harrington (bryce) on 2013-04-11
description: updated
Changed in xdiagnose (Ubuntu Quantal):
status: New → Fix Released

Hello lufuhao, or anyone else affected,

Accepted xserver-xorg-video-intel into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2.20.9-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Quantal):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello lufuhao, or anyone else affected,

Accepted xserver-xorg-video-intel into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.17.0-1ubuntu4.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Tomas Lycken (tlycken) on 2013-04-12
Changed in xserver-xorg-video-intel (Ubuntu Raring):
status: Confirmed → New
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.21.6-0ubuntu3

---------------
xserver-xorg-video-intel (2:2.21.6-0ubuntu3) raring-proposed; urgency=low

  * rules: Drop --enable-valgrind for now (causes FTBS).
 -- Bryce Harrington <email address hidden> Mon, 15 Apr 2013 10:33:24 -0700

Changed in xserver-xorg-video-intel (Ubuntu Raring):
status: Confirmed → Fix Released

We have test packages for quantal and precise but no package for lts-quantal as yet?

Bryce Harrington (bryce) wrote :

Verified

== Precise-proposed ==

Linux lynmouth.bryceharrington.org 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Before:

lynmouth+12.10:~$ grep apport-gpu-error /lib/udev/rules.d/*
/lib/udev/rules.d/40-xdiagnose.rules:#SUBSYSTEM=="drm", ACTION=="change", ENV{ERROR}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"
/lib/udev/rules.d/40-xserver-xorg-video-intel.rules:SUBSYSTEM=="drm", ACTION=="change", ENV{ERROR}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"

After:

lynmouth+12.10:~$ grep apport-gpu-error /lib/udev/rules.d/*
/lib/udev/rules.d/40-xdiagnose.rules:#SUBSYSTEM=="drm", ACTION=="change", ENV{ERROR}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"

== oneiric-proposed ==

Linux lynmouth.bryceharrington.org 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Before:

lynmouth+12.10:~$ grep apport-gpu-error /lib/udev/rules.d/*
/lib/udev/rules.d/40-xdiagnose.rules:# SUBSYSTEM=="drm", ACTION=="change", ENV{RESET}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"
/lib/udev/rules.d/40-xserver-xorg-video-intel.rules:SUBSYSTEM=="drm", ACTION=="change", ENV{ERROR}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"

After:

lynmouth+12.10:~$ grep apport-gpu-error /lib/udev/rules.d/*
/lib/udev/rules.d/40-xdiagnose.rules:# SUBSYSTEM=="drm", ACTION=="change", ENV{RESET}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.17.0-1ubuntu4.4

---------------
xserver-xorg-video-intel (2:2.17.0-1ubuntu4.4) precise-proposed; urgency=low

  * debian/xserver-xorg-video-intel.udev: Drop udev rule for gpu lockup
    apport hook. This hook is now provided by the xdiagnose package.
    (LP: #997470)
 -- Bryce Harrington <email address hidden> Thu, 11 Apr 2013 13:46:45 -0700

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Set back to verification needed for quantal as it doesn't seem to have been verified there.

tags: added: verification-needed
removed: verification-done
Bryce Harrington (bryce) wrote :

Actually I did test against quantal in #35, I just typo'd badly and called it oneiric. I apparently fail at the alphabet.

== QUANTAL-proposed ==

Linux lynmouth.bryceharrington.org 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Before:

lynmouth+12.10:~$ grep apport-gpu-error /lib/udev/rules.d/*
/lib/udev/rules.d/40-xdiagnose.rules:# SUBSYSTEM=="drm", ACTION=="change", ENV{RESET}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"
/lib/udev/rules.d/40-xserver-xorg-video-intel.rules:SUBSYSTEM=="drm", ACTION=="change", ENV{ERROR}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"

After:

lynmouth+12.10:~$ grep apport-gpu-error /lib/udev/rules.d/*
/lib/udev/rules.d/40-xdiagnose.rules:# SUBSYSTEM=="drm", ACTION=="change", ENV{RESET}=="1", RUN+="/usr/share/apport/apport-gpu-error-intel.py"

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.20.9-0ubuntu2.1

---------------
xserver-xorg-video-intel (2:2.20.9-0ubuntu2.1) quantal-proposed; urgency=low

  * debian/xserver-xorg-video-intel.udev: Drop udev rule for gpu lockup
    apport hook. This hook is now provided by the xdiagnose package.
    (LP: #997470)
 -- Bryce Harrington <email address hidden> Thu, 11 Apr 2013 13:24:19 -0700

Changed in xserver-xorg-video-intel (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers