Ubuntu

xdg-user-dirs translations not used

Reported by Timo Jyrinki on 2007-07-01
10
Affects Status Importance Assigned to Milestone
xdg-user-dirs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xdg-user-dirs

Changing description, the translation files are there, but they translations aren't used. The folders and menu entries are untranslated.

(description was:
Translations for xdg-user-dirs are not available in the binary package or the latest language packs (20070625). They are included in the xdg-user-dirs source package.)

confirming.

My locale is fr_CA and I have folder names in English popping up everywhere in my home. I also tested with fr_UTF8 on a fresh test account.

Changed in xdg-user-dirs:
status: New → Confirmed

I can confirm this as well!

I see that a new FR language pack was uploaded 3 days ago. Today, I ran this command:

xdg-user-dirs-update

and the ~/.config/user-dirs.dirs file was properly generated with translated paths. The folders, however, were not created, and I wonder why.

I have no idea if this will work out of the box, so I don't know if this is really fixed.

oh, nevermind, the folders *were* created, I just had to refresh nautilus with ctrl+R.

The thing is, however, that xdg-user-dirs-update-gtk doesn't work, so I still don't know if all this would work out of the box.

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

I have the folders, and running xdg-user-dirs-update I can get .config/user-dirs.dirs to update, but it doesn't use the translations from xdg-user-dirs.mo that is under locale-langpack/FI directory. xdg-users-dirs-gtk-update does update ~/.gtk-bookmarks, but doesn't user translations either.

Timo Jyrinki (timo-jyrinki) wrote :

I got more information from Sebastian Bacher. New folders shouldn't be created for existing accounts, ie. feisty -> gutsy upgraders. I guess my current gutsy installation was done before the translations were included, so the folders were created in English.

There seems to be a bug, though, since xdg-user-dirs-update and xdg-user-dirs-gtk-update does not seem to work at least in my locale, and for Jeff's too. They update the .config/user-dirs.dirs and .gtk-bookmarks when called correctly, but keep the English strings.

/usr/share/locale-langpack/fi/LC_MESSAGES/xdg-user-dirs.mo contains correct Finnish strings. The locale I'm using is fi_FI.UTF-8. The locale-langpack directory says "fi" as stated, and .config/user-dirs.locale reads fi_FI. I wonder if there's something wrong with mapping those fi/fi_FI/fi_FI.UTF-8 simply.

Timo Jyrinki (timo-jyrinki) wrote :

I used fi, fi_FI and fi_FI.UTF-8 and ran xdg-user-dirs-update, but always with the same results, ie. a file is touched but English kept. I also copied xdg-user-dirs.mo to /usr/share/locale/fi/LC_MESSAGES instead of locale-langpack, but didn't help either. Finally, I deleted the .config/user-dirs.dirs and ran xdg-user-dirs-update - it re-created the file but with only one entry ie. XDG_DIR_DIR="$HOME/". Also 0.9 version from upstream didn't help.

I don't have an idea what's wrong with either my usage (should it be used like xdg-user-dirs-update --set DIR /home/user or something else?) or xdg-user-dirs itself.

Timo Jyrinki (timo-jyrinki) wrote :

As an update, I now did a fresh install of Ubuntu daily-live, in Finnish language. However, I did not have network connection enabled during installation (something very common since it's not encouraged anywere in the installer), so I first did not have the Finnish language packs.

The xdg folders were created in English, and even after installing the language support and logging out and in, the folders are still in English. I think noticing the translations and the user's language is part of what xdg-dirs-update xdg-dirs-update-gtk should do automatically, since in many cases the language files are downloaded only after installation.

For a new user, the folders are created in the correct language now.

Timo Jyrinki (timo-jyrinki) wrote :

I'd suggest having all xdg-user-dirs translations on the CD, like is done with installer and apparently a few generic GTK strings. Not a big loss storage-wise, but might be the only way to create users properly in every case (ie. when network is not available at install time, most laptops for example if the user does not know to connect to an access point). Pitti and Carlos probably know more if you think it's a good idea.

Timo Jyrinki (timo-jyrinki) wrote :

Setting this to fixed since the current problem is quite far from the original missing translations bug. New bug has been filed: bug 147657.

Changed in xdg-user-dirs:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers