System lock on upgrade or new install

Bug #50041 reported by Walter Banks on 2006-06-16
148
This bug affects 6 people
Affects Status Importance Assigned to Milestone
wvdial (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: wvdial

System Dell Optiplex GX400 hangs when attempting to load pkg wvdial and does so with download upgrade from breezy or iso image .386. Only system lock with no additional info. Repeated failures with installation associated with wvdial.

Simon Law (sfllaw) wrote :

Hello Walter,

Which version of Ubuntu are you running? Which version of WvDial
are you trying to install?

Changed in wvdial:
status: Unconfirmed → Needs Info
Matthias Urlichs (smurf) wrote :

Saw the same thing just now. wvdialconf was trying to figure out what's behind my /dev/ttyS2.

What actually is behind that device is a Bluetooth adapter, which confused wvdialconf. So (according to strace) it did a bunch of strange things with that device, and then busy-waited forever in a select() loop.

This was a new edgy install.

It seems that wvdialconf needs a hard timeout, preferably in the shell script that calls it.

Matthias Urlichs (smurf) on 2006-10-19
Changed in wvdial:
status: Needs Info → Confirmed
Stefano Rivera (stefanor) wrote :

I got this when updating to 1.56-1.1ubuntu2 (feisty), because I'd been using my IRDA earlier, and left the ircom-tty module loaded.

A agree with Matthias - it seems that wvdialconf needs timeouts.

amadeov (amadeo3d) wrote :

I'm currently upgrading from Edgy to Feisty and my machine has been sitting on the following step of the dist-upgrade:

Setting up a bunch of packages ......
...
Setting up ubuntu-sounds (0.6) ...
Setting up wvdial (1.56-1.1ubuntu2) ...

It's been sitting there at this step for about 45 minutes. I can open other programs (slowly), but I don't know if I should just break the process and hope that the upgrade is completed or not... and then, I have no idea how this will affect my computer down the road.

I ran "sudo lsb_release -a" and received the message that the Release had been upgraded to 7.04 and the Codename was upgraded to Feisty, so I'm hoping everything's okay.

amadeov (amadeo3d) wrote :

OK... I broke out of the process of wvdial setting up and got the following message:

dpkg: error processing wvdial (--configure):
 subprocess post-installation script killed by signal (Interrupt)

It then continued to setting up xfonts-base and other packages...

However, now there seem to be more problems. Later on down:

dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on wvdial; however:
  Package wvdial is not configured yet.
dkpg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured

I have a feeling that that can't be good.

Hi,

amadeov:
> Setting up wvdial (1.56-1.1ubuntu2) ...
>
wvdial tries to talk to your serial ports, trying to find modems.

Long-standing bug, I'm afraid; I reported the same thing a year ago.

--
Matthias Urlichs | {M:U} IT Design @ m-u-it.de | <email address hidden>
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
And the child had a permanently runny nose and ought to be provided with a
handkerchief or, failing that, a cork.
  -- Terry Pratchett (Lords and Ladies)

Bharat Rajagopalan (mendred) wrote :

Theres a quick hack to make it bypass modem detection at install...

after the first time u install it using apt ..when it hangs at Setting up wvdial.. press CTRL-C

Then edit your /etc/wvdial.conf

[Dialer Defaults]
Phone =
Username =
Password =
New PPPD = yes
modem

basically just add the line modem at the end..

then do a
sudo dpkg --reconfigure -a

this should work..and give the fullowing message..

mendred@dantooine:~$ sudo dpkg --configure -a
Setting up wvdial (1.56-1.1ubuntu2) ...

/etc/wvdial.conf already exists -- not probing your modem.
  (Run wvdialconf manually if you want to re-detect your modem.)

Setting up kubuntu-desktop (1.32ubuntu1) ...

I figured this workaround after examining the /var/lib/dpkg/info/wvdial.postinst file that is generated..it does a grep -qui ^modem on the wvdial file and if it finds modem it does not try detection.

Its a lousy workaround but if u are like me and dont use wvdial, then this will atleast ensure that package manager is sane..

u can remove the last line i.e. "modem" after the dpkg run. Hopefully, this will be fixed in later versions..

-Bharat

bcrowell (launchpadcrowell07) wrote :

Two years later, and this bug is still present in hardy heron. I had to use the procedure at http://ubuntuforums.org/archive/index.php/t-254688.html to work around it.

Changed in wvdial:
importance: Undecided → High
status: Confirmed → Triaged
psylem (subnetjet) wrote :

Killing the process "wvdialconf /etc/wvdial.conf" worked for me, but just to be sure I also edited wvdial.conf added "modem" to the bottom and ran "wvdialconf /etc/wvdial.conf" again.

iamnelson (nelsoncarrerojr) wrote :

I don't know if this is the correct place, but while upgrading from 10.04 to 10.10 Setting up wvdial also froze my computer. I couldn't kill the process at all and after 45 minutes I pulled the plug. Had some serious errors on reboot a few times but eventually the PC started up. Was sluggish at first, hopped into terminal and changed the wvdial.conf to contain the "modem" at the bottom. Then proceeded to "sudo dpkg --configure -a and it seems to be starting off where the upgrade left off.

It seems to be setting up packages just fine now. Thanks.

Endolith (endolith) wrote :

Same problem upgrading from 11.04 to 11.10. I have a random number generator connected to /dev/ttyUSB0. :) Is that hanging it? That really shouldn't happen.

I killed wvdialconf and the setup continued.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers