package update-manager 1:0.87.16 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Bug #217368 reported by Luciano Panepucci on 2008-04-14
This bug report is a duplicate of:  Bug #50041: System lock on upgrade or new install. Edit Remove
6
Affects Status Importance Assigned to Milestone
wvdial (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I got the following terminal output on the upgrade distribution window:
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24-16-generic
Errors were encountered while processing:
 wvdial
Traceback (most recent call last):
  File "logging/__init__.py", line 753, in emit
    self.flush()
  File "logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "logging/__init__.py", line 753, in emit
    self.flush()
  File "logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "logging/__init__.py", line 753, in emit
    self.flush()
  File "logging/__init__.py", line 731, in flush
    self.stream.flush()
IOError: [Errno 9] Bad file descriptor
hardy: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
Setting up wvdial (1.60.1) ...

1. upgrading from gutsy to hardy. Now, even the upgrade proccess bein paused by the bug the About Ubuntu tells me I have installed: Ubuntu 8.04

2. $ apt-cache policy update-manager
update-manager:
  Installed: 1:0.87.16
  Candidate: 1:0.87.16
  Version table:
 *** 1:0.87.16 0
        500 http://br.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

(blind guess: might it br that the .br repositories are outdated?)

3. I expected the process would work or try alternate repositories (if that was the problem)...
4. The process has paused. Now I will hit ctrl+C and the upgrade window closed. will restart to see what happens next... my firefox has allready been upgraded to 3beta...

ProblemType: Package
Architecture: i386
Date: Mon Apr 14 14:43:27 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Package: update-manager 1:0.87.16
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.16 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.22-14-generic i686

Luciano Panepucci (lpanebr) wrote :

Luciano,

Could you please also attach the log files from /var/log/dist-upgrade so we can trace what happened before the crash

Changed in update-manager:
status: New → Incomplete
Luciano Panepucci (lpanebr) wrote :

Hello Richard,

After the distribution upgrade failed I restarted and there was a notification of the problem and I clicked it. It then tried to continue the upgrade but stopped at the same point. One detail I did not explain in detail is that both the first and the second time what happened was that the progress bar stopped and I waited a really long time before I was sure it was a bug. THEN with the process bar stopped I clicked on the terminal of the dist upgrade dialog and hit CRTL+C. After the CRTL+C the dist-upgrade asked me if I wanted to report this bug to the developers and thats how I got here.

ok. I have attached the files of /var/log/dist-upgrade
hope it helps!

Thanks for providing the logs. As indicated by the traceback update-manager seems to have a problem processing the wvdial package

Changed in update-manager:
status: Incomplete → Triaged
Michael Vogt (mvo) wrote :

Here is what caused the error:

2008-04-14 14:33:35,936 ERROR got an error from dpkg for pkg: 'wvdial': 'subprocess post-installation script killed by signal (Interrupt)
...
Setting up wvdial (1.60.1) ...
dpkg: error processing wvdial (--configure):
 subprocess post-installation script killed by signal (Interrupt)

Did you press ctrl-c while the upgrade was running? Did it hang in the wvdial postinst?

Luciano Panepucci (lpanebr) wrote :

HEllo,

Yes, as I described in my last comment. After waiting a really long time (many hours) with the progress bar still stopped I pressed crtl+c. Only then the process actually stoped and prompted me to report a bug.

Just to make myselt clear I mean I really waited many hours before pressing crtl-c.
I tryed to finish the upgrede process agains but again had the exact same issue.

If perhaps there was some kind of "watcher" program that I could iniciate before restarting the upgrade I could try it. Just give the orientation.

thanks

Luciano Panepucci (lpanebr) wrote :

Sorry if this question is not placed in the proper place but since it regrds updrading..
I have other computer (amd64) with Gutsy 64bits installed and I am not shure whether I should try the automatic upgrade or download the ISO and install from scratch...
Do you have any sugestions?
again sorry if the question is misplaced and feel free to remove it from this comments if you wish.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers