Please install and use the pulseaudio output plugin by default

Bug #402018 reported by Julian Lam on 2009-07-21
148
This bug affects 26 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: vlc

Upon upgrading to Karmic Alpha 2, VLC was also upgraded from 0.9.9 to 1.0.0-1ubuntu1.

I can no longer play videos on my laptop properly, because the audio skips almost every second, interrupting the audio and making the viewing experience almost unbearable.

I tried to kill pulseaudio, but in my limited experience, Ubuntu just restarted pulseaudio almost immediately after killing it. "pulseaudio --kill" did the same thing.

Didn't have this problem in Jaunty - does anyone have any ideas as to what I might try? It seems like a regression, although I haven't narrowed it down to which component is failing.

I've included my graphics card details, in case they may be necessary for debugging (Intel 82852/855GM on a Dell Inspiron 700m)

ProblemType: Bug
Architecture: i386
Date: Mon Jul 20 22:23:59 2009
DistroRelease: Ubuntu 9.10
Package: vlc 1.0.0-1ubuntu1
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SourcePackage: vlc
Uname: Linux 2.6.31-3-generic i686

Related branches

Julian Lam (julian-lam) wrote :
El Toozero (eltoozero) wrote :

I can confirm this bug is affecting Karmic Koala alpha 4.

When I bring up the "media information" while playing in VLC 1.0.1 I notice the audio skips out as the "Lost buffers" is incrementing, audio playback works fine using gstreamer plugin in Rythmbox.

I do not have a swap file but I have plenty of free memory:

milkman@leslie:~$ free -m
             total used free shared buffers cached
Mem: 2005 695 1309 0 37 396
-/+ buffers/cache: 262 1743
Swap: 0 0 0

Please let me know if there is any testing I can help with.

Daniel T Chen (crimsun) wrote :

Which output is VLC configured to use, e.g., ALSA, PulseAudio?

Changed in vlc (Ubuntu):
status: New → Incomplete
El Toozero (eltoozero) wrote :

I do not have an entry to explicitly select pulseaudio, I see "Default", and "ALSA Audio Output", and I get the same behavior in both modes.

I tested by setting the option, closing vlc, relaunching, and opening both a .m4a and .mp3 files.

Can you try the version of libasound2 in the ~ubuntu-audio-dev PPA?

On Aug 25, 2009 11:45 PM, "El Toozero" <email address hidden> wrote:

I do not have an entry to explicitly select pulseaudio, I see "Default",
and "ALSA Audio Output", and I get the same behavior in both modes.

I tested by setting the option, closing vlc, relaunching, and opening
both a .m4a and .mp3 files.

-- [i855] Choppy audio playback https://bugs.launchpad.net/bugs/402018 You
received this bug notif...

I have added the PPA, but as of this evening a new version of libasound2 was just pushed down. I still have the issue and still do not have a pulseaudio option in vlc.

$ sudo apt-get install libasound2
Reading package lists... Done
Building dependency tree
Reading state information... Done
libasound2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.

$ apt-cache policy vlc
vlc:
  Installed: 1.0.1-1ubuntu1
  Candidate: 1.0.1-1ubuntu1
  Version table:
 *** 1.0.1-1ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

The choppiness I experience seems to be happening at the beginning of the file, not sure if it's a buffering issue or what, the number of Lost buffers is not consistent other than some are lost on each played file, usually near the beginning.

El Toozero (eltoozero) wrote :

I later realized I could force the version through synaptic, I hope this is what you wanted me to do, it still did not alleviate the issue.

$ apt-cache policy libasound2
libasound2:
  Installed: 1.0.20-3ubuntu4~ubuntuaudiodev1
  Candidate: 1.0.20-3ubuntu4
  Version table:
     1.0.20-3ubuntu4 0
        500 http://us.archive.ubuntu.com karmic/main Packages
 *** 1.0.20-3ubuntu4~ubuntuaudiodev1 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status

Since it did not resolve the issue and the major/minor versions match, can I remove the forcing of the version? I still do not have Pulseaudio in the list of available outputs in vlc preferences.

Is vlc-plugin-pulse installed?

On Aug 26, 2009 3:20 AM, "El Toozero" <email address hidden> wrote:

I later realized I could force the version through synaptic, I hope this
is what you wanted me to do, it still did not alleviate the issue.

$ apt-cache policy libasound2
libasound2:
 Installed: 1.0.20-3ubuntu4~ubuntuaudiodev1
 Candidate: 1.0.20-3ubuntu4
 Version table:
    1.0.20-3ubuntu4 0
       500 http://us.archive.ubuntu.com karmic/main Packages
 *** 1.0.20-3ubuntu4~ubuntuaudiodev1 0
       500 http://ppa.launchpad.net karmic/main Packages

100 /var/lib/dpkg/status
Since it did not resolve the issue and the major/minor versions match,
can I remove the forcing of the version? I still do not have Pulseaudio
in the list of available outputs in vlc preferences.

-- [i855] Choppy audio playback https://bugs.launchpad.net/bugs/402018 You
received this bug notif...

I've been having this problem as well:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
VLC 1.0.1-1ubuntu1

Setting VLC to use the Pulse output module rather than the default (which I'm fairly certain was alsa) helped a bit when playing audio files, but videos seldom play flawlessly. Strangely, pausing, seeking, and hitting play several times will often eventually get the file playing correctly and it will usually continue to play correctly. It's very inconvenient, however, and definitely a regression from Jaunty (or possibly from an earlier karmic alpha, but I've only been testing since alpha4).

El Toozero (eltoozero) wrote :

I have installed vlc-pulse-plugin and the situation has vastly improved however buffers are still lost and this definitely wasn't happening in Jaunty.

Stuart Marks (malnilion) wrote :

Something I've discovered is that rebooting seems to help the problem (i.e. the problem seems to develop over a period of time) and also something strange...once the audio begins to start skipping horribly with the Pulse plugin, I change back to the alsa plugin and that seems to make things better. I would like to reiterate others' observation that video/audio works perfectly in other applications such as Rythmbox, Movie Player, Xine, mplayer.

El Toozero (eltoozero) on 2009-09-03
Changed in vlc (Ubuntu):
status: Incomplete → New
Loïc Martin (loic-martin3) wrote :

I can confirm this with an Intel ICH10 controler:
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

Jaunty started to show choppy audio during the summer (can't remember exactly what time), but it's still not to the levels of choppiness Karmic achieves.

The problem doesn't seem to appear with Totem (or very rarely), however Totem doesn't achieve a smooth display on a Q9450 (movies display as smooth as if they were about 10FPS). SMPlayer and MPlayer don't suffer from that problem (except at some odd times, usually when you really want to see a movie and both VLC and Totem have choppy audio), but in Karmic they often start stopping after 1 second of normal play (sound&video OK) when you've skipped to any point in the video, and won't be able to display more than 1 second of video each time you skip to another point in the video, till you restart the application and make a point not to navigate in the video anymore.

CPU utilization is just fine, no more than 25% on each core with VLC, with no spikes, either in Window mode or in fullscreen. Drivers are Nvidia 185.

DJ_DEF (dj-def) wrote :

same things with:
intel ich7 (mb asus p5ld2-x/1333)
nvidia 190.36

things are better if I select the pulseaudio output but anyway (following the statistics with ctrl+i) it looses the first 3 blocks at the start of the song/video

I'm having this problem in the Karmic beta. Upgraded from Jaunty using dist upgrade.

Generally using the command alsa force-reload will fix it temporarily, however I have just changed audio output to Pulseaudio in VLC preferences and so far it seems to have fixed it perfectly.

Not sure if it's related, but spotify in wine also has similar problems, eventually until it cannot playback music at all until I use the alsa force-reload command.

I have an m-audio audiophile 192 soundcard.

I'd just like to add that I was having this same problem, but the suggestion to set pulseaudio as default seems to have fixed all of the audio skipping in vlc.

I'm having further problems similar to this while playing Urban Terror. Using the ALSA reload command works to fix it temporarily again, suggesting it is related and not just a problem with VLC but with ALSA and pulseaudio itself.

qwazi (chris-mckitterick) wrote :

I was having the same problem, switched the output to pulseaudio in VLC. Now everything works.

summary: - [i855] Choppy audio playback
+ Please install and use the pulseaudio output plugin by default
Changed in vlc (Ubuntu):
importance: Undecided → High
status: New → Triaged
Haluchin (abacon) wrote :

I'm set to use just Pulseaudio, and the skipping is still unbearable.

File a separate bug with the contents of /var/log/user.log attached.
Please triage the bug to affect pulseaudio.

Reinhard Tartler (siretart) wrote :

I've committed a backported patch to the packaging repository. will be part of the next upload

Changed in vlc (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 1.0.2-1ubuntu2

---------------
vlc (1.0.2-1ubuntu2) karmic; urgency=low

  * PulseAudio: higher priority than ALSA, LP: #402018

 -- Reinhard Tartler <email address hidden> Mon, 19 Oct 2009 21:19:26 +0200

Changed in vlc (Ubuntu):
status: In Progress → Fix Released
Mahendra Tallur (mahen) wrote :

As of today (Karmic 9.10 AMD64 with backports and pre-relase enabled), I still have this issue (sound skipps / stutters every few seconds) with vlc only and no other player.

I tried version 1.0.2-1ubuntu2 as well as version 1.0.3 (ppa),

I tried OSS, alsa, pulseaudio modes. It actually sounds as if the videos were corrupt. But of course, the videos aren't and it doesn't occur with any other player (totem, mplayer...).

I have an ICH10 family audio board.
Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

Sound works OK in all other apps (except in audacious 2 : I had to select alsa instead of pulseaudio, otherwise some plugins were misbehaving, but this is probably an audacious 2 bug).

What may I do to help fix this issue ?

Torchmann (goodf2) wrote :
Download full text (5.0 KiB)

I don't have a problem with vlc but I was having a problem with UrbanTerror and found 2 important SDL libraries not installed by default.

These are my installed vlc libs
vlc
vlc-nox
vlc-data
vlc-plugin-pulse
libvlccore2
libvlc2
libvcdinfo0

There is also vlc-plugin-sdl that I DO NOT HAVE INSTALLED and I'm running fine without it.

Here is my report on how I fixed sound for UrbanTerror:

I was told..."Try and install libsdl1.2-debian-pulse so that sdl uses pulseaudio directly, and see if that helps."

I actually had libsdl1.2-debian-pulse installed. changing it to alsa as someone else recommended just killed my sound.
pulseaudio is just the sound server not a driver.
pulse actually controls alsa from what I've read on other threads.
libsdl-sound1.2 was missing along with libsdl1.2debian which is the SIMPLE DIRECTMEDIA LAYER.

SOLVED
I tried going all alsa found out pulse is only a server between alsa and the application running alsa. screwed it all up and had to re-install.

running compiz the game was quiet but I could play a few minutes using metacity...still crashed...

I tried debian and slackware...no luck
I installed Ultimate Edition 2.5...everything else working fine...back to no sound in Urban Terror. no metacity to switch to

Ultimate Edition might have given me a better repository or other libraries for success, anyway this is what I have going that makes UT work perfect. very perfect...

Made sure adobe 10 flashplayer that was lagging gnome and firefox wasn't the problem by leaving it out of this install.

I had to install the alsa mixer gui to get my mono base channel working on the soundcard but Urban Terror still kept crashing.

I found out that if your sound crashes instead of trying to back out of UT and locking up your system forcing a restart just hit alt+tab
and it will minimize the window and you can close the app with a right-click close

I tried switching to Libsdl-debian-alsa and I had absolutely no sound
I had to open pulse audio preferences and select the analog stereo duplex option, the digital feed was not working with my sigmatel 97 soundcard.
I tried switching to Libsdl-debian-all and that still worked for everything else but not urban terror.
I noticed that Libsdldebian1.2 (Simple Directmedia Layer) was NOT installed by default so i installed it.
No change yet...
I switched back to ubuntu 9.10 default Libsdl-debial-pulseaudio from the Libsdl-debian-all everyone was reccomending

Urban Terror works perfect,
No crash, no lag and I have compiz desktop cube active and am running under the ubuntu drivers so it was never an ati driver problem strictly audio. some people have said UT ran better under metacity and it did for me but still kept crashing the soundcard until I installed the missing 2 libraries.

Here is a list of what I have installed in synaptic under a search for sdl
libsdl-gfx1.2-4
libsdl pango1
libsdl-sound1.2
libsdl-ttf2.0-0
gambas2-gb-sdl
gambas2-gb-sdl-sound
libsdl1.2debian-pulseaudio
libsdl1.2debian
libsdlmpeg0
mplayer-skins
libsdl-image 1.2
libsdl-mixer 1.2
vlc-nox
mplayer
mplayernogui

Here is what's showing as manually altered under sdl (the ones I changed)
You have to have all 3 of these inst...

Read more...

This wasn't fixed. Even with pulseaudio output, on an intel 585, vlc audio still stutters.

Jay Ó Broin (ismise) wrote :

(Karmic x86 upgraded from Jaunty with Update Manager:) I had audio stuttering problems even with vlc-plugin-pulse installed. Switching to other audio output modes only made it worse. This fixed it though:

sudo apt-get remove --purge vlc-plugin-pulse
sudo apt-get install vlc-plugin-pulse

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers