Comment 23 for bug 402018

Torchmann (goodf2) wrote :

I don't have a problem with vlc but I was having a problem with UrbanTerror and found 2 important SDL libraries not installed by default.

These are my installed vlc libs
vlc
vlc-nox
vlc-data
vlc-plugin-pulse
libvlccore2
libvlc2
libvcdinfo0

There is also vlc-plugin-sdl that I DO NOT HAVE INSTALLED and I'm running fine without it.

Here is my report on how I fixed sound for UrbanTerror:

I was told..."Try and install libsdl1.2-debian-pulse so that sdl uses pulseaudio directly, and see if that helps."

I actually had libsdl1.2-debian-pulse installed. changing it to alsa as someone else recommended just killed my sound.
pulseaudio is just the sound server not a driver.
pulse actually controls alsa from what I've read on other threads.
libsdl-sound1.2 was missing along with libsdl1.2debian which is the SIMPLE DIRECTMEDIA LAYER.

SOLVED
I tried going all alsa found out pulse is only a server between alsa and the application running alsa. screwed it all up and had to re-install.

running compiz the game was quiet but I could play a few minutes using metacity...still crashed...

I tried debian and slackware...no luck
I installed Ultimate Edition 2.5...everything else working fine...back to no sound in Urban Terror. no metacity to switch to

Ultimate Edition might have given me a better repository or other libraries for success, anyway this is what I have going that makes UT work perfect. very perfect...

Made sure adobe 10 flashplayer that was lagging gnome and firefox wasn't the problem by leaving it out of this install.

I had to install the alsa mixer gui to get my mono base channel working on the soundcard but Urban Terror still kept crashing.

I found out that if your sound crashes instead of trying to back out of UT and locking up your system forcing a restart just hit alt+tab
and it will minimize the window and you can close the app with a right-click close

I tried switching to Libsdl-debian-alsa and I had absolutely no sound
I had to open pulse audio preferences and select the analog stereo duplex option, the digital feed was not working with my sigmatel 97 soundcard.
I tried switching to Libsdl-debian-all and that still worked for everything else but not urban terror.
I noticed that Libsdldebian1.2 (Simple Directmedia Layer) was NOT installed by default so i installed it.
No change yet...
I switched back to ubuntu 9.10 default Libsdl-debial-pulseaudio from the Libsdl-debian-all everyone was reccomending

Urban Terror works perfect,
No crash, no lag and I have compiz desktop cube active and am running under the ubuntu drivers so it was never an ati driver problem strictly audio. some people have said UT ran better under metacity and it did for me but still kept crashing the soundcard until I installed the missing 2 libraries.

Here is a list of what I have installed in synaptic under a search for sdl
libsdl-gfx1.2-4
libsdl pango1
libsdl-sound1.2
libsdl-ttf2.0-0
gambas2-gb-sdl
gambas2-gb-sdl-sound
libsdl1.2debian-pulseaudio
libsdl1.2debian
libsdlmpeg0
mplayer-skins
libsdl-image 1.2
libsdl-mixer 1.2
vlc-nox
mplayer
mplayernogui

Here is what's showing as manually altered under sdl (the ones I changed)
You have to have all 3 of these installed...
libsdl1.2debian-pulseaudio
libsdl1.2 debian
libsdl-sound1.2

and just for posterity if it had anything to do with alsa at all when I installed the alsa mixer and alsa gui...
this is what's showing up in synaptic filtering for manually installed under a search for alsa
alsamixergui
alsaplayer-common
libsd-alsa0
alsa-utils
gnome-alsamixer
alsa-oss
alsa-base
libsound2
alsa-tools-gui
libsound2-plugins
linux-sound-base
gstreamer0.10-alsa
qamix
libclalsadrv (this is the alsa driver c++ access library)
gamix
bluez-alsa

I'm sorry I cannot say if the sdl libraries I installed cured the problem alone...
Or if it was in combination with the alsa utilities I added.
All I can say is if you have the same sdl installs and UT still doesn't work try checking out the sdl file dependancies and see if you have the alsa installs I do.

I can definitely say it has nothing to do with the graphics card or drivers
I was getting lag and rough frames in UT but it was due to:
The UT default internet connection setting was set to 8, I'm on a cable modem so I set it to 24
The UT refresh rate was over 80 exceeding the 60 hz of my monitor and the setting of 50 in the compiz options.
I set the UT refresh rate to 50
I also maxed out the # of sends to the server
It works perfectly smooth now with no sound crashing.

6 year old Dell Inspiron 9100 with P4 1mb on die cache and 1gig ram with hyperthreading and a usb keyboard
I have the troublesome radeon mobility 9700 graphics card. It's actually a dell built 9600 with 128 pin bus and 128 ram.
I wish I had the 9800 with the 256 pin bus and 256 ram. my old 9700 won't run DOD source or RedOrechestra smoothly anymore even with rendering turned down
UT is playing better on my machine than dod non source, painkiller and doom3 ever did UT rocks
Compiz-fusion wasn't working for me under jaunty because the legacy drivers were not supported but works great under the stock Karmic setup...