'Installation failed' error message

Bug #1289314 reported by David Henningsson on 2014-03-07
70
This bug affects 17 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

When trying to create a usb startup disk, it immediately fails with an error message translating to 'Installation failed' (in both window caption and text).
Btw, I notice that a /dev/loop device is created (and not cleaned up) every time this happens.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: usb-creator-gtk 0.2.54
ProcVersionSignature: Ubuntu 3.13.0-14.34-generic 3.13.5
Uname: Linux 3.13.0-14-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Mar 7 12:57:23 2014
InstallationDate: Installed on 2013-11-04 (123 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131103)
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

David Henningsson (diwic) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Ivan Larionov (xeron-oskom) wrote :

Ok I tired of waiting maintainers to fix and found a bug and fixed it. Patch attached.

This bug caused by mount returns warning to STDERR when mounting read-only without -r flag. Example:

$ sudo mount -o loop /home/xeron/Загрузки/trusty-desktop-amd64.iso /tmp/tmp1c7s4pag
mount: блочное устройство /home/xeron/Загрузки/trusty-desktop-amd64.iso защищен от записи, монтируется только для чтения

In english:

$ LC_ALL=en_EN.UTF-8 sudo mount -o loop /home/xeron/Загрузки/trusty-desktop-amd64.iso /tmp/tmp1c7s4pag
mount: block device /home/xeron/Загрузки/trusty-desktop-amd64.iso is write-protected, mounting read-only

Possible bug duplicates (some are older, but I believe it's OK to mark them as duplicates if usb-creator will be fixed by patch provided in this ticket):

Bug #1273739
Bug #1266731
Bug #1264400
Bug #1253065
Bug #1013511 (may be)

Related bugs:

Bug #1289310 (same encoding problems with LC_ALL set to C or en_EN.UTF-8 and national localized Download dir)
Bug #948257 (not duplicate because it's about UI, but originally caused by same bug with ascii)

The attachment "usb-creator-fix.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

It prevents the package (or a dependent one) from functioning correctly at all.

Changed in usb-creator (Ubuntu):
importance: Undecided → High
Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.56

---------------
usb-creator (0.2.56) trusty; urgency=medium

  [ Ivan Larionov ]
  * Loop-mount iso in read-only mode, can't modify it anyway. (LP: #1289314)

  [ Daniel Lawrence ]
  * usb-creator doesn't refresh size error (LP: #521311)

  [ Jeremy Bicha ]
  * Always select the most recent image found (LP: #1087117)

  [ Yu Ning ]
  * GTK: Handle the backend.format_ended_cb callback otherwise the erasing
    operation will never ended. (LP: #1289269) (LP: #1273925)

  [ Dimitri John Ledkov ]
  * At the end of successful UDisks2 format, trigger device change to
    remount and recalculate the now formatted free space.
 -- Dimitri John Ledkov <email address hidden> Tue, 01 Apr 2014 15:04:39 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers