Kernel panic when dpkg attempts to install libc6

Bug #1303139 reported by David Oftedal on 2014-04-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

This bug is also reported in:
bug #1269483
bug #1269500
bug #1269669
bug #1286476

It affects users trying to install/upgrade libc6 using dpkg, and in my case occurred during an upgrade from 13.10 to 14.04.

Similar or related bugs are reported in:
bug #1269405
bug #1271440
bug #1269731

A workaround for the issue is found in:
https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1269405/comments/30 .

This is an umbrella ticket filed just to get the bug reopened. Please see the other tickets for details, attachments, screenshots etc.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
David Oftedal (rounin) on 2014-04-05
description: updated
David Oftedal (rounin) wrote :

Steve Langasek (vorlon) pointed out in bug #1269731 that the issue may in fact have been fixed, as I could have been running the old version of upstart when the error occurs.

Running the "telinit u" command after the upgrade seems to confirm this, at it does not cause a kernel panic.

Therefore, I think this was a false alarm.

David Oftedal (rounin) wrote :

Steve Langasek (vorlon) is now saying that the bug was in fact introduced after version 13.10, which raises some questions as to why this bug is triggered during upgrades to 14.04.

There is, therefore, a certain probability that users will be affected by this when upgrading to 14.04.

Steve Langasek (vorlon) wrote :

No, what I am saying is that this bug is not a duplicate of bug #1269731 and should not have been marked as one.

Bug #1269731 was only present in a version of upstart introduced in trusty after the 13.10 release. Your bug, since it involves an upgrade from Ubuntu 13.10 to 14.04, is not that bug.

David Oftedal (rounin) wrote :

Then I'm marking the bugs as duplicates of this one again, as none of the libc6 bugs should be marked as duplicates of bug #1269731.

David Oftedal (rounin) on 2014-04-06
description: updated
description: updated
description: updated
Steve Langasek (vorlon) wrote :

Any crasher bug in upstart is a very serious problem which we take seriously. While the issue is resolved for you (since the upgrade is now over), it's important that we find out the cause of the crash on your system, so that it doesn't happen to others.

I understand that you don't have any crash files in /var/crash for this. That's strange, and I'm not sure why that's the case. But there are a few other things we can look at to try to reproduce the problem.

Assuming you were upgrading from 13.10 to 14.04 using update-manager, you should have log files in /var/log/dist-upgrade. Can you please attach the apt.log. apt-term.log, and term.log from this directory?

There have not been other mentions of this bug being seen when upgrading to upstart 1.12, so it is clearly not trivial to reproduce. It may help in reproducing this bug to have a complete copy of your upstart configuration. Can you tar up the contents of your /etc/init directory (tar zcvf ~/upstart-configs.tgz /etc/init) and attach the resulting tarball?

David Oftedal (rounin) wrote :

The bug occurs when dpkg tries to install libc6 deb, and this triggers the telinit command.

As you are adamant that this bug is unrelated to the several bugs that are already filed which describe this exact problem, I've decided not to spend any more time on it.

If you wish to investigate the issue yourself, then I recommend you install 13.10 on a system and upgrate it with do-release-upgrade.

Steve Langasek (vorlon) wrote :

Closing. Impossible to reproduce without help from the submitter.

Changed in upstart (Ubuntu):
status: Confirmed → Invalid
Changed in upstart:
status: New → Invalid
Daniel Ahlenius (ubuntu-on) wrote :

Sorry to wake you guys, but this bug came to me while upgrading from 13.10 to 14.04 now. I tried related WO and could continue the upgrade after creating the softlink /root/bin/telinit -> /dev/true softlink.

David Oftedal (rounin) wrote :

Two other users have reported having the bug so far.

Changed in upstart:
status: Invalid → Confirmed
Changed in upstart (Ubuntu):
status: Invalid → Confirmed
David Oftedal (rounin) on 2014-04-26
description: updated
description: updated
Steve Langasek (vorlon) wrote :

And without logs from an affected system, there's still nothing we can do with this report.

Changed in upstart (Ubuntu):
status: Confirmed → Incomplete
Daniel Ahlenius (ubuntu-on) wrote :

I found a another screen picture with what I think is a dump... what other logs can I provide to you?

Softlink been removed and "telinit u" does not report anything now... so I cannot reproduce the error.

David Oftedal (rounin) on 2014-04-26
description: updated
David Oftedal (rounin) on 2014-04-26
description: updated
description: updated
Dimitri John Ledkov (xnox) wrote :

Interesting logs are:

* tarball of /etc/init/*
* tarball of /var/log/upstart/
* are you running sessions in chroots? (daemons managed by upstart)

I have exactly the same issue, see question https://answers.launchpad.net/ubuntu/+question/247836

David Oftedal (rounin) on 2014-05-01
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Bug attachments