[MASTER] Can't upgrade from 10.04LTS to 10.10 - E:Error, pkgProblemResolver::Resolve generated breaks - xorg-xserver-video-nouveau

Bug #721306 reported by Robert S. Grimes on 2011-02-18
484
This bug affects 70 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: update-manager

I tried to upgrade (twice, once three days ago, then again today), and after a while, I got a dialog with the following text in it:

"Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report."

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: update-manager 1:0.134.11
ProcVersionSignature: Ubuntu 2.6.32-28.55-generic 2.6.32.27+drm33.12
Uname: Linux 2.6.32-28-generic i686
Architecture: i386
Date: Fri Feb 18 09:55:26 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: update-manager

Robert S. Grimes (rsgrimes) wrote :
Robert S. Grimes (rsgrimes) wrote :
Robert S. Grimes (rsgrimes) wrote :
Robert S. Grimes (rsgrimes) wrote :
Manfred Hampl (m-hampl) wrote :

This can be a duplicate of bug 614993 (and dozens of similar ones)

If the package xserver-xorg-video-nouveau is installed, in several cases the 10.04 to 10.10 upgrade fails with the error message

"Could not determine the upgrade
An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu"

Several persons have reported that after removal of that package the upgrade was successful.

Try this workaround: Open a terminal and enter the command:

sudo apt-get remove xserver-xorg-video-nouveau

and try the upgrade again.

tags: added: lucid2maverick
Changed in update-manager (Ubuntu):
importance: Undecided → High
status: New → Triaged
Robert S. Grimes (rsgrimes) wrote :

Manfred, that workaround worked just great! Thanks a bunch.

If my bug is indeed a duplicate, I apologize. I did a search, and didn't see any matches, but when I finished my report, the system told me of several! I must not know how to search in this system very well at all...

Miko (mikosiko) wrote :

@Manfred: workaround worked for me too... thanks a lot....

Miko

Changed in update-manager (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
assignee: Jean-Baptiste Lallement (jibel) → Michael Vogt (mvo)
summary: - Can't upgrade from 10.04LTS to 10.10
+ [MASTER] Can't upgrade from 10.04LTS to 10.10
summary: - [MASTER] Can't upgrade from 10.04LTS to 10.10
+ [MASTER] Can't upgrade from 10.04LTS to 10.10 -
+ pkgProblemResolver::Resolve generated breaks - xorg-xserver-video-
+ nouveau
summary: - [MASTER] Can't upgrade from 10.04LTS to 10.10 -
+ [MASTER] Can't upgrade from 10.04LTS to 10.10 - E:Error,
pkgProblemResolver::Resolve generated breaks - xorg-xserver-video-
nouveau
Daniel Ellis (danellisuk) wrote :

I would say bug 614993 is the master bug, as that one was raised first. I think this should be marked as a duplicate of that bug, does anyone disagree?

RedSingularity (redsingularity) wrote :

@ Daniel Ellis

The developers want to use this as the master report instead of opening that older bug again.

BarryW (bazzawill) wrote :

Fix works for me

iheartubuntu (iheartubuntu) wrote :

RedSingularity, Thank you for the info. The terminal command provided by Manfred Hampl fixed the problem. Upgrade was successful.

How did u fixed the error ?

On Sat, Mar 5, 2011 at 2:41 AM, iheartubuntu <email address hidden> wrote:

> RedSingularity, Thank you for the info. The terminal command provided by
> Manfred Hampl fixed the problem. Upgrade was successful.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (721208).
> https://bugs.launchpad.net/bugs/721306
>
> Title:
> [MASTER] Can't upgrade from 10.04LTS to 10.10 - E:Error,
> pkgProblemResolver::Resolve generated breaks - xorg-xserver-video-
> nouveau
>
> Status in “update-manager” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: update-manager
>
> I tried to upgrade (twice, once three days ago, then again today), and
> after a while, I got a dialog with the following text in it:
>
> "Could not calculate the upgrade
>
> An unresolvable problem occurred while calculating the upgrade:
> E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused
> by held packages.
>
> This can be caused by:
> * Upgrading to a pre-release version of Ubuntu
> * Running the current pre-release version of Ubuntu
> * Unofficial software packages not provided by Ubuntu
>
> If none of this applies, then please report this bug against the
> 'update-manager' package and include the files in /var/log/dist-
> upgrade/ in the bug report."
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: update-manager 1:0.134.11
> ProcVersionSignature: Ubuntu 2.6.32-28.55-generic 2.6.32.27+drm33.12
> Uname: Linux 2.6.32-28-generic i686
> Architecture: i386
> Date: Fri Feb 18 09:55:26 2011
> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386
> (20100816.1)
> PackageArchitecture: all
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: update-manager
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/721306/+subscribe
>

--
Vaibhav

I think you sent this to the wrong person. I never fixed the error. I'm
waiting for 11.04.

On 03/05/2011 12:47 AM, Vaibhav wrote:
> How did u fixed the error ?
>
> On Sat, Mar 5, 2011 at 2:41 AM, iheartubuntu <email address hidden>
> wrote:
>
>> RedSingularity, Thank you for the info. The terminal command provided by
>> Manfred Hampl fixed the problem. Upgrade was successful.
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug (721208).
>> https://bugs.launchpad.net/bugs/721306
>>
>> Title:
>> [MASTER] Can't upgrade from 10.04LTS to 10.10 - E:Error,
>> pkgProblemResolver::Resolve generated breaks - xorg-xserver-video-
>> nouveau
>>
>> Status in “update-manager” package in Ubuntu:
>> Triaged
>>
>> Bug description:
>> Binary package hint: update-manager
>>
>> I tried to upgrade (twice, once three days ago, then again today), and
>> after a while, I got a dialog with the following text in it:
>>
>> "Could not calculate the upgrade
>>
>> An unresolvable problem occurred while calculating the upgrade:
>> E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused
>> by held packages.
>>
>> This can be caused by:
>> * Upgrading to a pre-release version of Ubuntu
>> * Running the current pre-release version of Ubuntu
>> * Unofficial software packages not provided by Ubuntu
>>
>> If none of this applies, then please report this bug against the
>> 'update-manager' package and include the files in /var/log/dist-
>> upgrade/ in the bug report."
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 10.04
>> Package: update-manager 1:0.134.11
>> ProcVersionSignature: Ubuntu 2.6.32-28.55-generic 2.6.32.27+drm33.12
>> Uname: Linux 2.6.32-28-generic i686
>> Architecture: i386
>> Date: Fri Feb 18 09:55:26 2011
>> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386
>> (20100816.1)
>> PackageArchitecture: all
>> ProcEnviron:
>> PATH=(custom, no user)
>> LANG=en_US.utf8
>> SHELL=/bin/bash
>> SourcePackage: update-manager
>>
>> To unsubscribe from this bug, go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/721306/+subscribe
>>
>
>

stefaan walleghem (stefwal) wrote :

If the package xserver-xorg-video-nouveau is installed, in several cases the 10.04 to 10.10 upgrade fails with the error message

uninstalling xserver-xorg-video-nouveau indeed did resolve my problem.
I'm answering here because it seems the bug I sent was a duplicate.

greets,
stefwal

Works for me too. Thanks very much.

Charles Whittington

Vaibhav (vaibhav-shetyeg) wrote :

uninstalling xserver-xorg-video-nouveau didn't work for me

Hello

I'm carlos

I made the bug by mistake, because it is already open and I, by ignorance,
duplicated it. and later I turn it into invalid state because I didn't know
how to delete the bug. but I found a partial anwer in the forum. I mean
partial because now I can not install any new program in the maverick. and
that have solution as I may have overfound in a quick search, but honestly I
can not advise you because I relative new in linux. sorry.

then what I have found is that 10.04 can't upgrade because there is a
package called xorg.xserver.video was, I don't know why, making some
problems with the upgrade. then I found one page that told me to de-install
that package , add the the new sources of software of 10.10 and then make an
actualitation. but now I can not install any program now.

I tink I may have corrupted the kernel. so I can not advise you in anything

Manfred Hampl (m-hampl) wrote :

@carlos: If you still have a problem with upgrading and the workaround of removing xserver-xorg-video-nouveau did not solve your problem, you should continue in your original bug 726503

Michael Vogt (mvo) wrote :

I tried to reproduce this in a vitual machine using the logs from Robert, but I could not get it to fail so far. I will try some more tomorrow.

govinda (gofmann) on 2011-05-19
Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
Kangarooo Jānis (kangarooo) wrote :

BTW i just today upgraded Xubuntu
witch was 09.10
on 2010 04 to 10.04
and just today to 10.10 and 11.04
to check how upgrade works for older versions. Had bug on each start on 10.10 but on 11.04 all faster then previous.

Brian Murray (brian-murray) wrote :

Reverting the status back to Triaged as there is no clear indication that this has been fixed.

Changed in update-manager (Ubuntu):
status: Fix Released → Triaged
djeyewater (showerheadsuk) wrote :

I am getting the same error, when I open the Update Manager I get the following message:

Could not determine the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug in the 'update-manager' package and try to include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions