system upgrade 9.10 --> 10.04 could not calculate upgrade when both xubuntu-desktop and ubuntu-desktop are installed

Bug #571743 reported by Kyle Baker on 2010-04-29
280
This bug affects 45 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

TEST CASE:
1. install xubuntu-desktop and ubuntu-desktop
2. ensure that libsdl1.2debian-alsa is installed
3. run do-release-upgrade
4. verify that the upgrade can not be calculated
5. run "do-release-upgrade --proposed
6. verify that it can be calculated now

Binary package hint: update-manager

When running sudo update-manager -d from 9.10, error message appears as follows:

first, here's the terminal dump -

$ sudo update-manager -d
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'
tar: Removing leading `/' from member names
WARNING: Failed to read mirror file

now, the error message in the dialog box that pops up -

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
The package 'ubuntu-desktop' is marked for removal but it is in the removal blacklist.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

Attached are the files from /var/log/dist-upgrade.

ProblemType: Bug
Architecture: i386
Date: Thu Apr 29 09:43:24 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: update-manager 1:0.126.9
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-21.59-generic
SourcePackage: update-manager
Uname: Linux 2.6.31-21-generic i686
XsessionErrors:
 (gnome-settings-daemon:1633): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1633): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1705): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1693): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (firefox:2117): GLib-WARNING **: g_set_prgname() called multiple times

Kyle Baker (kyle-midwrc) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

It appears this is caused by both ubuntu-desktop and xubuntu-desktop being installed.

ubuntu-desktop depends on libsdl1.2debian-pulseaudio and that conflicts on libsdl1.2debian-alsa

xubuntu-desktop recommends libsdl1.2debian-alsa and that conflicts on libsdl1.2debian-pulseaudio

Changed in update-manager (Ubuntu):
status: New → In Progress
summary: - system upgrade 9.10 --> 10.04 could not calculate upgrade
+ system upgrade 9.10 --> 10.04 could not calculate upgrade when both
+ xubuntu-desktop and ubuntu-desktop are installed
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
Kyle Baker (kyle-midwrc) wrote :

I removed xubuntu-desktop with apt-get remove xubuntu-desktop and my system is now upgrading without issue.

Michael Vogt (mvo) wrote :

I can reproduce the failure in my auto-upgrade-tester setup.

Michael Vogt (mvo) wrote :

It appears that the fix is as simple as:

-MetaPkgs=ubuntu-desktop, kubuntu-desktop, xubuntu-desktop, ubuntustudio-desktop, ichthux-desktop, mythbuntu-desktop, kubuntu-netbook
+MetaPkgs=xubuntu-desktop, ubuntu-desktop, kubuntu-desktop, ubuntustudio-desktop, ichthux-desktop, mythbuntu-desktop, kubuntu-netbook

so just switching the order around because "libsdl1.2debian-alsa" is only a recommends for xubuntu-desktop.

Rod McFarland (rod-mcfarland) wrote :

Thanks Michael, I wouldn't have persisted trying to upgrade for much longer if I hadn't found this hint. It also seems to work if you remove ubuntu-desktop but keep xubuntu-desktop.

Naveen BM (naveenbm) wrote :

Removing xubuntu-desktop fixed this issue with me as well.

Removing xubuntu-desktop did the trick!

Byron Gibson (byrongibson) wrote :

I have this same problem, but with ubuntu-desktop and mythbuntu. To clarify, is the workaround then to remove one of those (in my case ubuntu-desktop since that's my secondary), install the 10.04 upgrade, then reinstall ubuntu-desktop?

Martin (slayer-mod) wrote :

I found an hack, if you doesn't want to uninstall and perhaps loose settings:
Its dirty, but it worked.

I did that in the shell with sudo do-release-upgrade
I attached strace till the error cames out then and then I stopped it.
I checked the log file from strace and found out, that
a file was created: /tmp/<folder_with_random_chars>/removal_blacklist.cfg

So I let it restore to the old state, cleared the tmp folder,
restarted the tool and quick removed the *untu-dektop entries in the file removal_blacklist.cfg (there is then only one folder with random charas only in the tem dir), and saved.
i recommend vim because you can go quick in then type "d6d" (i think there are 6 lines) in command mode type :x and its saved.
I needed two runs, so you have to be quite fast till the updater reads the file.

dougp (dougp2000) wrote :

I have a Mythbuntu base install w/XFCE (Xubuntu desktop) and added Ubuntu desktop & Kubuntu desktop. Removing Ubuntu desktop has allowed me to do the distribution upgrade. Thanks to all for your help.

jcwinnie (jcwinnie) wrote :

I could remove ubuntu-desktop and still unable to finish upgrade. Same error msg something about util-linux and I should look at APT:Immediate Config

Funny thing. I thought I had xubuntu-desktop on PC. Aptitude shows a 'p' next to it. Am unable to remove it either with aptitude or apt-get.

@jcwinnie, you're experiencing another bug. could you please file a new report a attach the files in /var/log/dist-upgrade to that report ? Thanks.

DAP (akadap) wrote :

I was able to upgrade by uninstalling mythbuntu-desktop.
Once upgraded, I had to use video safe mode until I installed the proprietary video drivers (ATI).
For some reason, if I want to add back mythbuntu-desktop, it wants to uninstall ubuntu-desktop.
I'm leaving mythbuntu-desktop off for now.
This upgrade has so far broken mythfrontend, and google earth, and I'm barely started testing.
This is not inspiring confidence.

Don Nutter (don-nutter) wrote :

Removing mythbuntu-desktop allowed the upgrade to work for me.

L.Fen (l-fenelon+launchpad) wrote :

Got the same problem, and removing xubuntu-desktop worked for me too.

Same problem, removing xubuntu-desktop allows upgrade.

Georg (georg-lippold) wrote :

resolved as well, removing xubuntu-desktop works.

worked for me too. though i had to resume the instalation a few times
to complete it. it gave me errors with gxine, firefox-pdf, and some
other programs. removing them ono by one and reinstalling worked fine.

Dibakar Sen (adroit-dibs) wrote :

Removing xubuntu-desktop worked for me as well. Thank you all.

Aadil H (aadilh) wrote :

I had ubuntu & xubuntu desktop installed. I removed xubuntu-desktop without problems & it didn't remove any other components.

The upgrade error was solved, thanks.

Nikki! (necramirez) wrote :

I did what Martin did (#10) and it worked for me.

kar1oko (kar1oko) wrote :

I don't have xubuntu-desktop installed but I'm suffering same problem in two different computers with almost same configuration and 9.10_64

I attach the dist-upgrade log file

Bora (boraa) wrote :

Another way to do upgrade system without removing xubuntu and etc. is libsdl1.2debian-all installation.

sudo aptitude install libsdl1.2debian-all

Michael Vogt (mvo) on 2010-05-21
description: updated
Philip (rocketman768) wrote :

The proposed fix (removing ubuntu-desktop) did not work for me (also, I have kubuntu installed instead of mythbuntu). I still get the same error. My /var/log/dist-upgrade/main.log reads...

DEBUG none of the '['ubuntu-desktop', 'kubuntu-desktop', 'xubuntu-desktop', ubuntustudio-desktop', 'ichthux-desktop', 'mythbuntu-desktop', 'kubuntu-netbook']' meta-pkgs installed
DEBUG guessing 'ubuntu-desktop' as missing meta-pkg
...blah blah errors about kubuntu-desktop...

I have no other "-desktop" packages installed, and kubuntu-desktop IS marked in aptitude as installed, so I don't know what it is complaining about.

Casey Odom (codom10) wrote :

Bora (post #24) I tried your suggestion and that did not work for me.
Kinda new to this stuff so any ideas?

Accepted update-manager into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

I have reproduced the problem with update-manager 1:0.134.8 and have verified that the version of update-manager in proposed, 1:0.134.9, fixes the issue. I do not see any regressions when performing upgrades or updating packages with the version of update-manager in -proposed.

Marking verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.134.9

---------------
update-manager (1:0.134.9) lucid-proposed; urgency=low

  * DistUpgrade/DistUpgrade.cfg:
    - add ubuntu-netbook-remix and ubuntu-netbook to valid
      meta-packages to ensure clean transition for the rename
      of ubuntu-netbook-remix to ubuntu-netbook (LP: #574279)
  * DistUpgrade/DistUpgradeCache.py:
    - Check if the metapkg is actually upgradable. This covers
      the case of ubuntu-netbook-remix that may no longer be
      available to a user if "universe" is disabled (LP: #574279)
  * DistUpgrade/DistUpgradeQuirks.py:
    - Add workaround for nm-applet dying during the upgrade. At
      the start up of the update we take it down in a controlled
      way (LP: #456468)
    - add workaround for wine upgrade failure (LP: #571999)
    - help the upgrade if both ubuntu-desktop and xubuntu-desktop
      are installed (LP: #571743)
 -- Michael Vogt <email address hidden> Fri, 21 May 2010 09:49:43 +0200

Changed in update-manager (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase

I still have the same issue in upgrading from 11.04 to 11.10 on a system with both ubuntu-desktop and kubuntu-desktop installed. It first complained about kubuntu-desktop, and aborted the upgrade, I removed it and started the upgrade again, then it complained about update-manager-kde (instead of complaining about everything at once and saving time!), I removed that, and finally it has proceeded.

Changed in update-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers