"Upgrading Ubuntu to version 9.10" untranslated and missing for translation

Bug #460547 reported by Ricardo Pérez López on 2009-10-25
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
update-manager (Ubuntu)
Medium
Michael Vogt
Karmic
Medium
Unassigned

Bug Description

Binary package hint: update-manager

TEST CASE:
1. use german (or spanish) locales in jaunty
2. run "update-manager"
3. click on upgrade
4. verify that most of the main upgrader window is localized, but that the main string ""Upgrading Ubuntu to version 9.10" is not

5. repeat step 1
6. run "update-manager --proposed"
7. verify that the main ugprade dialog is now fully localized

When I upgrade my system from Jaunty to Karmic RC, update-manager shows the "Upgrading Ubuntu to version 9.10" string untranslated in my Spanish desktop. Translations in Launchpad does not include that string for translation in the update-manager template for Jaunty. Instead, it has the "Upgrading Ubuntu to version 9.04" string:

https://translations.launchpad.net/ubuntu/jaunty/+source/update-manager/+pots/update-manager/es/197/+translate

However, update-manager in Karmic does include the "Upgrading Ubuntu to version 9.10" string:

https://translations.launchpad.net/ubuntu/karmic/+source/update-manager/+pots/update-manager/es/204/+translate

ProblemType: Bug
Architecture: i386
Date: Sun Oct 25 18:11:24 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: update-manager 1:0.126.6
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=es_ES.UTF-8
 PATH=(custom, user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: update-manager
Uname: Linux 2.6.31-14-generic i686

Ricardo Pérez López (ricardo) wrote :
Michael Vogt (mvo) on 2009-10-26
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → karmic-updates
Michael Vogt (mvo) wrote :

I can confirm this here. The release ugprader is using the translations from karmic and ships its own embedded copy of them. The last language updates was from around ~2 weeks ago. This should get a refresh and the new strings should be included then.

Adi Roiban (adiroiban) on 2009-10-26
Changed in ubuntu-translations:
status: New → Confirmed
Michael Vogt (mvo) wrote :

I prepared a update for this in my bzr branch.

Michael Vogt (mvo) on 2009-10-27
Changed in update-manager (Ubuntu Karmic):
status: Confirmed → In Progress
Michael Vogt (mvo) on 2009-10-28
description: updated
Michael Vogt (mvo) wrote :

It turns out the issue is a missing locale.bindtextdomain() that is caused by moving to gtkbuilder. See https://bugzilla.gnome.org/show_bug.cgi?id=574520

=== modified file 'DistUpgrade/DistUpgradeViewGtk.py'
--- DistUpgrade/DistUpgradeViewGtk.py 2009-10-13 14:46:10 +0000
+++ DistUpgrade/DistUpgradeViewGtk.py 2009-10-28 14:00:33 +0000
@@ -27,6 +27,7 @@
 import gobject
 import pango
 import sys
+import locale
 import logging
 import time
 import subprocess
@@ -347,8 +348,8 @@
        # check if we have a display etc
        gtk.init_check()

- # FIXME: i18n must be somewhere relative do this dir
         try:
+ locale.bindtextdomain("update-manager",localedir)
           gettext.textdomain("update-manager")
         except Exception, e:
           logging.warning("Error setting locales (%s)" % e)

Michael Vogt (mvo) wrote :

I uploaded this into karmic-proposed. It has a i18n update as well because I initially thought it was just too late update of the translations.

Martin Pitt (pitti) wrote :

I reviewed the upload, and I'm not clear about this change:

--- update-manager-0.126.6/DistUpgrade/DistUpgradeController.py 2009-10-23 14:52:42.000000000 +0200
+++ update-manager-0.126.7/DistUpgrade/DistUpgradeController.py 2009-10-28 15:28:00.000000000 +0100
@@ -67,7 +67,7 @@

     def __init__(self, distUpgradeView, options=None, datadir=None):
         # setup the paths
- localedir = "/usr/share/locale/update-manager/"
+ localedir = "/usr/share/locale/"
         if datadir == None:
             datadir = os.getcwd()
             localedir = os.path.join(datadir,"mo")

Michael, what does it do?

Michael Vogt (mvo) wrote :

@pitti: thanks for the review. This change is intended. Its not strictly needed, but it was incorrect before, it was just not noticed because it would fallback to the langpack locales when it does not find them there. I can back it out again if that is prefered (but its more correct this way).

Michael Vogt (mvo) wrote :

The localedir in the code is later used in bindtextdomain(), the doc says:

       Message catalogs will be expected at the pathnames dirname/locale/cat‐
       egory/domainname.mo, where locale is a locale name and category is a
       locale facet such as LC_MESSAGES.

There is no /usr/share/locale/update-manager, but there is /usr/share/locale/de/LC_MESSAGES/update-manager.mo
(well, there is not because its stripped out and replaced with langpacks, this is why its not strictly needed but more correct).

Martin Pitt (pitti) wrote :

Accepted update-manager into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.126.9

---------------
update-manager (1:0.126.9) karmic-proposed; urgency=low

  * DistUpgrade/DistUpgrade.cfg:
    - really stop enabling apport during the upgrade (LP: #465619)

update-manager (1:0.126.8) karmic-proposed; urgency=low

  * when the server is overloaded and no Release file information
    can be obtained, show a better error message instead of the
    bogus "ubuntu-minimal" is missing (LP: #446956)

update-manager (1:0.126.7) karmic-proposed; urgency=low

  * po/*.po:
    - update translations from LP (LP: #460547)
  * UpdateManager/Core/DistUpgradeFetcherCore.py:
    - check if running on a system with noexec /tmp and give a propper
      error message (LP: #461744)
  * DistUpgrade/DistUpgradeViewGtk.py:
    - add missing locale.bindtextdomain() (LP: #460547)

 -- Brian Murray <email address hidden> Fri, 30 Oct 2009 13:54:08 -0700

Changed in update-manager (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Michael, can't copy to lucid because lucid's version is newer than karmic's. Please fix in lucid ASAP.

Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
milestone: karmic-updates → lucid-alpha-1

Is this still an issue? Please respond if the bug is still present

Changed in ubuntu-translations:
status: Confirmed → Incomplete
Gabor Kelemen (kelemeng) wrote :

In theory, this must be already fixed.

Changed in ubuntu-translations:
status: Incomplete → Fix Released
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
RégisC (regis-caspar) wrote :

Hello, I'm still seing this issue when upgrading from 10.10 to 11.04 but with french locale.

@RégisC, please file a new report. You might experience another issue or a regression.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.