upgrade from 9.04 to 9.10 hangs during 'getting new packages' (libapt download problem?)

Bug #460015 reported by Jamie Strandboge on 2009-10-24
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

On on up to date Ubuntu 9.04 system, I perform in a terminal:
$ sudo update-manager -d

I click through the defaults and the upgrade starts:
* Preparing the upgrade (finishes)
* Setting new software channels (finishes)
* Getting new packages (gets to 'Fetching file 1896 of 1896) and stops

The 'Terminal' option is grayed out, so I don't see what is going on. Will attach files from /var/log/dist-upgrade. I do have apt-listchanges installed along with unattended upgrades enabled.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: update-manager 1:0.111.9
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/ksh
SourcePackage: update-manager
Uname: Linux 2.6.28-16-generic i686

Jamie Strandboge (jdstrand) wrote :
Jamie Strandboge (jdstrand) wrote :
tags: added: jaunty2karmic
Jamie Strandboge (jdstrand) wrote :

Not attaching term.log-- it's empty.

Jamie Strandboge (jdstrand) wrote :

/var/log/apt/term.log only has information from the last upgrade within jaunty (ie, the recent tzdata upgrade).

Jamie Strandboge (jdstrand) wrote :

Looking at the ps output, I see:
root 4539 1.4 0.1 5500 2188 pts/0 S+ 12:37 2:56 /usr/lib/apt/methods/http

I use a local mirror and all the packages for the upgrade were downloaded within a few minutes.

Jamie Strandboge (jdstrand) wrote :

I killed the http process and update-manager went away. I this tried the upgrade again and it got past this point and is installing now. It is clear to me what went wrong because I got no feedback from update-manager. If it was a networking problem, perhaps a timeout of some sort would be in order to give the user some feedback.

papukaija (papukaija) wrote :

I think that the bug comes from your local mirror and not from update-manger.

Jamie Strandboge (jdstrand) wrote :

Perhaps, but it seems that the upgrade process should have handled this better.

Marko Vodanovic (morgoth84) wrote :

I have the same problem. It has stopped at "Fetching file 1294 of 1294". I have the amd64 version witch Croatian language.

Marko Vodanovic (morgoth84) wrote :

I've left it for a couple of hours to see if it would budge, but it didn't. So I closed the upgrade setup, killed the karmic process and started the upgrade again (Alt+F2, update-notifier-kde -u). Now it's working ok. It's installing new packages so hopefully in 15 minutes or so it will be done...

chuq (chuq) wrote :

Same problem here - stuck at "Fetching file 1226 of 1226" and has been stuck there overnight. i386 edition, US English. Using the Internode (Australia) mirror. I'll retry as mentioned by Jamie (#6).

chuq (chuq) wrote :

..and the workaround worked for me!

scg34 (s-c-graham) wrote :

Just to confirm - I saw the same behaviour (upgrade-manager hung on fetching the last file), but killing the upgrade-manager and then re-starting the upgrade worked fine.

Robin Stocker (nibor) wrote :

Same problem here, hangs on fetching the last file (2021 of 2021). Here's a backtrace:

#0 0xb7fb7430 in __kernel_vsyscall ()
#1 0xb7eb77b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7b17f06 in pkgAcquire::Run () from /usr/lib/libapt-pkg-libc6.9-6.so.4.7
#3 0xb7c813f1 in ?? () from /usr/lib/python2.6/dist-packages/apt_pkg.so
#4 0x080de562 in PyEval_EvalFrameEx ()
#5 0x080df587 in PyEval_EvalFrameEx ()
#6 0x080df587 in PyEval_EvalFrameEx ()
#7 0x080df587 in PyEval_EvalFrameEx ()
#8 0x080df587 in PyEval_EvalFrameEx ()
#9 0x080df587 in PyEval_EvalFrameEx ()
#10 0x080df587 in PyEval_EvalFrameEx ()
#11 0x080e00b8 in PyEval_EvalCodeEx ()
#12 0x080e0217 in PyEval_EvalCode ()
#13 0x080fe0e1 in PyRun_FileExFlags ()
#14 0x080fe43a in PyRun_SimpleFileExFlags ()
#15 0x0805c882 in Py_Main ()
#16 0x0805b972 in main ()

Dmitry Zhurikhin (zhurikhin) wrote :

I've got the same problem - updater constantly trying to fetch the last file and restarting the process again and again for some reason. But restarting the updater even several times didn't help. I was able to continue upgrading by removing this last package (in my case it was a manually installed from .deb nexuiz-data package; "sudo lsof | grep http | grep /var/cache/apt" during fetching helped to identify it).

BJ (bryn-jones1) wrote :

Okay - i think i've fixed this for me - i let it time out then it threw me an error unable to get package openexr6.deb (sorry i've shut the window now before i noted what it was.....) wo i installed this manually and boom 9.10 is now installing...... thats really sucky!!!

papukaija (papukaija) on 2009-11-03
Changed in update-manager (Ubuntu):
status: New → Confirmed
Ville Pilvio (vpilvio) wrote :

Just a ditto... the upgrade also hangs for me... will kill the process and restart the update. I fully agree, there should be a timeout action with some user feedback. Most end users will panic!

Matt Dittloff (mattdittloff) wrote :

Same thing here. The upgrade hangs after the new packages are downloaded. I clicked the Cancel button to exit out of the upgrade. In Update Manager, I clicked Distribuion Upgrade again, and now it is continuing on installing the packages that it downloaded.

Michael Vogt (mvo) wrote :

I have seen a similar hang before, it seems to be some sort of race condition in the libapt downloader. I have not found a way to reproudce it nor did I manage to get a gdb trace of it. If someone can find a way to reproduce the issue, I would be very thanksful.

Changed in update-manager (Ubuntu Karmic):
status: New → Confirmed
summary: - upgrade from 9.04 to 9.10 hangs during 'getting new packages'
+ upgrade from 9.04 to 9.10 hangs during 'getting new packages' (libapt
+ download problem?)
Jnik (grjohnis) wrote :

got the same thing. Stuck while downloading the last package.

Rolf Leggewie (r0lf) on 2011-10-02
Changed in update-manager (Ubuntu Karmic):
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in update-manager (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers