distribution upgrade via update-manager fails over remote GDM

Bug #322482 reported by thomasn80
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Fix Released
Undecided
Michael Vogt
Jaunty
Fix Released
Undecided
Michael Vogt

Bug Description

Binary package hint: update-manager

Hello

I was about to do a distribution upgrade from 8.10 latest to 9.04 alpha yesterday. I started it via a remote GDM session (which seems to run over SSH). I got a warning that the upgrade might fail and that a second sshd was started on port 9004. Well, probably nothings going to happen I thought.

After downloading all packages and upgrading for maybe 5-10 minutes my GDM session froze. I was unable to contact the client that I was upgrading, didn't even respond to ping.

When I was able to check the remote client out physically I noticed that my session previously active was still running. I couldn't use anything though, nothing was possible to start. I tried to restart X but it didn't start again. I could see lots of segfaults in dmesg and ifconfig showed that there was no eth0 any more.

My suggestion: Make the warning a LOT more scary! It took me a while to repair the system and my upgrade probably isn't that good because it's done mostly via aptitude and not update-manager.

Revision history for this message
Chris Jones (cmsj) wrote :

It seems like it would be sensible to simply not allow upgrades to be done in that manner. It's far too likely to go wrong.

Revision history for this message
Michele Mangili (mangilimic) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-manager:
status: New → Confirmed
Revision history for this message
Michael Vogt (mvo) wrote :

I agree with Chris here, I think remote gdm upgrades are too risky, I will add detection code for this.

Changed in update-manager:
milestone: none → jaunty-alpha-5
assignee: nobody → mvo
Revision history for this message
Steve Langasek (vorlon) wrote :

Michael,

The symptoms described here - segfaults in dmesg and eth0 going away - don't sound like they're related to gdm. Is added detection code really the answer here?

Revision history for this message
Michele Mangili (mangilimic) wrote :

Steve,

I don't know exactly what happened when Thomas upgraded that computer. He hasn't reported a bug against those segfaults in dmesg and eth0 going away, but he is just asking for making the warning message for gdm upgrades more scary. I believe that somehow he could solve that problem.

Revision history for this message
Michael Vogt (mvo) wrote :

Pointers/hints how to setup a test system so that I can try to get the detection done are very welcome :)

Steve Langasek (vorlon)
Changed in update-manager:
milestone: jaunty-alpha-5 → jaunty-alpha-6
Michael Vogt (mvo)
Changed in update-manager:
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.100

---------------
update-manager (1:0.100) jaunty; urgency=low

  [ Andy Whitcroft ]
  * DistUpgrade/cdromupgrade:
    - if cdromupgrade is run with a relative path we will fail to find the
      installer components and error out. Ensure that the path is absolute.
      (LP: #335360)

  [ Michael Vogt ]
  * fix crash when help is not avaialble (LP: #338098)
  * data/glade/UpdateManager.glade:
    - remove the "Keep your system up-to-date" text (design team,
      LP: #336800)
  * fix crash when no network is avaialble for changelog fetching
    (LP: #334002)
  * debian/control:
    - add conflict against update-manager-kde to update-manager-hildon
      (LP: #333464)
  * UpdateManager/Core/MyCache.py:
    - show proper urls for sources with epochs (LP: #328164), thanks
      to Richie
  * UpdateManager/ChangelogViewer.py:
    - support copy to clipboard for URLs (LP: #85644), thanks to
      Richie
  * UpdateManager/UpdateManager.py:
    - disable fixed-hight mode, it can cause incorrect height
      calculation (thanks to Richie), LP: #273184
  * DistUpgrade/DistUpgradeController.py:
    - do not allow gtk/kde upgrades over ssh session (LP: #322482)
  * merged aufs branch (disabled by default but useful for testing)

 -- Michael Vogt <email address hidden> Tue, 10 Mar 2009 20:25:55 +0100

Changed in update-manager:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers