[hardy] Update Manager and Synaptic fail to install recommended updates without any explanation

Bug #227282 reported by Daniel van Vugt on 2008-05-06
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Update Manager tells me there are 35 updates to be installed. So I click Install Updates, see "Reading package information", and absolutely nothing happens.

Now giving up on Update Manager, I open Synaptic and do a reload. Eventually Synaptic shows no updates available, while Update Manager /does/ show updates available. Looking more closely, Synaptic can't even see the higher versioned packages being listed by Update Manager. Synaptic lists the over versions, even after the reload.

I even tried changing repositories in Synaptic, did a reload and Synaptic still fails to see the new package versions reported in Update Manager.

Finally, running a "sudo apt-get upgrade" seems to be working and is upgrading all the same packages that Update Manager listed in the first place. But why are Update Manager and Synaptic both silently refusing to install anything?

Running: Ubuntu 8.04 desktop amd64 (clean installation).

And no, this is not bug 208612. I don't get any error messages and root's home is not broken.

Jeroen T. Vermeulen (jtv) wrote :

I'm getting the same thing. Install Updates prompts me for my password, then a progress bar dialog that says "Reading package information," which spends most of its time saying "Reading state information" underneath the progress bar, then back to the original UI and nothing's been installed.

FWIW, I got to Hardy by upgrading from Gutsy. The architecture is amd64. My sources.list is hand-edited but works fine with apt. It had some bad links (for Hardy versions that I'm waiting to see appear) but nothing changed when I removed those, restarted Update Manager, reloaded, and tried installing again.

Daniel van Vugt (vanvugt) wrote :

Added a screenshot which shows the problem. Update Manager shows newer updates available than Synaptic shows, despite having Reloaded in Synaptic multiple times.

The offending packages which refuse to install all seem to be "Recommended updates".

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please check your settings in synaptic in Settings/Preferences/Distribution ? To what option is that set?

Thanks,
 MIchael

Changed in update-manager:
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Settings/Preferences/Distribution was set to: Prefer versions from = hardy

And thanks, because that lead me to find the workaround: Set Prefer versions from = hardy-updates

Still, the default behavior is very confusing in terms of user interface so I'm leaving the bug open and changing the description.

Guru (i-t-guru) wrote :

Just my observation but both Synaptic and the update manager should be in sync as far as whatever updates are available. I have seen this same type of issue plague openSuSE. The update manager should be an extension of synaptic, not a separate package management component which conflicts. Are they linked? Do they communicate and share update info?
Just a thought.

Gagan Brahmi (gaganb) wrote :

I am having similar issues as well. Synaptic shows updates but when I say insatll it asks for the password, builds & reads the package information and gives me back the same screen where I asked it to install updates.

There is no change in the updates neither does it install any.

Warlon (sampsa-p) wrote :

I had this same problem too. I'm running 64bit 8.10. I had that distribution -option in synaptics set to prefer current version and I changed it to prefer the latest version. After that it installed the updates normally. Update manager should not show updates if "prefer current version" is selected.

WilliamsDanW (dan-wwilliams) wrote :

the specific problem is that the update manager is looking for

Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy/multiverse/binary-lpia/Packages.gz 404 Not Found [IP: 91.189.88.45 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/dists/hardy/universe/binary-lpia/Packages.gz

the directory binary-Ipia does not exist.

I do not know how to fix this (how to redirect to a different directory or which one to redirect to.

justin (justin-saeren) on 2009-11-29
Changed in update-manager (Ubuntu):
status: Incomplete → New
Kaur Männamaa (kaurman) wrote :

I am also experiencing this bug although I'm running a 32 bit lucid. It has to be said though that I recently upgraded from hardy to 10.04 and suffered from the bug already prior to the upgrade.

I have reason to believe it all started after I once cancelled a system upgrade from hardy to some next version. The cancellation was not brutal in any way. I just said no when it asked for the final confirmation and the system seemed to roll back all the changes (sources.lst etc.), as expected.

Yet, I have been unable to receive everyday upgrades via either synaptic or update manager from that point on. The symptoms seem to be the same as the ones characteristic to this bug. This means that I can upgrade via apt-get upgrade or aptitude safe-upgrade but it's still rather annoying.

Interestingly, I was able to use update manager to upgrade from hardy to lucid but the bug remained.

Moses Gingerich (wa4moe) wrote :

Attempt to run Synaptic results in message: An unhandlable error occured.
Details:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 786, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 965, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the kdelibs5-dbg package. This might mean you need to manually fix this package.

Running 10.10 on Quad processor

Moses

Daniel van Vugt (vanvugt) wrote :

@Moses, yours is bug 659438. Not this one.

Robert Roth (evfool) wrote :

Thank you for reporting this bug to Ubuntu. Hardy reached EOL on May 12, 2011.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

I've tried recreating this bug with Oneiric and was unable to, given the information you've provided. Please either a) upgrade and test or b) increase the verbosity of the steps to recreate it so we can try again.

Please feel free to report any other bugs you may find.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Changed in synaptic (Ubuntu):
status: New → Incomplete
gf (gf-interlinks) wrote :

Hello Daniel,
Thank you for submitting this bug and reporting a problem with synaptic. You made this bug report some time ago and Ubuntu has been updated since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you let us know and run the following (only once):
apport-collect BUGNUMBER
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu better.
G

Changed in synaptic:
status: New → Incomplete
Changed in synaptic (Ubuntu):
status: Incomplete → Invalid
Changed in update-manager (Ubuntu):
status: Incomplete → Invalid
no longer affects: synaptic
gf (gf-interlinks) wrote :

Thanks for closing the ticket, Daniel.
Have a great day!
:)
G

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers