Unable to use H.I.M.E. input method in the Unity search bar( & HUD also) in Ubuntu 12.04LTS | 無法於Ubuntu 12.04LTS的Unity searchbar(以及HUD)使用H.I.M.E.輸入法

Bug #973808 reported by V字龍(Vdragon) on 2012-04-04
This bug report is a duplicate of:  Bug #983254: Support input methods beside ibus. Edit Remove
94
This bug affects 22 people
Affects Status Importance Assigned to Milestone
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

OS version : Ubuntu 12.04 LTS Beta 2
Currently tested with hime (0.9.9) but probably other input method as well.

*update*
ibus WORKS 0_o, how could it happens?
Then there should be something wrong in either Unity or H.I.M.E. itself...

hime upstream bug tracker page : https://github.com/caleb-/hime/issues/336
related bug tracker page : https://bugs.launchpad.net/nux/+bug/983254
Ubuntu-tw forum announce page : http://www.ubuntu-tw.org/modules/newbb/viewtopic.php?topic_id=48572&forum=22&post_id=223318#forumpost223318

Input method failed to catch any keyboard event when launched the search bar.
Issue exist in HUD, too.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,snap,place,regex,move,grid,commands,vpswitch,imgpng,unitymtgrabhandles,resize,gnomecompat,mousepoll,session,animation,expo,ezoom,wall,workarounds,fade,scale,unityshell]
Date: Thu Apr 5 06:17:54 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=zh_TW:zh
 TERM=xterm
 LANG=zh_TW.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

hime-env output:
Linux -HDD-Ubuntu 3.2.0-22-generic #35-Ubuntu SMP Tue Apr 3 18:33:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

/etc/debian_version: wheezy/sid

/etc/issue: Ubuntu precise (development branch)

/usr/bin/hime: version 0.9.9, linked to /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
 /usr/lib/x86_64-linux-gnu/libdbusmenu-gtk.so.4
/usr/share/doc/hime/changelog.Debian.gz: hime (0.9.9+git120319-4) unstable; urgency=low

XMODIFIERS : XMODIFIERS=@im=hime
LANG : LANG=zh_TW.UTF-8
LANGUAGE : LANGUAGE=zh_TW:zh
LANG : zh_TW.UTF-8
LANGUAGE : zh_TW:zh
GTK_IM_MODULE: GTK_IM_MODULE=hime
QT_IM_MODULE : QT_IM_MODULE=hime

Running hime number: 1

hime socket number: 1

System library path: /lib /lib32 /lib64 /usr/lib /usr/lib32

:
.

gtk-query-immodules-3.0:
/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-hime.so

:
.

V字龍(Vdragon) (vdragon) wrote :
description: updated
description: updated
summary: - Unable to use input method in the search bar( & HUD also) in Ubuntu
- 12.04LTS
+ Unable to use input method in the Unity search bar( & HUD also) in
+ Ubuntu 12.04LTS | 無法於Ubuntu 12.04LTS的Unity searchbar(以及HUD)使用輸入法
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
summary: - Unable to use input method in the Unity search bar( & HUD also) in
- Ubuntu 12.04LTS | 無法於Ubuntu 12.04LTS的Unity searchbar(以及HUD)使用輸入法
+ Unable to use H.I.M.E. input method in the Unity search bar( & HUD also)
+ in Ubuntu 12.04LTS | 無法於Ubuntu 12.04LTS的Unity
+ searchbar(以及HUD)使用H.I.M.E.輸入法
description: updated
description: updated
V字龍(Vdragon) (vdragon) wrote :

wait... isn't the later bug report the duplicate...?

V字龍(Vdragon) (vdragon) wrote :

anyway, nevermind ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.0daily12.12.05-0ubuntu1

---------------
nux (4.0.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
    - Build-Depend on dh-autoreconf and gnome-common
  * debian/rules:
    - Use dh_autoreconf
    - Enable headless tests during build
  * Switch to dh9 and multiarch
  * Automatic snapshot from revision 700 (bootstrap)
    - Fix crash when lift clicking after right clicking (LP: #1057809)
    - Fix crash on amd64 from an invalid cast (LP: #1052765)
    - Fix a couple crashes in example code (LP: #1064918)
    - Fix dash and launcher being all black (LP: #1067860)
    - Fix launcher dragging the wrong way (LP: #1057995)
    - Only load textures once they are needed (LP: #816692)
    - Add pointer checks for invalid cached textures (LP: #1066788)
    - Fix some FTBFS's on armhf (LP: #1065293, LP: #1067081)
    - Fix a bunch of compile warnings (LP: #1056633)
    - Removed some unused code (LP: #937583)

  [ Didier Roche ]
  * Transition packaging to Nux 4.0
  * Add split mode for daily build

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)
  * make check-headless should respect DEB_BUILD_OPTIONS=nocheck
  * Does not need to be built with gcc 4.6 anymore (LP: #1044836)

  [ Ying-Chun Liu (PaulLiu) ]
  * Unable to use H.I.M.E. input method in the Unity search bar( & HUD
    also) in Ubuntu 12.04LTS | 無法於Ubuntu 12.04LTS的Unity
    searchbar(以及HUD)使用H.I.M.E.輸入法 (LP: #973808)
  * Support input methods beside ibus (LP: #983254)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 727
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:01 +0000

Changed in nux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers