Unity 5.6: key bindings (such as Super) don't work on empty workspace or on slow/loaded systems

Bug #953089 reported by Sascha on 2012-03-12
160
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Daniel van Vugt
Unity
Fix Released
High
Daniel van Vugt
Unity Distro Priority
High
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

1) Ubuntu 12.04 LTS Beta 1 (nightly build)

2) unity: Installiert: 5.6.0-0ubuntu1

3) Unity should work like known

4) On Unity (3D):

 If no program is visible on the screen (press ctrl+alt+arrowkey to switch to an empty desk then:

- the super key doesn't work - means, it doesn't start the dash, all the combinations like ctrl+alt+t for terminal or ctrl+alt+s, ctrl+alt+w don't work

- pressing and holding super doesn't show the numbers on the launchner

- pressing the alt key doesn't bring up the new menu for quickly accessing the program menus

But, if a software is loaded (like firefox) - and visible / active the, the key combinatoins work, except the one that pressing the windows key doesn't start the dash.

==================

Own keyboard combinations:

don't work, neither in Unity 3D nor in Unity 2D

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-services 5.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,compiztoolbox,snap,gnomecompat,mousepoll,move,unitymtgrabhandles,resize,grid,vpswitch,regex,place,wall,session,animation,fade,workarounds,expo,scale,ezoom,unityshell]
Date: Mon Mar 12 15:52:34 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-03-10 (1 days ago)

Related branches

Also, the F10 key doesn't work in Unity 2D. In Unity 3D it works, when a program like Firefox is loaded, when the desktop only is shown - it doesn't have any functionality.

Bilal Akhtar (bilalakhtar) wrote :

Does running unity --reset help? Seems like a compiz mess-up to me

No, running unity --reset only affected me to subscribe/report 3 different bugs:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/953270
https://bugs.launchpad.net/unity/+bug/778470

Okay, two - just saw, two are the same.

The F10 key still doesn't work, if only the desktop is visible - and super doesn't start the dash.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

removing the -2d part as there is not enough info for it. Please open a bug with ubuntu-bug unity-2d (and try to not mix different issues on the same bug report).

We are looking at your 3d issues which don't happen on all systems.

description: updated

I am very sorry, but from my point of view, like you can read in the header, this is exactly one bug, the bug that updating from Unity 5.4 to Unity 5.6 broke the complete Unity 2D and 3D. Before the update - both did work.
And sorry, that I can't file a bug for unity-2d, because I'm not anymore on Precise Pangolin. The last bug that occured was a killer, and the install media of Precise Pangolin from yesterday had a kernel lockup on my Eee PC, so I could only install Oneiric Ocelot.

Didier Roche (didrocks) wrote :

putting it as medium only because only two people on a huge number of upgrade are reporting it. Still tracking it though

Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity-distro-priority:
status: New → Confirmed
importance: Undecided → Medium
Didier Roche (didrocks) wrote :

@Sacha: you describe different issues, to make people hacking on the code life easier, it's better to separate them and not packed into one only bug as the source of the issues can be separated.

Changed in unity-distro-priority:
status: Confirmed → Fix Committed

I wiped my disk, installed first Oneiric Ocelot and updated Oneiric Ocelot up to the actual package versions from today, all was working well,

After that, I just installed via the update-manager -d command to the most actual version of Precise Pangolin.

After login just the first time to Unity, all described bugs of this reports are there.

In an effort to not deal with multiple bugs in a single bug, I've made this one just about the Super key.

summary: - Lots of regressions after update to Unity 5.6 like not working super key
- or alt key functionality
+ Unity 5.6: Super key doesn't start the dash
Daniel van Vugt (vanvugt) wrote :

Hello all,
I am unable to reproduce any issue with the Super key using Precise and Unity 5.6.0-0ubuntu3. Any hints or further information? If so, please add comments and then change the bug Status back to Confirmed. Remember this bug is just about the Super key now.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

What kind of information do you need to investigate this issue ?
Could you provide us with some advices how to help you debugging it ?

Changed in unity (Ubuntu Precise):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-12.04-beta-2
tags: added: qa-manual-testing rls-mgr-p-tracking
Changed in unity (Ubuntu Precise):
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

I would like to know how to reproduce the bug. I haven't yet been able to. Super always works in precise for me.

I can reliably reproduce this issue when firefox is reloading a page, or when other apps are busy. I have attached unity debug log that I hope has some useful information for finding the root cause of the issue.

David Barth (dbarth) wrote :

Here is how I can triggered it more systematically:
1. I load the cpu by starting a terminal with something like: while true ; do ls -altr /; done
(use something more aggressive if you have a high-end CPU)
2. I open the dash with SUPER while chrome or konversation has the focus; close the dash then
3. I switch to thunderbird, the main window with the inbox view
4. Then i press SUPER and the Dash doesn't appear

You describe a different bug then the one I suffered from. For me, the keyboard functionality was completely lacking.

When I logged into unity and only the desktop was loaded, I had this behaviour:

Pressing super key: nothing, no dash came up
Pressing alt key: nothing, no hud came up
Pressing F10: nothing, no menu came up
Pressing ctrl+alt+t: nothing, no terminal came up
Pressing ctrl+alt+right: nothing, no switch to the right window

Pressing on the launcher, I start any program. As soon, as it is loaded, all the keys are working. But now - pressing ctrl+alt+right - and so switching to an again empty desktop - that's it. On the blank desktop again, non of the keys didn't work.

I already erased my disk - reinstalled again, first Oneiric Ocelot, applied all updates, after that I updated via update-manager -d to Precise Pangolin, applied all updates, logged first into Unity - and the same bug as before, means - blank desktop - and no controlling keys are working.

The machine, that happens is a Asus Eee PC 1000H with 2 GB Ram.

Simeon (simeon5) wrote :

For me its just the super key that doesnt work.Super+S/T/1-9 all work no matter if I have apps open or not.

I confirm I suffer from the exact same symptoms on a DELL n4010.

The keybindings are restored temporarily if:
- I open window
- or reveal the dash and close it with the <Super> key
- or open an indicator menu, click on <Super> and close the menu

But as soon as I switch to an empty workspace, the keybindings are broken again.

The system receives keyboard events because if I press CTRL+ALT+Del, the logout dialog pops-up and CTRL+Alt+Fn switches to TTYn

summary: - Unity 5.6: Super key doesn't start the dash
+ Unity 5.6: key bindings doesn't work on empty desktop
summary: - Unity 5.6: key bindings doesn't work on empty desktop
+ Unity 5.6: key bindings doesn't work on empty workspace

one one of my netbooks I always have to press Super key twice to open the dash

To reproduce disable the key org.gnome.desktop.background show-desktop-icons in order _to not show icons_ on the desktop.

Changed in unity (Ubuntu Precise):
status: Incomplete → Triaged
Changed in unity:
status: Incomplete → Confirmed

I just installed Ubuntu 12.04 LTS Beta 1 on a freshly wipped disks and after the base installation, all keys worked.

After updating to the most actual packages, which ended 20 minutes ago and restarting the netbook, the superkey didn't work for starting the dash, the super combination keys are all working, like super+{1..9}, super+s, super+w ...
The alt key is working to for firing up HUD.

The other keycombinations missing happen only, after an upgrade-installation from Oneiric to Pangolin. The you don't have HUD or dash or the F10 key.

Updated the bug title to include "Super" so more people find this one instead of logging duplicates just about the Super key.

summary: - Unity 5.6: key bindings doesn't work on empty workspace
+ Unity 5.6: key bindings don't work on empty workspace (such as Super)
summary: - Unity 5.6: key bindings don't work on empty workspace (such as Super)
+ Unity 5.6: key bindings (such as Super) don't work on empty workspace
D. Wegener (dpwegener) wrote :

In my case, I can get the Dash to come once using Super if I wait for all processing to settle down after login. But I can't get Super to bring up the Dash after that. In fact, Super won't close the Dash. I have to use ESC to close the Dash. I'm running System Load Indicator in the panel and I can see that pressing Super does result in a spike in CPU usage.

Steps to reproduce problem:
Login.
Wait till System Load Indicator shows that system is essentially idle.
Press/Release the Super key.
Dash is displayed
Select an application to run or close with ESC
Press/Relese the Super key
NO Dash is displayed, but System Load indicates CPU spike.

It doesn't matter whether there is an application visible or whether only the Desktop is visible. The Dash doesn't come up on the Super key.

I have the Launcher set to Auto Hide and I have reduced the size of the Launcher icons to better fit my Netbook screen (1024x600). I have icons visible on my Desktop screen.

Daniel van Vugt (vanvugt) wrote :

Could someone who can reproduce this bug, and can compile their own code, please try removing this from fix_alt_pressing.patch in compiz?

@@ -1907,6 +1918,14 @@
        break;
     case FocusIn:
     {
+ /* When a menu etc gets a grab, it's safe to say we're not tapping
+ any key right now. e.g. Detecting taps of "Alt" and cancelling
+ when a menu is opened */
+ if (event->xfocus.mode == NotifyGrab &&
+ event->xfocus.window != priv->root &&
+ event->xfocus.window != priv->grabWindow)
+ priv->possibleTap = NULL;
+
        if (!XGetWindowAttributes (priv->dpy, event->xfocus.window, &wa))
            priv->setDefaultWindowAttributes (&wa);

Daniel van Vugt (vanvugt) wrote :

Or more accurately, please try removing this from src/event.cpp:

        /* When a menu etc gets a grab, it's safe to say we're not tapping
           any key right now. e.g. Detecting taps of "Alt" and cancelling
           when a menu is opened */
        if (event->xfocus.mode == NotifyGrab &&
            event->xfocus.window != priv->root &&
            event->xfocus.window != priv->grabWindow)
            priv->possibleTap = NULL;

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Simeon (simeon5) wrote :

On my other Precise installation (on a different PC), iot works flawlessly. Strange.

Daniel van Vugt (vanvugt) wrote :

It sounds like a race condition that only happens on slow or really busy machines. I'm the the process of installing on a very slow machine to try and test this bug.

Daniel van Vugt (vanvugt) wrote :

OK, I have a netbook I can reproduce the bug on now. My comments #25/#26 did not fix it so don't bother. I'll keep investigating.

Daniel van Vugt (vanvugt) wrote :

Narrowed the problem down to TapTimeUnderLimit() returning false, even though was_tap==true. No idea why it returns false on slow/busy machines. Maybe we need to use more accurate timing functions?

void Controller::HandleLauncherKeyRelease(bool was_tap)
{
  if (pimpl->TapTimeUnderLimit() && was_tap)
  {
    pimpl->SendHomeActivationRequest();
  }

If someone could solve this before I wake up tomorrow, that would be excellent...

"Narrowed the problem down to TapTimeUnderLimit() returning false, ... on slow/busy machines"

...
bool Controller::Impl::TapTimeUnderLimit()
{
  int time_difference = TimeSinceLauncherKeyPress();
  return time_difference < local::super_tap_duration;
}
...

I don't have a fix, but it isn't surprising that on a slow machine things* take longer.

* whatever is measured by "time_difference" is greater than "super_tap_duration". Apparently there's more to it than the physical keypress.

Robert Carr (robertcarr) wrote :

I am currently experiencing this bug on my quite fast desktop so my intuition is that it is just not just slow/busy machines.

Also if I am on the empty workspace, first super will not work at all. However, I can race opening the dash with super, with closing say an indicator menu...which seems to indicate it's something more?

Robert, is nautilus set to draw desktop on your system ?

i.e org.gnome.desktop.background show-desktop-icons set to True

Changed in unity:
status: Confirmed → In Progress
Omer Akram (om26er) on 2012-03-17
Changed in unity:
milestone: none → 5.8.0
importance: Medium → High
Changed in unity (Ubuntu Precise):
status: Triaged → In Progress
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Daniel van Vugt (vanvugt)
summary: - Unity 5.6: key bindings (such as Super) don't work on empty workspace
+ Unity 5.6: key bindings (such as Super) don't work on empty workspace or
+ on slow/loaded systems
Curtis Hovey (sinzui) wrote :

I am experiencing the keybinding failure on empty workspaces on a very fast computer which is idling. Changing the state of org.gnome.desktop.background show-desktop-icons does not fix the behaviour. It was True before I started the test.

Claus (linuxuser42) wrote :

Problem is also found here on a somewhat slow Samsung N150P netbook. I have pulled-down the package-source. Any code-change suggestions, e.g. to experiments with the timer durations, is welcome.

Claus (linuxuser42) wrote :

I just tried to adjust a few values inside LauncherController.cpp - the ones commented out being the old values

  const int super_tap_duration = 450; //250
  const int launcher_minimum_show_duration = 1450; //1250
  const int shortcuts_show_delay = 950; //750
  const int ignore_repeat_shortcut_duration = 450; //250

I really don't know what I'm doing. However, I think this actually made the super button work much better on my slow Samsung N150P. But it seems like the success-rate is inverse proportional with the load of the netbook. E.g. starting a few background programs like firefox/youtube, makes the superbutton 'unbound' again.

tags: added: rls-p-tracking
Changed in compiz-core:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz (Ubuntu Precise):
status: New → In Progress
status: In Progress → Confirmed
Changed in unity (Ubuntu Precise):
status: In Progress → Confirmed
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in compiz-core:
milestone: none → 0.9.7.2
Changed in compiz-core:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3059

Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

In progress again. I couldn't reproduce/test the empty desktop problem but I'm told it's not fixed. The slow/loaded machine problem is however fixed.

Changed in compiz-core:
status: Fix Released → In Progress
milestone: 0.9.7.2 → 0.9.7.4
Daniel van Vugt (vanvugt) wrote :

OK, I can finally reproduce the focus problem (sometimes). And I've debugged it enough to confirm it is caused by the fix for bug 806255. I will try to make a fix for this today that doesn't involve reverting the fix for bug 806255.

Didier Roche (didrocks) on 2012-03-22
Changed in unity-distro-priority:
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

Fix committed (v3?) into lp:compiz-core at revision 3066

Changed in compiz-core:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu Precise):
status: Confirmed → Fix Released

1) Ubuntu 12.04 LTS Beta 1 (nightly build)
2) unity: Installiert: 5.8.0-0ubuntu1
compiz: Installiert: 1:0.9.7.2-0ubuntu1

3) Fixed are now: Super+s, Super+w, Super+1..9, Super+arrow-key, Super+Alt+arrow-key. Also pressing the Super key, when a program window is open on the workspace - and shows the dash.

4) Still unfixed is Super on empty workspaces. Holding it for a long time brings up the numbers, the s and the t on the launcher, but it still doesn't stop everytime, when you let Super go, like I can show now in my screenshot. The numbers might remain. Tipping Super short doesn't start the dash yet, neither does tipping it two times, like it does on Unity 5.4.0 sometimes.

The bug that the numbers on the launcher doesn't go away is triggered easier, the longer I press the Super button.
Also it shows - on the launcher bar, that the numbering is broken on the symbols - here another screenshot showing that.
If the numbers are able to go away, the numbers on the symbols are in the right order, with no gap in numbering. Maybe this is a timing problem?

The last screenshot shows, when Super is pressed maybe one or two seconds - and the numbers on the launcher aren't stuck yet.

Work around:
If the numbers are stuck on the launcher - switch to an empty workspace with Ctrl+Alt+arrow-keys and back to the origin workspace, now the numbers on the launcher should be gone.

I was able to reproduce the actual buggy behaviour and recorded a video of it.
Now normaly, pressing super doesn't open the dash. But, when I press ALT+F2 the command window comes up. Pressing ESC and leaving it gives me the oportunity to press Super - and it works. It works as long, until something like the following happens: I switch with CTRL+ALT-arrow-keys the workspace. Again, pressing the Super key doesn't bring up the dash, I do it a second time, press ALT+F2, the command window comes up, press ESC to close it, press Super - and the dash opens.

Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Core 0.9.7.4

Changed in compiz-core:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-03-30
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Sasa Stamenkovic (umpirsky) wrote :

I am affected by this bug on Ubuntu 11.10. How can I install this fix?

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/953089

tags: added: iso-testing

This bug affects me now. On compiz 1:0.9.7.8-0ubuntu1.2 and Unity 5.12

Can somebody else reproduce it?

I'm also affected by this bug. However, I found out that, if I enable Nautilus to manage the desktop, the super key works even if there are no windows open.

I'm on Precise, 64bits, all up to date.

Daniel van Vugt (vanvugt) wrote :

Because this bug is marked Fix Released (rightly or wrongly), you won't get any help adding comments here. Please log your problems as new bugs where they will get more attention.

To post a comment you must log in.