compiz crashed with SIGSEGV in unity::hud::HudIconTextureSource::ColorForIcon()

Bug #935307 reported by Ilya YAROV on 2012-02-18
266
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Precise
High
Andrea Azzarone

Bug Description

compiz crashed with SIGSEGV in unity::hud::HudIconTextureSource::ColorForIcon()

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sat Feb 18 18:42:57 2012
DuplicateOf: https://bugs.launchpad.net/bugs/934364
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x7fbbae53dd4b <_ZN5unity3hud20HudIconTextureSource12ColorForIconEP10_GdkPixbuf+315>: movzbl 0x1(%rcx),%edi
 PC (0x7fbbae53dd4b) ok
 source "0x1(%rcx)" (0x00000001) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::hud::HudIconTextureSource::ColorForIcon(_GdkPixbuf*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 unity::IconTexture::IconLoaded(std::string const&, unsigned int, _GdkPixbuf*) () from /usr/lib/compiz/libunityshell.so
 unity::IconLoader::Impl::ProcessGIconTask(unity::IconLoader::Impl::IconLoaderTask*) () from /usr/lib/compiz/libunityshell.so
 unity::IconLoader::Impl::ProcessTask(unity::IconLoader::Impl::IconLoaderTask*) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in unity::hud::HudIconTextureSource::ColorForIcon()
UpgradeStatus: Upgraded to precise on 2012-02-16 (1 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare video

Related branches

Ilya YAROV (candibober) wrote :

StacktraceTop:
 unity::hud::HudIconTextureSource::ColorForIcon (this=0x4601ec0, pixbuf=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/HudIconTextureSource.cpp:62
 operator() (this=0xf50070, texture=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/HudIcon.cpp:60
 emit (_A_a1=@0x7fff30a20f38, impl=0x1545420) at /usr/include/sigc++-2.0/sigc++/signal.h:1010
 emit (_A_a1=@0x7fff30a20f38, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:2781
 unity::IconTexture::IconLoaded (this=0x1544bc0, icon_name=<optimized out>, size=<optimized out>, pixbuf=<optimized out>) at /build/buildd/unity-5.4.0/plugins/unityshell/src/IconTexture.cpp:172

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity (Ubuntu Precise):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Krzysztof Kierus (mistrz) wrote :

I just have opened notepad in Wine, and then pressed left Alt.
I repeat this crash several times, with different aplications runing under Wine.

Elvis Dominguez (elvisd79) wrote :

I was programming in eclipse.
Held the left alt key to move code (selected lines) up.

chickenSandwich (itforhire) wrote :

I did not have any applications open and was trying to type settings into the hud.

chickenSandwich (itforhire) wrote :

from syslog:
kernel: [21024.263199] compiz[2432] general protection ip:7fda31a68fb3 sp:7fff98483780 error:0 in libunityshell.so[7fda31970000+2e3000]

tags: added: bugpattern-needed
Changed in unity:
status: New → Confirmed
importance: Undecided → High
milestone: none → 5.10.0
Cliffm (c2mcatee) wrote :

Closing Doxbox when it crashed

Andrea Azzarone (azzar1) on 2012-04-11
Changed in unity (Ubuntu Precise):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Andrea Azzarone (andyrock)
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
status: Confirmed → In Progress
Changed in unity (Ubuntu Precise):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2012-04-11
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2012-04-11
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Bruce Pieterse (octoquad) wrote :

I was moving a window from one virtual desktop to another with CTRL+ALT+SHIFT+Right Arrow when the crash occurred. I have also noticed this behaviour in 11.10 with a clean install, which I get two or three times a day randomly. In Ubuntu 11.10 though there is no crash, you can just see compiz reloading the desktop.

Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

A similar crash is still happening --> bug 983646

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers