Ubuntu

Unity launcher does not auto hide when using dragging in Qt softwares

Reported by Jimmy Ng on 2011-04-24
690
This bug affects 166 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
qt4-x11 (Ubuntu)
High
Unassigned
Natty
High
Unassigned
unity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: unity

TEST CASE:
1. start clementine
2. drag a song from the library into the playlist window. The launcher will appear on the left and will not hide afterwards
3. Now install the proposed version of unity, see the problem does not happen.

This does not happen when you choose the option to append to the playlist.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,move,compiztoolbox,regex,vpswitch,grid,mousepoll,gnomecompat,snap,resize,place,commands,animation,imgpng,wall,workarounds,session,unitymtgrabhandles,expo,ezoom,staticswitcher,fade,scale,unityshell]
Date: Sun Apr 24 12:33:34 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Jimmy Ng (jimmyng-au) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Seems similar to bug #753872 but the other one got closed, let's keep this one then, there is also bug #770282 with another testcase

summary: - Unity launcher does not auto hide when dragging music in clementine
+ Unity launcher does not auto hide when dragging music in clementine or
+ other Qt softwares
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
importance: Low → High
Changed in unity (Ubuntu Natty):
importance: Low → High

This is also the case for drag&drop of email accounts in Opera's email sidepane.

Steps to repro:
* Open opera sidepane (hit F4)
* Select Email (you may need to have either email accounts or RSS feeds registered)
* Drag for example the "Feeds" heading
* Launcher will get stuck always open

It also doesn't matter if I change the launcher dodge behavior via ccsm.

I've attached a small video demonstrating the bug. It will not go away until I close the program. I cannot drag an item into there to make it seem like I wanted to drag it to the launcher all along.

Amit Schreiber (gnobal) wrote :

Also happens when you drag a tab in Konsole to reorder the tabs. In that case there's a workaround (which may work for other apps as well):
Right click the tab in Konsole and choose “Detach tab”, then drag the tab in the newly detached window back to where you intended to put the tab in the original window. When you’re done – the launcher will hide itself as it normally would.

Björn Torkelsson (torkel) wrote :

It happens for me when using the linux Spotify client (which is using QT) and dragging a song to a playlist. Work around in this case is to quit Spotify, then the launcher starts to autohide again. It happens no matter if the launcher is visible or not when I start dragging the song to the playlist.

DrKay (dr-jameskay) wrote :

Same problem with Kdenlive with dragging video clips from the Project Tree to the timeline (within the same application).

DrKay (dr-jameskay) wrote :

Additional info re: Kdenlive- Workaround (not ideal) is to drag clips from Project Tree to timeline, save project, quit Kdenlive, then relaunce Kdenlive and re-open project.

OpenSourceWay (opensourceway) wrote :

I can see exactly the same bug in MuseScore (soft based on QT).
When you want to drag an element on the left panel, Unity panel appears and don't want to hide itself.
If I want to hide Unity's menu I have to open an other soft and drag something (like an image in Firefox). After 2 or 3 seconds, Unity's panel auto-hide normally.

OSW

P.S. I'm very very very sorry for my bad english, I'm young and I'm a very bad student :)

Lukas0907 (lukas0907) wrote :

Same thing happens for me if I drag files in p4v (Perforce Visual Client).

Lumeng Lim (lumeng-lim) wrote :

same thing for me. the launcher does not hide even after setting it up in compiz after I upgraded to kernel 2.6.39.

Jacob Illum (jillum) wrote :

Also affects med when using IntelliJ IDEA. I happens every time, but I can't find a consistent reproducible error sequence.

Affected me when using Opera. It came to its original behavior only after closing opera.

Reik Schatz (reik-schatz) wrote :

@Jacob, happens when you drag/drop classes between packages in the project tree.

Sebastian Debray (galaxyxxl) wrote :

This also happens when using Amarok. Im dragging music from the search to the playlist and for some reason the sidebar pops up and stays poped up until I completely close Amarok.

I have same issue here.
It happened i.e. during burning CD in k3b.
After closing k3b program, menu hided.

It happens to me too in LibreOffice writer, Eclipse and Netbeans, every time I'm selecting some text and try to drag it somewhere.

But I have a silly temporary solution. I'm opening chrome browser and select and drag some random text from a random site in the launcher. After that the launcher starts hiding correctly again. This solution works only if I drag text from chrome not for example from LibreOffice writer!

Bado (robertobado) wrote :

I found a silly way to make the menu hide again.

The launcher gets stuck for a number of applications, but I always can make it hide again doing the following:

I am using google chrome as my web browser. Despite of which application actually make the launcher stuck, I can go to chrome, detach one of the tabs and reattach it again.

For some reason this makes unity launcher hide normally again. Until this is fixed, this could be a workaround.

Please let me know if this works for you guys. I haven't tested with Firefox, but it may work as well.

Bado see the post above #19!

Particle (particle) wrote :

#20 works for me.

akatdim (akatdim) wrote :

This bug topical for java-applications (like as PyCharm or NetBeans) too.

Thomas Däppen (daha) wrote :

I noticed this bug also only when using java-applications so far.

#20 works for me too. Awesome workaround! Thanks a lot!

sdaau (sd-imi) wrote :

God damn it, just make a button/shortcut which will:

* Force hide the bar
* Force show the bar
* Set the bar in auto-hide mode

... instead of me trying to figure out what application locked the bloody bar, and trying to drag tabs and whatnot. If it was done like that in the first place, I doubt I (and possibly, others) would have cared much if some application freezes the bar or not (since I could have always "forced" it to behave properly).

sdaau (sd-imi) wrote :

PS: For me it doesn't autohide for OpenOffice Calc and Firefox running together..

A workaround that works for me is dragging some icon from the desktop to the launcher and back again. After that it hides correctly (until some qt or java program makes it stick again).
Workaround described here:

https://bugs.launchpad.net/unity/+bug/763275/comments/4

vasilisc (vasilisc) wrote :

This bug affects me
[Ubuntu release]
Release: 11.04
Codename: natty

[uname]
Linux vasilisc 2.6.38-10-generic #44-Ubuntu SMP Thu Jun 2 21:32:22 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

[unity version]
 3.8.14-0ubuntu1~natty1

[unity version]
 3.8.14-0ubuntu1~natty1

it seems to be fixed for me. 11.04 with proposed and backports updates activated

Lukas0907 (lukas0907) wrote :

Still unfixed for me with unity 3.8.14-0ubuntu1~natty1

To Do (entodoays) wrote :

It happens to me too. I use a java program called Freeplane. I noticed that when I delete a node, I get a confirmation dialog box and at that moment unity launcher pops out and stays there until I use one of the fixed mentioned.

This is not the only situation when launcher covers a window. It happens "randomly" with Libreoffice (with java enabled).

Quite annoying.

ubeagle (fun-stuff) wrote :

Still unfixed and very annoying. There is a newer duplicate bug #784520 which says that toggling Num Lock makes the launcher hide again as well.

Bado (robertobado) wrote :

I am disappointed to see that such an annoying bug, which is featured in a new resource widely published by Canonical as being innovative, has so many people being affected by but haven't been prioritized to be fixed... :/

Please refrain from using this bug report for personal complaints. The issue is known and documented; yelling will not improve the situation. Comments should concern the bug's completion only.

Sebastien Bacher (seb128) wrote :

The issue there is not an Unity one but a Qt bug, Jason (one of the unity maintainers) says "Qt XDND does not release the XSelection when it's done with it"

summary: - Unity launcher does not auto hide when dragging music in clementine or
- other Qt softwares
+ Unity launcher does not auto hide when using dragging music in Qt
+ softwares
summary: - Unity launcher does not auto hide when using dragging music in Qt
- softwares
+ Unity launcher does not auto hide when using dragging in Qt softwares
Changed in qt4-x11 (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
status: Triaged → Confirmed
Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
importance: Undecided → High

Le jeudi 23 juin 2011 à 14:18 +0000, ubeagle a écrit :
> Still unfixed and very annoying. There is a newer duplicate bug
> #784520
> which says that toggling Num Lock makes the launcher hide again as
> well.

This trick works well with LibreOffice calc.

François

Got the same bug here. It happened twice today but can't figure out what actions did I make that causes the bug.
It appears randomly - non of the reported actions that causes the bug in #784520 can make this problem.

Got the same bug with NetBeans. The workaround that I use is just dragging a tab in Firefox (just a bit, don't even need to actually change its place).

Izidor Matušov (izidor) wrote :

It seems to me that just any "supported" dragging hide the launcher, e.g. dragging file icons in Nautilus.

sahas (napster-it) wrote :

#20 works for me as well. @Bado for president ! (at least till unity is patched) :-)

I believe this issue to be fixed in Ubuntu 11.10 Alpha-3 as I can't
reproduce it.

On Fri, Aug 5, 2011 at 10:24 PM, sahas <email address hidden> wrote:
> #20 works for me as well. @Bado for president ! (at least till unity is
> patched) :-)
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/769703
>
> Title:
>  Unity launcher does not auto hide when using dragging in Qt softwares
>
> Status in Unity:
>  Confirmed
> Status in “qt4-x11” package in Ubuntu:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
> Status in “qt4-x11” source package in Natty:
>  Confirmed
> Status in “unity” source package in Natty:
>  Confirmed
>
> Bug description:
>  Binary package hint: unity
>
>  To recreate the stuck unity launcher.
>  1. start clementine
>  2. drag a song from the library into the playlist window. The launcher will appear on the left and will not hide afterwards
>
>  This does not happen when you choose the option to append to the
>  playlist.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.8.10-0ubuntu2
>  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic x86_64
>  Architecture: amd64
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,move,compiztoolbox,regex,vpswitch,grid,mousepoll,gnomecompat,snap,resize,place,commands,animation,imgpng,wall,workarounds,session,unitymtgrabhandles,expo,ezoom,staticswitcher,fade,scale,unityshell]
>  Date: Sun Apr 24 12:33:34 2011
>  EcryptfsInUse: Yes
>  ExecutablePath: /usr/lib/unity/unity-panel-service
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
>  ProcEnviron:
>   SHELL=/bin/bash
>   LANGUAGE=en_US:en
>   LANG=en_US.UTF-8
>  SourcePackage: unity
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/769703/+subscriptions
>

Andrea Azzarone (andyrock) wrote :

Omer Akram, i can confirm... this bug should be fixed (https://code.launchpad.net/~vanvugt/unity/fix-805327).

Omer Akram (om26er) wrote :

anyone facing the issue in Natty please test this ppa
https://launchpad.net/~om26er/+archive/unity and see if it fixes the
issue

The updated unity package from om26er's ppa (#43) seems to fix the problem for me.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
Omer Akram (om26er) wrote :

The issue is fixed in Oneiric and it seems the problem was in Unity itself so closing the Qt4 tasks as well

Changed in unity (Ubuntu Natty):
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in qt4-x11 (Ubuntu):
status: Confirmed → Invalid
Changed in qt4-x11 (Ubuntu Natty):
status: Confirmed → Invalid
Omer Akram (om26er) on 2011-08-10
description: updated
Chris Halse Rogers (raof) wrote :

The upload for natty-proposed looks good, but I've got a couple of minor quibbles:
 - it's got an unrelated change to vapi/Makefile.am
 - the version should probably be 3.8.16-0ubuntu1~natty2

The versioning quibble is something reasonable men can disagree about, but the vapi/Makefile.am change either shouldn't be there, or should have a reason documented in the changelog why it must be there.

I've rejected the upload from the natty-proposed queue; please make a new upload with those issues addressed, and it can head into -proposed.

Changed in unity (Ubuntu Natty):
status: Confirmed → Incomplete
DrKay (dr-jameskay) wrote :

Omer's 3.8.16-0ubuntu1~natty1.1 from Omer's ppa in #43 above worked well for me using Digikam.

Thank you for your work! Much, much appreciated!

Changed in unity (Ubuntu Natty):
status: Incomplete → Fix Committed
Sebastien Bacher (seb128) wrote :

I've reuploaded the fixed version

Hello Jimmy, or anyone else affected,

Accepted unity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Tested. It seems to have fixed the problem. Not seeing any regressions.

Martin Pitt (pitti) on 2011-08-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1~natty2

---------------
unity (3.8.16-0ubuntu1~natty2) natty-proposed; urgency=low

  * src/Launcher.cpp:
    - Launcher does not autohide after drag in Qt apps. (LP: #769703)
 -- Omer Akram <email address hidden> Mon, 15 Aug 2011 16:26:52 +0500

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Nice to know the fix for bug 805327 actually fixed something :)

tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions