Ubuntu

In a double monitor setup the Unity top panel in the second screen is cut at the right

Reported by Walter Garcia-Fontes on 2011-04-04
214
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Unity
Low
Neil J. Patel
unity (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned

Bug Description

=== Test case ===

1. Install unity 3.8.16 from natty-proposed
2. Setup dual monitors so you have two panels
3. Start Skype/Mumble/any-app-that-uses-old-systray
4. Exit the application started in 3 (completely exit)
5. Every panel should still have all the indicators visible

===

Binary package hint: unity

I use a dual monitor setup. In the second screen, which I have on the right of the main screen, the Unity top panel does not seem to show everything on the right. The logout menu seems to be there but not shown. I attach a screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Mon Apr 4 18:54:59 2011
DistroCodename: natty
DistroVariant: ubuntu
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-01 (3 days ago)
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1

Just a clarification, the screenshot shows how I see the rightmost part of the panel in the second screen.

Omer Akram (om26er) wrote :

Could you please attach a full screenshot of your screen so that things are easy to understad.

Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete

I attach scrrenshots of my first and second sceen. I have a conky running in the second screen.

The truncation in the Unity top panel in the second screen is not reproduced in all logins.

Changed in unity:
status: Incomplete → New
Changed in unity (Ubuntu):
status: Incomplete → New
Alex Launi (alexlauni) wrote :

is it just the panel that goes off of the edge, or do applications go over as well?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete

It is just the panel, but right now this system cannot use Natty at all, it freezes after a couple of minutes of use, so this is quite low priority with respect to making Unity workable again. I updated 10 days ago and for the first 4 o 5 days it was very stable, but starting on Thursday last week it started freezing. Reported in bug 757387.

Changed in unity:
status: Incomplete → New
Changed in unity (Ubuntu):
status: Incomplete → New

I mean it cannot use Unity, Natty with Ubuntu Classic is fine.

Sebastien Bacher (seb128) wrote :

Could you try if that's still an issue, there was 2 updates this week and quite some bugs fixed some concerning dual screen

Yes, it is still here. I attach a screenshot of my second screen. But please assign low priority to this.

Now, I just got a large set of updates (compiz, unity, you name it) and it seems that the panel in the secon screen looks OK. I mark a invalid and reopen if I notice any problem.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Alex Launi (alexlauni) on 2011-04-11
Changed in unity:
status: Invalid → Confirmed
importance: Undecided → Low
Changed in unity (Ubuntu):
status: Invalid → Confirmed
importance: Undecided → Low

With the updates received on April 15 I see the panel in the second screen OK, everything is complete.

I will close this bug as this issue has completely dissapeared because now the panel in the second monitor just shows window titles and global menus and no panel indicator, as it should be.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid

I still see this in a dual monitor setup, now the hidden part of the indicators is even larger. The indicators shouldn't be there at all, in my opinion, they should only be in the main monitor.

Changed in unity:
status: Invalid → New
Changed in unity (Ubuntu):
status: Invalid → New

Forgot to comment I'm fully updated up to April 20, Unity 3.8.10

Alex Launi (alexlauni) on 2011-04-20
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed

Still seeing this fully updated upt to April 26

I can confirm the same behavior with Walter as of April 28th. The secondary monitor's top panel is cut in the right.

gdi2k (gdi2k) wrote :

I can confirm this too with a fully updated Natty system as of 30-Apr-2011.

I'm running a Lenovo X200 with two external screens attached (laptop screen is disabled). Intel graphics. Both screens are set to 1920x1080. The unity panel on the left screen is fine (primary), but the right screen has the panel cut off. See screenshot.

mabawsa (mabawsa) wrote :

I am getting this as well.

franco_bez (franco-bez) wrote :

The panel does not only get cut off on the right,
but if you work in a dual monitor setup, the indicator icons get shifted to the right by a few pixel from time to time.
At first only the System-Indicator (Shutdown Menu) is off the screen, After a few hours of continuous work i noticed that even the clock and mail indicators were gone.
A few hours later all the indicators were gone.
When I hit F10 the Menus do appear, but the indicator-icons are still off the screen.

Using the Control-Panel (Monitor - Settings) I switched off the second Monitor - hit apply - and keep Settings, then switched the second Monitor back on - hit apply -keep settings, the Indicators came back where they should be - all of them.

But once again they kept on shifting to the right as I continued working.

Very strange.

I confirm that I see exactly the same as franco_bez

franco_bez (franco-bez) wrote :

I found one way to provoce the shift of the indicators:

Open Skype ( or an other application that uses the old notification area ) and then quit skype so the icon disappears from the top Panel.

Then the indicators on the 2nd screen shift.

Rocko (rockorequin) wrote :

@franco_bez: well spotted! I confirm that on my second screen the indicators shift right whenever I close an app that is displayed in the tray. I tested with both Skype and Pidgin.

franco_bez (franco-bez) wrote :

Hit ALT-F2 and run
unity --replace

this temporaily fixes the Panel. (Also other Dual Monitor issues)

bob (icedout3e) wrote :

Chiming in to say that I am also affected by this bug.

Dual monitors with an ATI Radeon HD 3450

Buh (thebuh) wrote :

I'm also affected by this bug. And i can also confirm franco_bez's way of reproducing this bug - every time you quit Skype or other application that have a tray icon, tray area on second screen shifts off the edge a bit.

Felix Dreissig (f30) wrote :

I can exactly confirm the behaviour described by franco_bez as well. Dual-monitor setup with Intel graphics.

According to http://askubuntu.com/q/42940 this also happens after waking up from suspend (not tested by myself).

Grzegorz Śliwiński (fizyk) wrote :

Felix, It's at least how I noticed this happening. however later I noticed that it isn't only after waking up from suspend.

franco_bez (franco-bez) wrote :

I'm wondering why this is still "unassigned".
Is there really nobody feeling responsible for the fix ?

Oweoqi (oweoqi) wrote :

@franco_bez It's an ugly bug, but it's hardly a critical issue. I'm sure this will be fixed but we just have to be patient. The fact of the matter is that the issue has existed for over a month now, if it was a simple issue to fix, it would be fixed by now.

Still a problem as of May 18th for my dual monitor setup. Restarting resets the panel to the correct position.

I'm seeing this too. Dual monitors, 2nd monitor's indicators are running away.

rtjmay (rtjmay) wrote :

I am also seeing the same thing with my dual display setup on ATI graphics using the open source driver.

Thankfully the indicators are all duplicated on the second screen so I don't lose access to anything.

I am affected by this as well on two systems with nVidia graphics. For me maximizing is broken on the second display as well, with the maximized window apparently getting as wide as the top panel.

One of the affected systems has two displays with identical resolution, the on other one the displays have different resolutions.

Andrew Keyes (akeyes) wrote :

Came to report this and had a screenshot prepped, so I'll include that.

VGA compatible controller: nVidia Corporation G84 [Quadro FX 570] (rev a1)

Neil J. Patel (njpatel) on 2011-06-09
Changed in unity:
status: Confirmed → Fix Committed
milestone: none → 3.8.16
assignee: nobody → Neil J. Patel (njpatel)
luchon (ichekryg) wrote :

I am affected by issue as well with Intel integrated graphics.

Didier Roche (didrocks) on 2011-06-14
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Neil J. Patel (njpatel) on 2011-06-16
description: updated
Changed in unity (Ubuntu Natty):
status: New → Fix Committed
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1

---------------
unity (3.8.16-0ubuntu1) oneiric; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Launcher tooltips sometimes don´t show (lp: #769335)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
 -- Sebastien Bacher <email address hidden> Thu, 16 Jun 2011 18:10:09 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

I tried to get unity 3.8.16 from natty-proposed but it does not show up, so I got it from the ubuntu-desktop ppa. The indicators on the left in the dual monitor setup seem to be working perfectly. Cheers! one bug less.

Accepted unity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
gdi2k (gdi2k) wrote :

I also tested from the PPA, and it does fix the issue, but app icons that use the old systray now only appear on the left monitor, not both monitors. See attached screenshot. In my case I'm using Skype and KeePassX. Maybe this is a different bug, or not a bug at all?

gdi2k, it seems by design to me, but if you want to raise this issue maybe you can open a specific bug for this. In my opinion all indicators should appear only in the main monitor, but I haven't seen any other similar request, so maybe people are fine with having the indicators duplicated in all monitors.

Sebastien Bacher (seb128) wrote :

Could somebody confirm that the fix is working using the official natty-proposed version?

Sergey Prisacari (prisacar) wrote :

Yes, I installed unity update from natty-proposed and the problem is gone.

I also confirm it is woking.

tags: added: verification-done
removed: verification-needed
Rocko (rockorequin) wrote :

Version 3.8.16-0ubuntu1~natty1 from natty-proposed fixes it for me.

Felix Dreissig (f30) wrote :

@gdi2k: Even in previous versions, they always appeared on the most left monitor; never on all monitors.
This is known as Bug #742530 (maybe also Bug #737015), but seems hard to fix.

Tom Bamford (tombamford) wrote :

Problem fixed for me with unity-3.8.16-0ubuntu1~natty1 from natty-proposed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1~natty1

---------------
unity (3.8.16-0ubuntu1~natty1) natty-proposed; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
  * Revert commit for bug #769335, to fix a launcher autohidding issue
 -- Sebastien Bacher <email address hidden> Fri, 17 Jun 2011 12:22:35 +0200

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
franco_bez (franco-bez) wrote :

I can confirm that the indicators do no longer shift on my Acer Travelmate 6292 ( Intel Graphics ).

Still I'm not completely happy, as one issue remains:

When I connect the external Monitor the Top Panel has a nasty Background, the lower 1/4 of the Panel has the wrong color (see image attached)
When I call "unity --replace" the panel looks OK.
Disconnecting and reconnecting the Monitor, the panel looks ugly again.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers