Ubuntu

cannot paste into dash (particularly relevant for alt+f2)

Reported by Greg A on 2011-03-16
730
This bug affects 151 people
Affects Status Importance Assigned to Milestone
Unity
Low
Neil J. Patel
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

For instance:
1. copy "ubuntu-bug unity" onto the clipboard
2. press alt+f2 to open the dash
3. ctrl+v
4. see screenshot

Related bugs:
Cut doesn't work: bug #737731
Copy doesn't work: bug #737732
Undo doesn't work: bug #793677

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,vpswitch,move,animation,imgpng,shift,mousepoll,grid,gnomecompat,place,workarounds,wall,wobbly,expo,ezoom,staticswitcher,session,fade,scale,unityshell]
Date: Wed Mar 16 16:34:02 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-09 (6 days ago)

Greg A (etulfetulf) wrote :
Greg A (etulfetulf) wrote :

Possibly caused by, but definitely related to Bug #736162

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Bazon (bazonbloch) wrote :

Doesn't work for pasting by mouse middle click (normally enters highlighted text).
Please fix this, middle-click-pasting is a good and useful linux tradition!

Eric Appleman (erappleman) wrote :

Would like an importance assigned to this bug.

joopbraak (joopbraak) wrote :

Tagging it " regression-release" because it used to work with Alt+F2.

Maybe then this bug will get more attention.

tags: added: regression-release
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
David Barth (dbarth) wrote :

@Jason: I think you had something in preparation for fixing this bug, so I'm assigning it to you. Otherwise, feel free to see w/Mirco, as he is probably looking into the same code base to fix the dead keys support problem.

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Unseen (unseen-mail) wrote :

I would love a fix for that too, especially middle click pasting is nice! Additionally launching programs with arguments would also be very nice, like "vncviewer address:display", which does not work in the dash.

Benjamin Tayehanpour (konaya) wrote :

@Unseen: That'd be a different regression bug. File it if it hasn't already been filed.

Axel Pospischil (apos) wrote :

Very very annoying. That is really a big regression.

How can this be low importance? It's quite a bad usability issue. The dash doesn't support pasting *at all* in any context, the most painful ones being alt+2 run dialog and file Dash. Make it Medium at least please.

Ivan Akulov (gxoptg) wrote :

Copying from dash does not working too. It's not necessary to fix, but this possibility will be more pleasant to work with Dash.
[[I'm sorry, I speak English small. Original Russian text:]]
Также не работает копирование. Это не обязательно для исправления, но с этой возможностью работать с dash будет удобнее.

description: updated
Oldarney Maslata (oldarney) wrote :

shift-insert doesn't work either. alt-f2 with a long path is extremely painful without copy/paste.

+ for assigning higher priority

vlab22 (vlab22) wrote :

+ for assigning higher priority too

Buenol (bwenaul) wrote :

+ for assigning higher priority

Paul Sladen (sladen) wrote :

A reasonable work-around for this for the moment is to use 'gnome-terminal' and then do the command-editing in that; this also gets you bash-completion (name, argument and file-path completion).

Avidan Borisov (avidanborisov) wrote :

+ for assigning higher priority

DeadVirus (amfcosta13) wrote :

Why is this low priority? This is a feature regression (in relation to previous versions).

+ for assigning higher priority

Daniil (stddos) wrote :

+ for assigning higher priority. SHIFT+INSERT are not working too.

Magnes (magnesus2) wrote :

+ for assigning higher priority

Patrick Scott (patrickscott52) wrote :

Yes, I really hope this bug will be fixed for Oneric! Not being able to paste in the dash gives a really low quality feel to it - it's just another reasons for bloggers to "hate" Unity even though it is progressing in the right direction

+ for assigning higher priority

falkTX (falk-t-j) wrote :

+ for assigning higher priority

Patrick Scott (patrickscott52) wrote :

I just noticed this bug has been fixed in Unity 2D on Oneric Alpha 3. Can somebody confirm is this has been fixed in Unity 3D too? If it has been, I guess this bug can be closed! :)

Patrick Scott (patrickscott52) wrote :

Just tested in Unity 3D (only got it working on VBOX now) on Oneric Alpha and the bug still exists there even though it has been fixed in Unity 2D. It looks like Unity 2D is more stable all around in Oneric - Let's hope they get this and some of the other Unity 3D issues resolved during the beta phase...

Omer Akram (om26er) on 2011-08-31
Changed in unity:
milestone: none → 4.12.0
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
Omer Akram (om26er) on 2011-08-31
Changed in unity:
assignee: Jason Smith (jassmith) → Neil J. Patel (njpatel)
Neil J. Patel (njpatel) on 2011-09-01
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-09-01
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.12.0-0ubuntu1

---------------
unity (4.12.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - P3: [natty] Cannot click on indicators (LP: #819202)
    - Icons not visible in the launcher or alt-tab switcher (LP: #833905)
    - [dash] Search field in Unity can not support iBus (LP: #663776)
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - SysTray icons have a white square background in Unity. (LP: #823407)
    - new dash does not fit a normal netbook screen (LP: #825370)
    - Dash picks random weird colors (yellow, green), fonts invisible (with
      blur en- or disabled) (LP: #828363)
    - Music Lens doesn't display items until you search (LP: #824892)
    - Dash - Adjustments to stateful behaviour (LP: #838667)
    - Dragging from dash to launcher still doesn't work (LP: #824833)
    - Click on 'More Apps' et al closes the dash (LP: #824842)
    - cannot paste into dash (particularly relevant for alt+f2) (LP: #736222)
    - Ctrl X doesn't cut selected text in Dash search field (LP: #737731)
    - Ctrl+C doesn't copy selected text in Dash search field (LP: #737732)
    - The indicators shows a big white square when systray whitelisted
      (LP: #822672)
    - ARM FTBFS fix (LP: #834576)
  * debian/control:
    - build on latest nux
  * debian/rules:
    - bump shlibs
 -- Didier Roche <email address hidden> Thu, 01 Sep 2011 17:33:06 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers