[FFe/UIFe] Unity launcher gets cluttered when having multiple partitions and/or external volumes attached

Bug #713423 reported by Alex Moldovan on 2011-02-04
218
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Andrea Azzarone
ubuntu-docs (Ubuntu)
Low
Unassigned
Raring
Low
Unassigned
unity (Ubuntu)
Medium
Andrea Azzarone
Raring
Undecided
Unassigned

Bug Description

Having a multi-boot system, multiple partitions, USB keys, SD cards and external hard drives makes Unity launcher cluttered very quick (see screenshot).

To resolve this issue the following changes are required:

1) It should be possible to remove specific file system icons from the Launcher by un-checking the “Unlock from Launcher” option (or dragging to the trash).

2) In the case of non-removable file systems, the system should remember these settings so that rebooting will not return these icons to the Launcher.

3) In the case of removable file systems (USB keys, SD cards, etc...), if a removable file system is removed and then re-attached it should re-appear in the Launcher. If the removable file system is not removed and the user has removed it's icon from the Launcher, the icon should not return to the Launcher even if the computer is re-booted.

4) All 'specific file system' icons that the user has removed from the Launcher should be displayed in the Dash file Lens in the “Favourite Folders/Folders” category. This allows the user to re-add these icons to the Launcher at a later date.

Mailing list links
------------------
# doc: https://lists.ubuntu.com/archives/ubuntu-doc/2012-September/016829.html
# translator: https://lists.ubuntu.com/archives/ubuntu-translators/2012-September/005567.html

Related branches

Alex Moldovan (alexmoldovan) wrote :
summary: - Unity launcher gets cluttered when having multiple partitions and/or usb
- drives
+ Unity launcher gets cluttered when having multiple partitions and/or
+ external volumes attached

I have also reported exactly these two issues, but focused on the questionmark icon instead of the cluttered launcher, see bug #710809

Changed in unity (Ubuntu):
status: New → Confirmed

Thanks for the report. I think you are correct, I've sent a proposed
solution to John Lea in the design team and will ask him to update the
bug report accordingly.

 status confirmed

Mark

I to find this annoying. I dont want USB's and CD-rom's on my unity launcher bar. But i think it is ok that they show up as desktop icons. The other partitions on my hdd with other systems i dont want in my unity launcher nor as desktop icons. Would love for an easy or complicated howto to hide the unwanted elements.

Alex Launi (alexlauni) on 2011-02-18
Changed in unity:
status: New → Opinion
status: Opinion → Confirmed
John Lea (johnlea) on 2011-02-23
description: updated
tags: added: udt
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → John Lea (johnlea)
David Barth (dbarth) on 2011-03-01
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
Neil J. Patel (njpatel) on 2011-03-01
Changed in unity:
milestone: none → 3.6.4
David Barth (dbarth) on 2011-03-01
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
David Barth (dbarth) on 2011-04-08
tags: added: too-late
Changed in unity:
milestone: 3.8.6 → backlog
zzarko (zzarko-gmail) wrote :

Sorry if I'm asking a question with obvious answer, but is this problem solved? I would really like to blacklist some of my partitions from showing in launcher. A simple dialog box titled Blacklist (or something like this), with all storage devices listed and checkbox for each one would be the perfect solution for me (what is checked - it doesn't show in launcher). Or even an edit box (or gconf option) where blacklisted paths could be entered manually (something like Mount screenlet) would be fine.

Olivier Tilloy (osomon) wrote :

@zzarko: the status of the bug in both unity and unity-2d is 'Confirmed', meaning it isn’t fixed yet. There has been design work to solve it though, as suggested by the status of the bug for the Ayatana Design project.

John Lea (johnlea) on 2011-04-19
tags: added: udo
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: backlog → ux-backlog-1
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Jorge Castro (jorge) on 2011-06-07
tags: added: backlog
Andrea Azzarone (azzar1) on 2011-06-22
Changed in unity:
status: Confirmed → In Progress
assignee: Neil J. Patel (njpatel) → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2011-06-23
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2011-07-26
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2011-08-01
Changed in unity:
milestone: none → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.6.0-0ubuntu1

---------------
unity (4.6.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in __strlen_sse2() (LP: #814619)
    - PlacesHomeView::PlacesHomeView leaks memory (LP: #818450)
    - PluginAdapter::MaximizeIfBigEnough leaks memory (LP: #818477)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Launcher - clicking on a App launcher icon incorrectly un-minimizes
      windows (LP: #783434)
    - Unity doesn't get any mouse wheel scroll event in Indicators InputArea
      (LP: #814574)
    - Unity launcher gets cluttered when having multiple partitions and/or
      external volumes attached (LP: #713423)
    - Unity panel menus and indicators slow to respond. Too much lag.
      (LP: #742664)
    - In Unity the distinction between GVolume, GDrive and GMount is a bit
      confusing. (LP: #799890)
    - Launcher - When a item is deleted by dragging to Trash, the trash should
      pulse once before the Launcher disappears (LP: #750311)
    - ccsm needs an option to change launcher opacity (LP: #815032)
    - add a ccsm option to hide volumes in launcher (LP: #794707)
    - scale plugin doesn't work as desired when "Click Desktop To Show
      Desktop" is true (LP: #810315)
    - mute/unmute sound when user clicks on sound applet using scroll button
      or middle mouse button (LP: #609860)
    - Secondary activate (i.e. middle click) support for indicators advanced
      usage (LP: #812933)
  * debian/control:
    - dep on latest libunity-misc
    - dep on latest nux
    - add build-dep on libgnome-desktop-3-dev
  * debian/rules:
    - bump libunity-core-4.0-4 shlib for ABI break
    - don't ship unity dialogs right now. Not ready for alpha quality
  * distro-patch the grey to darker grey (until the blur is done in nux)
  * Switch to dpkg-source 3.0 (quilt) format
  * debian/patches/01_revert_removed_function_for_unity2d_to_build.patch:
    - revert a removed API making unity-2d not building
 -- Didier Roche <email address hidden> Mon, 01 Aug 2011 19:53:15 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Tested with a USB stick and fails the following tests:

- No 'Keep in Launcher' option displayed (see item 1 in the bug description)
- Unable to test item 3 due to lack of 'Keep in Launcher' option
- Unable to test item 4 for the same reason.

Reverting to confirmed

Changed in unity:
status: Fix Released → Confirmed
Neil J. Patel (njpatel) on 2011-08-25
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Andrea Azzarone (azzar1) on 2011-08-25
Changed in unity:
assignee: Andrea Azzarone (andyrock) → nobody
Andrea Azzarone (azzar1) wrote :

@JohnLea

"1) It should be possible to remove specific file system icons from the Launcher by un-checking the “Keep in Launcher” option (or dragging to the trash)."

What happens if a usb icon is dragged to the trash: it should be un-pinned or it should be ejected?

Andrea Azzarone (azzar1) on 2011-09-03
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2011-09-03
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress

@Andrea: I think we should dump blacklisted devices in a file formatted like your ~/.gtk-bookmarks, stored in something like ~/.local/share/unity/device-blacklist. We already have a parser in the files lens for this format hence the reuse.

The gtk-bookmarks file has a format ala:

<uri> [label]
<uri> [label]
...

So for my particular setup it could look like:

$ cat ~/.local/share/unity/device-blacklist
file:///media/Windows7_OS
file:///media/SYSTEM_DRV
$

And the files lens would just parse this file and append it to the Folders category.

Given all this, I don't know if unity supports dragging devices into the launcher yet? So that may be a work item as well.

Andrea Azzarone (azzar1) wrote :

Why not use gsettings? Currently we use it to save a whitelist, I have already converted to a blacklist.

In the lense the blacklist become a whitelist. Is it possible something like that in a lense?

That would create a dep from the lenses on the Unity gsettings schemas which is no catastrophe, but not really elegant either... It does have the advantage of giving us change notifications for free though.

I was also considering adding something to libunity on this because both the unity, files lens, and others might be interested in this data. But that may grow the task out of scope for now as a good api needs some thought...

Andrea Azzarone (azzar1) wrote :

Ok, return to the solution of comment #10. To implement dnd of devices into the launcher i think we should use a prefix, something like:

device:///....

Instead of using a path what about using the uuid? So

device:///1123581321-34

uuid works for (most) flash and hard drives, but not necessarily network mounts, optical drives or other... But I guess Unity needs some way to figure out that something is a device in order to place it at the correct position in the Launcher.

I agree that using mount path is slightly hacky though - but it will be reliable for almost all users. Eeek - except I just discover that CD-ROMs are mounted under /media/$disk_label :-/

Andrea Azzarone (azzar1) wrote :

Network mounts are not considered in Unity and IMHO it makes no sense blacklist a cd-rom.

John Lea (johnlea) wrote :

@andyrock

To answer your question "What happens if a usb icon is dragged to the trash: it should be un-pinned or it should be ejected?"

It should be ejected (and of course also un-pinned)

Andrea Azzarone (azzar1) wrote :

@John Lea: a cd-rom icon should have the quicklist item: "Keep in launcher"?

John Lea (johnlea) wrote :

@andyrock

re. your question "a cd-rom icon should have the quicklist item: "Keep in launcher"?"

Yes, a cd-rom should have the quicklist item "Keep in launcher". A user might not want their cd-rom displayed in their Launcher. They can always add it back to the Launcher at a later date by searching for it in the Dash, and drag and dropping it back into the Launcher, see point 4 in the bug description.

thanks!

Omer Akram (om26er) on 2011-09-17
Changed in unity:
milestone: 4.6.0 → backlog
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Andrea Azzarone (azzar1) on 2012-01-26
Changed in unity:
status: In Progress → Triaged
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2012-02-21
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Andrea Azzarone (azzar1) on 2012-08-09
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2012-08-14
Changed in unity:
milestone: backlog → 6.4
description: updated
Andrea Azzarone (azzar1) on 2012-08-30
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Update: Unity 6.4 is revision 2632, so this is actually fix committed for Unity 6.6.

Changed in unity:
status: Fix Released → Fix Committed
milestone: 6.4 → 6.6
Andrea Azzarone (azzar1) on 2012-09-11
summary: - Unity launcher gets cluttered when having multiple partitions and/or
- external volumes attached
+ [FFe/UIFe] Unity launcher gets cluttered when having multiple partitions
+ and/or external volumes attached
Changed in unity:
status: Fix Committed → New
Changed in unity (Ubuntu):
status: Fix Committed → New
description: updated
Omer Akram (om26er) on 2012-09-11
Changed in unity-2d (Ubuntu):
status: Confirmed → Won't Fix
Changed in unity-2d:
status: Confirmed → Won't Fix
Andrea Azzarone (azzar1) on 2012-09-11
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-09-11
Changed in unity (Ubuntu):
status: Confirmed → New
Jeremy Bicha (jbicha) wrote :

Ok, +1 from the Docs Team.

Changed in ubuntu-docs (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
manny (estelar57) wrote :

A type of "Drawer", might also be another solution for this. i.e. :

http://www.iloveubuntu.net/create-bundles-files-and-folders-unity-launcher-fancy-drawers-ppa-available

Iain Lane (laney) wrote :

I think this seems sensible, but I'm a little unclear about what I'm supposed to be approving. I see this was apparently partially, but not completely, fixed in Oneiric. What's changing now? How bad is the current situation?

Iain Lane (laney) wrote :

Oh, and when can this land?

Setting to Incomplete, please reset to New once you've provided this info. Thanks :-)

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
John Lea (johnlea) wrote :

It was not fixed in Oneiric unfortunately, but it is ready to land now ;-)

This is a much requested change, giving the user the ability to configure their Launcher icons as they please. For example this change would enable a user to place their workspace switcher launcher iconat the top of their launcher if they so choose. This functionality has been requested by many, many, many users since we originally launched Unity.

Changed in unity (Ubuntu):
status: Incomplete → Triaged
Omer Akram (om26er) on 2012-09-17
no longer affects: unity-2d
Changed in unity:
status: New → Triaged
no longer affects: unity-2d (Ubuntu)
Iain Lane (laney) on 2012-09-17
Changed in unity (Ubuntu):
status: Triaged → New
Changed in unity:
milestone: 6.6 → 7.0
status: Triaged → Fix Committed
Iain Lane (laney) wrote :

Approved, please go ahead ASAP

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 6.6.0-0ubuntu1

---------------
unity (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixes non-escaped character sequences in dash previews (LP: #1039020)
    - Updated background layer for preview cover-art and details panels
      to be 10% low-light
    - Expand a PlacesGroup if it is the only category that contains results
      (LP: #950710)
    - Update unity autopilot tests to match autopilot API
    - Updated the convert files to fix some typos in the key names
    - Add gmodule dependency
    - Activate proper result if the categories aren't displayed in-order
      (LP: #1040101)
    - Refactor device launcher icons (LP: #713423)
    - LauncherController: make the controller enable the launcher struts,
      based on hide-mode option (LP: #1044005)
    - Launcher: make always possible to drag an icon to the bottom or top
      of its sub list (LP: #1043968)
    - Don't desat bfb/hud icon in DNDReset (LP: #1043963)
    - Progressively adjust the speed of the minimize animation. First
      time it is used is slower, then speeds up the more it is used.
      (LP: #1017510)
    - Implement new ordering of categories for home lens. (LP: #1043915)
    - UnityWindow now implements ScaleWindowInterface (LP: #876017)
    - Launcher: restore an icon position after that the dragging has been
      cancelled (LP: #955561)
    - LauncherDragWindow: cancel drag on window mapped/unmapped
      (LP: #1044723)
    - Now there is a check of an override color in RefreshColor (which is
      called when a PropertyNotify event happens). Also added a check in
      FullySaturateColor to a void division by zero. (LP: #975350)
    - Queue redraw after cover-art texture is updated from a url/file source.
      (LP: #1043947)
    - Fixed ability to delete glib::Source wrapper during its callback
      (LP: #1044823)
    - Close preview when dash is hidden. (LP: #1045298)
    - LauncherModel: rewrite the Reordering functions to keep the icon
      priority deltas (LP: #761155)
    - Make sure we can pass extra hints when activating preview actions.
      (LP: #1046352)
    - UnityWindow: scale window code improved (LP: #1033935)
    - The mouse will now cause the HUD buttons to change selection
      (LP: #1042692)
    - "Alt+Space" shortcut to reveal the window menu is not hardcoded, but a
       Compiz key option. " (Hold)" should also be translated. Made all
       Compiz plug-in names and all Compiz plug-in option names in
       unityshell.cpp static constants.
    - remove unity --reset, it's not anymore really needed now that we are
      in stable days of unity and we moved to gsettings
    - Removed the variables 'oldPrev' and 'oldNext' which got assigned the
      value NULL, but then were never used
    - Fixed the size of the previews to 770x380 pixels. (LP: #1045243)
    - UnityWindow: use smart pointers, use static close_icon (with dynamic
      state) and PanelStyle context (LP: #1033935) (LP: #1045127)
      (LP: #1046124) (LP: #1046126)
    - Remove everything in the #ifndef USE_MODERN_COMPIZ_GL ifdefs and remove
      the ifdefs alltogether. unity now requires compiz...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2012-10-11
Changed in ubuntu-docs (Ubuntu):
status: Triaged → Won't Fix
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udo udp udt
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Raring):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in ubuntu-docs (Ubuntu Raring):
status: Triaged → Won't Fix
Changed in unity (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers