Unity plugin should depend on "Desktop Wall" plugin

Bug #683211 reported by Hernando Torque on 2010-11-30
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Currently the "Desktop Wall" plugin is needed to focus an application on a different workspace. Therefore I think it shouldn't be possible to deactivate the "Desktop Wall" plugin without deactivating Unity.

To reproduce:

1.) Start Compiz with the "Desktop Wall" plugin disabled
2.) Open a program like gedit
3.) Switch to another workspace
4.) Open another program like gnome-terminal
5.) Click on the gedit icon in the launcher bar

=> gnome-terminal loses focus, appmenu updates to gedit's menu, no workspace switching.

Related branches

Alex Launi (alexlauni) on 2010-11-30
Changed in unity (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) wrote :

not fixed, will fix it quickly…

Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
status: New → Triaged
Neil J. Patel (njpatel) on 2010-12-01
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
assignee: Didier Roche (didrocks) → nobody
importance: Undecided → High
milestone: none → 3.2.4
assignee: nobody → Didier Roche (didrocks)
Neil J. Patel (njpatel) on 2010-12-02
Changed in unity:
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.4 → 3.2.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
Bowmore (bowmore) wrote :

This fix is a tradeoff in the sence that the introduced Unity dependence to Desktop Wall conflicts with the Cube. In other words the Cube will no longer be a Compiz feature when running Unity. Is that a decision being taken for Unity?

Doug McMahon (mc3man) wrote :

This is an extremely shortsighted decision unless there is some valid reason why the cube shouldn't be used with unity. ATM I don't see any - the cube works fine here with the current 3.2.6 version. What the Op was complaining about is not that important and by default the the Desktop wall is enabled, so where is the problem exactly?

Exactly don't even see the point here at all, following the steps outlined above with the cube enabled the behavior is exactly as expected - is this all about preventing someone disabling the wall and not enabling the cube? - if so, well too bad, the likelihood of that is minute

People should be free to choose as they want, please revert this or at least provide a diff for those that wish to.
(or provide a link to commit that caused this if you could.

Hernando Torque (htorque) wrote :

So you think focusing an application on a different workspace isn't that important? ;-)

Anyways, yes - if any other sane combination of plugins can make this work, the Unity plugin should rather depend on Desktop Wall OR such combinations.

Doug McMahon (mc3man) wrote :

No - what I'm asking is this 'bug' valid if someone doesn't disable the desktop wall which I'll assume will be enabled by default as will the unity plugin?

IF (this bug), is only when the wall is disabled and the cube/rotate cube is not enabled then why is that a concern of ubuntu?
How exactly will the wall be disabled other than a user initiated action?

(anyway found the source change so see no issue personally to revert but still this was an uncalled for 'fix'

Bowmore (bowmore) wrote :

The workaround (revert back) until this regression of the compiz functionallity is fixed is to remove the desktop wall dependency in the file /usr/share/compiz/unityshell.xml, i.e remove the line <plugin>wall</plugin> in the <requirement> clause on line 35 followed by a relogin.

Personally, I think this bug should be reset until a more solid solution is found.

On Mon, Dec 13, 2010 at 7:54 PM, Bowmore <email address hidden> wrote:
> The workaround (revert back) until this regression of the compiz
> functionallity is fixed is to remove the desktop wall dependency in the
> file /usr/share/compiz/unityshell.xml, i.e remove the line
> <plugin>wall</plugin> in the <requirement> clause on line 35 followed by
> a relogin.
>
> Personally, I think this bug should be reset until a more solid solution
> is found.

If it is consistent with the design we can make the unity plugin
depend on the largedesktop feature.

>
> --
> You received this bug notification because you are a member of Unity
> Team, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/683211
>
> Title:
>  Unity plugin should depend on "Desktop Wall" plugin
>
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Binary package hint: unity
>
> Currently the "Desktop Wall" plugin is needed to focus an application on a different workspace. Therefore I think it shouldn't be possible to deactivate the "Desktop Wall" plugin without deactivating Unity.
>
> To reproduce:
>
> 1.) Start Compiz with the "Desktop Wall" plugin disabled
> 2.) Open a program like gedit
> 3.) Switch to another workspace
> 4.) Open another program like gnome-terminal
> 5.) Click on the gedit icon in the launcher bar
>
> => gnome-terminal loses focus, appmenu updates to gedit's menu, no workspace switching.
>
>
>

--
Sam Spilsbury

Bowmore (bowmore) wrote :

The focusing issue seems to require either "Desktop wall" or "Rotate cube" feature to function.
- plane: Desktop wall (wall)
- cube: Rotate cube (rotate), which in turn requires Cube

Thus, Cube is not alone an option but only in combination with Rotate cube when it comes to Unity.

Preferably, the requirement "wall OR rotate" is there for Unity but not for Classic desktop.

Doug McMahon (mc3man) wrote :

I see the requirement has been changed to largedesktop, a bit 'funky' if switching from wall to rotate/cube or back again, (unity has to be disabled then re-enabled
Also that's still one of those things in ccsm that will unset all plugins, but overall seems a good compromise

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers