Icon resized between 32 - 48 - 64 look jaggy

Bug #1036231 reported by Guillaume on 2012-08-13
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
5.0
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone
Precise
Medium
Andrea Azzarone

Bug Description

[Impact]

Ugly icon resizing method hindering user experience.

[Test Case]

Observe scaled icons in Launcher before and after when Launcher icon size is non-even (for example 57) - jagged edges should change to smooth.

[Regression Potential]

Non-scaled icons should not become blurrier.

---

The resize is done with nearest interpolation which is a poor, loosing-information algorithm. It should use at least linear filter or if possible bicubic interpolation for a smooth resize and appearence

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Aug 13 10:50:08 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ZOTAC International (MCO) Ltd. Device [19da:4199]
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=en_US:
 PATH=(custom, no user)
 LANG=en_US
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=d7772776-869d-4d7a-ac4c-c17ee552ac85 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/17/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3506
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z68-V LX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3506:bd01/17/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8Z68-VLX:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.8-0ubuntu1.2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Guillaume (gufide-g) wrote :
summary: - Icon resized between 32 -48 -64 look jaggy
+ Icon resized between 32 - 48 - 64 look jaggy
Guillaume (gufide-g) wrote :
Guillaume (gufide-g) wrote :
Guillaume (gufide-g) wrote :
affects: xorg (Ubuntu) → unity (Ubuntu)
Omer Akram (om26er) wrote :

that's not unity's fault. The icons provided in the icon theme are either 32px, 48px or 64px anything between these is supposed to look jagged since the icons are rescaled

Changed in unity (Ubuntu):
status: New → Invalid
Guillaume (gufide-g) wrote :

I know that creating icons between 48 64 and 32 is illogical, but unity can use better filter than nearest.

Unity use OpenGL, so it can use linear or bicubic filter to make icons smoother.
So it's unity's fault to use nearest filter. We can choose a better one.

Daniel van Vugt (vanvugt) wrote :

It is Unity's fault for not using a correct texture minification filter.

Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in unity:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 6.4
Andrea Azzarone (azzar1) on 2012-08-21
Changed in unity:
importance: Low → Medium
status: Confirmed → Triaged
Andrea Azzarone (azzar1) on 2012-08-21
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) wrote :
Andrea Azzarone (azzar1) wrote :
Andrea Azzarone (azzar1) wrote :
Omer Akram (om26er) on 2012-08-21
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu Precise):
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (andyrock)
status: New → In Progress
Guillaume (gufide-g) wrote :

it seems that before the fix, enabling the bicubic filter plugin wasn't affecting the unity launcher. Unity should respond to this plugin too. I think this is a bit off-topic here, should we open a new bug here?

Andrea Azzarone (azzar1) on 2012-08-22
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package unity - 6.4.0-0ubuntu1

---------------
unity (6.4.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Home lens: Applications show up in Music category (LP: #1040101)
    - WARN unity.hud.hud Hud.cpp:185 Attempted to close the hud connection
      without starting it (LP: #1039451)
    - Text field textures do not update when maximum width changes.
      (LP: #1037187)
    - An application is closed if manually removed from favorites on gsettings
      (LP: #1032157)
    - The switcher (Alt+Tab) is showing incorrect windows after using Deskop
      Wall (Ctrl+alt+<direction>) (LP: #1031959)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Screen flickers when changing launcher icon size. (LP: #1024113)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - [previews] Music album tracks do not have a scroll-bar when needed.
      (LP: #1039462)
    - [USE_MODERN_COMPIZ_GL] With unity scrollbar support enabled, hotplugging
      monitors doesn't work (LP: #1039410)
    - [previews] Track titles aren't escaped (LP: #1039020)
    - Launcher - Edge of tiles (with backlight disabled) is too opaque
      (LP: #1038138)
    - [USE_MODERN_COMPIZ_GL] Benchmark window appears behind the Unity shell
      now (LP: #1036609)
    - [GLES] [USE_MODERN_COMPIZ_GL] Unity shell (Launcher and Panel) are
      missing if framebuffer_object is disabled (LP: #1036569)
    - [USE_MODERN_COMPIZ_GL] Benchmark window is mostly invisible, shrunken
      and displaced (LP: #1036528)
    - Unity quicklist menu items leak memory (LP: #1036338)
    - Icon resized between 32 - 48 - 64 look jaggy (LP: #1036231)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - [regression] Selecting an item of the BFB quicklist when the dash is
      open, causes it to hide (LP: #1035641)
    - Launcher - Switch on "backlight toggles" mode by default (LP: #1033866)
    - Unity spends 15% of time in PlacesGroup::ComputeContentSize when opening
      dash (LP: #1033306)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Bottom - Up key navigation is broken in dash filterbar (LP: #1028810)
    - Launcher - SD card can not be ejected by drag-n-dropping to trash
      (LP: #960910)
    - Alt-tab - The app name in the integrated menu should not change during
      Alt-tab switching (LP: #950782)
    - Dash - If only one Category Header is displayed, it should be
      automatically expanded (LP: #950710)
    - Launcher - Unity mouse wheel scroll too small (LP: #906072)
    - boot moves desktop icons (LP: #886667)
    - Alt-tab - Reduce the spread delay for all items other than the initial
      item the select lands on after alt-tab opens (LP: #838232)
    - Launcher - Launcher should never autohide when the cursor is positioned
      over the Launcher (e.g. When ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

A fix for 12.04 will be appreciated.

description: updated

Hello Guillaume, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.18.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Looks good now (although could of course also use bicubic instead of linear).

tags: added: verification-done
removed: verification-needed

Here it's kind of ok. It is not distorted now, though when the size is set
to an uneven number, icons are a bit blurred, like they are out of focus.
So I wouldn't mark this as not solved or something, I'm just saying that
this could be better (in theory, at least :)).

2012/11/30 Timo Jyrinki <email address hidden>

> Looks good now (although could of course also use bicubic instead of
> linear).
>
> ** Tags removed: verification-needed
> ** Tags added: verification-done
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1063159).
> https://bugs.launchpad.net/bugs/1036231
>
> Title:
> Icon resized between 32 - 48 - 64 look jaggy
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1036231/+subscriptions
>

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.18.0-0ubuntu1

---------------
unity (5.18.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher: start the drag icon request from the original mouse-down
      position. (LP: #858540)
    - Ignore transient unmmaped windows on minimize/unminimize
      (LP: #929712)
    - Fixes alt+tab losing focus when alt+tabing to quickly due to ubus
      being to slow to send a message (LP: #1035628)
    - If no icon is found then use the default one. This will cause all
      blank icons to be a '?' icon (LP: #886778)
    - Use GMountOperation in g_volume_mount. GMountOperation provides a
      mechanism for interacting with the use. (LP: #713432)
    - Do not reuse the menu entries if their order changes (LP: #1062283)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes. This avoids to get "?" icons. (LP: #772986)
    - Use linear filtering to draw icons (when needed). (LP: #1036231)
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 14:17:04 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.