Provide an "open this folder" button

Bug #633201 reported by Pete Goodall on 2010-09-08
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Medium
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned
unity-asset-pool (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

I want to browse a folder that is not either a Favourite folder or recently used then I seem to have no way to open a Nautilus window. If I plugin a USB key I get a Nautilus window, but if I close that window I have no way to get it back. That also means I have no way to eject that volume (which is a separate bug).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.34-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Wed Sep 8 14:49:15 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

Pete Goodall (pgoodall) wrote :
Didier Roche (didrocks) wrote :

to eject it, you can either right-click -> eject (in the quicklist) or drop the icon from the launcher.
(but the bug it's still valid)

summary: - Opening a nautlius window is next to impossible
+ Opening a nautilus window is next to impossible

Pete: the workaround , i use for this is using the "Trash" tile below ;-)

The trash folder in nautilus opens up, from where i navigate elsewhere ..

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

Pete, nautilus is one of the default icons in the Launcher, or it used
to be. Is that no longer the case?

Mark

@Mark: I removed it before beta, as we added it a long time before as a workaround about not of the file places. Do you think we should add it again as a default launcher?

No, you're probably right, we should rather refine the Files place.

Pete, can you outline a couple of use cases again, and we'll do that?

Mark

Changed in unity:
milestone: none → 2010-09-16

The Files IX spec mentions that there should be a "Browse This Folder"-button on the far right in the path-bar when you are in folder browsing mod. Clicking that would open Nautilus on the right folder.

This would at least somewhat mitigate this problem, and should maybe be small enough in scope for ui/feature freeze break exception to be granted..?

 On 10/09/10 09:53, Mikkel Kamstrup Erlandsen wrote:
> This would at least somewhat mitigate this problem, and should maybe be
> small enough in scope for ui/feature freeze break exception to be
> granted..?

If it can be implemented quickly and cleanly, +1

Mark

see https://wiki.ubuntu.com/FreezeExceptionProcess on how to get exception, you need to subscribe ubuntu-release and notify the documentation and translations teams about the change before doing it

Sebastien: thanks

In order to proceed swiftly with this I mocked up something you can find in the attachment. It looks a lot like David's original spec at least :-)

Attaching the SVG for the icon in a sec...

Pete Goodall (pgoodall) wrote :

Ok, just to clarify a bit here. I think the case of a usb-connected volume is a separate bug and I will file that next.

@Mark - Even if Nautilus was one of the default folders in the launcher I have since removed it because I didn't think I needed it. As this is an editable item in the launcher I don't think we can rely on it existing there. Unless we want to make it mandatory, but that might seem redundant to the files place.

The core bug still stands, that it is next to impossible to open a nautilus window. The proposed fix of putting a folder icon the section title bar does avoid breaking translations freeze, but doesn't really indicate that I can open that folder. Can we not use stock translations for this? I have a hard time believing we have never translated "Open Folder". A couple more use cases:

* I exported a bunch of pictures to my Desktop and I want to zip them into one file to send to my parents. In order to do this I need to open a nautilus window, but can't seem to do so. I click find the Desktop folder in the "Folders" filter, but clicking on that folder stays in Unity and doesn't allow me to select multiple files, much less perform any other action than opening the file.

* I download a form from my local town council that is an editable pdf. The pdf can't be edited in Evince, so I want to open it in Adobe Reader, but there is no right-click function in Unity.

* I want to get to a diagram I have stored in my Projects folder I created in my home directory. I haven't accessed this folder in a while, but want to view the diagram to see if it is appropriate to send on. As the Projects folder was never set as a "Favourite" folder and doesn't show up in my history I can't seem to find it in Unity.

I'll try to come up with some more, but it really is quite frustrating to not have access to a file browser.

I think the principle of an "open this folder in the file manager"
button is correct, so we'll go with that for 10.10. I think the
execution could be more visual, so we'll review that for 11.04.

Mark

A couple more use cases:
How do I access a non mounted volume? (I am dual booting lucid and meerkat)
How do I access other network shares?

As a comment I am using lucid netbook as my desktop in my pocket, and think the full screen apps, left hand menu is good. But I found nautilus did not fit well, it always looks out of place old world. So I was looking forward to how unity would get over this.
However for now I need open nautilus as an application.
David

When I first noticed that I couldn't do everything I wanted in the Unity browser, I just ran nautilus once from the terminal, and then pinned it to the launcher once it ran - so now if I want to do something more involved I can click on the nautilus icon instead of the Files icon.
I wanted to add a +1 for some sort of 'open/browse in File Manager' functionality, from a discussion with Mikkel on a (now) duplicate bug. An icon would do the trick (especially for touch screens) but my preference for netbooks would be to have access to the option by right-clicking a folder. As noted above there's currently no right-click function, and it would be good for the right mouse button to have something to do! :)

 Hi David

I'd be interested to hear what you think of the Elementary Nautilus
interface on your device. I haven't tried it, but folks have said good
things.

Mark

Mark
I was not aware of nautilus elementary, so I have now installed it 2.31.1 & 2.31.90, and my comments are first impressions.
It does not really address my feeling that nautilus does not integrate well with the 10.04 netbook interface. This may now be irrelevant as unity is here, but the "Files and Folders" menu tab stood out as different in how it worked from all the others. All the icons presented opened the same nautilus, but with the selected focus, this always felt wrong.
In lucid I like the improvements in nautilus elementary.
In meerkat I am having problems with bugs, but I think I will like it. RGBA is not for me, but I like configurable, so people who like RGBA can use it. But I would like to try the ClutterView but can not get it do do anything. Configurable vertical menu is good for me (if I can get it to work!).
Personally I think replacing the "files and folders" action with nautilus elementary will suit me fine.
Maybe it could be an option with the current action + an advanced button as an alternative.
I realise my requirements are very different from the dual boot not much file system model.
David
ps I am using the trash icon as launch nautilus.

ammonkey (am-monkeyd) wrote :

@David Stevenson : nautilus and nautilus-elementary are highly unstable on ubuntu maverick 10.10 due to libgtk
Already reported bug here https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/626040
same applies for libgtk-2.21.7

more information here http://ammonkey.posterous.com/multiple-problems-about-nautilus-nautilus-ele

If you want to talk about the future file browsing/managing in Unity then please open a thread on the ayatana list or in another bug. Let's keep this bug to be about what we'll do for Maverick.

Just the "open this folder" button is sufficient for Maverick, this bug
can be closed when we achieve that.

Mark

David Barth (dbarth) on 2010-09-15
summary: - Opening a nautilus window is next to impossible
+ Provide an "open this folder" button
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
Changed in unity:
assignee: Neil J. Patel (njpatel) → Mikkel Kamstrup Erlandsen (kamstrup)
status: New → Fix Committed
Neil J. Patel (njpatel) on 2010-09-16
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2010-09-17
Changed in unity-asset-pool (Ubuntu):
status: New → Triaged
affects: unity (Ubuntu) → unity-place-files (Ubuntu)
Didier Roche (didrocks) on 2010-09-17
Changed in unity-place-files (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2010-09-17
Changed in unity (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) wrote :

Reviewing u-asset-pool, this just adds an icon. Approved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-asset-pool - 0.8.16-0ubuntu1

---------------
unity-asset-pool (0.8.16-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - add icon for providing an "open this folder" button (LP: #633201)
 -- Didier Roche <email address hidden> Fri, 17 Sep 2010 13:52:45 +0200

Changed in unity-asset-pool (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.24-0ubuntu1

---------------
unity-place-files (0.5.24-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Provide an "open this folder" button (LP: #633201)
    - Fix typo You -> Your (LP: #637305)
 -- Didier Roche <email address hidden> Fri, 17 Sep 2010 14:06:23 +0200

Changed in unity-place-files (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.40-0ubuntu1

---------------
unity (0.2.40-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fix inactive menus accessible (LP: #604505)
    - Fix some more memory leaks (LP: #604777, #621690, #628144)
    - Fix weird behaviors of quicklist (LP: #617339)
    - Provide an "open this folder" button (LP: #633201)
    - Hidden menu causing gap (LP: #600191)
    - Cannot go fullscreen for flash videos (LP: #631381)
    - Can't access menu items from the keyboard (LP: #636728)
    - Don't register for MDRAGs since they aren't used (LP: #632613)
    - Don't run indicator on special launchers (LP: #627488)
    - Center arrows position in folded launcher tiles (LP: #633084)
    - Launcher icons first appear as white upon login (LP: #601093)
    - Removes jittering when rubber band is in use on the launcher (LP: #632991)
    - Mutter restarts on closing almost any application (LP: #634701)
    - Can't launch apps like synaptic with root privileges from launch bar
      (LP: #599298)
    - Launcher tile dragging shouldn't be masked (LP: #631443)
    - Fix Carousel-ed icons have distorted perspective (LP: #607515)
    - Use no longer sync call (LP: #620011)
  * update debian/libunity0.symbols
 -- Didier Roche <email address hidden> Fri, 17 Sep 2010 14:02:54 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Scott Kitterman (kitterman) wrote :

Unsubscribing ubuntu-release to get it off the team bug list.

John Lea (johnlea) on 2011-02-28
Changed in ayatana-design:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers