if you enable onscreen keyboard and then login/logout, onscreen stays checked but will not load automatically

Bug #973922 reported by Mark Bokil on 2012-04-05
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
Undecided
Unassigned
unity-greeter (Ubuntu)
Low
Matt Fischer
Nominated for Precise by James M. Leddy

Bug Description

The onscreen keyboard menuitem shows a checked state but the keyboard is not visible. This forces the user to uncheck the onscreen keyboard menuitem and then select it again to make the keyboard visible. This occurs if the onscreen keyboard is used to login. Subsequent logins with the onscreen keyboard will show it as checked in the menu but its visibility is false. My guess is that the menu is defaulting to checked for onscreen keyboard but the keyboard visibility is false. The state of the onscreen keyboard menuitem needs to be unchecked if keyboard visibility is false when greeter screen is shown.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Matt Fischer (mfisch) on 2012-06-29
Changed in unity-greeter (Ubuntu):
status: Confirmed → Triaged
Matt Fischer (mfisch) wrote :

I cannot repro this in test-mode, but it certainly happens under normal usage.

Matt Fischer (mfisch) wrote :

Odd, onboard is running, just not being shown.

Matt Fischer (mfisch) on 2012-06-29
Changed in unity-greeter (Ubuntu):
assignee: nobody → Matt Fischer (mfisch)
summary: - onscreen keyboard menu item checked state wrong
+ if you enable onscreen keyboard and then login/logout, onscreen stays
+ checked but will not load automatically
Michael Terry (mterry) on 2012-06-29
Changed in unity-greeter (Ubuntu):
assignee: Matt Fischer (mfisch) → Michael Terry (mterry)
Matt Fischer (mfisch) on 2012-06-29
Changed in unity-greeter (Ubuntu):
assignee: Michael Terry (mterry) → Matt Fischer (mfisch)
importance: Undecided → Low
Mark Bokil (mark-bokil) wrote :

One other small issue I noticed with the greeter is the theme of the keyboard changes back to Ambiance when I log off. If I set the theme to Droid or something else in preferences it will always return to Ambiance in greeter. It is pretty minor but inconsistent. When the keyboard appears it should probably check the preferences config and apply those changes for the greeter also.

Matt Fischer (mfisch) wrote :

Mark,

How do you set the theme of the keyboard? It is not obvious to me.

Mark Bokil (mark-bokil) wrote :

From the indicator on the panel Preferences -> Theme or from the keyboard click the Snippets key in lower right and then click the Preferences button with the wrench and screwdriver icon.

Matt Fischer (mfisch) on 2012-06-30
Changed in unity-greeter (Ubuntu):
status: Triaged → In Progress
Matt Fischer (mfisch) wrote :

Mark,

Since I just did a MP to fix this, please file a separate bug on the theme issue and please include a screen cap if you can. The wrench/screwdriver icon for me is unclickable.

Francesco Fumanti (frafu) wrote :

Quite some time ago, the Ubuntu developers patched Onboard for security reasons to not open the preferences dialog under the display manager. As we integrated that patch into the following releases of Onboard, the wrench does not work by design under the display manager.

@ marmuta (who is coding Onboard and who is probably watching this thread; otherwise, I will contact him directly in a few days)

What about hiding the wrench when Onboard is running under the display manager instead of simply disabling it? This way, people would not think it to be broken.

Moreover, what about adding the option "Apply the theme changes also to the login screen" in the Preferences dialog tab about the themes? I am aware, that it should be called with root privileges, but I think that it should be feasible. The main difficulty might be to do it for the various display managers that are available. But again, we could make that new option available only for determined display managers.

Francesco Fumanti (frafu) wrote :

I have created a separate bug for the theme issue containing my idea about adding an additional option to the Preferences dialog in the desktop session in order to apply the change to the login screen. If you have a better idea about how to solve the problem, please let us know.
https://bugs.launchpad.net/onboard/+bug/1019590

Michael Terry (mterry) on 2012-08-07
Changed in unity-greeter:
status: New → Fix Committed
Matt Fischer (mfisch) on 2012-08-21
Changed in unity-greeter (Ubuntu):
status: In Progress → Fix Committed
Robert Ancell (robert-ancell) wrote :

Fixed in unity-greeter 12.10.1

Changed in unity-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.2-0ubuntu1

---------------
unity-greeter (12.10.2-0ubuntu1) quantal; urgency=low

  [ Robert Ancell ]
  * New upstream release:
    - Show network indicator (bug 1042757, but currently disabled)
    - Add support for remote logins (bug 1040221, but currently disabled)
    - Show onboard keyboard on startup if enabled already (LP: #973922)
    - Support multiple simultaneous prompts from PAM (LP: #1043593)
    - Fix tabbing through widgets sometimes taking too many tabs
    - Set average background colour atom based on background (LP: #1043572)
    - Add a man page
    - Finess UI (LP: #932162)

  [ Michael Terry ]
  * debian/unity-greeter.pkla, debian/install:
    - Install a policykit authentication file to disallow any mucking
      with NetworkManager in anticipation of adding NM to the greeter.
  * debian/control:
    - Require lightdm 1.3.3
  * debian/patches/01_disable_remote_login.patch,
  * debian/patches/02_disable_nm_applet.patch:
    - Disable a couple features until their FFes are approved.
 -- Michael Terry <email address hidden> Mon, 20 Aug 2012 14:14:17 -0400

Changed in unity-greeter (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers