update-initramfs fails: ./lib/udev/firmware.sh does not exist

Bug #519855 reported by Jamie Strandboge on 2010-02-10
324
This bug affects 66 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: udev

After upgrading to udev 151-1, dpkg fails with:
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-12-generic
cpio: ./lib/udev/firmware.sh: Cannot stat: No such file or directory
update-initramfs: failed for /boot/initrd.img-2.6.32-12-generic
dpkg: subprocess installed post-installation script returned error exit status 1

ProblemType: Bug
Architecture: amd64
CustomUdevRuleFiles: 45-libmtp7.rules
Date: Wed Feb 10 08:24:14 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
Package: udev 151-1
ProcCmdLine: root=UUID=027f6784-68b4-4dad-8387-c5319fedda74 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: udev
Uname: Linux 2.6.32-12-generic x86_64
dmi.bios.date: 08/04/2006
dmi.bios.vendor: Intel Corp.
dmi.bios.version: CO96510J.86A.4462.2006.0804.2059
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DQ965GF
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD41676-400
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrCO96510J.86A.4462.2006.0804.2059:bd08/04/2006:svn:pn:pvr:rvnIntelCorporation:rnDQ965GF:rvrAAD41676-400:cvn:ct2:cvr:

Jamie Strandboge (jdstrand) wrote :
Michael Jeanson (mjeanson) wrote :

A simple patch.

Stefan Ebner (sebner) wrote :

Seeing this issue too so setting to "Confirmed"

Changed in udev (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2010-02-10
Changed in udev (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Scott James Remnant (scott)
Olof Kindgren (flamingolof) wrote :

A temporary workaround to get dpkg back to a working state is to just symlink firmware-> firmware.sh

Alex Valavanis (valavanisalex) wrote :

The patch seems to fix the issue for me

tags: added: patch
Harry (harry33) wrote :

This bug is fixed in the new source package udev_151-2

Omer Akram (om26er) wrote :

I have not rebooted yet will rebooting make my system unbootable?

Brian Murray (brian-murray) wrote :

udev (151-2) lucid; urgency=low

  * debian/udev.initramfs-hook: /lib/udev/firmware.sh got rewritten as a
    C helper, somehow missed this in testing.

Changed in udev (Ubuntu):
status: Triaged → Fix Released
Harry (harry33) wrote :

om26er,
please update the udev, libgudev nad libudev packages to the version 151-2.
You can reboot your system.

saewelo (saewelo1) wrote :

"om26er,
please update the udev, libgudev nad libudev packages to the version 151-2.
You can reboot your system."

Can't do it Harry

Getting this on the command line and as a pop-up when starting synaptic.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

saewelo (saewelo1) on 2010-02-10
Changed in udev (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Christian (jcbrasen) wrote :

I have tried to make the patch work - without success - what would you have to write.

Nicolas Valcarcel (nvalcarcel) wrote :

Worked for me i just did:
cd /lib/udev
sudo ln -s firmware firmware.sh

saewelo (saewelo1) wrote :

"Worked for me i just did:
cd /lib/udev
sudo ln -s firmware firmware.sh"

Yep that does it.

Cheers

 _/\_
      __\ /__
     <_ _>
       |/ )\|
SAEWELO /

Christian (jcbrasen) wrote :

got it.

xeneyes (xeneyes) wrote :

thanks, it works for me too !

is the fix added, packaged & uploaded to repositories ?

cement_head (andorjkiss) wrote :

+1

Nicolas Valcarcel (nvalcarcel) wrote :

looks like it is published already, yes.

kshitij gaipal (kgaipal) wrote :

@saewelo : worked for me too!

Dave Stroud (bigdavesr) wrote :

I tried the above and its still not working. What did I do wrong?

Ah, thanks for the fix, mates. linked, regenerated and updated. Worked like a charm. :)

psierra (pscbarros) wrote :

i'm using i386 arch and it worked just fine. tks for the post!

Dave Stroud (bigdavesr) wrote :

reapplied patch. now works. thanks

Majestyx (majestyx) wrote :

Thanks Harry!

The Solution in #12 works for my too.

riverbird (sal) wrote :

worked for me. thanks folks

michaelgod5 (michaelgod5) wrote :

The Solution in #12 works for my too.
Very useful, thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers