"Value could not be retrieved" keeps appearing ont the control panel

Bug #722485 reported by David Planella on 2011-02-21
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Low
Natalia Bidart
ubuntuone-control-panel (Ubuntu)
Low
Natalia Bidart

Bug Description

Binary package hint: ubuntuone-control-panel

I'm trying to sync files and I keep getting the "Value could not be retrieved" message in the control panel (see attechment).

If this is a message that needs to be presented to the user at all, I'd suggest making it a bit more descriptive and user-friendly, as the current text does not give much info on what's actually going on.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubuntuone-control-panel-gtk 0.8.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Feb 21 08:33:14 2011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ca_ES@valencia:ca:en_GB:en
 LANG=ca_ES.UTF-8
 LC_MESSAGES=ca_ES.utf8@valencia
 SHELL=/bin/bash
SourcePackage: ubuntuone-control-panel

Related branches

David Planella (dpm) wrote :
Natalia Bidart (nataliabidart) wrote :

Hi David,

Thanks for your report. Yes, we need to improve the error messages but is not easy, since we're getting exceptions back from the backend and we need to show a fixed, translatable error for the end users. Right now we can't define strings for all the possible errors from syncdaemon, so we are showing predefined errors.

Anyways, I agree we should try to improve this somehow.

Changed in ubuntuone-control-panel:
status: New → Triaged
Changed in ubuntuone-control-panel (Ubuntu):
status: New → Triaged
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → Low
Changed in ubuntuone-control-panel:
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → Low
tags: added: desktop+ u1-gui u1-natty
Sebastien Bacher (seb128) wrote :

Confirmed on natty beta1, the device tab display this error in red which is not a real user friendly way to say I've no device configured ;-)

Natalia Bidart (nataliabidart) wrote :

Sebastien's report was isolated in bug #745790, since is not this exact same issue.

Changed in ubuntuone-control-panel:
status: Triaged → Fix Committed
Changed in ubuntuone-control-panel (Ubuntu):
milestone: none → ubuntu-11.04-beta-2
tags: added: u1-natty-beta
removed: u1-natty
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 0.9.5-0ubuntu1

---------------
ubuntuone-control-panel (0.9.5-0ubuntu1) natty; urgency=low

  * New upstream release:

    [ <email address hidden> ]
      - Now that we set the launcher urgency from ubuntuone-client, the control
      panel needs to remove it when its window receives focus (LP: #747677).
      - changed default value for switch_to to empty string, and now don't call
      switch_to method when the value is empty string (or anything else falsy)
      (LP: #752943).
      - Added proper defaults to the command line arguments (LP: #746489).
      - Fixed issue where closing the panel resulted in a runtime error
      (LP: #745987).
      - This adds a method to the dbus service that allows switching between
      panels, and/or drawing attention to the control panel (LP: #742008).
      - Removed the shortcut group that causes two Ubuntu One entries to appear
      in the messaging menu when syncdaemon is not running (LP: #721525).
    [ Natalia B. Bidart <email address hidden> ]
      - If servers reply with a 401, clear credentials and ask user to
      authenticate (LP: #726612).
      - Moving style_check down so the exit code from u1trial is not hidden by
      && operator.
      - Unify disable/enable file sync functionality among Services tab and
      global file sync status (LP: #729301).
      - Cloud Folders tab is now disabled when the file sync service is
      (LP: #747482).
      - Improving legend for plugin installation to ease translations
      (LP: #746374).
      - Added volumes.ui to the translation list (LP: #746370).
      - Small improvement to show something else besides the generic "Value can
      not be retrieved." error (LP: #722485).
      - Made the backend robust against possible None values (or any non
      basestring instance) sent from the API server (LP: #745790).
      - Decoupled device list retrieved from the web from the local settings
      retrieved from syncdaemon (LP: #720704).
      - Stop the control panel backend once the UI is done
      (LP: #704434).
      - After initial computer adding, syncdameon is asked to connect
      (LP: #715873).
 -- Natalia Bidart (nessita) <email address hidden> Fri, 08 Apr 2011 15:53:02 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers