Two Ubuntu One entries in the Message Panel

Bug #721525 reported by Konstantin Molchanov on 2011-02-18
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
Eric Casteleijn
Ubuntu One Control Panel
Medium
Eric Casteleijn
ubuntuone-client (Ubuntu)
Medium
Ubuntu One Client Engineering team
ubuntuone-control-panel (Ubuntu)
Medium
Natalia Bidart

Bug Description

Binary package hint: ubuntuone-client

Message panel contains to identical Ubuntu one entries. The only difference is that one is with an icon, the other is not.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubuntuone-client 1.5.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic x86_64
Architecture: amd64
Date: Fri Feb 18 22:04:52 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
UbuntuOneSyncdaemonExceptionsLog:

Related branches

Konstantin Molchanov (moigagoo) wrote :
Gaurav Butola (gauravbutola) wrote :

I also see two "Ubuntu One" entries in Messaging Menu.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Martin Albisetti (beuno) on 2011-02-19
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntuone-control-panel:
status: New → Triaged
Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntuone-control-panel:
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntuone-client (Ubuntu):
status: Triaged → Invalid
Changed in ubuntuone-control-panel:
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 0.8.5-0ubuntu1

---------------
ubuntuone-control-panel (0.8.5-0ubuntu1) natty; urgency=low

  * New upstream release:

    [ Natalia B. Bidart <email address hidden> ]
      - Restored 'Services' tab. Fixed desktopcouch dependencies management.
      - Improve .desktop file to avoid duplication on messaging menu
      (LP: #721525).
      - Fixing tests according to latest changes to syncdaemon.
      - 'Limit bandwidth' layout was improved (LP: #715812).
      - Commenting styling code out to allow UX people to create a proper .rc
      file (LP: #715717).
      - Added 'ubuntuone' to the list of installable modules.

    [ Bilal Akhtar <email address hidden> ]
      - AskUbuntu.com link button has now tooltip (LP: #715879).

    [ Alejandro J. Cura <email address hidden> ]
      - Checkbox in devices tab to toggle notifications (LP: #717172).

    [ Robert Roth <email address hidden> ]
      - Fixed usage string to be more readable (LP: #715710).

  * debian/control:
    - bumped depends ubuntuone-client (>= 1.5.4),
    - bumped depends ubuntu-sso-client (>= 1.1.11),
    - ubuntuone-control-panel-gtk package also depends on python-aptdaemon and
    python-defer
 -- Natalia Bidart (nessita) <email address hidden> Wed, 23 Feb 2011 10:58:25 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntuone-control-panel:
status: Triaged → Fix Released
David Planella (dpm) wrote :

This isn't fixed for me. Even with 0.8.5-0ubuntu1 installed, I still get the two entries in the menu. Is there any additional action to be taken after the update, such as clear some cache, etc?

Natalia Bidart (nataliabidart) wrote :

Hi David,

the double entry is a problem in the ubuntuone-client project, since all the messaging entries are added by syncdaemon itself.
Eric already landed a branch that should fix that, but is not packaged yet.

Changed in ubuntuone-client (Ubuntu):
status: Invalid → Triaged
Changed in ubuntuone-client:
status: New → Fix Committed
assignee: nobody → Eric Casteleijn (thisfred)
Changed in ubuntuone-client (Ubuntu):
importance: High → Medium
Changed in ubuntuone-client:
importance: Undecided → Medium
dobey (dobey) on 2011-03-10
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.5.6-0ubuntu1

---------------
ubuntuone-client (1.5.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Remove already upstreamed patch
    - Release pathlock when command cancelled (LP: #729158)
    - syncdaemon continuously hashing (LP: #580855)
    - Self conflict when saving the same file a lot (LP: #718924)
    - SYS_QUOTA_EXCEEDED not being sent (LP: #720797)
    - The check_condition call may be too heavy (LP: #720844)
    - AQ_DOWNLOAD_CANCELLED is no more (LP: #721479)
    - SD should update a single notification (LP: #723227)
    - Two entries in Messaging menu (LP: #721525)
    - Singular form incorrect for notification (LP: #723327)
    - File names should be shown on notifications (LP: #729055)
  * Moved icon files to ubuntuone-client package (LP: #727195)
 -- Rodney Dawes <email address hidden> Wed, 09 Mar 2011 21:11:44 -0500

Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Released
Robert Roth (evfool) wrote :

Setting this back to Confirmed as this happened to me with ubuntuone-client 1.5.6-0ubuntu2 on Natty, see the screenshot attached,

Changed in ubuntuone-client (Ubuntu):
status: Fix Released → Confirmed
Robert Roth (evfool) wrote :

Setting this back to Confirmed as this happened to me with ubuntuone-client 1.5.6-0ubuntu2 on Natty, see the screenshot attached.

RomeReactor (romereactor) wrote :

Still seeing it here with ubuntuone-client 1.5.8-0ubuntu2. Once Ubuntu One is open the icon-less entry disappears.

Eric Casteleijn (thisfred) wrote :

Reproduced this by killing syncdaemon. If it's not running we get two entries, one with and one without the icon.

Changed in ubuntuone-client:
status: Fix Released → Confirmed
Eric Casteleijn (thisfred) wrote :

Found the problem with Ken Vandine's help: There is a grouping entry in the .desktop file of the control-panel that causes this behavior.

Changed in ubuntuone-control-panel:
status: Fix Released → In Progress
Changed in ubuntuone-client:
status: Confirmed → In Progress
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntuone-control-panel (Ubuntu):
status: Fix Released → In Progress
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntuone-client:
status: In Progress → Fix Released
Changed in ubuntuone-control-panel (Ubuntu):
assignee: Naty Bidart (nataliabidart) → Eric Casteleijn (thisfred)
Changed in ubuntuone-control-panel:
assignee: Naty Bidart (nataliabidart) → Eric Casteleijn (thisfred)
Changed in ubuntuone-control-panel (Ubuntu):
milestone: none → ubuntu-11.04-beta-2
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
Changed in ubuntuone-control-panel:
status: In Progress → Fix Committed
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Changed in ubuntuone-control-panel (Ubuntu):
assignee: Eric Casteleijn (thisfred) → Naty Bidart (nataliabidart)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 0.9.5-0ubuntu1

---------------
ubuntuone-control-panel (0.9.5-0ubuntu1) natty; urgency=low

  * New upstream release:

    [ <email address hidden> ]
      - Now that we set the launcher urgency from ubuntuone-client, the control
      panel needs to remove it when its window receives focus (LP: #747677).
      - changed default value for switch_to to empty string, and now don't call
      switch_to method when the value is empty string (or anything else falsy)
      (LP: #752943).
      - Added proper defaults to the command line arguments (LP: #746489).
      - Fixed issue where closing the panel resulted in a runtime error
      (LP: #745987).
      - This adds a method to the dbus service that allows switching between
      panels, and/or drawing attention to the control panel (LP: #742008).
      - Removed the shortcut group that causes two Ubuntu One entries to appear
      in the messaging menu when syncdaemon is not running (LP: #721525).
    [ Natalia B. Bidart <email address hidden> ]
      - If servers reply with a 401, clear credentials and ask user to
      authenticate (LP: #726612).
      - Moving style_check down so the exit code from u1trial is not hidden by
      && operator.
      - Unify disable/enable file sync functionality among Services tab and
      global file sync status (LP: #729301).
      - Cloud Folders tab is now disabled when the file sync service is
      (LP: #747482).
      - Improving legend for plugin installation to ease translations
      (LP: #746374).
      - Added volumes.ui to the translation list (LP: #746370).
      - Small improvement to show something else besides the generic "Value can
      not be retrieved." error (LP: #722485).
      - Made the backend robust against possible None values (or any non
      basestring instance) sent from the API server (LP: #745790).
      - Decoupled device list retrieved from the web from the local settings
      retrieved from syncdaemon (LP: #720704).
      - Stop the control panel backend once the UI is done
      (LP: #704434).
      - After initial computer adding, syncdameon is asked to connect
      (LP: #715873).
 -- Natalia Bidart (nessita) <email address hidden> Fri, 08 Apr 2011 15:53:02 -0300

Changed in ubuntuone-control-panel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers