Ubuntu

No partition labels in the resize widgets

Reported by d❤vid seaward on 2012-03-05
202
This bug affects 60 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Dimitri John Ledkov
Precise
High
Dimitri John Ledkov

Bug Description

[Impact]

 * No sensible way to guess how to perform automatic dual-boot install

[Test Case]

 * Use a machine with a sufficiently large hard-drive to hold an additional ubuntu installation, and perform side-by-side installation, e.g.:
 * Create a 20GB big VM
 * Install Ubuntu once
 * Boot into updated 12.04.4 daily candidate image
 * Perform side-by-side installation
 * At the resize, disk allocation step it should be clearly visible existing & new installation, their disk names and sizes. A clear resize area should be visible which should be possible to drag left & right.

[Regression Potential]

 * Bug #1240532, fix for which is also included in the update. Make sure you do complete the dual-boot installation.

[Other Info]

I clicked through the 12.04 LTS Beta 1 installation wizard and selected "Install 12.04 LTS alongside 11.10". I am presented with a simple slider to manage the partitions for the existing and new version of Ubuntu. However, the only labels present on the partitions are the sizes (approx 240GB and 60GB). Which one is for 12.04 and which for 11.10?
<https://launchpadlibrarian.net/95739592/2-partition-sizing.png>

At the moment I can't continue past this step knowing what is going to happen, which means I don't really want to! :)

<http://goo.gl/bM1JH>: "Each operating system item should contain a description that has the name and version of the operating system (as obtained from os-prober), and the block device or partition label, filesystem type, and size..."

d❤vid seaward (kwill) on 2012-03-05
tags: added: usability
tags: added: ui
tags: added: alongside partition
tags: added: ubi-partman
tags: added: precise
Brian Murray (brian-murray) wrote :

A screenshot would still be helpful here.

Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
d❤vid seaward (kwill) wrote :
description: updated
d❤vid seaward (kwill) wrote :

Added screenshots for previous screen and ambiguous partitions. Any confirmation on which is which would be a helpful workaround for now :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
IKT (ikt) wrote :

Was this a design decision or accident?

Setting to wish list makes me think it was done on purpose.

hexafraction (rarkenin) wrote :

I think this is a usability bug, hindering users' attaining information about and configuring their installation.

Hm... there should be Ubuntu Circle of Friends logos on both sides, and a label. At least that's what happens on full disk install, for example.

S Barnes (ironictoo) wrote :

Happened to me, only I was installing alongside Windows 7. This is a real show stopper if you want uneven partitions. Also I was using 12.04 (not beta) 64bit, and it was Win 7 64 bit.

tags: added: bitesize
tags: added: rls-p-incomming
alex decker (alex-decker) wrote :

This happened to me as well, installing 64 bit 12.04 alongside Windows 7 64. There is a duplicate of this bug where it is mentioned that if you drag the window off screen, the Ubuntu logo will show up where it should be. I confirmed this myself earlier this morning. So the images are where they should be, but for whatever reason are not being displayed properly unless they are first dragged off screen.

I should also probably note that I have a Lenovo Ideapad Y570, with both the onboard Intel graphics as well as the nvidia graphics card. I assume that the installer would be using the Intel graphics?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
alex decker (alex-decker) wrote :

If anyone comes here looking for a quick answer: Your current installation should be on the left (the beginning of your disk), while the new install will be the right hand side (the end of your disk).

Dimitri John Ledkov (xnox) wrote :

I did some more investigation on this bug. In the minimal example the logo and labels are painted, but the z-order is wrong such that the dotted pattern wipes them. Strangely enough the "use_disk" mode (when multiple disks are present), shows the logo & that the titles correctly.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Triaged
no longer affects: ubiquity (Ubuntu Quantal)
Changed in ubiquity (Ubuntu):
importance: Wishlist → High
Changed in ubiquity (Ubuntu Precise):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in ubiquity (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
summary: - No partition labels in 12.04 partition wizard
+ No partition labels in the resize widgets
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/947107

tags: added: iso-testing
Changed in ubiquity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
description: updated

still have this issue on the latest raring 13.04 beta image. This causes a lot of confusion during installation. Its silly if in the middle of an install one has to search the internet to try and figure this out! The average person will not waste their time and will just goto some other distro or just stick to windows!

tags: added: rls-s-incoming
Ricardo Tomasi (ricardobeat) wrote :

Thanks alex! This just happened to me while installing Elementary OS.

Odin Hørthe Omdal (velmont) wrote :

So, this still not being done. What is actually the error, I seem to remember there being some icons on there before? Are the icons just missing or renamed or invalid PNG or something? This sounds like it could be an easy picking. At least, it's a very irritating flaw :)

(note, I just had to search (again) when installing 13.04, so I'm not in 13.10)

Jason Robinson (jaywink) wrote :

This problem is still on the Lubuntu 13.10 latest daily builds, very bad :P

tags: added: saucy
Dimitri John Ledkov (xnox) wrote :
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Dmitrijs Ledkovs (xnox)
Dimitri John Ledkov (xnox) wrote :

Looking very slick =)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.15.25

---------------
ubiquity (2.15.25) saucy; urgency=low

  * Remove all cairo styling from partition boxes in automatic
    partitioning, instead use gtk3/css styling. (LP: #947107)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 16 Oct 2013 09:58:29 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Changed in ubiquity (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Dimitri John Ledkov (xnox)

Hello d❤vid, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.29 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Erick Brunzell (lbsolost) wrote :

@ Stéphane,

Should we just wait until the change hits the 12.04.4 dailys or would it be OK to "update" and then "install" ubiquity to grab the updated version?

I'm a bit concerned about libs if I try a hack :^(

d❤vid seaward (kwill) wrote :

@Stéphane - I'm also not sure how to proceed. Would it be valid to: get the new package on my system, use Startup Disk Creator to create an ISO/USB installer, test with that installer (either on my live machine or a VM)? Or better to just use the daily ISO as Erick suggested?

Erick Brunzell (lbsolost) wrote :

Looking at the current manifest:

http://cdimage.ubuntu.com/precise/daily-live/current/precise-desktop-i386.manifest

Still shows:

ubiquity 2.10.28

But I'll play in the next few hours and report back ;^)

Erick Brunzell (lbsolost) wrote :

I'm gaining, it took me a while to adjust to the fact that "proposed" is enabled by default in the 12.04.4 20140123 i386 image.

It does appear to be fixed but I want to document the whole process to make sure it makes sense to Stéphane.

Erick Brunzell (lbsolost) wrote :

Arrgh, ubiquity crashed, please see bug #1272272.

Erick Brunzell (lbsolost) wrote :

That updated version does work OK with "something else"/ aka manual partitioning but I was surprised to see that it defaulted to "do not use this partition" w/o a reboot.

Erick Brunzell (lbsolost) wrote :

That last comment was poorly written :^(

After ubiguity crashed I reported bug #1272272.

When I was done reporting that bug I restarted ubiquity w/o rebooting and chose "something else".

Once I selected the partition that had been created during the auto-resize process and clicked on change I noticed that the default was "do not use this partition" which I think is odd. Or is it?

d❤vid seaward (kwill) wrote :

Unfortunately I do not get a side-by-side option on the machines I have access to (laptop already dual-booting, and VM is acting up :P ), so I can't confirm this on my side.

One query: in the screenshots I have seen so far, the existing partition is always fully labelled ("Ubuntu 13.10") but to-be-installed partition is always called just "Ubuntu" (rather than "Ubuntu 12.04.4 LTS"). Is this intential?

On 24 January 2014 14:20, d❤vid seaward <email address hidden> wrote:
> Unfortunately I do not get a side-by-side option on the machines I have
> access to (laptop already dual-booting, and VM is acting up :P ), so I
> can't confirm this on my side.
>
> One query: in the screenshots I have seen so far, the existing partition
> is always fully labelled ("Ubuntu 13.10") but to-be-installed partition
> is always called just "Ubuntu" (rather than "Ubuntu 12.04.4 LTS"). Is
> this intential?

This bug is now used to track a Stable Release Update. As per policy,
Stable Release Updates do not modify existing behavior in any way, but
to fix declared bug reports.

During Stable Release Updates, please make sure you can first
reproduce the bug in question (e.g. using 12.04.3 released desktop /
ubiquity image), before attempting to verify that the update fixes the
bugs it claims to fix. As otherwise it's hard to tell, if it resulted
in an improvements and didn't regress below the baseline.

If you have any support, behaviour / design questions, please open new
bug reports using "ubuntu-bug ubiquity".

First please try to reproduce your bugs/questions using a daily
release image, e.g. Trusty Tahr, which you can fetch from from:

     http://iso.qa.ubuntu.com/qatracker/milestones/308/builds

By selecting desired image type / architecture, and clicking through
to download instructions.

--
Regards,

Dimitri.

Erick Brunzell (lbsolost) wrote :

Even though ubiquity 2.10.29 landed in the Precise 20140124 images I was still unable to give this a verification-done status because of bug #1051935, but the python-apt and python-apt-common updates landed in the 20140125 i386 image so I can now almost safely change the status to verification-done. I even tested the "slider" but I did overlook bug #1240532 so I need to rinse-n-repeat to be sure there was no regression related to the "back button" ..... clearly the install button worked properly because the installation completed successfully. So I need to perform one last test being certain that the back button works OK ............. shouldn't be long.

Erick Brunzell (lbsolost) wrote :

In an overabundance of caution I tested the link to the "advanced partitioning tool" as well as the quit button and all is well so I'm marking this verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.29

---------------
ubiquity (2.10.29) precise; urgency=low

  [ Dimitri John Ledkov ]
  * Show labels in automatic side-by-side installation. Fixed by removing
    all cairo styling from partition boxes in automatic partitioning,
    instead use simple bg styling. (LP: #947107, #1240532)
  * Automatic update of included source packages: grub-installer
    1.68ubuntu5.3.

  [ Brian Murray ]
  * Use the apt cache with with so that we close the cache when we are done
    with it. (LP: #1051935)

  [ Hao-Ran Liu (Joseph Liu) ]
  * src/wallpaper/wallpaper.c: Cropping wallpaper image instead of
    stretching it if image's aspect ratio doesn't match monitor's aspect
    ratio (LP: #1207249)

  [ Colin Watson ]
  * Update translations from Launchpad.
 -- Dimitri John Ledkov <email address hidden> Wed, 22 Jan 2014 14:35:56 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

d❤vid seaward (kwill) wrote :

I'll really appreciate this the next time I need to install a dual-boot. Thanks everyone involved!

To post a comment you must log in.