Ubuntu

Installing packages from CD repository fails due to changed CD-ROM default mount point

Reported by Jean-Baptiste Lallement on 2011-03-02
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned
Natty
High
Unassigned
ubiquity (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

ISO Testing: Ubuntu Desktop AMD64 20110302

After the initial OEM installation the user oem can't proceed with the preparation for shipping to the end-user. oem-config is not installed on the system

TESTCASE:
1. Install Ubuntu Desktop AMD64 OEM
2. Restart
3. You're automatically logged in as 'oem'

Result
The icon 'prepare for shipping' is not on the desktop.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Wed Mar 2 14:16:33 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubiquity (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Confirmed by pedro on i386.
Kubuntu is affected also.

Changed in ubiquity (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Tobin Davis (gruemaster) wrote :

I have been able to get oem-config to work properly on my vm install, but it isn't pretty. After pressing F4 and running through the install and rebooting, the system logs in as oem user. From there, I reinstalled oem-config-gtk (and all of it's dependencies), then ran 'sudo touch /var/lib/oem-config/run' and rebooted. With this, I was able to successfully get through oem-config and now have a properly installed system.

Changed in ubiquity (Ubuntu Natty):
milestone: none → natty-alpha-3
Colin Watson (cjwatson) wrote :

Reproduced. The proximate cause is:

  Err cdrom://Ubuntu 11.04 _Natty Narwhal_ - Alpha i386 (20110302)/ natty/main oem-config-gtk all 2.5.22
    File not found

... but I haven't tracked down why this is yet.

Changed in ubiquity (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I think this was caused by the fix to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=611569 (although I do not expect that the correct fix would be to revert that change).

Martin Pitt (pitti) wrote :

Could that be related to bug 726581 in any way? Perhaps the Kubuntu install also tries to install something from the CD repository and doesn't find it?

Michael mentioned a recent apt default mount point change from /cdrom to /media/cdrom/, could that be related?

Martin Pitt (pitti) wrote :

Confirmed that this works when I create a /media/cdrom -> /cdrom/ symlink before starting the installation.

Martin Pitt (pitti) on 2011-03-03
summary: - oem-config is not installed after initial system installation, and the
- user can't proceed with the step 'prepare for shipping'
+ Installing packages from CD repository fails due to changed CD-ROM
+ default mount point
Martin Pitt (pitti) wrote :

Current plan of record: Install the symlink in casper for alpha-3, and sort out the real fix in apt/casper/ubiquity after that.

Changed in casper (Ubuntu Natty):
importance: Undecided → High
milestone: none → natty-alpha-3
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.259

---------------
casper (1.259) natty; urgency=low

  * scripts/casper-bottom/05mountpoints: Create a /media/cdrom -> /cdrom
    symlink, to work around apt's changed default mount point for Alpha-3.
    (LP: #727783)
 -- Martin Pitt <email address hidden> Thu, 03 Mar 2011 11:52:38 +0100

Changed in casper (Ubuntu Natty):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2011-03-03
Changed in ubiquity (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Colin Watson (cjwatson) on 2011-03-03
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Fix Committed
Fabio Marconi (fabiomarconi) wrote :

Fixed for me in 20110306 build

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.23

---------------
ubiquity (2.5.23) natty; urgency=low

  [ Evan Dandrea ]
  * Ensure we always have an automatic partitioning option selected.
  * Merge in latest change to apt-clone from Michael Vogt:
    - Current apt_pkg API methods.
    - Better command line argument parsing.
    - Set DPkg::Chroot-Directory (LP 727758).
  * Do not attempt to proceed to a second page with the biggest_free
    option (LP: #727842, LP: #652852). This will change once we have an
    interface for the biggest_free option.
  * If the partition table is full and a copy of Windows exists, replace the
    resize option with a copy of wubi.exe to the Windows startup folder,
    followed by a reboot.
  * Temporary fix for translations with carriage returns (LP: #730498).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup
    1.57ubuntu10.

  [ Colin Watson ]
  * Set Dir::Media::MountPath as well as Acquire::cdrom::mount (in line with
    base-installer), and pass all the options set by configure_apt to
    python-apt as well so that attempts to install packages from python-apt
    will behave consistently (LP: #727783).

  [ Julien Lavergne ]
  * bin/ubiquity-dm:
   - Wait lxsession before launching the panel, to have theming support.
     (LP: #684802)
  * src/panel/panel.c
   - Load lxpanel background for the panel when it's available.
 -- Evan Dandrea <email address hidden> Mon, 07 Mar 2011 09:16:26 +0000

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released

I appear to be having a similar problem on 64 bit alternate installer.

I tried ln -s 'ing /cdrom to /media/cdrom at very beginning of install

I can see contents in /media/cdrom and at /cdrom

I selected 'guided using entire drive' without LVM

the message is:
'Please insert the disc labeled: 'Ubuntu 11.04 _Natty Narwhal_ - Release amd64 (20110426)' in the drive '/media/cdrom/' and press enter.

Not sure where to go from here...

gratefulfrog (gratefulfrog) wrote :

I have the same problem on the alternate amd64 iso.

This is after I've spent 3 weekends trying to install an upgrade on my previously broken 10.04.

What a sad state of affaire.

It seems to me that the repository list in apt is still set to look for the CD with that name.

So much more time wasted for such a little issue - testing???

Please update me on how to go forward.
Cheers,
Bob

aboaboit (andrea-borgia) wrote :

Just bumped into this bug, I guess: clean install of Kubuntu 11.04 AMD64 using alternate cd, full disk with guided partitioning.
Failed twice, checked the cdrom for errors and found none, spotted this report.
Workaround for me was symlink + cd'ing to /media/cdrom (just in case the link is removed on umount).

snooffy (snooffy) wrote :

Hi guys, I've probably bumped to this bug as well, I've downloaded it yesterday (don't know what build it is thought). Checked the CD for errors - none found. Tried the workaround when I had the message popping up I've switched to tty 2, the CDROM was mounted /cdrom/ and i could see the files, however there was nothing in /media/, nevertheless creating a simlink in /media/ for cdrom and cd'ing into did not work. How can I do it before installation?

snooffy (snooffy) wrote :

Good news:) I've managed to install the system yesterday. Only trouble is I've done 2 things and I'm not so sure which one of them actually cured my problem:
1. I found out that my BIOS is obsolete so I've upgraded it to its latest version
2. During the installation from the alternate CD for 11.04 Kubutnu (downloaded 12.07.2010 around 5pm GMT) I've created a symlink (ln -s /cdrom/ /media/) in 2nd terminal session.

The installation went flawlessly until the end, the new system booted with no issues.

Dan Crack (m3tadan) wrote :

FYI: Trying to install this currently and I can't get the workaround to work

Method:
As soon as press Install Ubuntu Server Alt+F2 to terminal session
ln -s /cdrom/ /media/cdrom

It still asks me to insert the disk to /media/cdrom during the installation :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.