ubiquity crashed with AttributeError in reset_locale(): 'NoneType' object has no attribute 'get'

Bug #649895 reported by Domenico Rotolo on 2010-09-28
This bug affects 220 people
Affects Status Importance Assigned to Milestone
ubiquity
Invalid
Undecided
Unassigned
ubiquity (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

Ubiquty crashed with AttributeError in reset_locale

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: ubiquity 2.4.4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Tue Sep 28 14:52:49 2010
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4751/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with AttributeError in reset_locale()
UserGroups:

Domenico Rotolo (rotolonico) wrote :
tags: removed: need-duplicate-check
tags: added: iso-testing
visibility: private → public
Emmanouel Kapernaros (kapcom01) wrote :

i just want to add that this bug exist also an 64bit. It crashes every time i quit the installer.

2bcandid (wsj7x) wrote :

System freezes after selecting "Try Ubuntu 10.10" from CD(ISO).

Andres Muniz (andresmp) wrote :

To me it happend after quitting the install ubuntu.

I want to note that the connected HDD with USB of the Ubuntu 10.10 is
installed without any problems.

The best regards, Gregory

2010/11/5, Andres Muniz <email address hidden>:
> To me it happend after quitting the install ubuntu.
>
> --
> ubiquity crashed with AttributeError in reset_locale()
> https://bugs.launchpad.net/bugs/649895
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (668403).
>
> Status in "ubiquity" package in Ubuntu: New
>
> Bug description:
> Binary package hint: ubiquity
>
> Ubiquty crashed with AttributeError in reset_locale
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: ubiquity 2.4.4
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Tue Sep 28 14:52:49 2010
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.6
> LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386
> (20100928)
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4751/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with AttributeError in reset_locale()
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/649895/+subscribe
>

--
=================================
С наилучшими пожеланиями Григорий Хегай

tags: added: bugpattern-needed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
gregory (ghegay) wrote :

Thanks

2010/12/3, Paolo Rotolo <email address hidden>:
> ** Changed in: ubiquity (Ubuntu)
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (668403).
> https://bugs.launchpad.net/bugs/649895
>
> Title:
> ubiquity crashed with AttributeError in reset_locale()
>
> Status in "ubiquity" package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: ubiquity
>
> Ubiquty crashed with AttributeError in reset_locale
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: ubiquity 2.4.4
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Tue Sep 28 14:52:49 2010
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.6
> LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386
> (20100928)
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4751/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with AttributeError in reset_locale()
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/649895/+subscribe
>

--
=================================
С наилучшими пожеланиями Григорий Хегай

summary: - ubiquity crashed with AttributeError in reset_locale()
+ ubiquity crashed with AttributeError in reset_locale(): 'NoneType'
+ object has no attribute 'get'

it is correct

2011/1/7, Riccardo Angelino <email address hidden>:
> ** Summary changed:
>
> - ubiquity crashed with AttributeError in reset_locale()
> + ubiquity crashed with AttributeError in reset_locale(): 'NoneType' object
> has no attribute 'get'
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (668403).
> https://bugs.launchpad.net/bugs/649895
>
> Title:
> ubiquity crashed with AttributeError in reset_locale(): 'NoneType' object
> has no attribute 'get'
>
> Status in Ubiquity:
> New
> Status in "ubiquity" package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: ubiquity
>
> Ubiquty crashed with AttributeError in reset_locale
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: ubiquity 2.4.4
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Tue Sep 28 14:52:49 2010
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.6
> LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386
> (20100928)
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4751/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with AttributeError in reset_locale()
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubiquity/+bug/649895/+subscribe
>

--
=================================
С наилучшими пожеланиями Григорий Хегай

tota (antonio-tavares) wrote :

For me it's just that it crashed when exiting. But it doesn't matter really because the result is what I wanted anyway - get out of the instaler!

Andree Wille (dreewill) wrote :

happened on macbook 2,1. clicked on try ubuntu. nothing happened except showing the wheel. after a couple of minutes i clicked on x to close the window. the system bootet into the live cd and the crash report appeared.

gregory (ghegay) wrote :

I'll wait for the next updated version, and now not test ubuntu 10.10

2011/1/18, Andree Wille <email address hidden>:
> happened on macbook 2,1. clicked on try ubuntu. nothing happened except
> showing the wheel. after a couple of minutes i clicked on x to close the
> window. the system bootet into the live cd and the crash report
> appeared.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (668403).
> https://bugs.launchpad.net/bugs/649895
>
> Title:
> ubiquity crashed with AttributeError in reset_locale(): 'NoneType'
> object has no attribute 'get'
>
> Status in Ubiquity:
> New
> Status in "ubiquity" package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: ubiquity
>
> Ubiquty crashed with AttributeError in reset_locale
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: ubiquity 2.4.4
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Tue Sep 28 14:52:49 2010
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.6
> LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386
> (20100928)
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4751/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with AttributeError in reset_locale()
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubiquity/+bug/649895/+subscribe
>

--
=================================
С наилучшими пожеланиями Григорий Хегай

Architecture: i386
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Xubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
Package: ubiquity 2.5.14
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Tags: natty
Uname: Linux 2.6.38-1-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: natty
tags: added: apport-collected

apport information

apport information

apport information

apport information

Vic (ubuntu-slagter) wrote :

Booted Ubuntu 10.10 from USB. Started the Ubuntu 10.10 installer and then cancelled the intaller.

Evan (ev) wrote :

We only track bugs for ubiquity in its source package. Please do not file bugs in the ubiquity project task. Thanks!

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Changed in ubiquity:
status: New → Invalid

Still affects the latest Natty daily build.

Brian Murray (brian-murray) wrote :

Bug 728880 is a Natty bug which has been marked as a duplicate of this one.

Changed in ubiquity (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
Brian Murray (brian-murray) wrote :

All of the duplicates of this contain the string LiveMediaBuild in the bug description.

tags: added: bugpattern-written
removed: bugpattern-needed
Colin Watson (cjwatson) on 2011-03-25
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.30

---------------
ubiquity (2.5.30) natty; urgency=low

  [ Evan Dandrea ]
  * Add an error message for apt-clone failing.
  * Do not consider Windows Recovery partitions in the list of operating
    systems.
  * Add unit tests, which can be run via ./tests/run or by building the
    package. To override a failing test causing the package build to
    fail, use the UBIQUITY_NO_TESTS environment variable.
  * Divert initctl around apt-clone to prevent packages with Upstart
    jobs from failing to be reinstalled.
  * Ensure that the partition description labels all wrap at the same
    point (LP: #741664).
  * Move test dependencies into build-depends. Thanks Colin Watson!
  * Move the apt-clone working directory into /var/log/installer at the
    end of installation (LP: #739492).
  * Set the next button back to its original label once done calculating
    its size.
  * Automatic update of included source packages: migration-assistant
    0.6.9, user-setup 1.28ubuntu14.

  [ Colin Watson ]
  * Start debconf in ubiquity.i18n.reset_locale if it isn't already running
    (LP: #649895).
  * Remove grub_device_label from string_extended, now that the boot loader
    question is only asked from the partitioning page rather than a separate
    dialog (LP: #726740).
 -- Evan Dandrea <email address hidden> Mon, 28 Mar 2011 18:30:33 +0100

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released
Jessie (iluminameluna) on 2011-09-19
Changed in ubiquity:
status: Invalid → Opinion
status: Opinion → Incomplete
status: Incomplete → New
Changed in ubiquity:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers