Ubuntu

ubiquity partition step does not show some hard drives

Reported by Matt Joiner on 2009-10-23
110
This bug affects 18 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Matt Joiner
Nominated for Lucid by Matt Joiner
Nominated for Maverick by Matt Joiner

Bug Description

Binary package hint: ubiquity

this seems like it could be similar to #60868.

during the partition step of the installer, sda is not coming up at all either in manual partition or automatically partition.
there are 2 other disks, sdb and sdc, sdb has windows installed on it.
none of the drives are mounted.

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 23 23:51:29 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release Candidate amd64 (20091020.3)
Package: ubiquity 2.0.2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: ubiquity
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:3441): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:3441): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:3495): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:3520): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Matt Joiner (anacrolix) wrote :
Jim Leinweber (jiml-mail) wrote :

The 9.10RC Karmic Koala ubiquity disk partitioning steps (#4, #5 in the installation screens) seem to have regressions when booting the AMD64 ubuntu live desktop CD on systems with multiple disks.

On one system, the "side by side" radio button only showed sdc. "Erase" would allow choosing sda, sdb, or sdc. The "manual" partitioning option showed all partitions on all three drives and seemed normal.

On another system, recently loaded with windows 7 professional on a 250 GB sda, the "side by side" radio button line was missing entirely, and the manual option didn't show either the sda or the sdb SATA disk drives (intel chipset).

It looked normal on a system with only 1 SATA drive.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Matt Joiner (anacrolix) wrote :

I can confirm this also occurs in both in live mode, and pure installer mode, for the i386 AND amd64 RC installers.

Disconnecting the disks I did not want to install on did not fix the problem, instead the installer session never managed to load X during boot. I'm not sure if this is related.

Matt Joiner (anacrolix) on 2009-10-27
summary: - ubiquity partition step does not show first hard drive
+ ubiquity partition step does not show some hard drives
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Jim Leinweber (jiml-mail) wrote :

It looks like the ubiquity in the 10/27/2009 daily build (karmic-desktop-amd64.iso, sha256 sum 69530b9166767668b7ab36ad7475d02f4fbe35da42516a46a6a698abc0f91a09) fixes the problem, at least under vmware.

I fed it dual IDE and dual SCSI virtual disks, and it showed the first disk both times.

The lack of "side by side" on the win7 pro system I mention Sunday night 10/25 was probably due to the 10/22 CD version fixating on some random USB device around /dev/sdh or so which offered block access, but was not a hard drive, and contained no formatted data partitions. Testing the 10/27 daily build DVD I got "side by side" if the sda device contained a formatted partition, but only "erase" and "free space" and "manual" if it was either blank (no partition table) or had unformatted partitions of some type. If I picked the "largest contiguous free space", depending on what I'd been doing with fdisk behind it's back from a terminal window it might shift focus to sdb. It's looking back to normal, and even subtly smart about presenting the most relevant options to the user.

I'll retest one of the problem physical systems when I get home.

Jim Leinweber (jiml-mail) wrote :

Also OK on a physical Dell Inspiron 531s with dual SATA drives, as expected.

Matt Joiner (anacrolix) wrote :

If you need additional validation of this fix, I can test tonight (about 7 hours away here). Just let me know.

themusicalduck (themusicalduck) wrote :

This problem effects me and is not fixed in the daily build (28/10). I can't either select a disk in the dropdown menu, or use the manual partitioner to select any partition on my two SATA drives. The drives are just not listed. My one IDE drive is detected fine. The drives are also detected fine by the live CD and gparted, but not ubiquity.

Kaaahn! (cnetrix) wrote :

This is affecting me too... does not appear to be fixed as of 28/10.

I'm using the amd64 live CD. Ubiquity does not detect my SATA drives... I just see a blank screen on step 4. There is no way to continue the installation from here.

Changed in ubiquity (Ubuntu):
status: Fix Committed → Confirmed
Jim Leinweber (jiml-mail) wrote :

Just tested the i386 desktop CD under vmware; it saw two virtual SCSI disk, like it should. So for me, it's looking fixed.

I'm wondering if there are multiple issues going on. The release candidate definitely had the regression; but I'm wondering if themusicalduck's and Kaahn1!s problem is something different, maybe a "fakeraid" controller issue or something.

Not sure what you mean by fakeraid, but interesting you should mention raids. I fixed this problem by deleting the raid my disk was setup in (It needs to be in raid for the bios to boot from it for some reason). After installing Ubuntu, I recreated the single disk raid array and it booted up fine.

I still think it might be a bug of some kind, because it worked ok in Jaunty, I think 8.10 and the Karmic beta too. Only after the release candidate did it stop seeing my raids.

Kaaahn! (cnetrix) wrote :

Now that Karmic is finally out, I downloaded a fresh live CD and popped it into my machine.

Going into the live session and running the installer program... and I still can't see anything on step 4. Looks exactly the same as the screenshot I attached earlier.

Matt Joiner (anacrolix) wrote :

This issue is still not fixed for me (i386-desktop). My first hard drive doesn't show up at all, the partitioning step takes a very long time to load.

Matt Joiner (anacrolix) wrote :

I was able to install using the alternate installer. An option comes up to disable software raid, which I accepted. As a result I'm able to see all disks. Later after installation completes, I ran update-grub, and got some errors about software raids (of which I should have none, and if I do they're unintentional), and it fails to parse operating systems on other drives. I removed the "dmraid" package, and reran update-grub, and it works correctly.

This problem is somehow related to incorrectly picking up software raid volumes that aren't in use, or previously existed.

A workaround is as I explained, use the alternate installer, and immediately remove the "dmraid" package.

I confirm that the problem is present also on the release version of Kubuntu 64bits (LiveCD).

Richard Bailey (rmjb) wrote :

I was also getting this. On the live cd I uninstalled the dmraid package, restarted the installer and now sda shows.

Jeff Tougas (tougasj) wrote :

I also was receiving this error. Richard's workaround has worked for me. For what its worth, here's my relevant hardware setup:

Core i7 processor
MSI X58M motherboard
Only 1 SATA drive

Relevant details will likely only include the existence or
preexistence of software raid setups on your system.

Hardware specifics should be unnecessary.

On Sun, Nov 1, 2009 at 7:37 AM, Jeff Tougas <email address hidden> wrote:
> I also was receiving this error.  Richard's workaround has worked for
> me.  For what its worth, here's my relevant hardware setup:
>
> Core i7 processor
> MSI X58M motherboard
> Only 1 SATA drive
>
> --
> ubiquity partition step does not show some hard drives
> https://bugs.launchpad.net/bugs/459054
> You received this bug notification because you are a direct subscriber
> of the bug.
>

David Smith (dsmithhfx) wrote :

I just did a dry run and the ubuntu-9.10-desktop-amd64 installer found, and correctly identified my 3 hdd's (2x ide, 1 sata) and the numerous distro and data partitions, including 3 windows installs, gutsy, jaunty, and sundry NTFS and FAT32s...

I do not use raid on my system.

Kaaahn! (cnetrix) wrote :

I'm not using any raid in my machine... I have 1 sata drive that was partitioned by Windows 7... so it has two NTFS partitions and an ext4 partition.

eggbloke (eggbloke) wrote :

I can confirm Richard Bailey's removing dmraid workaround works.
On Ubuntu 64 bit

Kaaahn! (cnetrix) wrote :

Removing the package dmraid worked for me, too, from the Ubuntu 64-bit live CD.

I can confirm this bug affected update-grub and os-prober for me too. Although I didn't get any errors, just that the os-prober only saw the one OS installed on my IDE drive, but not the raids. Removing dmraid fixed it as well.

Jim Leinweber (jiml-mail) wrote :

The idaho computer I don't have direct access to, which probably has some legacy intel software RAID stuff lurking on disks somewhere in spite of repartion/quick format/reinstall of OS (32-bit vista -> 64 windows 7 on sda2), had a better experience after the "apt-get remove dmraid" workaround. Does anyone know where intel puts its software raid config info?

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Matthew Joiner

Confirm that you know Matthew Joiner
https://www.linkedin.com/e/isd/856848884/5M6F0Rdh/

Every day, millions of professionals like Matthew Joiner use LinkedIn to connect with colleagues, find experts, and explore opportunities.

------
(c) 2009, LinkedIn Corporation

oomgosh (oomgoshcd) wrote :

I'm seeing the same problem, when reaching step 4/7 my prepare partition screen is blank. Removing the dmraid and simply going back (to step 3) and going forward again brought up the expected "Prepare disk space" screen on the installer.

My system has a single IDE CD-ROM drive. An SATA drive connected to SATA4 port. I have booted into a live 9.10-i386 from a USB flash drive.

I've attached a sysinfo dump for reference.

Rick Maddox (rhmaddox) wrote :

this is not good. How can we ever expect more users when you have to be a magician to install Linux?

Nick (nickharlow) wrote :

I've had an identical problem with OpenSUSE 11.2 but Mandriva 2010 seems ok. I don't know what Mandriva have done differently, but their live CD detected the SATA drives fine, but neither Ubuntu 9.10 nor OpenSUSE 11.2 did. I managed to get OpenSUSE to see them with noraid boot option and then install it, so I assume you could do the same with Ubuntu? OpenSUSE then broke with an upgrade that made the hard drives invisible again except in failsafe mode.

Matt Joiner (anacrolix) wrote :

This problem was solved for me in the Red Hat Bugzilla.
Here's the link: https://bugzilla.redhat.com/show_bug.cgi?id=533703

I was directed to look at this issue: https://fedoraproject.org/wiki/Common_F11_bugs#dmraid-nodmraid
Running the recommanded command `dmraid -rE` then solved the problem, on both Fedora *and* Ubuntu.

I've seen various comments around the place mentioning that this problem is due to changes in the kernel and how it handles BIOS RAID settings. Hopefully it will eventually be fixed upstream, if not here.

Same here. Ubiquity during manual partitioning master hard drive is not seen at all and slave hard disc is referenced as sda. Installing anyway and the system will not boot, grub comes up with error 15.

I rebooted into Karmic live CD and then Hardy live CD and ran cfdisk and gparted from both. None of the 4 are showing the master hard disc and all reference the slave as sda.

I had been wanting to try Karmic and installed to spare hard discs. I have reverted to my normal single hard disc with Hardy and cannot test further.

Best Wishes to you.

Matt Joiner (anacrolix) wrote :

@Chris, try the fix I found in #28.

@Matt, Thanks, I will try it out prob late tomorrow.

Hopefully this will be fixed for 10.04. Removing dmraid worked for me from ubuntu live cd 64 bit.

Jacques (j-nodtech) wrote :

Had the same problem loading past step 4 on Ubuntu 9.1 install.
Change SATA mode from ATA to AHCI in bios, reboot & Ubuntu saw the Drive ready for partition.

Hope this helps anybody.

Hardware: Dell Inspirion 1525

Imran Chaudhry (ichaudhry) wrote :

@jacques

Thank you for posting that. I will try that later and report the result here.

I found this bug after Googling and finding this: http://swiss.ubuntuforums.org/showthread.php?t=1303703

Sadly that thread is closed so I could not refer to your suggestion.

I am facing the issue with a Lucid Lynx i386 Desktop install. I have Win7 installed already with 40GB free space on the SATA HDD on which I want to install Ubuntu. At Step 4, the "Prepare partitions" table is empty. If I choose quit and enter the Live CD desktop I can use cfdisk to find and create partitions but without Ubiquity finding it I cannot install.

I'm having the same problem on lucid. Also had the same problem on Ubuntu 9.10. I'm also using them in combination with windows 7 (64 bit).

Deinstalling the package dmraid on the live cd seemed to work for me on both distros.

I'm using a fujitsu siemens amilo XA 3530.

Imran Chaudhry (ichaudhry) wrote :

Removing the dmraid package worked for me also.

aptitude remove dmraid

Before trying that, I tried the following which did NOT work:
- choosing AHCI for SATA mode in the BIOS
- choosing the other options for SATA mode (i.e. options that were not the default which is "IDE mode")
- choosing the nodmraid boot option on the LiveCD (press F6 for Options)

Cyril (cyril-fournillon) wrote :

I had the same problem with 10.04 booting from an USB stick.
I wanted to install on a PATA HDD (/dev/sda) that would never show up in the devices proposed for installation.
gparted showed the HDD though.
I tried with and without an additional SATA HDD in the machine with no result.

Running the liveCD then sudo apt-get remove dmraid (as explained in post #28) made /dev/sda to show up in the installer.

Installation on the way.
Thank you for the wrokaround !

tags: added: ubiquity-2.0.2
tags: added: karmic
Nicolas Krzywinski (nsk7even) wrote :

I first encountered this bug on Lucid on one of my PCs. Skipped installation of Ubuntu therefore and waited for Maverick. But there and in Natty this problem is still not solved!

Switching IDE/AHCI mode, Ubuntu/Mythbuntu installers, booting into live environment and starting ubiquity from there all did not helped.

The workaround of removing the dmraid package finally succeeded with current Natty installer of Ubuntu 64 Bit - thanks for that!

This system is Clarkale-based: Core i3 something, running on P7H55D-M EVO with SSD connected via SATA.

Id2ndR (id2ndr) wrote :

I encountered the trouble in Ubuntu 12.04.1, and I removed dmraid package during live session to get ubiquity working. The computer is configured to use RAID in the BIOS, and switching the setting to AHCI prevent Windows from booting, so I revert to RAID setting and remove dmraid package.

Phillip Susi (psusi) wrote :

Please post the output of parted -l, and identify which disk does not show up in the installer.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.