Ubuntu GNOME 16.04 runs ubiquity without root so it fails

Bug #1579454 reported by Ilya on 2016-05-08
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Unassigned

Bug Description

The crash occurs in both UEFI and legacy modes.
New installation with pre-existing /home on a separate partition.
Installing from the live session results in a crash during "copying files" step with this message in the log:

    ValueError: invalid literal for int() with base 10: ''
        status = int(status)
    File "/usr/lib/python3/dist-packages/debconf.py", line 83, in command
        lambda *args, **kw: self.command(command, *args, **kw))
    ....

The slideshow graphics never appears. Removal of the ubiquity-slidewshow-ubuntu-gnome package lets the file copying to go through but the installer crashes during "installing the system" step.

Log shows:

    ubiquity.install_misc.InstallStepError: Plugin language failed with code 4

Hardware: ASUS UX301L ultrabook

The very same installation media was successfully used on a desktop workstation

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.63
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
Date: Sat May 7 22:21:45 2016
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
LiveMediaBuild: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Release amd64 (20160421)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Ilya (ilya-shamovsky) wrote :

Exception during installation:
May 8 02:21:37 ubuntu-gnome /plugininstall.py: Traceback (most recent call last):
May 8 02:21:37 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1778, in <module>
May 8 02:21:37 ubuntu-gnome /plugininstall.py: install.run()
May 8 02:21:37 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
May 8 02:21:37 ubuntu-gnome /plugininstall.py: func(self)
May 8 02:21:37 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 198, in run
May 8 02:21:37 ubuntu-gnome /plugininstall.py: self.configure_locale()
May 8 02:21:37 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 562, in configure_locale
May 8 02:21:37 ubuntu-gnome /plugininstall.py: self.run_plugin(language_plugin)
May 8 02:21:37 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 547, in run_plugin
May 8 02:21:37 ubuntu-gnome /plugininstall.py: "Plugin %s failed with code %s" % (plugin.NAME, ret))
May 8 02:21:37 ubuntu-gnome /plugininstall.py: ubiquity.install_misc.InstallStepError: Plugin language failed with code 4
May 8 02:21:37 ubuntu-gnome /plugininstall.py:

tags: added: ubiquity-2.21.63
tags: added: installer-crash

I have the same issue with a fresh XPS 13 and an ubuntu gnome ISO (both release and nightly). This is a blocker. I have been completely unsuccessful at installing Ubuntu Gnome.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Ilya (ilya-shamovsky) wrote :

The workaround for me was to use "Install UBUNTU GNOME" option without booting to the full live session.

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical

Sadly, the stated workaround does not help me, since I need to unlock an existing LUKS partition before starting the setup process.

My hardware: Macbook Pro 11,1

Phillip Susi (psusi) wrote :

It looks like you are trying to replace the OS on an existing partition and the permissions are messed up somehow. Can you mount the partition and provide the output of ls -al /mnt/etc/default? You should be able to mount it with:

sudo -s
mount -t ext4 /dev/sda1 /mnt

Assuming the partition in question is number 1, otherwise you will need to change the number.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired

I have the same issue.
It seems to be a permission problem caused because the "ubuntu" user runs /usr/lib/ubiquity/localechooser/post-base-installer (instead of root).

So, when the script try to execute:
 sed -i 's/^# LANG=$/LANG="'es_ES.UTF-8'"/' /target/etc/default/locale
 echo $?
 --> 4

"sed" command fails because it can not open a temporal file in /target/etc/default/ folder.

A workaround for this is to run ubiquity as root by using "sudo" command:
 sudo ubiquity

Best regards!

Vincenzo Costa (cvincenzo16) wrote :

I confirm that this bug still exists on the 16.04.1 image when installing ubuntu gnome in an Asus Zenbook UX305.
The workaround of installing directly without passing through the "live session" seems to work.

Changed in ubiquity (Ubuntu):
status: Expired → New
Phillip Susi (psusi) on 2016-12-08
Changed in ubiquity (Ubuntu):
status: New → Triaged
summary: - Ubuntu GNOME 16.04 installer crashes during either copying files or
- installing the system steps
+ Ubuntu GNOME 16.04 runs ubiquity without root so it fails
fossfreedom (fossfreedom) wrote :

Just experimenting with this - it looks like there is a missing dependency on ubiquity.

After install python-pyicu on the liveCD session, the installer completes successfully.

Jeremy Bicha (jbicha) wrote :

> After install python-pyicu on the liveCD session, the installer completes successfully.

python3-pyicu is already installed. The installer shouldn't require Python2…

Kenneth Davis (blackt1ger) wrote :

Happens for me, too. Ubuntu 16.04.02. The installation stops before the slideshow with the error message described above: ubiquity.install_misc.InstallStepError: Plugin language failed with code 4.

I tried directly installing and installing from the LiveCD, both fail. I executed the install link which was:

sh -c 'ubiquity gtk-ui'

with the following modification:

sudo -c 'ubiquity gtk-ui'

and it worked completely.

Kenneth Davis (blackt1ger) wrote :

whoops (is there no 'edit' in this forum????)

the correct modification is:

sudo sh -c 'ubiquity gtk-ui'

MWorks (hugop02) wrote :

Hello everyone, I´m trying to install Ubuntu Gnome 16.04.3 to my Asus Rog GL552VW, I´ve been able to go into the try option (I can enter and try ubuntu) but when I try to install, right after it officially starts (after selecting region, language, and which partition it will use) an error pops up, saying: System Program Problem detected, and the installations hangs eternally,

I noticed the window that was about to open, the one that shows you random ubuntu stuff, doesn´t load (its right when its about to load when the error appears). I´ve found the /var/crash/ folder, and it says:

total 15656
-rw-r——-1 root whoopsie 16005864 _usr_lib_ubiquity_bin_ubiquity.0.crash
-rw-r—–1 root whoopsie 22082 _usr_share_ubiquity_plugininstall.py.0.crash
Any help will be appreciated.

Happy Christmass you all 😀

Leonardo Donelli (learts92) wrote :

Ok, sorry for the late answer. Attached here is a fragment of journal errors, this is the part that always gets logged when I close and reopen the lid with no external monitor attached. I collected it using `journalctl -b --priority warning --lines 50 --follow`

Leonardo Donelli (learts92) wrote :

Sorry guys, I have no idea how my last comment got here, I was replying to another bug report!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers