Comment 10 for bug 1579454

I have the same issue.
It seems to be a permission problem caused because the "ubuntu" user runs /usr/lib/ubiquity/localechooser/post-base-installer (instead of root).

So, when the script try to execute:
 sed -i 's/^# LANG=$/LANG="'es_ES.UTF-8'"/' /target/etc/default/locale
 echo $?
 --> 4

"sed" command fails because it can not open a temporal file in /target/etc/default/ folder.

A workaround for this is to run ubiquity as root by using "sudo" command:
 sudo ubiquity

Best regards!