installer hangs retrieving langpacks when network is down

Bug #145012 reported by Steve Langasek on 2007-09-25
74
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan

Bug Description

Binary package hint: ubiquity

Accidentally booting Kubuntu gutsy beta in VMWare without networking enabled, the installer fails to complete the install when choosing French as the language, hanging at 87% while trying to download language packs. This problem does not occur when choosing English as the language or when the network is present.

Related branches

Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Simone Tolotti (simontol) wrote :

Same here with italian langpacks.
I did retry with network enabled and all gone right.
But, this is still a big problem for who don't have the chance to connect to the internet via LiveCD.
I think to usb modems or other hardware that needs custom drivers or firmware.
Please mark it as "High".
thanks

exactt (giesbert) wrote :

just installed the Gutsy beta in German without network and i also got an error message regarding aspell. yet besides giving the error the installation finished successfully.

Wiktor Wandachowicz (siryes) wrote :

I just tried to install Gutsy beta in Polish, without network and the installation hangs at 87%.

Then I configured the network manually (so I am typing this using LiveCD), but in Polish the installation still hangs at 87%, trying to download the lang packs. But this time it at least displayed that there is 1:09 estimated time left.

Not to mention that installation still hangs after mounting Vista's NTFS partitions, as described in Bug #135370.

It's apparently bug squash time!

Jan Frybort (jan.frybort) wrote :

I can confirm this with Czech language. The installation hangs at 87%. English installation proceeded without problems. Internet connection was available.

Martin Emrich (emme) wrote :

I am just installing from the Gutsy Beta CD (German), and the installer hangs at 84% ("Downloading language packs"). There is a "D" /usr/lib/apt/methods/http process. Network is up and running.

Ciao

Martin

Arne Goetje (arnegoetje) wrote :

It should happen for any language besides English (I personally got the confirmation for Chinese), because the necessary files need to be downloaded from a network (which is apparently not available).

Suggestion: either disable (grey out) the possibility to install in a different language than English, or display a popup Window explaining to the user that a network connection is required for this feature. Or probably both...

amikron (amikron) wrote :

The bug occurs even if internet connection is up and running. The problem must be something else, at least with Polish installation.

Colin Watson (cjwatson) on 2007-10-03
Changed in ubiquity:
assignee: nobody → evand
Jens (jens-launchpad-net) wrote :

The problem is that the language packs are not on the server, and the background download task gets a "404" error and does not catch it.

Ubuntu's Gtk based installer displays an error message and offers to continue the installation without the langpacks. Kubuntu's installer just sits there, consumes 100% CPU and freezes, making a full installation of Kubuntu Gutsy impossible.

IMHO this is a showstopper bug for Kubuntu Gutsy.

FiNeX (finex) wrote :

I can confirm the problem on Gutsy beta while installing the Italian language packages. The installer hangs on 87% with and without the network connection.

Colin Watson (cjwatson) wrote :

ubiquity (1.6.6) gutsy; urgency=low

  [ Evan Dandrea ]
  * Back out recent test for the user existing in the m-a debconf
    section. It isn't necessary and it breaks the installer when m-a is
    used (LP: #151243).

  [ Colin Watson ]
  * Ignore IOError exceptions while fetching packages; they happen when the
    network is disconnected, and aren't important enough to result in scary
    error messages or even hangs (LP: #145012).
  * Remove apt_pkg.init() workaround for LP #131294, which had too many
    other ill effects. We're fixing this in apt-setup instead.
  * Automatic update of included source packages: apt-setup 1:0.21ubuntu4.

 -- Colin Watson <email address hidden> Wed, 10 Oct 2007 18:31:50 +0100

Changed in ubiquity:
status: Confirmed → Fix Released
Ilja Pavkovic (ipavkovic) wrote :

I had this problem before. I downloaded

http://de.releases.ubuntu.com/kubuntu/7.10/kubuntu-7.10-rc-desktop-i386.iso

and now it works.

Good work! Thanks!

I confirm that this issue is fixed with Kubuntu Gusty 7.10 RC, for a french installation all now goes well.

DJ Wings (djwings) wrote :

The final is out, and I'm still getting it on Xubuntu.

Andries van Tonder (outoppie) wrote :

On several versions of Ubuntu and Xubuntu I found the same hang on "configuring language-pack-en-base". Installing on an old IBM 600 laptop that used to run Win ME.

Managed to get 4.10 "Warty Warthog" installed but it does not support the USB and Network plug in cards.

I'm still experiencing this on Precise using the alternative installer (text interface). It has hung at "Configuring language-pack-en-base" having made the mistake of choosing British English en-GB.

Why on earth would it attempt to make a download when it has already asked me if it should proceed without networking. It's also on a slow machine (Athlon 900 MHz).

Steve Langasek (vorlon) wrote :

Cefn, this bug was fixed four years ago. Whatever issue you're experiencing is unrelated - the ubiquity package isn't even present on the alternate CDs.

"Configuring language-pack-en-base" means that the package is already present and being *configured*, not downloaded; and the package in question is on the CD so would not be downloaded anyway.

Please file a separate bug report for your issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers