Argentina is 1 hour ahead when it shouldn't

Bug #278419 reported by Alberto Bertogli on 2008-10-05
58
Affects Status Importance Assigned to Milestone
tzdata (Debian)
Fix Released
Unknown
tzdata (Ubuntu)
High
Martin Pitt
Dapper
High
Unassigned
Feisty
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
High
Unassigned
Intrepid
High
Martin Pitt

Bug Description

Binary package hint: tzdata

I've just noticed that the clock went forward one hour, when it shouldn't have.
It looks like a bug in tzdata.

So at Oct 5 00:46 (Argentinian time), my Ubuntu boxes reported 01:46.

All of them were running 8.04, with tzdata 2008e-1ubuntu0.8.04; and I've been
told this bug is also present in Debian lenny and etch.

If you need any additional information, please let me know.

Thanks,
    Alberto

Juan F. Codagnone (jcodagnone) wrote :

This is "fixed" in tzdata2008f. I quote tzdata's southamerica:
-------------8<-----------------------------------8<------------------------_
# From Alexander Krivenyshev (2008-09-05):
# As per message from Carlos Alberto Fonseca Arauz (Nicaragua),
# Argentina will start DST on Sunday October 19, 2008.
#
# <a href="http://www.worldtimezone.com/dst_news/dst_news_argentina03.html">
# http://www.worldtimezone.com/dst_news/dst_news_argentina03.html
# </a>
# OR
# <a href="http://www.impulsobaires.com.ar/nota.php?id=57832 (in spanish)">
# http://www.impulsobaires.com.ar/nota.php?id=57832 (in spanish)
# </a>

Rule Arg 2007 only - Dec 30 0:00 1:00 S
Rule Arg 2008 max - Mar Sun>=15 0:00 0 -
Rule Arg 2008 max - Oct Sun>=15 0:00 1:00 S
-------------8<-----------------------------------8<------------------------

But im not sure this is the right fix (this is for upstream...) i found no law that says what is the summer time
for 2008/2009: http://infoleg.mecon.gov.ar/infolegInternet/verNorma.do?id=136191

Changed in tzdata:
importance: Undecided → High
status: New → Triaged
Martin Albisetti (beuno) wrote :

Time changes in Argentina are dictated by random one-time laws.
The change applied last year should of been reverted after is was changed back.
For the time being, Argentina is UTC -3, without any daytime savings policy.

A fix has been uploaded to Debian, the package should be synced in Intrepid, and backported to Hardy (bonus points for backports to the rest of the actively maintained versions).

Quote from Debian bug report:
> > Given this kind of thing happens every year, I think we should stop
> > using "max" in the definition of the Argentinian timezone, and only use
> > "only" to define the DST rules year by year instead of using the rule of
> > the previous year.
>
> I agree. Also, I'd like to note that last year, when the law was
> passed, it was explicitely said that the government would set the
> dates for 2008/2009 as they saw fit, whever they saw appropiate. So,
> it should always have been "only". And it should keep being "only",
> unless they state that whatever they decide is to be applied in the
> future.

Please do not subscribe the Ubuntu Development Team to bugs! It spams many, many people!

Changed in tzdata:
status: Unknown → New
Matt Zimmerman (mdz) on 2008-10-06
Changed in tzdata:
importance: Undecided → High
status: New → Triaged
importance: Undecided → High
status: New → Triaged
Martin Pitt (pitti) wrote :

 tzdata (2008g-1) unstable; urgency=low
 .
   * New upstream version.
 .
 tzdata (2008f-2) unstable; urgency=low
 .
   * Fix Argentinian timezone wrt DST. Closes: #501169
 .
 tzdata (2008f-1) unstable; urgency=low
 .
   [ Christian Perrier ]
   * debian/po/pt.po: update from Ricardo Silva. closes: #498963
 .
   [ Clint Adams ]
   * New upstream release.
 .
 tzdata (2008e-4) unstable; urgency=low
 .
   * Add a README.Debian file explaining the difference between the
     "posix" and the "right" versions of the timezone data.
   * Only build the posix version of the timezone data on emdebian.
   * Don't build solar87, solar88 and solar89 on emdebian as they are
     useless.
 .
 tzdata (2008e-3) unstable; urgency=low
 .
   * Provide a tzconfig compatibility script. Closes: #493978.

Changed in tzdata:
status: Triaged → Fix Released
Martin Albisetti (beuno) wrote :

Amazing turn-around time.
You guys rock, thank you.

Emilio (turl) wrote :

I can confirm tzdata 2008g-1 solves the problem, and the time is now correct.

When will this get on Hardy? Should I workaround the bug by changing my timezone to an explicit GMT-3? (I won't do it if the fix gets on Hardy in an hour from now :P).

Mariano Draghi (chaghi) wrote :

Is there a reason to release the fix for Intrepid (the beta version of Ubuntu) before fixing Hardy which not only is the stable release, but a LTS one?
I don't mind having the wrong time in a spare box and/or virtual machine being used to test Intrepid, but having the wrong time in my laptop, my desktop, and a server with Dapper at work is really annoying.
Is there a recommended workaround for Hardy and Dapper?

Changed in tzdata:
status: New → Fix Released

Mariano,

Yes, it gets tested on intrepid first, to check that it doesn't make anything else explode. Obviously, having things exploding in stable, especially LTS releases, is very bad.

I presume this will get updated in stable releases very quickly.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tzdata:
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Please note that the feisty/gutsy/hardy update comes in "tzdata", while the dapper update comes in "locales".

Changed in tzdata:
status: New → Fix Committed
status: New → Fix Committed
Martin Pitt (pitti) wrote :

The usual 7 day maturing period will be waived for this update. Testing the proposed update and giving feedback quickly is highly appreciated, so that we can move this to -updates really soon.

Changed in tzdata:
status: Triaged → Fix Committed
Mariano Draghi (chaghi) wrote :

I confirm that the -proposed package for Dapper works as expected.
I'll try -proposed for Hardy in a few hours.
Thank you!

m4v (m4v) wrote :

It works in hardy

Martin Pitt (pitti) wrote :

Copied to -updates, thanks for testing!

Changed in tzdata:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Bit-Man (victor-bit-man) wrote :

It works in hardy x86_64

Marcelo Fernandez (fernandezm) wrote :

Ok, I installed the updated tzdata (from hardy-updates), and by now the time is correct. The problem is, in two weeks (Oct 19) we will have the same problem!

$ zdump -v /etc/localtime | egrep "2008|2009"
/etc/localtime Sun Mar 16 01:59:59 2008 UTC = Sat Mar 15 23:59:59 2008 ARST isdst=1 gmtoff=-7200
/etc/localtime Sun Mar 16 02:00:00 2008 UTC = Sat Mar 15 23:00:00 2008 ART isdst=0 gmtoff=-10800
/etc/localtime Sun Oct 19 02:59:59 2008 UTC = Sat Oct 18 23:59:59 2008 ART isdst=0 gmtoff=-10800
/etc/localtime Sun Oct 19 03:00:00 2008 UTC = Sun Oct 19 01:00:00 2008 ARST isdst=1 gmtoff=-7200
/etc/localtime Sun Mar 15 01:59:59 2009 UTC = Sat Mar 14 23:59:59 2009 ARST isdst=1 gmtoff=-7200
/etc/localtime Sun Mar 15 02:00:00 2009 UTC = Sat Mar 14 23:00:00 2009 ART isdst=0 gmtoff=-10800
/etc/localtime Sun Oct 18 02:59:59 2009 UTC = Sat Oct 17 23:59:59 2009 ART isdst=0 gmtoff=-10800
/etc/localtime Sun Oct 18 03:00:00 2009 UTC = Sun Oct 18 01:00:00 2009 ARST isdst=1 gmtoff=-7200

There are no plans from our government (Argentina) to set a DST this summer... so this version of tzdata (2008g) should be corrected, and updated again. :-\

Regards,
Marcelo

What the hell? I thought the fix REMOVED DST for this year!

Oct 19 is just a *rumor* from a news site *last year*.

Martin Albisetti (beuno) wrote :

Setting all statuses back to confirmed, since the problem will persist after Oct 18th.
I apologize in the name of our sloppy politicians...

Changed in tzdata:
status: Fix Released → Confirmed
status: Fix Released → Confirmed
status: Fix Released → Confirmed
status: Fix Released → Confirmed
status: Fix Released → Confirmed

Oh well, at least I got my correct clock back, and you have almost two weeks to fix it correctly... (actually, are you coordinating with the upstream maintainers of tzdata or just going on your own? I hate it when distros fix bugs on their own without letting everyone else benefit from the fix)

On Tue, Oct 7, 2008 at 7:13 PM, Nicolás Alvarez
<email address hidden> wrote:
> What the hell? I thought the fix REMOVED DST for this year!
>

Remember that some argentinian places has no confirmed the change or
not for this year

http://www.lanacion.com.ar/nota.asp?nota_id=1056251
http://www.lanacion.com.ar/nota.asp?nota_id=1052700
http://www.mdzol.com/mdz/nota/72048-Jaque-no-adhiere-al-cambio-de-horario-propuesto-por-Cristina/

--
             .::MAbeeTT::.

 mabeett [at] gmail [ dot] com
 some time ago:

 mtspcchaiaeia [at] gmail [dot] com

Alberto Bertogli (albertito) wrote :

On Tue, Oct 07, 2008 at 11:05:10PM -0000, MAbeeTT wrote:
> On Tue, Oct 7, 2008 at 7:13 PM, Nicolás Alvarez
> <email address hidden> wrote:
> > What the hell? I thought the fix REMOVED DST for this year!
> >
>
> Remember that some argentinian places has no confirmed the change or
> not for this year
>
> http://www.lanacion.com.ar/nota.asp?nota_id=1056251
> http://www.lanacion.com.ar/nota.asp?nota_id=1052700
> http://www.mdzol.com/mdz/nota/72048-Jaque-no-adhiere-al-cambio-de-horario-propuesto-por-Cristina/

That has nothing to do with this situation. It just states that IF the
goverment decides to set a date for DST, Mendoza will ignore it. Given
that there is already a special timezone for Mendoza, this is not an
issue at all.

At the moment, there is absolutely NO indication whatsoever that
Argentina (either with or without Mendoza) will change its timezone in
October.

There is no reason to expect so. tzdata should be changed to reflect
this, and obviously it should be fixed upstream.

Yes, it is possible that we do change the timezone sometime this year;
however, at this moment, nobody knows when. So it's a tzdata bug to make
guesses about it.

Last year we had to wait until the law passed (just about 3 days before
the timezone change took place) to change tzdata, which is a very
reasonable requirement.

Now they're playing guesses with our timezone based on a rumor written
on an almost-unknown online newspaper?

Thanks,
  Alberto

Matias Pecchia (mabeett) wrote :

On Tue, Oct 7, 2008 at 9:43 PM, Alberto Bertogli
<email address hidden> wrote:
> On Tue, Oct 07, 2008 at 11:05:10PM -0000, MAbeeTT wrote:
>> On Tue, Oct 7, 2008 at 7:13 PM, Nicolás Alvarez
>> <email address hidden> wrote:
>> > What the hell? I thought the fix REMOVED DST for this year!
>> >
>>
>> Remember that some argentinian places has no confirmed the change or
>> not for this year
>>
>> http://www.lanacion.com.ar/nota.asp?nota_id=1056251
>> http://www.lanacion.com.ar/nota.asp?nota_id=1052700
>> http://www.mdzol.com/mdz/nota/72048-Jaque-no-adhiere-al-cambio-de-horario-propuesto-por-Cristina/
>
> That has nothing to do with this situation. It just states that IF the
> goverment decides to set a date for DST, Mendoza will ignore it. Given
> that there is already a special timezone for Mendoza, this is not an
> issue at all.
>
>
> At the moment, there is absolutely NO indication whatsoever that
> Argentina (either with or without Mendoza) will change its timezone in
> October.

You right,

http://www.boletinoficial.gov.ar/Bora.Portal/CustomControls/PdfContentResponse.aspx?fp=28122007&pi=10&pf=10&s=0&sec=01

See page 3, 3rd column (Public Journal in Argentina's Official
Language, Spanish, PDF)

>
> There is no reason to expect so. tzdata should be changed to reflect
> this, and obviously it should be fixed upstream.
>
>
> Yes, it is possible that we do change the timezone sometime this year;
> however, at this moment, nobody knows when. So it's a tzdata bug to make
> guesses about it.
>
> Last year we had to wait until the law passed (just about 3 days before
> the timezone change took place) to change tzdata, which is a very
> reasonable requirement.
>
> Now they're playing guesses with our timezone based on a rumor written
> on an almost-unknown online newspaper?

Well Argentina pays for a Canciller ( ~ Foreign Minister ). :-S

Thanks for your response.

--
             .::MAbeeTT::.

 mabeett [at] gmail [ dot] com
 some time ago:

 mtspcchaiaeia [at] gmail [dot] com

Colin Watson (cjwatson) wrote :

Nicolás: the fix for this bug came from tzdata upstream.

nico (nmacia) wrote :

Ok, but what should i do to fix it in my hardy?

Colin Watson wrote:
> Nicolás: the fix for this bug came from tzdata upstream.
>

Martin Pitt (pitti) wrote :

Right, it was fixed upstream.

So now I am totally confused. This is the current data, which this original bug report was all about:

# From Alexander Krivenyshev (2008-09-05):
# As per message from Carlos Alberto Fonseca Arauz (Nicaragua),
# Argentina will start DST on Sunday October 19, 2008.
#
# <a href="http://www.worldtimezone.com/dst_news/dst_news_argentina03.html">
# http://www.worldtimezone.com/dst_news/dst_news_argentina03.html
# </a>
# OR
# <a href="http://www.impulsobaires.com.ar/nota.php?id=57832 (in spanish)">
# http://www.impulsobaires.com.ar/nota.php?id=57832 (in spanish)
# </a>

Rule Arg 2007 only - Dec 30 0:00 1:00 S
Rule Arg 2008 max - Mar Sun>=15 0:00 0 -
Rule Arg 2008 max - Oct Sun>=15 0:00 1:00 S

This means that starting on October 19, DST will be *start* in Argentinia. So is this right or not? I. e. was DST start just moved to October, or won't 2008 have DST at all then?

Please give some current references to the definitive place, then we can fix it and work with upstream to fix it for everyone. Thanks!

Changed in tzdata:
assignee: nobody → pitti
status: Confirmed → Incomplete
Chris Coulson (chrisccoulson) wrote :

Martin,

I think the problem is that there are no official sources saying that DST will start on 19th October, so there isn't really any source to reference to. That dates seem to be a rumour from an unofficial news site. Until an official announcement is made, it should probably be assumed that there will be no DST starting in October.

Martin Pitt (pitti) wrote :

OK, thanks. I'll report this upstream, too.

Changed in tzdata:
status: Incomplete → Confirmed
ajonat (ajonat) wrote :

Hi Martin,

Martin Pitt wrote:
> Right, it was fixed upstream.
>
> So now I am totally confused. This is the current data, which this
> original bug report was all about:
[...]
> This means that starting on October 19, DST will be *start* in
> Argentinia. So is this right or not? I. e. was DST start just moved to
> October, or won't 2008 have DST at all then?
>

Quoting http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501169#57 :
"The current state of affairs regarding HOA is provided by
National Law 26350 [1]. It says that during most of the year the time
zone will be UTC-3, and that in summer it will be UTC-2. It also says
that the executive branch of the federal goverment will set *yearly*
the beginning and ending date of the summer time. Last summer it was
from December 30th, 2007 to March 16th 2008 (and I really hated it),
but clearly there is no fixed rule to follow and code in tzdata."

In short, there's _no_ indication that DST will start in two weeks. We're
waiting for the government to set the date when DST will start (and end).
In fact, we're not sure if we'll have DST this year, so the rules in tzdata
are _wrong_.

[1] http://www.hidro.gov.ar/Observatorio/QueHoraUtiliza.asp

--
Saludos,
Alex.

Hello tzdata maintainers,

in https://launchpad.net/bugs/278419 we first handled the recent
Argentina DST change and uloaded 2008g to all stable Ubuntu releases.
However, now there are some followup comments which say that is not at
all clear whether October 19 will actually switch to DST, as indicated
by the current rules. The last comment subsumes this as

  "I think the problem is that there are no official sources saying
  that DST will start on 19th October, so there isn't really any
  source to reference to. That dates seem to be a rumour from an
  unofficial news site. Until an official announcement is made, it
  should probably be assumed that there will be no DST starting in
  October."

I can just play messenger here, and I don't speak Spanish either, but
I thought notifying you about possible problems would be a good idea.

Settling this soon would be good, since it always takes a while until
tzdata package updates are actually downloaded and used by people.

Thanks,

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

This is from today newspaper
http://www.lanacion.com.ar/nota.asp?nota_id=1057552&pid=5188348&toi=6279 (Spanish)

The DST will start on sun 19 but the president will sign the law 3 o 4 days before. At least that's what the newspaper says today.
The end of DST is march, no exact date yet.

MarianoAbsatz (el-baby) wrote :

Hi Martin,

although I participate in the timezone database discussion list I do not maintain it or have any influence on it (other than Olson and Eggert's opinion on my past comments).

I do live in Argentina and, as steavieleeking just posted, it seems the change will actually happen next Sunday.

As for my opinions on whether there is a bug or not upstream, I just posted there:
http://article.gmane.org/gmane.comp.time.tz/2366
and
http://article.gmane.org/gmane.comp.time.tz/2368

You might want to read thru all the thread at http://thread.gmane.org/gmane.comp.time.tz/2346/focus=2368

Regards

Martin Albisetti (beuno) wrote :

I can confirm that it has *just* been approved.
The time will change on Oct 19th until Mar 15th.

Martin Pitt (pitti) wrote :

Thanks for confirming. So all is well, after all.

Changed in tzdata:
status: Confirmed → Fix Released
status: Confirmed → Fix Released
status: Confirmed → Fix Released
status: Confirmed → Fix Released
status: Confirmed → Fix Released
MarianoAbsatz (el-baby) wrote :

Yeah... for now... anyway, stay tuned, since, as some of the Provinces won't adhere to the National Law and the presidential decree, there *will* be changes (and tzdata will likely reflect them in new releases)...

I don't know if you, Martin, are the maintainer of the ubuntu tzdata package... if you are so, let me invite you to join the time zone mailing list if you haven't done so yet... there's info at http://www.twinsun.com/tz/tz-link.htm about how to subscribe to it.

Regards.

Watch the tz-data mailing list, there is some not-completely-official-but-good-enough information on what provinces will *not* use DST.

On Thu, Oct 16, 2008 at 6:13 PM, Nicolás Alvarez
<email address hidden> wrote:
> Watch the tz-data mailing list, there is some not-completely-official-
> but-good-enough information on what provinces will *not* use DST.

In Fact, Mendoza won't use DST:

http://www.gobernac.mendoza.gov.ar/boletin/pdf/20081016-28259-normas.pdf

Ley 7955 (Mendoza's Public Journal, Official Language: Spanish, PDF)

The law stablish for Mendoza Official's posible's times UTC-3 and
UTC-4; then UTC-2 won't be used un Mendoza.

--
             .::MAbeeTT::.

 mabeett [at] gmail [ dot] com
 some time ago:

 mtspcchaiaeia [at] gmail [dot] com

MarianoAbsatz (el-baby) wrote :

Hi, as of today (October 17th) we have two Decrees published in the Boletín Oficial.

I sent a patch to the tz mailing list to update tzdata2008h with this info: http://thread.gmane.org/gmane.comp.time.tz/2346/focus=2410

I also compiled all the data for Argentina in one file in http://wiki.clueless.com.ar/ActualizarTimezonesConTzdata?action=AttachFile&do=get&target=argentina-baby-2008-10-17.zoneinfo

and I wrote a Province => timezone mapping table for it in http://wiki.clueless.com.ar/ActualizarTimezonesConTzdata#provincia_tz_baby

I just posted this same info to bugs.debian.org but I think we're in a different path than they are: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502430#42

Regards

We're now in DST, but my clock didn't change.

This feels like 2007 all over again...

Skip all the useless testing and get the package updated as soon as possible!

Testing here *is* useless. Come on, you can't render a machine unbootable by changing timezone information. In this case it's more harmful to delay the update than to send it without testing it "enough".

Alberto Bertogli (albertito) wrote :

On Sun, Oct 19, 2008 at 03:27:05AM -0000, Nicolás Alvarez wrote:
> We're now in DST, but my clock didn't change.

It worked just fine here (hardy, tzdata 2008g-0ubuntu0.8.04)...

Thanks,
  Alberto

Tabris (theangeltabris) wrote :

Here is perfect. At 00:00 the clock changed to 01:00 automatically.

Kubuntu Hardy Heron 64 Bits up-to-date.

MarianoAbsatz (el-baby) wrote :

It also worked fine here (using America/Argentina/Buenos_Aires with tzdata 2008h-0ubuntu0.8.04 from hardy-proposed)...

Now if you're living in Salta, Catamarca, La Rioja, San Juan, Mendoza, La Pampa, Neuquén, Rio Negro, Chubut, Santa Cruz or Tierra del Fuego, your time probably changed and it shouldn't...

You have two choices:
select "America/Argentina/San_Luis" or "Etc/GMT-3"... the time will be right, but times in the past can be wrong.

If this is a problem for you, use the instructions I wrote at http://wiki.clueless.com.ar/ActualizarTimezonesConTzdata#parche_baby_2008_10 and select your timezone according to the table beneath it at http://wiki.clueless.com.ar/ActualizarTimezonesConTzdata#provincia_tz_baby

MarianoAbsatz (el-baby) wrote :

FWIW, I'm enclosing the patch I sent to the tz mailing list last Friday.

I did some testing and it seems to work OK

Martin Pitt (pitti) wrote :

Nicolas, the current tzdata in -proposed does not change Argentinian DST, see bug 284648.

Mariano, thanks for the patch, will do that update now.

Martin Pitt (pitti) wrote :

*sigh* reopening yet again.

Changed in tzdata:
status: Fix Released → In Progress
status: Fix Released → In Progress
status: Fix Released → In Progress
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Intrepid fixed by syncing from Debian:

 tzdata (2008h-2) unstable; urgency=high
 .
   * Apply patch from Margarita Manterola to fix DST for Argentina this
     weekend. closes: #502430.

However, the patch from Margarita (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502430#25) and the patch from Mariano here are quite different. Can anyone else confirm one or the other?

Changed in tzdata:
status: In Progress → Fix Released

Actually, I forgot to follow up here. The fix *did* work for me. I just had to logout, and undo a stupid workaround I had used back when Ubuntu entered DST when it shouldn't have (two weeks ago) and the updated package took days to be released.

So what exactly is broken now (and fixed in Debian)? The provinces that decided not to switch? And, if it's correct, why wasn't the Debian fix sent back to upstream maintainers?

MarianoAbsatz (el-baby) wrote :

Martin,

in the "practical" part, Margarita's patch differred from mine in the following:

In hers, Jujuy wouldn't apply DST which (as of early last Saturday, was wrong, but now it's right... that is Jujuy decided it would NOT apply DST on the afternoon of Saturday 18th, setting a new record of non-anticipation).

In hers, she is not considering that Salta, La Pampa, Neuquén and Río Negro are no longer part of the America/Argentina/Cordoba timezone and people from those Provinces should have to chose another timezone that wouldn't apply DST this year... the only problem (which is small) is that times in the past will eventually be wrong on those places. My patch created a new timezone (America/Argentina/Salta) for this provinces (considering Salta the most populated city among these four provinces), following the tzdata recommendations.

The other thing I did was to reorder the provinces within the files following the recommendations in the zone.tab file (which hasn't any effect on the inner working of tzdata, only for humans reading the sources).

Anyway, since my patch had wrong data for Jujuy, I'm enclosing a new one with that corrected.

HTH

PS: Martin, feel free to contact me off-launchpad if you need more info.

Juan F. Codagnone (jcodagnone) wrote :

there are some related packages to watch related to this issue:
   * If someone runs java applications, he should have installed tzdata-java.
   * Also, php in hardy seems to use it own timezone database (so php apps show and store incorrect hours). Theres a hack to quickly fix this: https://bugs.launchpad.net/ubuntu/+source/php5/+bug/279980

MarianoAbsatz (el-baby) wrote :

Martin,

FWIW, at http://thread.gmane.org/gmane.comp.time.tz/2420 you'll find Olson's proposed patch for Argentina... if there's no opposition, he'll publish it next Monday.

the patch is similar to mine without the reordering.

I think you should install Olson's patch since it would eventually become the official tzdata2008i.

Regards and thanx for your patience.

Martin Pitt (pitti) wrote :

Mariano,

great, that makes me happy, a patch which both you and upstream agree about. :-) I'll get that into stable releases ASAP. Thanks for your diligence!

Martin Pitt (pitti) on 2008-10-21
Changed in tzdata:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Fix uploaded for Intrepid, waiting in unapproved queue now (will go in after the release candidate is out).

Changed in tzdata:
milestone: none → ubuntu-8.10
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Updates for hardy, gutsy, and dapper uploaded to -proposed. Please test them thoroughly and let me know if they do the right thing now. Thank you all!

Changed in tzdata:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzdata - 2008h-2ubuntu1

---------------
tzdata (2008h-2ubuntu1) intrepid; urgency=low

  * Replace debian/patches/argentina-no-dst.diff with an even more correct
    one which will go upstream, too. Many thanks to Mariano Absatz!
    (LP: #278419)

 -- Martin Pitt <email address hidden> Tue, 21 Oct 2008 11:54:39 +0200

Changed in tzdata:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Hm, I take the lack of feedback as "works now". Copied to -updates.

Changed in tzdata:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
MarianoAbsatz (el-baby) wrote :

Well... it works for me at least... thanx for all the work, Martin.

In case you're interested, this morning Olson published[1] the new release 2008i of the zoneinfo database[2]. The only difference with 2008h-2ubuntu1 regarding Argentina is the order in which the time zones are within the southamerica source.

There's also a change in the order in the zone.tab file introduced due to some problems in Indiana (USA)[3].

I don't know if this deserves yet another upgrade, but it might be interesting at least that the new release goes into Intrepid (which I ain't using yet).

Regards.

[1] http://thread.gmane.org/gmane.comp.time.tz/2440/focus=2440
[2] ftp://elsie.nci.nih.gov/pub/tzdata2008i.tar.gz
[3] http://thread.gmane.org/gmane.comp.time.tz/2424/focus=2424

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.