Can't select/copy/paste address block from Address Book in Thunderbird

Bug #235101 reported by komputes on 2008-05-26
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: mozilla-thunderbird

Very often in my day to day work, I need to send someone an address. It seems that Thunderbird won't allow me to select the address from the "Card Summary Pane" in the Address Book. I must go in the card and copy/paste each field manually.

Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.

reopening.

Confirmed Linux 2001110908

reassigning to racham.

In , Nbaca (nbaca) wrote :

Marking nsbeta1 because you should be able to highlight items in the card pane,
right click and Copy. Bug# 35837 covers the case where a Copy would take all the
contents of the card, not just the highlighted region.

I think this should be slove as people can have their Needed information being
copy. And it wouldn't hurt any thing for doing so.

May I know the status now?

Mail triage team: nsbeta1+/adt3

Correction to last comment:
Mail triage team: nsbeta1-

Mozilla Thunderbird 0.2 (2003090) - Bug still there... :(

In , Robp (robp) wrote :

This would be a *huge* help in my job (even more than real vCard support). I can
work around this limit by clicking the get-map button and copying the address
out of MapQuest, but that procedure is pretty much the definition of "kludge."
Being able to edit an address-book entry in this preview page would be even
better, but I'd be content for a while if I could just copy this text--just as I
can in almost every other application that presents text fields. (Yes, I'm kind
of amazed that this wasn't built in from the start.)

*** Bug 138161 has been marked as a duplicate of this bug. ***

*** Bug 236944 has been marked as a duplicate of this bug. ***

*** Bug 210275 has been marked as a duplicate of this bug. ***

Changing hardware/OS to All

*** Bug 254198 has been marked as a duplicate of this bug. ***

Shouldn't there is a way to send an Address book?
E.g I want to send someone on my Addressbook on the email using vcard?

I think that is the very good way and This Copy on the address book will ease
our problem when we want to put them in the online address book somehow.

*** Bug 172294 has been marked as a duplicate of this bug. ***

Requesting blocking-aviary1.1 flag

Since can't forward VCards yet, there is currently no easy way to copy an
address into an email or other document - you have to either retype the
information (!?!) or copy and paste each line (line 1, line2, city, state...)
separately from the card properties window. This is basic functionality
currently missing from the address book.

If the card preview window was selectable/copyable, this would make the window
function the way a user would expect, and provide a way to easily extract
address information.

Today a field representative called me and asked how to forward a Mozilla
address book entry to someone. He is accustomed to Micrsoft Outlook, so he
expected a button to forward as a vCard.

After checking it out, I was disappointed to discover no support of any kind for
forwarding address book entries. (that would be bug 11406 and bug 20304 and bug
176803
)

I then started to walk him through copying-and-pasting the address book entry to
the body of an e-mail, which I figured was a decent workaround... but it is
impossible to copy text-- impossible even to select it!

Don not ever set bug flags to + if you are not in any special group that manages
releases, please.
Many Mozilla suite versions have shipped with that, SeaMonkey will not block a
release for that.
Also unsetting bogus (very old) target milestone of unassigned bug.

*** Bug 301230 has been marked as a duplicate of this bug. ***

In , Mcow (mcow) wrote :

*** Bug 266553 has been marked as a duplicate of this bug. ***

In , Mcow (mcow) wrote :

Despite being a Suite bug, TB bugs are being duped against this (following
Scott's lead at comment 16). Presumably that means this feature is actually
Core.

This bug is actually an RFE, but I'm not going to change the severity.

*** Bug 319151 has been marked as a duplicate of this bug. ***

*** Bug 346073 has been marked as a duplicate of this bug. ***

This behavious bugs the hell out of me, any sign of it getting fixed? It was first reported five years ago!

See related Bug 365421 ... is it a dupe?

(In reply to comment #28)
> See related Bug 365421 ... is it a dupe?

not a dupe. this is about copying selected text. 365421 is about extracting data from a clickable field.

*** Bug 406185 has been marked as a duplicate of this bug. ***

*** Bug 361895 has been marked as a duplicate of this bug. ***

komputes (komputes) wrote :

Binary package hint: mozilla-thunderbird

Very often in my day to day work, I need to send someone an address. It seems that Thunderbird won't allow me to select the address from the "Card Summary Pane" in the Address Book. I must go in the card and copy/paste each field manually.

komputes (komputes) wrote :

I could use several times a week

*** Bug 468091 has been marked as a duplicate of this bug. ***

I could also use this about every day. Going to the edit screen, then the notes, then scrolling to find text, then copying is a bit tedious.

Joel Goguen (jgoguen) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugzilla.mozilla.org/show_bug.cgi?id=96968

Changed in mozilla-thunderbird:
status: New → Confirmed
Changed in thunderbird:
status: Unknown → Confirmed

This has been reported at https://launchpad.net/bugs/235101. Any word on where this fits in the grand scheme of things?

Joel Goguen (jgoguen) wrote :

Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in mozilla-thunderbird (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

The ability to copy the total contents of an address card in one operation is TOTALLY essential.
This is particularly so because it is impossible to highlight the address card name in one list, then copy it to the clipboard and add the address card to another list

A much more sensible solution would be to allow the link to an address card to be used in 1 or more lists to enable that card to be used by all the selected lists.
Currently a new card has to be opened in each list and the required contents have to be tediously filled in. This causes not only much frustration but also errors and omissions.
The result is that the several cards (in different lists) my not contain the same data. Indeed some may contain out of date phone numbers or email addresses.

This has been an issue for me for years now. I use the address book as my central repository of contact information and not being able to copy & paste is a HUGE inconvenience. PLEASE, Please, please someone take this on and fix it! I will name my first child in your honor if you do.

Another alternative might be to keep the address books in XML or LDIF format, or any other HUMAN READABLE format, so that I can create my own tools to manage the books. The MORK format is ubiquitous inside Mozilla and I've rarely seen anything more useless. How about moving into the 21st century with XML?

(In reply to comment #37)
> This has been an issue for me for years now. I use the address book as my
> central repository of contact information and not being able to copy & paste is
> a HUGE inconvenience. PLEASE, Please, please someone take this on and fix it! I
> will name my first child in your honor if you do.
>
> Another alternative might be to keep the address books in XML or LDIF format,
> or any other HUMAN READABLE format, so that I can create my own tools to manage
> the books. The MORK format is ubiquitous inside Mozilla and I've rarely seen
> anything more useless. How about moving into the 21st century with XML?

It is high time that such a simple fix is carried out.
How about gettingmit done!

*** Bug 557148 has been marked as a duplicate of this bug. ***

*** Bug 561757 has been marked as a duplicate of this bug. ***

In , Wazz (wazz) wrote :

I had thought or hoped opensource software had matured. Apparently not. This issue has been around for almost 10 years and nothing done about it. Microsoft is lovin' it.

File a bug upstream. Saying things like you did
should be posted somewhere else as it does not
have anything to do with the bug.

On 04/26/2010 04:55 AM, Wazz wrote:
> I had thought or hoped opensource software had matured. Apparently not.
> This issue has been around for almost 10 years and nothing done about
> it. Microsoft is lovin' it.
>

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

John Vivirito (gnomefreak) wrote :

Please ignore last comment by me. I was thinking of a different bug report

Changed in thunderbird:
importance: Unknown → Medium

*** Bug 635496 has been marked as a duplicate of this bug. ***

*** Bug 735365 has been marked as a duplicate of this bug. ***

*** Bug 698183 has been marked as a duplicate of this bug. ***

Thank you Frantisek for advising about the add-on. (I nearly missed it)
This solved the problem for me (on Mac) it is a great help.
Could this feature be incorporated into the main application?

*** Bug 849506 has been marked as a duplicate of this bug. ***

Oh good, I'm not the only one desiring this functionality. Of course, 20 versions, 12 years and 18+ duplicate bug filings later, I'm not very hopeful.

Then again, why fix what can be worked around with a 3rd party add-on? /s

Sorry to be so demanding :( I just want to copy-n-paste.

*** Bug 224852 has been marked as a duplicate of this bug. ***

*** Bug 733062 has been marked as a duplicate of this bug. ***

*** Bug 1036626 has been marked as a duplicate of this bug. ***

Changed in thunderbird:
status: Confirmed → Fix Released
affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)
Paul White (paulw2u) wrote :

Upstream bug report shown as "RESOLVED FIXED" on 2018-04-05
Target release - Thunderbird 61
But fixed in Thunderbird 60 beta 3
Tested ok using Ubuntu 18.04 and Thunderbird 60.2.1
So closing by marking "Fix Released"

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.