Comment 34 for bug 1797945

When I tried installing xul-ext-lightning , I got blocked, whether via the Synaptic Package manager or Software Center or using apt from the command-line. The essence of the error message was:

xul-ext-lightning: Depends: thunderbird (= 1:38.6.0+build1-0ubuntu1) but 1:60.2.1+build1-0ubuntu0.16.04.4 is to be installed

I think I noticed that 1:38.6.0 was the version number of xul-ext-lightning; maybe somehow that got copied over into some field that describes the version of Thunderbird? I don't know, but in any case, that did not work for me.

I followed Jeffery To (jefferyto)'s advice in #12, #15 and #21 (which are repeated in #28 and #32 (except step 5 is not as explicit as Jeffery's) and, I'm relieved to say, that worked.

This is really a dreadfully convoluted way to handle the matter. I'm sure only a very persistent few will find it, and the rest will be bemoaning loss of important functionality.

So, yes, please, let's get this to be part of the automatic upgrade.