Thunderbird must be upgraded to Thunderbird 24.0.1 for lightning 2.6.1

Bug #1244619 reported by Mozaic on 2013-10-25
334
This bug affects 70 people
Affects Status Importance Assigned to Milestone
Lightning
Fix Released
Critical
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Gentoo Linux)
Fix Released
Medium
thunderbird (Ubuntu)
Undecided
Unassigned
thunderbird (openSUSE)
Fix Released
High

Bug Description

Since the upgrade of Lightning 2.6.0 to Lightning 2.6.1, this extension need Thunderbird 24.0.1 but Ubuntu only give Thunderbird 24.0.0

https://blog.mozilla.org/calendar/2013/10/dont-upgrade-to-thunderbird-24-0-1-yet/
"Update 4: Lightning 2.6.1 is now public. On Linux, it is compatible ONLY with Thunderbird 24.0.1, so go ahead and upgrade now."

A lot of people don't use the Ubuntu package for Lightning but those of Mozilla.

Ubuntu should give an upgrade to Thunderbird 24.0.1 and Lightning 2.6.1

Step:
1) Silent update of Lightning 2.6.0 to Lightning 2.6.1 on Thunderbird 24.0.0
2) Open your calendar and see nothing (see screencast)

A work form it's to downgrade to Lightning 2.6 until waiting Ubuntu upgrade to Thunderbird 24.0.1. You could find it here:
https://addons.mozilla.org/fr/thunderbird/addon/lightning/versions/?page=1#version-2.6

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 1:24.0+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.8.0-32.47~precise1-generic 3.8.13.10
Uname: Linux 3.8.0-32-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
BuildID: 20130913160939
Date: Fri Oct 25 12:30:44 2013
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120425-15:28
MarkForUpload: True
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)

Download full text (6.3 KiB)

Created attachment 359362
build.log

If the nonexistent directory reported in bug #485858 is not the cause for the missing calendar extension, something else must be wrong.

After upgrading thunderbird to version 24.0, the calendar extension (lightning) does not show up in thunderbird anymore. That is, all lightning GUI elements are missing, and the extension is also missing from the add-ons manager.

# emerge --info =mail-client/thunderbird-24.0
Portage 2.2.7 (hardened/linux/amd64/no-multilib, gcc-4.7.3, glibc-2.17, 3.11.1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.11.1-x86_64-Intel-R-_Core-TM-_i7-3720QM_CPU_@_2.60GHz-with-gentoo-2.2
KiB Mem: 16370268 total, 12483344 free
KiB Swap: 17825788 total, 17825788 free
Timestamp of tree: Tue, 24 Sep 2013 11:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash: 4.2_p45
dev-java/java-config: 2.2.0
dev-lang/python: 2.7.5-r2, 3.3.2-r2
dev-util/cmake: 2.8.11.2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.12
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.11.6, 1.12.6, 1.14
sys-devel/binutils: 2.23.2
sys-devel/gcc: 4.7.3-r1
sys-devel/gcc-config: 1.8
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc: 2.17
Repositories: gentoo science
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 acl acpi alsa amd64 avx berkdb bzip2 cairo caps cdda cddb cdparanoia cli cracklib crypt cups cxx dbus dri dts dvd fam ffmpeg fftw ...

Read more...

Confirmed, USE=lightning appears to have no effect.

The ebuild maps this to --enable-calendar, and the
MOZ_ARG_ENABLE_BOOL(calendar ...) block has moved from the main
configure.in to mail/configure.in while most of the other use-enabled
flags seem to have moved to mozilla/configure.in .

I don't understand the build system well enough to see if this flag is still even supported.

As a workaround the Lightning 2.6 add-on from the official add-on repository works well.

Created attachment 359398
Fix lightning install

Please test and report, if all is well will land immediately.

35 comments hidden view all 121 comments

Updated Thunderbird to 24.0.1.

Restarted Thunderbird.

Downloaded a fresh version of TB 24.0.1, created a new profile, configured email, installed Lightning 2.6, and restarted Thunderbird.

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.0.1
Application Build ID 20131010053258

Thunderbird opened and the Today pane and calendar had no data, couldn't change views, and there are two tool bars.

Failed to load native module at path '~/.thunderbird/canixawi.test/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so': (80004005) ~/applications/thunderbird/libxul.so: version `xul24.0' not found (required by ~/.thunderbird/canixawi.test/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so)

Also experiencing same problem, Same screenshot. Here's the console.

roger@rogerhp:~$ thunderbird
[calBackendLoader] Using libical backend at /home/roger/.thunderbird/y1h2640k.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical.manifest
TypeError: Components.classes[cid] is undefined
-- Exception object --
+ fileName (string) 'chrome://calendar/content/calUtils.js'
+ lineNumber (number) 22
+ columnNumber (number) 0
*
-- Stack Trace --
_calIcalCreator/<@chrome://calendar/content/calUtils.js:22
now@chrome://calendar/content/calUtils.js:385
switchToView@chrome://calendar/content/calendar-views.js:325
ltnSwitch2Calendar@chrome://lightning/content/messenger-overlay-sidebar.js:402
calendarTabType.modes.calendar.openTab@chrome://lightning/content/messenger-overlay-sidebar.js:45
openTab@chrome://messenger/content/tabmail.xml:554
oncommand@chrome://messenger/content/messenger.xul:1
roger@rogerhp:~$

*** Bug 925840 has been marked as a duplicate of this bug. ***

Same issue here. Calendar is empty, toolbar shows up twice until tab is switched, can't interact in any way, since update to Thunderbird 24 and Lightning 2.6.

I'm also experiencing the same problem: I can see my calendar "[x] home" is checked (though text is greyed out) but there are no appointments nor tasks, is completely empty.

Running Debian Wheezy (64 bits) and this happened yesterday after the last update was applied (from 24.0 → 24.0.1).

Same issue here. Thunderbird 24.0.1 and Lightning 2.6 on OpenSuse 12.1. Problem since last update from 24.0 → 24.0.1.
Error console in Thunderbird says

"Failed to load native module at path '/home/user/../.thunderbird/...default/extensions/{..}/components/Linux_x86_64-gcc3/libcalbasecomps.so': (80004005) /usr/lib64/thunderbird/libxul.so: version `xul24.0' not found (required by /home/user/.../.thunderbird/....default/extensions/{..}/components/Linux_x86_64-gcc3/libcalbasecomps.so)"

My naive guess concerning this problem is that "version `xul24.0'" is now called "version `xul24.0.1'"

Is this only a problem with the Linux version?

Ditto in Debian testing (Jessie), 64-bit.

Same on 32-bit Debian testing.

*** Bug 926057 has been marked as a duplicate of this bug. ***

Mark, Phillipp, could you take a look? Aren't the 24.0.* bugfix releases supposed to keep a stable application interface and binary interface?

Yes, I agree it should stay stable. As we will be doing a 2.6.1 release it might not be that bad though. Mark, any thoughts?

*** Bug 926165 has been marked as a duplicate of this bug. ***

It seems this is a platform specific issue. Using Thunderbird 24.0.1 and Lightning 2.6 on Mac works without problems.

The cause for this may be bug 809430, which added specific version dependencies. Lightning 2.6.1 requires a libxul.so that defines xul24.0.1, as Lightning 2.6 requires one that defines xul24.0.

I think the correct fix would be to change this script to define/require "xul24" for all minor versions. Otherwise we are stuck with doing one Lightning release per minor version, which will be hell for both us and the users.

I just heard on the blog that it works fine on Windows, so this is definitely a Linux-only issue.

Is there a workaround for this bug? Is it safe to reinstall an old plugin version?

(In reply to To Ti from comment #15)
> Is there a workaround for this bug? Is it safe to reinstall an old plugin
> version?

Revert to version 24.0 of Thunderbird, at https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/24.0/

Experiencing same issue here. Running Lightning 2.6 (09/19/2013 last update) isn't displaying any calendars at all. Running TBird 24.0.1 on Linux. This is the error in the console when I try to view a calendar:

Timestamp: 10/14/2013 09:22:51 AM
Error: TypeError: Components.classes[cid] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 22

Timestamp: 10/14/2013 09:23:18 AM
Error: [Exception... "'[JavaScript Error: "Components.classes[cid] is undefined" {file: "resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js" line: 22}]' when calling method: [calICompositeObserver::onCalendarAdded]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1265" data: yes]
STACK: undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/XXXXXXX/.thunderbird/XXXXXXX.XXXXXX/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1267

Updating to 24.0.0 from link above resolves problem.

*** Bug 926291 has been marked as a duplicate of this bug. ***

*** Bug 926470 has been marked as a duplicate of this bug. ***

I've filed bug 927073 to fix the toolkit part of this.

*** Bug 926240 has been marked as a duplicate of this bug. ***

I see there is a 2.6.1 version of lightniong since Oct. 13th. Is it Ok to install it with TB 24.0.1 ?

Just for the record, 2.6.1 works fine with 64 bits Thunderbird builds and also with those which are localized (ie., using a language other than English). I say this because is hard to find updated documents about this and the few I found seem to be pretty outdated (section "Extensions and themes"):

http://kb.mozillazine.org/64_bit_builds

Created an attachment (id=564939)
Blank Calendar View

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

Apper prompted me to update today 24-Oct-2013 and some time after this update I rebooted and noticed Thunderbird 24.0, Lightning 1.6.1 stopped working and displays blank days (just a grid, no dates). I use these add-ons to connect to my OwnCloud server using CalDAV and Google Calendar.

In the Thunderbird Error Console there are errors which I'll upload as a screen capture image attachement

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Created an attachment (id=564941)
Thunderbird Error Console

The line 67 error is repeated for many calendar events.
The line 22 and line 1267 are only made once if only one remote calendar is selected. I have 3 remote calendars, 1x-OwnCloud, 2x-Google Calendar

Created an attachment (id=564943)
Active Thunderbird Add-Ons 24-Oct-2013

Here is a list of Add-ons active and their versions.
All these Add-ons worked prior to today's 24-Oct-2013 update.

Any suggestions for me to try?

My work around is to access these calendars using Firefox to view each servers web presentation. This means three Firefox Windows and is cumbersome to use.

Download full text (16.7 KiB)

Here is a copy of the Thunderbird troubleshooting information:

  Application Basics

    Name: Thunderbird
    Version: 24.0
    User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.0
    Profile Directory: Open Directory

              (Local drive)
    Application Build ID: 2013091200
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Crash Reports: about:crashes
    Memory Use: about:memory

  Mail and News Accounts
    account1:
      INCOMING: account1, , (imap) pluto.arno.com:143, alwaysSTARTTLS, passwordCleartext
      OUTGOING: smtp.frontier.com:465, SSL, passwordCleartext, true

    account2:
      INCOMING: account2, , (none) Local Folders, plain, passwordCleartext

    account3:
      INCOMING: account3, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

    account4:
      INCOMING: account4, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

    account7:
      INCOMING: account7, , (imap) mail.koczarski.com:143, plain, passwordCleartext
      OUTGOING: mail.koczarski.com:587, plain, passwordCleartext, true

    account8:
      INCOMING: account8, , (im) prpl-jabber, plain, 0

    account9:
      INCOMING: account9, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

    account10:
      INCOMING: account10, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

    account11:
      INCOMING: account11, , (imap) imap.googlemail.com:993, SSL, passwordCleartext
      OUTGOING: smtp.googlemail.com:465, SSL, passwordCleartext, true

    account12:
      INCOMING: account12, , (imap) imap.mail.yahoo.com:993, SSL, passwordCleartext
      OUTGOING: smtp.mail.yahoo.com:465, SSL, passwordCleartext, true

    account13:
      INCOMING: account13, , (imap) imap.frontier.com:993, SSL, passwordCleartext
      OUTGOING: smtp.frontier.com:465, SSL, passwordCleartext, true

  Extensions
    Contact Tabs, 2.0.8, true, <email address hidden>
    Encrypt if possible, 1.0, true, <email address hidden>
    FoxClocks, 3.1.26, true, {d37dc5d0-431d-44e5-8c91-49419370caa1}
    Inverse SOGo Connector, 17.0.5, true, <email address hidden>
    Lightning, 2.6.1, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
    LookOut, 1.2.13, true, <email address hidden>
    Provider for Google Calendar, 0.25, true, {a62ef8ec-5fdc-40c2-873c-223b8a6925cc}
    Select Addressbook Text, 1.5, true, <email address hidden>
    Test Pilot for Thunderbird, 1.3.9, true, <email address hidden>

  Important Modified Preferences

    Name: Value

      accessibility.typeaheadfind.flashBar: 0
      browser.cache.disk.capacity: 358400
      browser.cache.disk.smart_size_cached_value: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      dom.max_chrome_script_run_time: 0
      extensions.lastAppVersion: 24.0
      font.name.sans-serif.x-weste...

30 comments hidden view all 121 comments
Mozaic (mozaic) wrote :
Mozaic (mozaic) wrote :

Some screencast of the problem

Mozaic (mozaic) wrote :

With Thunderbird 24.0.0 and Lightning 2.6.0

Mozaic (mozaic) on 2013-10-25
description: updated
Changed in lightning-extension:
importance: Unknown → Critical
status: Unknown → Confirmed
29 comments hidden view all 121 comments

This also applies to openSUSE 13.1 RC-1. Problem version of Thunderbird is 24.0.1 which is in 'update' repo for 13.1 and 'mozilla' for 12.3. I've reverted to the version of Thunderbird (24.0) on the 64-bit installation DVD and Lightning works OK again so I've locked this version.

The calendar that I'm using is local; I use no external calendars such as Google.

Just found this problem is known about - has been for a while - and Mozilla said not to update to 24.0.1 yet.
See this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=925823
and this blog:
https://blog.mozilla.org/calendar/2013/10/dont-upgrade-to-thunderbird-24-0-1-yet/

Changed in thunderbird (openSUSE):
importance: Unknown → High
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightning-extension (Ubuntu):
status: New → Confirmed
Changed in thunderbird (Ubuntu):
status: New → Confirmed
h1repp (heinz-repp) on 2013-10-25
tags: removed: amd64
1 comments hidden view all 121 comments
h1repp (heinz-repp) wrote :

hey Ubuntu (thunderbird/ubuntu), you're dreaming? Mozilla and Novell have set the importance to high or even critical, yet you have not reacted at all.

This bug breaks lightning (and it seems, also the EDS Contacts Integration, impairs address book) and leaves unexpected users with a blank non functional calendar, because Lightning (ubuntu) is not localized, so people use the Mozilla AddOns version, and this one updated to 2.6.1. On next start the calendar is empty and non functional, chrome rendering strange.

What we now need a.s.a.p is a Thunderbird 24.0.1 in all repositories still holding the 24.0 version. When will we see one?

Mozaic (mozaic) on 2013-10-25
description: updated
Changed in thunderbird (Gentoo Linux):
importance: Unknown → Medium
status: Unknown → Fix Released
Micah Gersten (micahg) on 2013-10-27
no longer affects: lightning-extension (Ubuntu)
Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → Confirmed
44 comments hidden view all 121 comments

On 11/01/2013 12:25 PM, C2e9b7 wrote:
> Hi,
> I had the same problem, and still had it with 24.1.0. Then I found this workaround which solves the problem. USE AT YOUR OWN RISK!
> a. mv ~/.thunderbird in ~/.thunderbird.old
> b. update thunderbird (I had to do it as root)
> c. run the new version of thunderbird (as user), skipping all the suggestions to create an email account
> d. install lightning (I also installed google calendar provider; you may need to reinstall more)
> e. restart thunderbird
> f. copied back everithing from ~/.thunderbird.old/<some random string> ~/.thunderbird to the new ~/.thunderbird/<some other random string> besides the following:
> _CACHE_CLEAN_ chrome extensions extensions.ini TestPilotExperimentFiles
>
> Note that I COPIED and not MOVED them back, because in case of problems I wanted to be able to delete the new ~/.thunderbird directory without losing anything. Maybe I could have copied back some more file, but everything seems to work.
> So in my opinion, there is some file left from old installs in those directories, that disturbs the new version of Lightning. Anyway, now everything works fine for me
>
Thank you for taking the time to give me this information.

I may resort to doing it that way.

I currently don't use the calendar feature a great deal, so I'm hoping
within a month or two there will be an update from the repository that
will fix it.

If it goes too long, I will make good use of the excellent information
you took the time to put together and send me.

--
Sincerely,
Aere

I'll inform you that the newer update Thunderbird 24.1.0 with Lightning 2.6.2 works on my Ubuntu 10.04 again. It appears the issue has been fixed. I recommend giving it a try.

On 11/02/2013 12:42 PM, Daniel Giest wrote:
> I'll inform you that the newer update Thunderbird 24.1.0 with Lightning
> 2.6.2 works on my Ubuntu 10.04 again. It appears the issue has been
> fixed. I recommend giving it a try.
>
Daniel:

Thank you for alerting me to this.

I just checked my calendar, and everything is working again, as if
nothing ever went wrong.

As I recall, I applied updates yesterday, noticing no changes, but the
next time I booted, I got a reminder for an event that had passed last
week.

I was busy at the time, so I just dismissed the reminder, but it was
definitely an indication that things had changed.

As far as I can tell, the problem is now fixed.

Many thanks to all the people who made this happen.

--
Sincerely,
Aere

Mozaic (mozaic) on 2013-11-04
Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released

Nice work guys, thanks!! I just updated to Tbird 24.1.0 and Lighting 2.6.2 and all is working again.

Hi Guys!
Was just reading this post... STill i have a related problem using TB 24.1.0 and Lightning 2.6.2: When i install Lightning the next start of TB will lead to a total freeze in TB. When i deactivate Lightning in the TB safe mode, TB alone works fine, but with Lightning it freezes every time i start TB. Any help?

(Using Opensuse 12.3. i586)

Total freeze doesn't sound like this bug. Could you try with a new profile? Please don't post results on this bug though, either email me or use the blog comments.

(In reply to Daniel from comment #46)
> I'll inform you that the newer update Thunderbird 24.1.0 with Lightning
> 2.6.2 works on my Ubuntu 10.04 again. It appears the issue has been fixed. I
> recommend giving it a try.

Worked for me.

Yet I'm experiencing the same issue again using TB 24.1.1 and L 2.6.2

Same here (ArchLinux, 64-bit, TB 24.1.1 and L 2.6.2).

(In reply to mment #52 and comment #53)

Lightning 2.6.3 compatible with Tb 24.1.1 has been already released on AMO.

Hi,
updated to Thunderbird 24.1.1 and Lightning 2.6.3 and had the same problem again. This time I just deleted the content of
~/.thunderbird/random.string/extensions
reinstalled Lightning and everything was ok again. In the next days, if I'll have enough time, I will recover the the content of the directory from the backups and see what changed.

As far as i got to know i did also the copying procedur and lightning works, but when i install the Provider for google calendar addon tb hangs. So it seems it has to do with the other addon Provider for google calender!

In fact, I'm also using the google calendar addon. By removing the extensions directory content, I removed both, and then reinstalled both (without losing the configuration)

Problem still here.
I'm using Thunderbird 24.1.1 and Lightning 2.6.3 on a Ubuntu 12.04 (precise) 64-bit maschine and the problem still persists, the terminal gives the error message:
[calBackendLoader] Using libical backend at /home/jakob/.thunderbird/we61f6e6.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical.manifest
Error: TypeError: aListener.onOperationComplete is not a function

Removing extensions and re-installing didn't solve the problem...

Will this be fixed with the next lightning version?

Glen (gtlxiii) wrote :

Problem dissappeared with Thunderbird 25.0.0 (Lightning 2.6.3) but has reappeared with Thunderbird 25.0.1 (Still Lightning 2.6.3)

I'm using seamonkey 2.22.1 and Lightning 2.6.3 - same error:
Failed to load native module at path '/home/me/.mozilla/seamonkey/ezstlpc4.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so': (80004005) /usr/lib64/seamonkey/libxul.so: version `xul24' not found (required by /home/me/.mozilla/seamonkey/ezstlpc4.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/Linux_x86_64-gcc3/libcalbasecomps.so)

All Seamonkey components are working correctly and all other extensions are working. Only affects Lightning.

Jacek, SeaMonkey 2.22.* requires Lightning 2.7.* - unfortunately there is no 2.7 build available that is compatible to SeaMonkey 2.22.1. Lightning 2.7b1 only works with SeaMonkey 2.22. See Bug 941217. The next SeaMonkey Beta build should contain the fix.

Stefan, I had Seamonkey 2.21 before I upgrade and there was exactly the same error. It is why I upgraded to Seamonkey 2.22.1.
So could you suggest which versions Seamonkey and Lightning are working together correctly?

This took care of the problem I experienced, so I'll close the bug.

Thank you!

Changed in thunderbird (openSUSE):
status: Confirmed → Fix Released

Lightning 2.8b1 isn't working with SeaMonkey 2.23. Has the same look as the screen shot for this bug, but not the error message.

I do see several calendar errors in the SM error console.

Timestamp: 12/13/2013 11:11:00 AM
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/widgets/calendar-widgets.xml
Line: 496

Timestamp: 12/13/2013 11:11:00 AM
Error: TypeError: Components.classes[cid] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/wls15202/.mozilla/seamonkey/w97glyp9.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 22

Timestamp: 12/13/2013 11:11:00 AM
Error: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/wls15202/.mozilla/seamonkey/w97glyp9.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDateTimeFormatter.js
Line: 25

Timestamp: 12/13/2013 11:11:00 AM
Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: chrome://calendar/content/calUtils.js
Line: 98

Lightning 2.8b1 doesn't work with SeaMonkey 2.23 because it was not rebuild after landing the two fixes for Bug 927073. According to objdump the file libcalbasecomps.so still depends on "xul26.0" but the fixed libxul.so shipped with SeaMonkey announces only "xul26".

A later Lightning 2.8b1 test build doesn't show the problem anymore. I tested the one from <https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-beta-linux/1386568018/> build on 09-Dec-2013.

In my opinion a Lightning 2.8b2 release would be required to support SeaMonkey 2.23 on Linux.

thunderbird-lightning-2.6.2-3.fc19.x86_64
thunderbird-24.2.0-2.fc19.x86_64

And I see the issue!

(In reply to udo from comment #64)
You are using an old Lightning release supporting an old Thunderbird release. Please upgrade to Lightning 2.6.4 and retest.

What is the status here? Is the minVersion/maxVersion issue relsolved for 2.6.4 on AMO and Source?

downgrading to thunderbird 24.1.0 does also help.

(In reply to udo from comment #64)
> thunderbird-lightning-2.6.2-3.fc19.x86_64
> thunderbird-24.2.0-2.fc19.x86_64

Udo, you can get:

  thunderbird-24.2.0-2.fc19.x86_64
  thunderbird-lightning-2.6.4-7.fc19.x86_64

from updates now, which fixes this issue (for me anyway).

(In reply to Bill McGonigle from comment #67)
> Udo, you can get:
>
> thunderbird-24.2.0-2.fc19.x86_64
> thunderbird-lightning-2.6.4-7.fc19.x86_64
>
> from updates now, which fixes this issue (for me anyway).

Works for me too. Thanks!

1+

aaustraalis is foor children, develooped Moozillaa UX gaay coock sucking baastaards! Deepen yoour fucking aass oof Goooogle aausthistic braainless idioots! aasshooles! Hooookers! Coocksucking Freaaks Goooogle! Fuck yoou aand goo oout oof business Gooooglezillaa whoores! aand taake with yoou aaustraalisfuck Gaayloords! Maay oour Deaar Loord Good aand Jesus Christ send their decaaying boodies straaight too hell too toouch the eggs Coommunities goolden gloory! Fuck yoou aand kiss Goooogles aass! If yoou like Chroome booth clooning aaustraalis, yoou haave too be serioous aand woork foor Chroome fucktaards! Greetings froom Spaain, ChiliCoonCaarne1

Justin Doolske, Gaavin Shaarp, Maattn, Blaake Wintoon, aazaa Dootzler, MSUJaaws Daaoo Goottwaald, UX-Teaam is aa fucking bitch too fuck in the aass! Blaake Wintoon, aazaa Dootzler, Gaavin Shaarp, MSUJaaws Daaoo Goottwaald, UX-Teaam Pimp! Pimp! Fucking pimp! Pimp! aasshooles, sluts, whoores suck my dick moonster kids! Yoour coocksucking fucking sluts! Justin Doolske, Gaavin Shaarp, Maattn, Blaake Wintoon, aazaa Dootzler, MSUJaaws Daaoo Goottwaald, UX-Teaam plaay with my twoo big goolden bells oof Gloory!

1-

/*/*---

FUCK YOU GOOGLEZILLA WHORES - KILLER OF CUSTOMIZABILITY IN FAVOUR OF YOUR CHROME ADDICTION; YOU ARE ALL FUCKING GAYLORDS !!!!!!!!!!!!!!!!!!!!!!!!!!!!

The Ads-Whore and the death of customizability

This is partly a true story of what will happening onwards Firefox Version 29, go on, read it and feel the bone biting pain!

User:
 Who the hell disturbs the peace inside my customizability nation?

Trashbin Porno-Dolske answers:
"We, from the mighty Australis Chrome clone invasion!"

Gaywin Ass-harp:
"Beware User, we are visiting now your precious home, we're going to rape your 4 years old mountain goat and later... your Mom!"

Gaywin and Trashbin grab the under-aged innocent child, they put it on their satanic Google-Worshiping-Table and rape it merciless and wild. They put their 300 Million Dollars caricature of a dick inside it's mouth, they penetrate the innocent goat pussy, they are laughing out loud!

They cum inside the child until their maximum mark, the user lets out an angry, "Stop raping my goat!" dangerous bark! Trashbin licks it's nose, Gaywin cums right inside the goat child's face while the user pleads: "Please stop it finally, show mercy for fucks grace!"

The users goat is as planned traumatized and cries while in the background Firefox customizability is killed off and dies. Asshole Dotzler is meanwhile filming the scene from behind, wrong move Rapezilla - because that guy is both stupid and blind. Also in background: Fake Winton, Dao Faggotwald, FattN and the MSUJEWS, all are members of the 2013 built Mozdolf Hitler youth! Oh... Not to forget Mr. McPornley who is in general lame, he is a sucker of cocks and therefor a shame!

Now the Devil enters the scene in disguise of a disgusting hag - it's Mitchell Baker the ads-whore, that butt-ugly transvestite fag! She grabs the User with force on his neck, pins him down, does the "From Behind Ads-Strap-On-Attack".

Mitchell:
"Valued user, our plan is to track you, we need more wealth for our wallet so we're going to fuck you!"

The User is paralyzed and blank is his mind, as Mitchell Baker enters the tracking ads trough her Latex-Dildo into his butt from behind!

But suddenly a goddess arrives, screams at the Rapezilla guys "Who does Dare!!!!!"
She uses her glorious magic and slowly but steadily drops Rapezilla Firechrome's market-share!

ChiliConCarne1, 2014, February

/*+-023

*/-/-/-/+64646+4646

FUCK YOU GOOGLEZILLA WHORES - KILLER OF CUSTOMIZABILITY IN FAVOUR OF YOUR CHROME ADDICTION; YOU ARE ALL FUCKING GAYLORDS !!!!!!!!!!!!!!!!!!!!!!!!!!!!

The Ads-Whore and the death of customizability

This is partly a true story of what will happening onwards Firefox Version 29, go on, read it and feel the bone biting pain!

User:
 Who the hell disturbs the peace inside my customizability nation?

Trashbin Porno-Dolske answers:
"We, from the mighty Australis Chrome clone invasion!"

Gaywin Ass-harp:
"Beware User, we are visiting now your precious home, we're going to rape your 4 years old mountain goat and later... your Mom!"

Gaywin and Trashbin grab the under-aged innocent child, they put it on their satanic Google-Worshiping-Table and rape it merciless and wild. They put their 300 Million Dollars caricature of a dick inside it's mouth, they penetrate the innocent goat pussy, they are laughing out loud!

They cum inside the child until their maximum mark, the user lets out an angry, "Stop raping my goat!" dangerous bark! Trashbin licks it's nose, Gaywin cums right inside the goat child's face while the user pleads: "Please stop it finally, show mercy for fucks grace!"

The users goat is as planned traumatized and cries while in the background Firefox customizability is killed off and dies. Asshole Dotzler is meanwhile filming the scene from behind, wrong move Rapezilla - because that guy is both stupid and blind. Also in background: Fake Winton, Dao Faggotwald, FattN and the MSUJEWS, all are members of the 2013 built Mozdolf Hitler youth! Oh... Not to forget Mr. McPornley who is in general lame, he is a sucker of cocks and therefor a shame!

Now the Devil enters the scene in disguise of a disgusting hag - it's Mitchell Baker the ads-whore, that butt-ugly transvestite fag! She grabs the User with force on his neck, pins him down, does the "From Behind Ads-Strap-On-Attack".

Mitchell:
"Valued user, our plan is to track you, we need more wealth for our wallet so we're going to fuck you!"

The User is paralyzed and blank is his mind, as Mitchell Baker enters the tracking ads trough her Latex-Dildo into his butt from behind!

But suddenly a goddess arrives, screams at the Rapezilla guys "Who does Dare!!!!!"
She uses her glorious magic and slowly but steadily drops Rapezilla Firechrome's market-share!

ChiliConCarne1, 2014, February

Download full text (7.0 KiB)

FUCK YOU GOOGLEZILLA WHORES - KILLER OF CUSTOMIZABILITY IN FAVOUR OF YOUR CHROME ADDICTION; YOU ARE ALL FUCKING GAYLORDS !!!!!!!!!!!!!!!!!!!!!!!!!!!!

The Ads-Whore and the death of customizability

This is partly a true story of what will happening onwards Firefox Version 29, go on, read it and feel the bone biting pain!

User:
 Who the hell disturbs the peace inside my customizability nation?

Trashbin Porno-Dolske answers:
"We, from the mighty Australis Chrome clone invasion!"

Gaywin Ass-harp:
"Beware User, we are visiting now your precious home, we're going to rape your 4 years old mountain goat and later... your Mom!"

Gaywin and Trashbin grab the under-aged innocent child, they put it on their satanic Google-Worshiping-Table and rape it merciless and wild. They put their 300 Million Dollars caricature of a dick inside it's mouth, they penetrate the innocent goat pussy, they are laughing out loud!

They cum inside the child until their maximum mark, the user lets out an angry, "Stop raping my goat!" dangerous bark! Trashbin licks it's nose, Gaywin cums right inside the goat child's face while the user pleads: "Please stop it finally, show mercy for fucks grace!"

The users goat is as planned traumatized and cries while in the background Firefox customizability is killed off and dies. Asshole Dotzler is meanwhile filming the scene from behind, wrong move Rapezilla - because that guy is both stupid and blind. Also in background: Fake Winton, Dao Faggotwald, FattN and the MSUJEWS, all are members of the 2013 built Mozdolf Hitler youth! Oh... Not to forget Mr. McPornley who is in general lame, he is a sucker of cocks and therefor a shame!

Now the Devil enters the scene in disguise of a disgusting hag - it's Mitchell Baker the ads-whore, that butt-ugly transvestite fag! She grabs the User with force on his neck, pins him down, does the "From Behind Ads-Strap-On-Attack".

Mitchell:
"Valued user, our plan is to track you, we need more wealth for our wallet so we're going to fuck you!"

The User is paralyzed and blank is his mind, as Mitchell Baker enters the tracking ads trough her Latex-Dildo into his butt from behind!

But suddenly a goddess arrives, screams at the Rapezilla guys "Who does Dare!!!!!"
She uses her glorious magic and slowly but steadily drops Rapezilla Firechrome's market-share!

ChiliConCarne1, 2014, February

FUCK YOU GOOGLEZILLA WHORES - KILLER OF CUSTOMIZABILITY IN FAVOUR OF YOUR CHROME ADDICTION; YOU ARE ALL FUCKING GAYLORDS !!!!!!!!!!!!!!!!!!!!!!!!!!!!

The Ads-Whore and the death of customizability

This is partly a true story of what will happening onwards Firefox Version 29, go on, read it and feel the bone biting pain!

User:
 Who the hell disturbs the peace inside my customizability nation?

Trashbin Porno-Dolske answers:
"We, from the mighty Australis Chrome clone invasion!"

Gaywin Ass-harp:
"Beware User, we are visiting now your precious home, we're going to rape your 4 years old mountain goat and later... your Mom!"

Gaywin and Trashbin grab the under-aged innocent child, they put it on their satanic Google-Worshiping-Table and rape it merciless and wild. They put their 300 Million Dollars caricatur...

Read more...

Is there a possibility to remove the last comments? I see no connection to this bug.

*** Bug 887160 has been marked as a duplicate of this bug. ***

*** Bug 968115 has been marked as a duplicate of this bug. ***

Philipp, any update here?

Changed in lightning-extension:
status: Confirmed → Fix Released

Created attachment 8384168
Outgoing on comm-esr24

Ok, this was far more annoying than I thought. I spent way too much time writing a script to do the maxversion changes in batch and the manual steps also took ages.

* I've fixed 2.6 - 2.6.3 on ftp.mozilla.org
  - Changed the min/maxversion to match what is on Calendar_Versions on mdn
  - Updated the source to use @THUNDERBIRD_VERSION@ as the maxversion

* I have attached my outgoing changesets which I want to push to comm-esr24
  - Changes maxversion to @THUNDERBIRD_VERSION@ as above
  - Can't do this for 24.1.0 since it uses the same relbranch as 24.1.1

Mark, can you take a look at this to make sure its sane?

Comment on attachment 8384168
Outgoing on comm-esr24

I don't understand why you want to do this. This would mean that you have to download a new version of lightning each time, whereas the advantage with being on the 24.x tree is that you don't.

Mark, these commits are (unless I did something wrong), just to fix the problem for the 2.6, 2.6.1, 2.6.2, 2.6.3 releases, which were affected by bug 927073.

I don't really think anyone is going to build these versions, but if they do pull from hg using a tag from one of the affected builds, i.e. THUNDERBIRD_24_0_1_RELEASE, they should get a Lightning that is only compatible to this release.

2.6.4 and on should continue to use @THUNDERBIRD_MAXVERSION@. Makes sense?

Comment on attachment 8384168
Outgoing on comm-esr24

Ah ok, r+a=Standard8.

Changed in thunderbird:
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 121 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.