synaptic pinning/locking does not work

Bug #67146 reported by Jacob Winski on 2006-10-20
108
This bug affects 3 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: synaptic

Distro: Edgy 6.10 (frozen beta)
Synaptic package: 0.57.11ubuntu12

Problem:
Highlighting an installed package and going to Package -> Lock Version refreshes the package view, but the package is NOT locked.

After an attempt to pin/lock a package, going back to the package shows that nothing has changed. Icon is the same and the "Lock package" selection is also the same (no check mark). Looking into /var/lib/synaptic/preferences confirms this (empty).

Permissions on the preferences file seem correct:
-rw-r--r-- 1 root root 0 2006-08-13 08:58 preferences

Tested locking/pinning with these packages:
metacity
some gstreamer0.10 plugin
openoffice.org
adduser
bluefish

sudo dpkg --get-selections | grep hold shows nothing (empty).

/etc/apt/preferences does not exist.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Locking is currently broken in synaptic. It will be fixed very soon after the release but currently the archive is frozen so I can't upload the fix.

Cheeers,
 Michael

Changed in synaptic:
assignee: nobody → mvo
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :
Jacob Winski (winski) wrote :

Thank you for the great work on this (and others, of course) bug.

Thank you for the debdiff.

Cheers!

xstaticxgpx (optimum-reflex) wrote :

how do i use the debdiff file?

Michael Vogt (mvo) wrote :

I uploaded a fix for this to edgy-proposed. I would welcome testing :)

Changed in synaptic:
status: Confirmed → Fix Committed
Jacob Winski (winski) wrote :

Michael Vogt: Are you sure that you uploaded this fix to edgy-proposed? I cannot find it. Is there another edgy-proposed besides the one on archive.ubuntu.com?

And what would I look for? What would be the new version # of synaptic?

This is the proposed repo used to check:
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed universe main multiverse restricted

Ramaddan (ramaddan) wrote :

Hi, the problem is still there.
Still cannot lock to unlock anything.

Ramaddan (ramaddan) wrote :

Hi, never saw anything from edgy proposed.
Will this be fixed soon, or was it already fixed, and I missed it? Thanks.

Ben Bromley (benuski) wrote :

I am also still getting this problem. Whenever I lock a file it just reverts to a blank screen with no search history or anything, and then the package is not locked.

Simon Law (sfllaw) wrote :

The package that fixes this bug is not yet in edgy-proposed.

Changed in synaptic:
status: Fix Committed → In Progress
rasz (citizenr) wrote :

rasz@capek:~$ wget http://archive.ubuntu.com/ubuntu/dists/edgy-proposed/main/binary-i386/Packages.gz
--15:24:12-- http://archive.ubuntu.com/ubuntu/dists/edgy-proposed/main/binary-i386/Packages.gz
           => `Packages.gz'
Resolving archive.ubuntu.com... 195.248.90.38, 195.248.90.35
Connecting to archive.ubuntu.com|195.248.90.38|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 28,192 (28K) [text/plain]

100%[====================================>] 28,192 42.66K/s

15:24:13 (42.59 KB/s) - `Packages.gz' saved [28192/28192]

rasz@capek:~$ gzip -d Packages.gz
rasz@capek:~$ grep < Packages syna
Depends: xserver-xorg-input-elographics, xserver-xorg-input-evdev, xserver-xorg-input-kbd, xserver-xorg-input-mouse, xserver-xorg-input-synaptics, xserver-xorg-input-wacom

not there :(
we really need this fix as there are MANY broken/bugged packages in edgy (like libsdl) that need locked local copies

socket (anton-mark) wrote :

I concur. This is VERY annoying for anyone who has to deal with custom packages.

Pausanias (pausanias) wrote :

I wouldn't mind hearing an explanation for why something so simple and essential that worked perfectly in all the previous versions is now broken.

Colin Watson (cjwatson) wrote :

Accepted into edgy-proposed. Please proceed with testing.

Changed in synaptic:
status: In Progress → Fix Committed
rasz (citizenr) wrote :

thank you, almost working
checking "lock version" works, packages get pinned, but after that synaptic window resets and chosen tab/search filter is gone

rasz (citizenr) wrote :

"sudo apt-get upgrade" doesnt respect the lock/pin

On Tue, 2006-12-19 at 05:31 +0000, rasz wrote:
> "sudo apt-get upgrade" doesnt respect the lock/pin

That is Bug #42178.
--
Bruce Cowan <https://launchpad.net/people/bruce89>

mannheim (kronheim) wrote :

I have been using the version from edgy-proposed for a while now. Locking works fine for me with this version. However, "Force Version ... " does not work.

I don't know if this is the same bug. "Force version ..." behaves in the same way that "Lock Version" used to behave. That is, after selecting "Force Version" from the menu and selecting the desired version in the dialog box, Synaptic churns away and refreshes its list, but in the end nothing is marked.

Martin G Miller (mgmiller) wrote :

I have a similar problem. If a version shows as locked in Synaptic, if you try to remove the locked check mark, the screen refreshes, but the locked package remains locked. It's entry is not removed from /var/lib/synaptic/preferences

n3ko (n3ko74) wrote :

I've installed the version from edgy-proposed. Now locking works for me. A small issue: invoking Package/Lock from some search results it resets the search criteria (or the window), i'd restart the search with selecting [search] and [ok] again.
"Force Version" stil doesn't work. (prompts for version to force, and do nothin')

Brian Murray (brian-murray) wrote :

I installed the synaptic version from edgy-proposed and was able to lock and unlock packages successfully.

Martin Pitt (pitti) wrote :

Copied to edgy-updates.

Changed in synaptic:
status: Fix Committed → Fix Released
Randy Noseworthy (randynose) wrote :

Huh. It's now 2009, and I have Jaunty, and... I'm not able to lock/pin a file that I don't want updated, as I applied a patch to it. I'm new to this, so HOW do I do it from the command line?

roffik (roffik) wrote :

Pretty weird. I was able to lock a banshee package as soon as they published 1.0 version (June 2008?), but today (in Jaunty) I want to lock wpasupplicant and synaptic cannot do this.

@RandyNose: I found this link:
http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.en.html#s-pin
which appears to work. I think I successfully locked that package, as it isn't shown in update-manager, but synaptic doesn't mark it as locked. It just says that the newest version is currently installed (which is not true, of course). This is my /etc/apt/preferences file:

Package: wpasupplicant
Pin: version 0.6.4-2
Pin-Priority: 1001

Dr D J Clark (djc-online) wrote :

I'm not sure if this is the same bug, but Pinning still appears broken in Jaunty Synaptic.

I downloaded the source for vpnc, recompiled and installed with dpkg. When reloading the package index vpnc then appears in the list of updateable packages. I then pinned the package in synaptic. It appears in the status listing as 'Pinned'. If I reload then it no longer appears in the upgradeable list. So far so good. But if I 'Mark all Upgrades' although the pinned package is not marked when I click on 'Apply' the pinned package is included in the list of packages to be upgraded. So it appears to be pinned and the /var/lib/synaptic/preferences file contains an entry, but nonetheless synaptic is still marking it for update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers