[Intrepid] Synaptic unusable - Can not find packages

Bug #288797 reported by Ingo Gerth on 2008-10-24
This bug affects 22 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
shelton william dotson iv
Michael Vogt

Bug Description

Well this is a really strange bug that occurs to me on a freshly installed Ubuntu 8.10 RC.
The search tool as well as the quick-search tool does not work.
Check out the screenshots for evidence!

Could you please open a terminal and run "sudo update-apt-xapian-index" and restart synaptic.

Ingo Gerth (igerth) wrote :
Ingo Gerth (igerth) wrote :

Which version of synaptic ? 0.62.1-ubuntu10 works for me here.

Ingo Gerth (igerth) wrote :

I am using the same version. Since today the normal search is working, whereas the quick search stil is not.

Dan MacDonald (allcoms) wrote :

I'm running 8.10 RC x86-64 and I'm also having problems with synaptic search, both the new quicksearch and normal search. Both only work partially in that only a small proportion of the available packages that I search for are found. I've had many packages (such as videolan and dvd95) fail to be found under the latest synaptic but they install fine from command line.

A broken synaptic in a Ubuntu RC - yikes! Whats happening guys? I can't help but feel the introduction of quick search is to blame for this bad ass flaw and I never had a problem with hitting CTRL+F to open a 'quicksearch' box anyway.

Ingo Gerth (igerth) wrote :

Thanks for your comment. Since you are experiencing it too, I changed the status to confirmed.

Changed in synaptic:
status: New → Confirmed
Vadim Peretokin (vperetokin) wrote :

Confirmed. Quick search fails to display results or the normal search, but when you search for nothing after it, the previous results are displayed.

IE, search for "liferea" in quick search. You'll get no results. Then clear the entry field, press enter, and liferea shows up!

Vadim Peretokin (vperetokin) wrote :

Michael Vogt suggested to do "sudo update-apt-xapian-index" and restart Synaptic, which does help.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please open a terminal and run "sudo update-apt-xapian-index" and restart synaptic and let me know if that helps?

Changed in synaptic:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → intrepid-updates
status: Confirmed → Incomplete
Ingo Gerth (igerth) wrote :

Yes, it does. However, the user should not have to do that in order to get the quick search running.
Thanks for that advice anyway!

Michael Vogt (mvo) wrote :

@Ingo: Thanks for confirming. Its clearly a bug, I'm was just curious if the command fixes it or not.

Changed in synaptic:
status: Incomplete → Triaged

I also have this bug on a fresh intrepid install...running sudo update-apt-xapian-index solve the problem , but since normal users will not come here to see the fix , I believe it importance should be more than medium.

pkrnjevic (peter-krnjevic) wrote :

Thanks to Michael for the work-around but this issue is of far more than a "medium" importance. As an experienced user, I switched to apt the moment I realized Synaptic was broken. However, new Ubuntu users will likely find this very frustrating and won't be impressed with Ubuntu's quality - too bad since this is probably the best release yet.

kindofabuzz (kindofabuzz) wrote :

I'm having the exact same problem. but the actual search is sometimes broken on mine.


I'm a new Ubuntu user. I had the same problem with the quick search and the "sudo update-apt-xapian-index" fixed it, thanks guys.

I've observed one thing that might help you to find the problem. When I start Synaptic, it shows all the packages, but when I write 2 or more letters in the Quick Search, it automatically show ONLY THE INSTALLED PACKAGES whit these two letters.

Sorry for my bad English, I'm Spanish.

I've just made another test. I want to install CDemu, so I have added to synaptic:

$ echo deb http://ppa.launchpad.net/cdemu/ubuntu intrepid main | sudo tee /etc/apt/sources.list.d/cdemu.list
$ sudo apt-get update

Everything is OK, in /etc/apt/sources.list.d there's a new file cdemu.list, and http://ppa.launchpad.net/cdemu/ubuntu intrepid main is marked in the Synaptic third party repositories.

However, a quick search for "cdemu" can't find anything. The regular search works fine and finds 7 packages.

With a new "sudo update-apt-xapian-index" both searchs work fine.

I hope this might help.

description: updated
acimmarusti (andrescimmarusti) wrote :

I had Ubuntu intrepid installed (from live cd) and the quick search and the search utilities in synaptics worked well. However I had some other issues with scratchy sound, keyboard and touchpad behaving abnormally (sometimes) so I decided to try installing a fresh copy of intrepid but using the alternate CD. It fixed my issues, for the most part, but it screwed up my quick search and search in synaptics. I used the work around you came up with and it solved the problem. But I find this whole thing rather strange.

amid1999 (amidsin1999) wrote :

If it matters, I can confirm once more that "sudo update-apt-xapian-index" fixes the problem.
Also I would like to join the opinion that it is a bud with high importance. Package installation is the one thing, which can be expected to be rock solid.

KalmanFilterer (zzzzz-pearson) wrote :

Under 8.10, installed with wubi alongside XP, neither my "sudo apt-get" nor my synaptic
were working. "sudo update-apt-xapian-index" appears to have fixed both.

RobMagus (robmage2) wrote :

I had the same bug, and the "sudo update-apt-xapian-index" command fixed it. Fresh install of Ubuntu 8.10 from live CD on an HP laptop running on an AMD Turion 64.

I also want to point out that when scrolling down in the list in synaptic I -could- find packages from multiverse and other non-standard repositories; and also found them using the full search tool. Only when using quick search did no results appear.

I've just installed another repository: http://deb.mulx.net/ intrepid main . I had to apply the xapian solution once again.

I think this ploblem is highly important.

starchild7778 (starchild7778) wrote :

I ran into this same problem with Intrepid, fresh install from the live CD. Looking in "Add/Remove Programs", I can find a given program. Yet, when using quick search in Synaptic and regular search, I only see installed packages. In a previous install, this problem went away after I installed some community-supported software. I have since done a new fresh install and again saw the problem.

The "sudo update-apt-xapian-index" command fixed this issue for me, also.

> The "sudo update-apt-xapian-index" command fixed this issue for me,
> also.

This isn't really a synaptic bug per se, but I'm not sure where it
should be reassigned. Essentially we should arrange for the index to be
generated either on the first apt/synaptic run, or at the end of the
install process.

GPG key available at: <http://www.robertcollins.net/keys.txt>.

Mohammad Alhobayyeb (mih1406) wrote :

I have the same issue. Quick Search, searches only installed packages!!
Finaly, 'sudo update-apt-xapian-index' solved this issue, but do I have to do this for every new repo??

Christoph Langner (chrissss) wrote :

In my eyes the solution for this should be inside software-properties-gtk. When you add a new repo via software-properties-gtk, the index should be updated aswell along with the repositories.

syming (syming) wrote :

"sudo update-apt-xapian-index" did make things better. But there is some other strange behavior of QuickSearch, e.g., with key word "linux", all those "linux-*" packages won't show up, but with "linux-", they, together with many other packages, will show up.

This is just to confirm the issue on a fresh install of Intrepid. The workaround worked for me too. Notice that I installed the system with Internet connection disabled.

Jeust (miguelvilhena) wrote :

It's a hipotesis, but this issue seems to worsen when the computer is connect with a hidden wireless network. When in an unsecure wireless network synapse worked nicely,

Michael Vogt (mvo) wrote :

The problem here is that the apt-xapian-index information is copied from the livecd. This is fixed now in ubiquity, it will not copy this over. This means that synaptic will build the index on first run.

Michael Vogt (mvo) on 2009-03-30
Changed in synaptic (Ubuntu Jaunty):
status: Triaged → Fix Committed
Michael Vogt (mvo) wrote :

This should be fixed now in jaunty (current dailies), feedback is very welcome.

Michael Vogt (mvo) on 2009-04-08
Changed in synaptic (Ubuntu Jaunty):
status: Fix Committed → Fix Released
EmmaJane (emmajane) wrote :

This bug persists for me in Jaunty. The solution of running sudo update-apt-xapian-index is still valid.

Philip Macpherson (philipmac1) wrote :

Just installed the release candidate which came out after the fix was released and have to mention that it's still not fixed (at least on my computer) But the workaround works which is good.

yurx cherio (cherio) wrote :

I can confirm the problem. It occurs on different machines when searching for freenx package (Repository setup unstructions can be found here <https://help.ubuntu.com/community/FreeNX>).

I can also confirm that "sudo update-apt-xapian-index" workaround is working though it is a nuisance.

marcomolinari (marco-molinari) wrote :

I had the same problem on Jaunty RC; "sudo update-apt-xapian-index" didn't work (I closed Synaptic), so I deleted /var/lib/apt-xapian-index/ and then the fix worked.

Michael Vogt (mvo) wrote :

Thanks for this additional information. The bug that got fixed is that the index is outdated on fresh installs and does not contain universe. There is a pending SRU fix for the problem that the index is not updated on upgrades quickly enough (bug #365151).

The bug described in comment 33 is probably still valid, when adding a new repository it does not index that immediately. That should filed as a new report.

As for comment 31,32,34: please tell me under what circumstance you are hit by the problem.

Omen_20 (omen20) wrote :

'sudo update-apt-xapian-index' worked for me as well. And I also installed without internet connection. My wireless driver didnt pick up until second reboot.

DeOS (deoslepapillon) wrote :

I can confirm it on a fresh Jaunty RC install.

It occured when adding "deb http://www.ftd4linux.nl/releases/ubuntu jaunty main" and the matching key (http://www.ftd4linux.nl/releases/ubuntu/gpg.key) to the Synaptic Package Manager.

"sudo update-apt-xapian-index" worked for me as a fix.

OlaJi (ola-jirlow) wrote :

I can confirm this bug on a fresh Jaunty Netbook Remix. "sudo update-apt-xapian-index" do not fix it. Deleting the /var/lib/apt-xapian-index/ directory and rebuilding with "sudo update-apt-xapian-index" solved the problem

On an upgrade from Hardy to Jaunty (via Intrepid) I found out that package apt-xapian-index was not installed.

Installing it solved this problem for me. After installing it, an indexing task started automatically, which progress is shown by issuing: sudo update-apt-xapian-index.

Upon completion of the indexing, the quick search in Synaptic became usable


This bug persists for me in Jaunty. The solution of running sudo update-apt-xapian-index is still valid.

Paul Elms (scifly) wrote :

I can also confirm that this bug persists as can be seen from this duplicate #356318.

beb (m-grauwelman) on 2009-07-24
Changed in synaptic (Ubuntu Jaunty):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
saderfer (saderfer) wrote :

Hi, I made a fresh install of Ubuntu 9.04 Jaunty AMD64 and the quick search box on Synaptic wasn't working, so looking on the net I found 3 solution, and only 1 worked out.

The first one... old bug: sudo update-apt-xapian-index (didn't work)
The second one... changing the repo of the package (didn't work either)
And the third one, the BIG ONE I found it here... the post numer #33... check this out!

I had the same problem on Jaunty RC; "sudo update-apt-xapian-index" didn't work (I closed Synaptic), so I deleted /var/lib/apt-xapian-index/ and then the fix worked.

Soooo.... the solution was to delete the folder "/var/lib/apt-xapian-index/"
then I reopened Synaptic and apears the message "Reloading the index" (or something like that, I have it in spanish) I waited for like 1 minute and... TSCHA TSCHAAAAN!!! was working!

So thanks a lot to the GNU/Linux comunity to share their knowledge!

PD: My PC is a AMD Sempron 2600, OC to 2.0 Ghz... 1 GB RAM and gc GeForce fx5600.... and everyhing fly so smooth!!!

Best Regards

SLX (slx) wrote :

I also have problem with Quick Search function in Synaptic. When I enter the word "psi" into search field I only get one answer "psi-translations". The searching by "Search" buton find more packages, especially the "psi" package. None of above solution help me.

Changed in synaptic (Ubuntu Jaunty):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
cremac (cremac23) wrote :

Hi, I just installed Ubuntu Karmic and same bug appeared. I was able to find packages only using search (pop-up). If i used quick search only installed packages are listed.


solution described in comment #34 helped

If you need more information, let me know.

dirteur (dirteur) on 2010-01-27
Changed in synaptic (Ubuntu Jaunty):
status: Fix Released → New
Changed in synaptic (Ubuntu Jaunty):
status: New → Fix Released
Michael Vogt (mvo) wrote :

@cremac: this may well be a different bug than the original one, could you please let me know if this is reproducable? Did synpatic not detect that the search index is out-of-date and rebuild it?

Michael Vogt (mvo) wrote :

I woudl also be interessted in the output of (in a termnal):
$ sudo synaptic -o Debug::Synaptic::Xapian=true

Rippie35 (m-riphagen2) on 2010-02-10
Changed in synaptic (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Stuart (stuartneilson) wrote :

This bug persists in Ubuntu 10.04

In a brand new installation of Ubuntu 10.04 the quicksearch does not display Thunderbird or (*any*) Broadcom packages. The packages are plainly available in the sources and commandline apt-get install thunderbird functions correctly.

Charlie Kravetz (charlie-tca) wrote :

Did updating help? Did the normal 'search' button find any?

h1repp (heinz-repp) wrote :

Confirming this bug after an upgrade from Hardy LTS to Lucid LTS. The command-line (rebuild Xapian index) restored the quick search functionality, but the search button search is still unable to find most packages ...

h1repp (heinz-repp) wrote :

oops, sorry for the last post, the command-line rebuild of the Xapian cache restores also the search button - I had the target still set to "version" from previous trials. So, summarizing: after upgrade from LTS to LTS the Xapian cache is outdated, and Synaptic doesn't recognize this and so misses a rebuild.

security vulnerability: no → yes
Changed in synaptic (Ubuntu):
status: Fix Released → In Progress
Changed in synaptic (Ubuntu Jaunty):
status: Fix Released → Incomplete
status: Incomplete → Confirmed
Changed in synaptic (Ubuntu):
assignee: Michael Vogt (mvo) → shelton william dotson iv (sheltondotso)
Ingo Gerth (igerth) wrote :

Does this bug still occur to anyone in 10.10? It does not to me. So I would propose to close it.

Charlie Kravetz (charlie-tca) wrote :

Please do not close a bug in 10.04 LTS if it is reproducible in that package. For help when trying to reproduce bugs, please contact the bugsquad on IRC freenode channel #ubuntu-bugsquad. No bug that is valid in 10.04 should be closed if it can be fixed.

i have installed 10.04 64bit
i applied updates via Synaptic Package manager (got latest version of all things)

now go to Electronics (universe), scroll down to qucs <- this is what you are searching for, and note that it contains the words Circuit and Simulator

now you do not need to go back to ALL - Just type Circuit in the search box and all items disappear.

If it is taking over 2 years to clear a bug, how long is it going to take to do mine!!!

one solution might be to (not) search for Adept (KDE universe) but that would mean downloading 288MB of stuff to run KDE stuff - id rather use the CDrom but synaptic dont seem compatible with the install CDRom (i filed a bug for that)...

Did it to me once, and once only, on 64 bit 10.04, and then an update seemed to fix it.

Have you tried the xapian workaround in comment 34?

Jamie Strandboge (jdstrand) wrote :

Thank you for reporting this bug to Ubuntu. - has reached EOL
(End of Life) and is no longer supported. As a result, this bug is
being marked "Won't Fix". Please see this document for currently
supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Please feel free to report any other bugs you may find.

Changed in synaptic (Ubuntu Jaunty):
status: Confirmed → Won't Fix
Changed in synaptic (Ubuntu):
milestone: intrepid-updates → none
status: In Progress → Won't Fix
Siddharth Fadnis (sidfadnis) wrote :

Can confirm that the problem persists for me in Natty Ubuntu 11.04 (fresh install). However it fixed itself as soon I ran some updates to linux headers

BadBoy (sklep-szybkieczytanie) wrote :

Won't fix after such a long time? Muahaha.. You lammas...

Extender (msveshnikov) wrote :

Can confirm that bug for Oneiric Beta2 with all updates (upgraded from 11.04). Or maybe it is another bug? Quick search displays only a.... to f.... results, no packages for g..... to z..... package names.
sudo update-apt-xapian-index didn't work too.

Michael Vogt (mvo) wrote :

Hello Extender. Thanks for this additional information. Could you please run:
$ sudo update-apt-xapian-index
and attach the output to this report?

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers